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1. Starting with Click&DECiDE 

1.1. Using the Click&DECiDE Start Menu 

The Click&DECiDE Start menu displays the following modules. To display the Start menu click Start> All 
Programs> Click and DECiDE. 

 

Administration Manager: click Administration Manager to launch the Administration Manager. The 
Administration Manager enables you to define and setup each data source you want to access. In the 
Professional and Enterprise Edition, the Administration Manager also enables you to define the Security when 
accessing data sources: User Groups, Users, Menus used in the Web Portal and the Authentication mode. 

In the Express and Standard Edition, this command only allows to define and setup each data source you 
want to access. 

Web Portal: click Web Portal to access your Click&DECiDE Web Portal. The Web Portal will be launched. 

1.1.1. Using the Start Menu’s Business Application Intelligence Folder 

Builder: click Builder to launch the Click&DECiDE Builder. The Builder is the main program which enables 
you to start the application to create queries, reports and cross-tables, all saved in the same project with a 
“.wfv” extension. 

Configuration Wizard: click Configuration Wizard to launch the Click&DECiDE Configuration Wizard again. 
You may choose to run the Configuration Wizard again in the following cases: 

If you need to change your license certificate. 
If you need to change the Web Portal Authentication mode. 
If you need to change your Mail Server name. 
If you need to change the SQL Server Authentication mode. 
If you need to change the Working Folders in the Web Portal. 

Service Profile Wizard: click Service Profile Wizard for changing the prfile of the Click & DECiDE. 

1.1.2. Using the Start Menu’s  Tools Folder 

Model: click Model to launch the Click&DECiDE Model program (Enterprise Edition only). 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

6 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

 

This program is installed with BAI version 19 only for compatibility reasons, and it should be discontinued in a 
future version. We recommend to leave the use of Model and to migrate to views designed in database. You 
can also use the Click and Decide Queries data source for complex models. See the KB How to use the new 
Click&DECiDE Queries Data Source? for details. 
 

Web Menu: click Web Menu to launch the Click and DECiDE Web Menu program (Enterprise Edition only). 
This program allows the Administrator to create the Menus they want to publish via the Web Portal, according 
the User Groups defined in the Administration Manager. 

1.1.3. Using the Start Menu’s iSeries Tools Folder: 

iSeries Help: click iSeries Help to open the Click and DECiDE iSeries Online Help. 

iSeries Host Program Installation: click iSeries Host Program Installation to run the tools required to 
upload to the AS/400 Host Program. 

iSeries Interface Batch Setup: click iSeries Interface Batch Setup to run the tools managing the rights for 
the Batch Facility. This is a specific feature for iSeries that must be prepared by the AS/400 Administrator. 

1.1.4. Using the Start Menu’s Documentation Folder 

Products and Solution Data Sheets: click Products and Solution Data Sheets to product and solution 
documents on the Click&DECiDE web site. 

Readme: click Readme to open the Readme file and read about the new features in the current version. 

Technical Documentation: click Technical Documentation to open technical documents on the 
Click&DECiDE web site. 

 

1.2. Defining Data Source Access (Express Edition or Builder standalone) 

Once you have installed Click&DECiDE and you want to start using the product, you first need to define the 
data source you want to access. If you installed the Express Edition or only Builder from Desktop or 
Enterprise Edition then please follow the instructions in this section as the Administration Manager linked in 
the Start Menu will launch the Click&DECiDE Data Sources Configuration module which is only for the 
Express Edition of Click&DECiDE or Builder installed as standalone. 
If you installed the Enterprise Editions, please follow the instructions in section 1.3. 

To define the access to your data source, please follow the steps below. 

1. Click Start> All Programs> Click and DECiDE> Administration Manager. The Click and DECiDE 
Data Sources Configuration module appears. This program allows you to add configure the access for 
each data source you want to use. 
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1.2.1. Creating a New Data Source 

To create a new data source, please follow the steps below. 

1. Right-click in the middle pane to add a new data source. 

2. Click New Data Source or click File> New. 

3. Enter the name you want for the new data source. 

 

4. Select the data source in the Type drown-down list. In this example we will add a new iSeries TCP/IP 
data source.  
Note: for iSeries TCP/IP source you must run the Host Program Installation first before creating this 
data source. Select Start> All Programs> Click and DECiDE> iSeries Tools> iSeries Host 
Program Installation to run the tools required to upload to the AS/400 Host Program. 

5. Click OK. 

6. Enter the iSeries Name or IP address.  
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7. Enter the RDB Name tab: 
 

        

8. Modify the default RDB Name (SNI3X) if necessary. 

9. Click Validate. 

Note: Once the test connection is OK, your new iSeries data source will be ready to use with Click&DECiDE.  

1.2.2. Modifying an Existing Data Source 

To modify an existing data source, please follow the steps below. 

1. Right-click on the Local SQL Server icon. 

2. Select Properties (or select File>Properties), the Settings dialog box appears. 

 

3. Enter the Server Name or Server Name\Instance Name for the SQL Server you want to access. 

4. Select or clear the check boxes and drop-down list as appropriate. 

5. Click OK.  

6. Right-click on the data source. 
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7. Click Test Connection. Note: if your SQL Server was setup with SQL Server Authentication then 
enter your login (User ID and Password). If your SQL Server was setup with Windows Authentication 
then do not enter your login. 

 

8. Note the context menu displays the following other options: 

Delete: deletes this data source. 

Authorized User Groups: display the list of groups who are granted access to the data source (only 
for secured data sources): 

 

9. To rename a datasource, press F2. 

 

1.3. Defining Data Source Access (Enterprise Edition) 

If you have installed the Professional or Enterprise Edition, then if you click Administration Manager in the 
Click and DECiDE Start menu, the Click and DECiDE Administration Manager module will be launched. Click 
and DECiDE Administration Manager allows you to perform the following tasks: 
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• Add and configure each data source you need to access 

•  Manage Users and User Groups 

• Manage the Security for each data source that must be accessible according to the User Group 

• Grant access to User Groups to predefined Web Menus. 

 

To learn more about the Click and DECiDE Administration Manager, please refer to the Click&DECiDE BAI 
Administration Manager Manual. 

 

2. Using Click and DECiDE Builder 

Now that the data source you need is ready, you can start using Click and DECiDE Builder. 

To launch Click and DECiDE Builder, select Start> All Programs> Click and DECiDE> Business 
Application Intelligence> Builder. 

 

2.1. Introducing Key Concepts 

Click and DECiDE Builder saves your work in a Project file with the file extension .wfv. The Project *.wfv file 
contains all the queries, reports and cross-tables you created for your project.  You can create an unlimited 
number of projects. 
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Several tabs appear in a project: such as Queries, Reports and Cross-tables. 

Queries tab: contains all the required queries used as is or used to feed a report, a graph inside a report, a 
sub-report or a web query for Excel. The queries can also be used to feed a Dashboard application. 

Reports tab: contains all the reports, based on existing queries in the same project file. Each report can 
include several graphs or sub-reports but also external objects such as a Microsoft Excel graph or other 
Active-X components. 

Cross Tables: contains Cross-tables based on existing queries in the same project file. 

Project items such as queries or reports can be exported to send data to all the output formats supported by 
Click and DECiDE Builder such as ASCII File, HTML, PDF, Excel DDE, Excel XLS and XLSX (native format), 
Google Data Table, formatted text file (RTF), Clipboard and other databases. 

 

2.2. Opening a Project. 

To “Open” a project, please follow the steps below. 

1. Select File> Open Project or click the Open Project  icon. 

 

 

2. Select Computer if the project is located on your computer. 

3. Select the required project file with the*.wfv extension. 

4. Or Select Web Portal if the project is already saved in the Server managing the Web Portal. 
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5. Enter the Web Portal URL and click the right icon : (if needed, login to the Web Portal) 
 

 

 

6. Log In to access the Web Portal and see the available Menus: 
 

 

 

7. Display the Menu Shared Folders and Folders 
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8. Select the Shared Folder from where you want to open a project. 

 

9. Select the required project file with the*.wfv extension. 

10. Click Open 

 

2.3. Creating a Project 

To create a new project, please follow the steps below. 

1. Select File> New Project or click the New Project  icon. 

2. Browse a local directory, for example 
C:\Users\Public\Documents\Click and DECiDE Samples\Web Portal\Shared Folder 
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3. Enter a File name for the new project. This project must be first saved locally on your computer but 
you can later save it on the Web Portal using the Save As command. 

4. Click Save. 

Note: this project is now ready to store the queries, reports or cross-tables that you are going to create. 

2.4. Creating a New Query with Only One  Table 

To create a query, you must first create a data source (please see section 1). If you have already created the 
data source you need, then you can now create your first query. To do so, please follow the steps below. 

1. Click the New Query icon  or select File> New> Query. 

 

2. Click the required data source to display the available sublevels. 

3. Select the table you need: (if you are not using the Windows Authentication mode you will be 
prompted for a login). 
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4. Right-click in the right pane. 

5. Select Display> Details to see the description for the tables. 

 

 

6. Double-click a table if you only need one table for your query. The column list will automatically be 
displayed. 

 

 

7. Click the Run icon to get the result for the Top 50 records by default for all the fields in the data grid. If 
no fields have been selected, all the fields will be selected by default when running a query). If you 
want to modify or remove this Top value, refer to the Applying a Top Value section. 
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See also: 

Selecting Fields – Column Header and Data format – Sorting Data – Modifying column order – Deleting 
columns – Query information – Removing Query – Saving query – Aggregate fields – Virtual fields –  
Joining several tables. 

 

2.5. Creating a New Query with Two or More Tables 

If you need two or more tables in your query, you first need to add each table in the Table tab when selecting 
the tables in the list by performing a drag-and-drop operation for both the tables required. To do so, please 
follow the steps below: 

1. Select the table you want to use for the query. 

2. Drag it into the lowest pane. 

3. Select the other table you want to use. 

4. Drag it into the lowest pane. 
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5. Note that the default join condition is automatically proposed if the program finds two columns with 
same name, same type and same length. (Note: if you do not wish the join being automatic, you can 
disable this feature in Tools> Options> Query Tab and uncheck the “Link Tables Automatically”. 
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Note: if you need to remove a table from the lowest pane, select the concerned table and press the Del key. 

2.6. Defining the Join Condition 

To modify the join condition, please follow the steps below: 

1. Double click the  equal sign in the square between the two tables The Join Properties dialog box 
appears. 

 
 

2. Select the required join type. Note: in the majority of cases, the Join Criteria must be set to “equal”. 

3. Click OK.  

Note: You can remove the join condition by pressing DEL on the square  with the equal sign. 

To manage the join relation for several tables, please follow the steps below: 

1. Click “Click and DECiDE Joins…” in the context menu. The Joins / Relations dialog box appears. 
This displays all the defined join relations. 
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2. Add or remove a join condition. 
Note: this will not modify the Join Type. 

 

In the above screen; you can add a new Join condition or remove an existing join condition but you cannot 
change the Join Type, which can be changed in the screen explained previously. 
(see “Double click the  equal sign”). 

3. Click on “Show Native Virtual Fields” in the context menu if you need to add a join on a native virtuel 
field.  
 

 
 
See Join Condition with Virtual Field for more detail. 
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2.7. Defining Native Joins 

You can also express joins in native SQL language. This is useful for more complex joins, for example if you 
need to combining several conditions with the OR operator or if you want to use database-specific features. 

1. To express joins in native SQL language, click on “SQL Native FROM Clause” in the context menu in 
the Tables view: 

 

 
If the query already contains Click and DECiDE joins, they are converted into native SQL as far as 
possible. 

2. Enter / update the FROM clause for all the query in the text area: 
 

 

Use the mouse to drag/drop fields names from the Tables view to the text area. 

You can use parameters in native joins. See Defining Parameters in Native Joins for more detail. 

Note: No syntax and semantic check is applied at this level, so it is your responsibility to ensure your native 
SQL code is valid. If not, you will have an error when running the query. 

 

2.8. Selecting some Fields 

To select the columns you need in a query, please follow the steps below: 
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1. Click the Query tab. The tables appear. 

 

2. Select the columns you need by double-clicking the left grey square near the column name. 

Example 

1. Select Join Type = 1 (this join type only includes records from both tables where the joined field match 
the join criteria).  

2. Create a new query using the Sales and Salesman Tables. 

3. Keep the default Join Type 1.  

4. Select the SALNAME and TOTAL fields. 

5. Right-click on the TOTAL field. 

6. Select Aggregate> Sum. 
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7. Click Run to run the query. The result will appear in the lower pane; only the result for salesmen with 
records in the Sales tables will be displayed. 

 

8. Return to the Tables tab. 

 

9. Select Join Type#3: 
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10. Click OK. 

11. Click Run to run the query again. The result will appear for all the salesmen, even if they made no 
sales in the Sales table. 

 

Note: the Join type = 4  is not supported by all databases, such as ODBC Access, but supported for example 
by the MS SQL Server database and the iSeries, Oracle or UDB-DB2 database.  This Join type will retrieve all 
the records from each table. (It is equivalent of type 2 + type 3 together). 

 

2.9. Defining a Join condition including virtual field(s) 

You can add a Join condition between a native virtual field and another column or between 2 virtual 
fields. The “Show Native Virtual Fields” option must be activated in the context menu of the Tables view to 
display existing native virtual fields in the column list. 
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Example: if we create 2 virtual fields using the Category and Sales_Details tables as follow: 

 

Then we can define a join between these 2 virtual fields (or between one virtual field and another column): 

- Go to the Tables Tab and click in the context menu on “Click and DECiDE Joins…”. 

- Select in the left and right windows the fields to be joined. 

- Click Add 

 

- Click Delete if you need to remove this join. 

 

2.10. Selecting or Removing All Fields 

Note: if no fields are selected when you click Run, all the fields from all the tables will be selected by default.  

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

25 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

 

To select fields, please follow the steps below. 

1. Select the table title (Table Alias). 

2. Right-click to display the context menu.  

 

3. Note the following options appear in the context menu: 

Add a formula…: adds a virtual field whose formula can be calculated by the data source engine or 
by Click and DECiDE. This option will be described later in this document. 
Select All Fields: selects all the columns in this table. Note: you also can double-click directly on the 
Table Alias to select all fields in a table. 
Clear All Selected Fields: clears the selection for all the columns from this table. 
Properties: displays the Table Properties. 

4. Click Properties to display the Table Properties. 

 

5. Note the following properties appear: 

Alias Source: the name of the data source of the query (defined in the Administration Manager). This 
cannot be modified here. 
Table Name the full table name (this cannot be modified here). 
Alias: the visible Table Alias that can be modified here, if necessary. 
Table Formula: you can use a formula for building the table name. This can be useful if the table 
name depends on the user who runs the query. See Click & DECiDE Formula and Updating a 
Parameter with a User Property for more details. 

6. Double-click each required column if you only want to select some columns. The columns will 
automatically appear from left to right in the Data Grid pane. In this example we will select AREA, 
SALNAME, DATE and TOTAL. 

7. Click Run. 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

26 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

 

 

2.11. Modifying the Column Order 

If you want to move one or several columns from right to left or left to right, please follow the steps below. 

1. Select the required column(s). 

2. Keep the mouse cursor pressed down. 

3. Move the column as necessary. 

2.12. Modifying the Column Header and Data Format 

By default the column header will be the same as the field name. There are two methods of modifying the 
column header. 

Method 1: Using the Field Description as the Column Header 

To use the field description as the column header, please follow the steps below. 

1. Select Tools> Options> Query> Use Field Description as heading. 

Method 2: Modifying the Column Header by Hand 

To modify the column header by hand, please follow the steps below. 

1. Select the column whose header you want to modify. 

2. Right-click. 

3. Click Properties.  
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4. Note the Properties pod appears. 

5. Drag the floating Properties pod to the border (left, right, upper, lower) you want to dock it in the 
Click&DECiDE Builder and use the pin icon to pin/unpin it. 

 

6. Drop the dialog box when the location is reached. The Properties pod will remain here until you 
decide to close or move it. Note:  you can Auto Hide the Properties pod. 
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7. Modify the Header for the field you selected. In this example we will replace DATE by Purchase Date. 
See also: Using Formula in Column Header. 

8. Specify a format. In this example we will select the long date format. 

9. Select another column to modify its name and format if necessary. In this example, we have modified 
the name and format for the TOTAL column. 

 

 

The proposed formats for numeric fields, or date, time and date time fields, are those defined in Windows 
according to your Regional Settings. Nevertheless, you can customize numeric formats and date formats as 
follows. 
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Numeric Format: use the # number sign with your Windows thousand and decimal separator, with zero if you 
need to see this value. Examples: 

Value Customized format Result 

1456.2 #,###.# 1,456.2 

1456.2 #,###.00 1,456.20 

     0.3 #,###.00         .30 

     0.35 #,##0.00       0.35 

2150 #,###.## 2,150 

2150 #,###.00 2,150.00 

     0 #,### (not visible) 

     0 #,##0        0 

   45.1 #,##0_);[Red]-#,##0.00      45.10 

  -28.6 #,##0_);[Red]-#,##0.00     -28.60 

Date format: use the ddmmyyy characters as follows: d=day, m=month and y=year. 

Value Customized format Result 

 
If the day 5 of a month 

is Wednesday 

d 5 

dd 05 

ddd Wed 

dddd Wednesday 

 
If the month is April 

m 4 

mm 04 

mmm Apr 

mmmm April 

If the year is 2015 yy 15 

yyyy 2015 

11/27/2015 dddd dd of mmmm, yyyy Friday 27 November, 2015 

 

2.13. Deleting a Selected Column 

If you no longer want to use a selected field, please follow the steps for one of the methods below. 

Method 1:  

1. Select the column you want to stop using. 

2. Press DEL. 

Method 2: 

1. Click the right-most column (the Select column) for the field you no longer want to display. 

Method 3: 

1. Select the field you no longer want to display. 

2. Right-click; 

3. Click Select> Off. 
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2.14. Saving the Query 

To save your query, please follow the steps below. 

1. Select File> Save or Save As. 

2. Enter a name. 

3. Click OK. 

 

 

2.15. Saving As a Project 

To “Save As” a project, please follow the steps below. 

1. Select File> Save as command. 
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2. Select Computer if the project has to be saved locally on your computer. 

3. Or Select Web Portal if the project has to be saved on the Server Web Portal. 

 

4. Enter the Web Portal URL and click the right icon : (if needed, login to the Web Portal) 

 

5. Log In to access the Web Portal and see the available Menus: 
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6. Display the Menu Shared Folders and Folders 

 

7. Select the Shared Folder where you want to save the project. 

 

8. Enter a new name. The extension will be automatically *.wfv. 

9. Click Save 

 

2.16. Save All command 

This command will save all opened item and also the project.wfv itself. At the same time, the project will be 
automatically compacted. Sometimes it is recommended to compact your project file, when you have created 
or deleted several items such as queries, reports and cross-tables. This action is now automatic when you 
save the project, and will reduce the project size on the disk.  

Use the File > Save All command or the corresponding icon:  

2.17. Query Information 

Once you have closed the query, you can see all queries already made in your Click&DECiDE project file. 
To view the properties for each query, select the query and note the properties appear in the General tab in 
the Properties pod.  
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The General tab displays the following properties. 

Name: displays the query name in your Project file. 
Data Source: displays the query’s data source. 
Description:  enter the description you want in the Description text box. 
Created: the date and time the query was created. This cannot be modified. 
Modified: the date and time when the query was modified for the last time. This cannot be modified. 
Author: who the author is. This will use the Windows User Name for the person who created the query. 

Note: the list of queries can be viewed in several display modes (Large Icons, Small Icons, List, Details). To 
view the details displayed in the Properties pod General tab click the Details icon (please see the screen 
shot above). This enables the user to view the query’s properties even when the Properties pod is closed. 

2.17.1. Defining Query Properties to Display in the Web Portal 

It is possible to specify properties for a query that will only be visible in the Click&DECiDE Web Portal 
(Professional and Enterprise Editions). To do so, please follow the steps below. 

1. Select the query whose properties you want to define. 

2. Click the Properties tab in the Properties pod. 

 

3. Enter the Properties you want to be visible in the Web Portal: 

Display Name: the name that will be visible in the Web Portal if the project file is in a Shared Folder 
(this is not the same as the one used in your Project file). 
Visible:  hide the query in the Web Portal if the project file is in a Shared Folder. 
Details: the Description that will be visible in the Web Portal if the project file is inside a Shared Folder 
(this is not the same as the one used in your Project file). 
Default Destination: enter the path and/or the file name to be used when exporting to PDF format 
(Acrobat Reader), either from Click&DECiDE Builder, or from Click&DECiDE Web Server. This can 
also be a formula which generates a dynamic query name, for example, including date elements in 
the file name (e.g.: Path + File Name + YYMMDD + .PDF). 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

34 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

 

Model: Report: enter the Report Template to be used when exporting the query to the PDF format. 

 

2.17.2. OData Support  

A Click & DECiDE query can be exposed using the OData protocol: data can then be accessed using an 
OData link, to be used from other applications such as Microsoft Excel Power Pivot or PowerView. 
OData support is defined for each query: 

Enable OData: Yes/No (Default value is Yes when creating a new query). 
If Enable is set to “No”, then other options are grayed and cannot be changed.  
If Enable is set to “Yes”, you can specify other options: 

Cache Mode: you can choose among No Cache, Cache with Delay or Permanent Cache: 

 

Cache Delay: if Cache Mode is set to “Cache with Delay”, you can choose the duration for this delay. 
This must be an integer number. 

Cache Delay Unit: if “Cache Delay” is not grayed, you can specify here the Unit among Day, Hour or 
Minute: 

 

Global Cache: Yes/No. Default value is “No”. In that case the Cache will apply to the Connected User. 
If you wish to have a global cache for everyone (any user), then select Yes for this option. 
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The project file must be "saved as" any name inside a Menu Shared Folder for the Web Portal on the Server 
where Click&DECiDE V19 Enterprise is installed. Even if you are working on the Server machine, do not used 
the "Save As" command selecting "Computer…". 

Warning: this "Save as" command to the Web Portal doesn’t work with the Forms mode if using the 
Click&DECiDE Authentication. You must use the HTTP Digest or the HTTP Basic modes, or the Windows 
Authentication mode. 

2.18. Removing a Query 

To remove a query, please follow the steps below. 

1. Open the Click&DECiDE Builder project file which the query you want to delete is in. 

2. Click the Query tab. 

3. Select the query to be removed. 

4. Press DEL or the Remove button. A warning message appears. 

5. Click Yes to confirm. 

Note: before removing a query, check that the query is not used by another query (sub-select), report, graph, 
sub-report, or a sub-query in a report or cross-table. As you cannot restore a query once it has been deleted, 
we recommend that you regularly backup your project files.  

2.19. Sorting Data in a Query 

To sort data in a query, please follow the steps below. 

1. Open the query you want to sort data in. In this example, we will open the Query 2 tables query. 

2. Click the rightmost column to select the field you want to sort data for. The column must be selected 
as the source database cannot apply a sort on an unselected field. 

3. Click the sort column to the left of the field you want to sort data for. 

4. Click the black histogram Sort icon to alter the sort from an Ascending to a Descending sort and vice 
versa. 

 

5. Select Query> Order By... if you want to add several sort conditions. This will display all the sort 
conditions. In this example, the first ascending sort will apply to the Area field, then, for the same 
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area, the second ascending sort level will apply to the Salesman Name, then, for the same 
salesman, the third descending sort level will apply the Total field.  

 

Modify the hierarchy of the sort conditions in the Order by… dialog box by using the up and down 
arrows. To remove a sort condition, click the red delete icon. 

Note: the position of each field in the data grid does not matter: you can apply a sort condition to any 
field in the data grid regardless of its position. In the following screen shot the sort is applied to the 
Date (field #3), but the Area and Salesman Name fields are in first and second place. 

 

Note: Click&DECiDE Builder allows you to hide any selected fields if necessary. Right-click on the field you 
want to hide and click Select> Hidden. 
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2.20. Applying a Top Value 

To apply a Top value, for example to display results for the top 10 Salesmen, please follow the steps below. 

1. Click the  Query Properties icon to display the Query Properties pod. 

2. Note the Number of Records in Data Grid value is set to 50 by default. This limits the number of 
records displayed in the Data Grid in the lower pane to 50. This does not apply to exports and 
printing. To modify this limit, select Tools> Options> Query and modify or remove the value in the 
Number of Records in a New Query's Data Grid text box. 

 

3. Enter a number in the First Records text box to define a Top value. For example you can ask for the 
TOP 10 number of records. In this case, the TOP value will apply to any export or printing from this 
query, cross-table or report based on this query. Note that the First Records box displays an 
asterisk by default when a new query is created.  

4. Define whether you want the top number to be converted as a percentage by selecting Yes in the 
Percentage drop-down list. For example, you can ask for the TOP 10% records. In this case, the 
TOP value will apply to any export or printing from this query, cross-table or report based on this 
query. 

5. Make sure that you sort the query data according to the correct field to ensure that the Top Value is 
treated correctly. Note that a TOP usually applies to a numeric field, with the descending sort 
condition if the Top applies to the Top greater values, or Ascending sort condition if the Top applies 
to the Top lower values. 

For example: no limit in the Data Grid and Top 20 for export or print action: 
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Note: refer to the section explaining how to use a Parameter to define a Dynamic Top Value for a query. 

 

2.21. Defining Criteria 

If you want to filter your data to only get the information you want, you will need to apply criteria.  
To do so, please follow the steps below. 

Only the records matching the criteria condition you set will be displayed in the data grid, output format, report 
or cross-table. 

1. Click the leftmost column of the field you want to set criteria for. The Criteria dialog box appears. 

 

2. Select the field from the Columns drop-down list. 

3. Select the Operator. 
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4. Note that you can apply the criteria with the following four possibilities: a Value, the content of another 
Column, an Expression (formula) or the values given by another Query. 

Value tab allows you to enter a value (text, number, date and so on) as a comparison value. However, you 
can also use the browse button to search for available values in the Host database in real-time or to 
automatically create a dynamic list of values.  

Column tab allows you to use the content of another column as a criteria condition. For example you can 
create a criteria such as TABLE1.DEBIT >= TABLE2.CREDIT 

Expression tab allows you to use a formula as a criteria condition. For example a TABLE.DATE can be 
compared to the formula = CurrentDate() – 7 to get all the records whose DATE contains the value from one 
week ago. 

 Query tab allows you to use the result given by another query as criteria condition. 

5. Click the Value tab. 

6. Click Browse… 

 

Browse displays a warning message explaining that this action may take a while because the distinct list of 
value will be generated dynamically from the source database. 

7. Click Yes to get the list of values. 
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8. Select the required value(s) and click OK. The Criteria dialog box appears as in this example: 

 

The result will be all records where the AREA field is equal to ‘CENTRAL’, but if you need to run again the 
query for another AREA you will need to modify the criteria each time. That is why the other option “Display 
List of Values” can be used to get a dynamic list of value without the need to modify the criteria. 

 

 

Display List of Values: will automatically create a parameter fed by a sub-query which dynamically retrieves 
the distinct values found in the AREA field.  

9. Click the Display List of Values. The Criteria dialog box appears. 
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10. Click OK. 

11. Click Run to run the query. You will be prompted to select a value for the AREA field. 
Note: leave IGNORE (equivalent to All Values) if you want to run the query for all the data. 

12. Click the down arrow to expand the dynamic list of distinct values. 

 

13. Select the value(s) you want. 

 

14. Click the  icon. 

15. Click OK. The result will be displayed. 
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Important: note that a parameter, named P_AREA, has automatically been created and displayed in the 
Expression tab.  

16. Click Query> Parameters to display the details about this parameter: 

 

The above screen will be explained more in detail later in this manual, in the section concerning Parameters.  

2.21.1. Working with Criteria for Sub-Select Queries 

Another query is called a "sub-select" and can be a result coming from another table. To create a sub-select 
query, please follow the steps below: 

1. Click the Query tab in the Criteria dialog box. 

2. Click the Browse button  to dynamically create the sub-select.  

3. Note that if you save the sub-select created, the name will be used in the criteria box, if not, the SQL 
will be used in the criteria box (this is not recommended if you are not familiar with SQL syntax). 

Note:   the result given by the sub-select must be accepted by the criteria operator you have chosen. For 
example an equal condition can be used only if the sub-select retrieve one value. However, an In List 
condition can accept a list of values given by the sub-select. Usually the sub-select must always give the 
result of one field whose content can be compared with the field used in the Criteria dialog box. In the 
following example the sub-select will retrieve the values 3, 6 and 16, that is, the salesman code values for all 
the salesmen from the SOUTH area. 
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Each criteria added in the query will appear in the Where tab in the Criteria dialog box if the criteria concerns 
a host field. Please refer to the section concerning defining criteria for virtual fields or group fields further on in 
this document. 

Note: when defining more than one criterion, a default and statement is automatically added between each 
criterion. It may sometimes be necessary to modify the and into an or statement, or use the not condition if 
necessary and combine certain criteria with each other by using parenthesis levels as you can see in the 
following example. 

 

2.21.2. Exercise 1: Defining Criteria 

In this exercise we are going to create a query from the SALES DETAILS, PRODUCT and CATEGORY tables 
in order to get the Family, the Product Name and the Quantity (sorted by descending quantity) for the selected 
Family, using an automatic list of values to choose the Family. To do so, please follow the steps below. 

1. Create a query from the SALES DETAILS, PRODUCT and CATEGORY tables. 

2. Define the joins between the tables as follows (if they are not automatically created): 
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3. Select the following columns: 
Sales_Details: QTY 
Product: PRODUCT 
Category: FAMILY 

4. Define an Descending Sort for the QTY field. 

5. Modify the Column Headers. 

6. Configure the Number Format for the QTY column. 

7. Configure the Decimal Places for the QTY column. 

 

 

8. Click the leftmost column of the FAMILY field to open the Criteria dialog box for the FAMILY field. 

9. Click the … Browse button. 
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10. Click Display List of Values. 

 

11. Click OK. 

12. Click Run, to run the query in the data grid to check the result.  

13. Click File> Save As to save you query as Exercise 1. 

2.21.3. Exercise 2: Using Keywords 

In this exercise we will create a query from the SALES table in order to get the Customer Names, the date 
and the total amount for the sales made during the current month. To do so, please follow the steps below. 

1. Create a query from the SALES table and the CUSTOMER table. 

2. Select the following columns: 
Sales: DATE 
Sales: TOTAL 
Customer: CUSTNAME 
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3. Click the leftmost column of the DATE field. The Criteria dialog box appears. 

4. Select the equal Operator. 

5. Click the arrow to display the context menu. 

6. Click Display Predefined Dates: 

 

7. Click OK. A new parameter named P_DATE has been automatically created and placed in the 
Expression tab. 

8. Click OK. 

9. Click Run to run the query. The Parameters dialog box appears. 

10. Select a keyword, such as Today, Yesterday, This Month and Last Month. In this example, select 
This Month. 

11. Click OK. 

 

12. Note that only the data for the date corresponding to the current month is displayed. 

2.21.4. Exercise 3. Working with Two Criteria 

Now we will add a new criteria condition to also get data from Last Month, so that you can compare data from 
two periods, This Month and Last Month. To do so, please follow the steps below.  

1. Click the leftmost column of the DATE field. The Criteria dialog box appears. 

2. Click New to add a new criterion for the DATE field. 

3. Select the equal operator. 

4. Select the Value tab. 

5. Click the arrow to expand the context menu. 

6. Click Display Predefined Dates. A new parameter is automatically created and placed in the 
Expression tab. 
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7. Note that the two criteria are separated by the and statement. 

8. Click and in the middle pane, the statement is automatically replaced by the or statement. The or 
statement enables you to get results if you select This Month for the first criteria and Last Month for 
the second criteria. 

 

9. Click OK. 

10. Click Run to run the query. The Parameters dialog box appears. 

11. Select This Month for the first parameter. 

12. Select Last Month for the second parameter: 

13. Click OK. 

 

14. Note that you get data for both the periods you selected (Last Month and This Month) because you 
used the or statement. T If you used the and statement no result would have been generated, 
because each record has a single date - Last Month OR This Month OR another period.  

2.21.5. Exercise 4. Customizing your Query Parameters 

You can easily customize the titles and default values which are displayed in the Parameters dialog box when 
you run a query. To do so, please follow the steps below. 

1. Click the Query Parameters icon to display the Query Parameters.  

2. Select the P_DATE parameter. 
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3. Modify the Title to Select First Period. 

4. Modify the Default Value to 0 months ago|This Month. 

5.  Select the P_DATE1 parameter. 

6. Modify the Title to Select Second Period. 

7. Modify the Default Value to 1 months ago|Last Month. 

8. Click OK.  

 

Important: in this example we use keywords for Dates fields with the following syntax: 

Invariant Keyword|Language Keyword 

Invariant Keyword will always work independent of your regional settings. 

Language Keyword: can be in the language you want. 

For example 0 months ago is an invariant keyword where months is always written with an “s” and 0 can be a 
number between 0 and 12. For more than 12 months, you can use 1 years ago as invariant. 

You also can use direct keywords in your language if your language system is: English, French, German, 
Spanish, Italian, Swedish or Catalan. In this case, the invariant keyword can be ignored as well as the pipe 
separator. Please refer to the keyword list for each language at the end of this document. 

2.21.6. Exercise 5: Modifying AND Statements to OR Statements 

Now, we will add a new criteria condition to explain why you sometimes need to combine or ungroup several 
criteria together. To do so, please follow the steps below.  

1. Click the leftmost column of the STATE field (in the Customer table). The Criteria dialog box appears. 

2. Select the Customer.STATE Column. 

3. Select the equal Operator. 

4. Select the Value WA. 
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5. Note the criteria are added in the middle pane. 

6. Click OK. 

 

7. Click Run to run the query. 

8. Note the following result appears. 

 

9. Note records for states other than WA appear in the STATE column in the result. This is because the 
SQL was as follows:  

Sales.DATE = This Month OR Sales.DATE = Last Month AND Customer.STATE = ‘WA’ 
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The two conditions linked by the AND statement are Date = Last Month and State = ‘WA’, so for October we 
only got the State ‘WA’, but the first condition Date = This Month is not linked to any criteria in the State field 
because of the OR statement. The solution is to add the correct parenthesis using the Combine button. 
Please see Exercise 5 to find out how to combine criteria. 

2.21.7. Exercise 6: Using the Combine Button 

To add parenthesis using the Combine button, please follow the steps below. 

1. Click the leftmost column for the DATE field. The Criteria dialog box appears. 

2. Click on the first criterion Sales.DATE = P_DATE. 

3. Press CTRL+Click on the second criterion Sales.DATE = P_DATE1. 

4. Click the Combine button: 

 

5. Click OK. 

6. Click Run to run the query. 

7. Note that now only the data for the WA state appears for this month and last month.  

 

2.21.8. Exercise 7: Using the Not Button 

The Not button can be used sometimes in the Criteria dialog box to modify one or several group of criteria, 
the Not can be applied to one row in the criteria or one group of rows between parenthesis. Please follow the 
steps below for more information. 

1. Click the leftmost column of the DATE field. The Criteria dialog box appears. 

2. Click Not. 
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3. Click OK. 

4. Click Run to run the query. 

2.22. Copying a Query to Start a New Query 

Sometimes you can save time by copying an existing query if you want to create a new query, this enables 
you to keep some features already defined, such as join conditions, sort conditions, criteria and so on. There 
are two possible methods of copying a query. 

Method 1: Save As 

1. Open the query you want to copy. 

2. Select File> Save As. 

3. Enter the name for the new query which will be a copy of this query. 

4. Click OK. 

Method 2: Copy & Paste 

1. Close the query you want to copy if it is open or select File> Save. 

2. Go to the Project tab. 

3. Select the Query button to the left. 

4. Select the query you want to copy. 

5. Either: 

a. Right-click> Copy. 

b. Right-click> Paste. 

6. Or: 

a. Select Edit> Copy 

b. Select Edit> Paste. 

7. Right-click> Rename and rename the copied query from “*-copy” to the name you want. 

8. Open the new query. 

9. Select Edit> Clear Query if you want to remove certain features in the copied version of the query. 

10. Select the appropriate check box(es). 
Clear All: removes the selection of the fields, existing join conditions, sort conditions and all existing 
criteria. 
Clear Fields:  removes the selection of the fields and sort conditions because a field which has not 
been selected cannot be sorted 
Clear Joins:  removes existing join conditions. 
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Clear Criteria:  removes existing criteria without removing corresponding fields if they are selected. 
Clear Sorts: removes existing sort conditions without removing corresponding fields. 

11. Click OK. 

12. Select File> Save. 

13. Note that existing parameters are not removed by this action, so check if your still need them and if 
so, you will have to assign some of them to required fields in the Criteria dialog box if necessary. 

 

2.23. Copying a Query from a Project to another Project 

1. Open the first project 1 containing the query to be copied 

2. Start a new instance of Click&DECiDE Builder (Builder is started twice). 

3. Create a new project ort open an existing project 2 being the target 

4. Make a drag and drop with the mouse of the concerned query from Project 1 to Project 2. 

5. The same method can be used for a Report or a Cross-table. 

2.24. Using Aggregate Functions 

By default when selecting any field in a table, the result will be the detailed result corresponding to each 
existing record, according to the criteria and order defined. The aggregate fields or grouping functions allow 
you to get results grouped by one or several fields. The most simple aggregate field is the COUNT(*), this will 
return the number of records from a table. To insert a Count(*) field, please follow the steps below. 

1. Create a new query using the SALES table. 

2. Select Query> Insert> Count(*) to insert a Count(*) field. 

3. Click Run to run the query. 

4. Note the result will be the number of records in the SALES table. 

5. Add only one field, for example the SAL field, (with the Salesman code). 

6. Run the query again. 

7. Note the number of records appears in the SALES table for each salesman code. 

8. Select the SQL tab.  
Note: you can see that an aggregate function will generate a GROUP BY statement for all fields that 
are not aggregate fields. 

Note: concerning other common aggregate functions, when you right-click any field, you can select 
the COUNT(*) field however other function groups are provided. 

Group Aggregate function Can apply to 

 

 
Min Any field type 

Max Any field type 

Sum Numeric field only 
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Aggregate 

Average Numeric field only 

Standard Deviation Numeric field only 

Population Standard Deviation Numeric field only 

Variance Numeric field only 

Population Variance Numeric field only 

Count Any field type 

 

 

Distinct Aggregate 

Sum Numeric field only 

Average Numeric field only 

Standard Deviation Numeric field only 

Population Standard Deviation Numeric field only 

Variance Numeric field only 

Population Variance Numeric field only 

Count Any field type 

 
Exercise 1: 

In this exercise we are going to directly obtain the sum of the total, to do so please follow the steps below. 

1. Create a new query with the SALES and SALESMAN tables. 

2. Join the two tables (please see the previous section). 

3. Select the TOTAL field.  

4. Right-click the TOTAL field. 

5. Select Aggregate> Sum or select Query> Insert> Aggregate> Sum. The TOTAL field’s selection 
will be cleared and anew SUM(TOTAL) field will appear.  

6. Click Run, to run the query only the main total will appear from all the records. 

Exercise 2: 

In this exercise we are going to directly display the minimum value, to do so please follow the steps below. 

1. Select the TOTAL field. 

2. Right-click the TOTAL field. 

3. Select Aggregate> Minimum or Query> Insert> Aggregate> Minimum to define the MIN(TOTAL).  

4. Click Run to run the query to display the minimum value. 

Exercise 3: 

In this exercise we are going to directly display the maximum value, to do so please follow the steps below. 

1. Select the TOTAL field. 

2. Right-click the TOTAL field. 

3. Select Aggregate> Maximum or Query> Insert> Aggregate> Maximum to define the MAX(TOTAL).  

4. Click Run to run the query to display the minimum value. 

5. Add a Count(*) to get the number of records. 
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6. Add another field from the SALES table or the SALESMAN table. 

7. Note the same information will be displayed however it will be sorted for each different value of the 
new field.  

8. Select the salesman name. 

9. Move the SALNAME field to the leftmost position. A GROUP BY statement is automatically added in 
the SQL followed by all fields that do not have an aggregate function. 
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Note: all the aggregate functions are calculated grouped by the field that does not have an aggregate function 
or all the fields that do not have an aggregate function. 

Exercise 4: 

1. Add another field, such as the CUST field (customer code). 
Note: the aggregate functions will apply to all the combinations between the Salesman name and the 
customer code. The row for Georges Dunel will appear for all his customers. 

2. Add a sort condition on the Salname fields to check that the total of the Count column gives 27. Or 
add a criteria on the Salname field = Georges Dunel. 

 
 

2.25. Working with Virtual and Calculation Fields 

Virtual fields are additional fields created in the query by the user and can be used in two ways. 

2.25.1. Working with Data Source Formula 

The formula must be understood by the host database and will be calculated by the host database, as if it was 
a table field. In this case it is possible to apply a sort condition because the job is performed by the host 
database SQL engine before sending the result to Click&DECiDE Builder. It may take more resources to send 
it to the host database server.  

Click&DECiDE Builder proposes a standard syntax for all the Host formula that will be translated according to 
the Host database syntax. Nevertheless, it is possible to use the Host database syntax written between single 
quotes and parenthesis and preceded by the word HOST as in the following example: 

Click&DECiDE Builder will use the following formula to concatenate two or more strings: 
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Concat( CUSTOMER."CP" , Concat('-' , CUSTOMER."COUNTRY" )): will translate it with the following 
syntax if the data source is an AS400 database: 

CUSTOMER."CP" concat '-' concat CUSTOMER."COUNTRY" 

However,you can write and use the AS400 syntax directly by writing the following native formula: 

HOST('CP Concat ''-'' Concat CITY') 

Note: you must write the single quote twice in the formula. 

2.25.2. Working with Click & DECiDE Formula 

The formula must be understood by Click&DECiDE Builder and will be calculated by the Click&DECiDE 
Builder SQL Engine on the PC side only when the result rows are sent by the host database. In this case it is 
not possible to apply a sort condition. However, the benefit of this option is that it uses less resource to the 
host database server and uses the PCs power. Another benefit is that some functions provided by 
Click&DECiDE Builder are not supported by the Host database, such as the “Cumul” function for example and 
so on. 

In both cases, criteria can be applied to a virtual field. 

Exercise 1:  

1. Create a query giving the final price for each product according to the given discount in the SALES 
DETAIL table linked to the PRODUCT table by the PRODREF field.  

2. Select the PRODUCT fields.  

3. Right-click. 

4. Select Add Formula... or select Query> Insert> Formula. The Formula Editor Dialog box appears. 

5. Define a name for the first virtual field. 

 

6. Enter a Name for the virtual field. 

7. Select the result Type if it is a Data Source formula.  

Note: if you select a Click and DECiDE formula, the type will be automatically be defined by 
Click&DECiDE Builder. 
 

Length: only applies to an output format to a database. 

Scale: only applies to an output format to a database. 

Comment: this is optional but can help you to remember what the purpose of the formula is. 

8. Click Generate... the Quick Expression property sheet appears. The Quick Expression property 
sheet allows you to easily edit your formula. 
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 Note: the proposed formula will depend on the option button you selected (Data Source or Click 
and DECiDE formula).  

 

9. Edit the above formula to get the required result. 

10. Select the Fields tab to select any field or virtual field already defined 

11. Select the Functions tab to select any function from any group (String, Mathematic, Date Time, 
Aggregation, Conversion and Misc). The purpose of each function appears in the Description panel. 

12. Select the Parameters tab to select any existing parameter. 

Note: when working in the Expression text box, you can use the  +, -, * buttons., when you use 
these buttons a default syntax is proposed with the §2 variable that will be replaced by your selection. 
The Next Variable button allows you to switch to the next §2 if it exists. 

13. Click the Expression button  to resize the Quick Expression property sheet. This enables you to 
enlarge the top or lower part of the screen.. The last size you defined for the property sheet will be 
saved and automatically displayed the next time you use the Quick Expression property sheet. 

Exercise 2: Use the Cumul Formula 

Among the available Click&DECiDE Builder internal functions, the CUMUL function is specific to 
Click&DECiDE Builder and allows you to obtain a cumulative value from one record to another record. 

1. Create a query on the SALES and SALESMAN tables. 

2. Select the SALNAME field (salesman name) and the TOTAL field.  

3. Apply an ascending sort to the SALNAME field.  

4. Add a Click and DECiDE virtual field named Cumulated Total with the following formula: 
CUMUL(SALES.”TOTAL”). 

5. Click Run to run the query: the Cumulated Total column will be displayed each time the TOTAL is 
cumulated with the value of the previous record (please see the screen shot below). 
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6. Note that when the value of the SALNAME field changes from Bill Raley to Diane Meyer, the 
Cumulated Total field does not reset to zero and displays cumulated values up to the end of the data 
grid result. This function also provides a reset to zero option as explained in the next exercise. 

Exercise 3: 

1. Modify the virtual field in the query you created for Exercise 2 above. 

2. Modify the virtual field with the following formula: 

Cumul(Sales.TOTAL, Salesman.SALNAME ) 

3. Click Run to run the query again. The Cumulated Total column will be displayed each time the 
TOTAL is cumulated with the value of the previous record. However, when the value of the SALNAME 
field changes, a reset to zero is performed (please see the screen shot below). 
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Exercise 4: Use the IF Formula 

Most databases now support the IF formula, however you can also run this function calculated by Click and 
DECiDE. To do so, please follow the steps below. 

1. Create a query on the PRODUCT table.  

2. Select all the fields. 

3. Click Run to run the query.  

4. Create a virtual field using the IF function in the Conditional group of the Functions Tab in the Quick 
Expression and select the following function. 

If (§Cond,§RetTrue,§RetFalse) where:  

§Cond will be the condition to evaluate. 

§RetTrue will be the result to be used if the condition is true. 

§RetFalse will be the result to be used if the condition is false. 

In this example, §Cond must be replaced with the following formula to search if the PRODUCT field 
contains the word “women”: Product.PRODUCT like '%women%' 

The §RetTrue will be replaced for example with the text ‘Woman bicycle’ 

The §RetFalse will be replaced for example with the text ‘Man bicycle’. 

The final formula is: IF( Product.PRODUCT like '%women%','Woman bicycle','Man bicycle') 
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Note: you can replace §RetTrue or §RetFalse with another IF function.  For example: 

IF( Product.PRODUCT like '%cruiser%','Cruiser bicycle', IF( Product.PRODUCT like 
'%racer%','Racer bicycle', IF( Product.PRODUCT like '%speed%','Speed bicycle','Other 
bicycle'))) 

 

2.26. Using Conversions commands on Fields 

Conversion commands are available in the context menu of a field, and allow you to automatically create a 
formula converting the field value. 

1. Create a query on the Sales table. 

2. Select the DATENUM field, right-click and select the YYYYMMDD to Datetime command: 

 

 

3. The dt_DATENUM formula is automatically created: 
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The following table shows provided conversion commands depending on the field type: 
(YYYY = year on 4 digits; MM = month on 2 digits; DD = day on 2 digits; WW: week number on 2 digits 

Field type Conversion function Sample  

String ToDecimal 

‘123.45’  123.45 

(the decimal separator is the one 
configured in the host database) 

Numeric 

Length min 

YYYYMMDD to Datetime* 20190327  3/27/2019 

Milliseconds to Datetime 
3763207114584  4/2/2019 3:18PM 
(NTP Epoch, milliseconds since 
January, 1st 1900) 

Seconds to Datetime 3763266395  4/3/2019 7:46AM 

HHMMSS to Time** 114803  11:48:03 

HHMM to Time** 1148   11:48 

YYYYWW to Datetime* 201913   3/24/2019 

Date 
Time 
Timestamp 

Date to Day of the Month 03/27/2019  27 

Date to Day of the Week Number 
03/27/2019  4 
(depending on the first day of the 
week in the host database) 

Date to Day of the Week Name 03/27/2019  Wednesday 

Date to Day of the Year 03/27/2019  86 

Date to Month Number 03/27/2019  3 

Date to Month Name 03/27/2019  March 

Date to Year 03/27/2019  2019 

Date to Week 03/27/2019  13 

Date to Quarter 03/27/2019  1 

Date to First Day of the Month 03/27/2019  3/1/2019 

*: YYYY = year on 4 digits, MM = month on 2 digits, DD = day on 2 digits and WW: week number on 2 digits. 
**: HH = hour on 2 digits, MM = minutes on 2 digits and SS = seconds on 2 digits. 

Note: Some conversion functions may not be available depending on the host database.  
In BAI version 19, they are provided for SQL Server and AS400. 

2.27. Using Dynamic Criteria with Parameters 

Click&DECiDE Builder enables you to customize a query using parameters instead of fixed criteria. This 
saves you from having to modify the criteria each time to obtain a different result. Each criterion can be 
associated with a value, a list of values, an input, an input list and so on. The user can enter or select the 
required values when running the query. Two steps are required to use parameters: defining a parameter and 
assigning a parameter. 

2.27.1. Defining a Parameter 

A parameter can be defined at the project level, or at the query level. A project parameter can be modified in 
one place instead of in several queries. The method of defining parameters is the same in both cases.  Please 
follow the steps below to define a parameter. Note the Query Parameters dialog box enables you to create, 
define, modify or remove any parameters. 
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2.27.2. Selecting an Existing Query Parameter 

To select an existing query parameter, please follow the steps below. 

1. Select Query> Parameters or click the  Query Parameters icon, the Query Parameters dialog 
box appears.  

2. Click the Name text box to display the drop-down list to select an existing parameter. 

3. Select an existing parameter from the Name drop-down list.  
Note:  the icon is not the same for a Local Query Parameter and a Project Parameter. 
 
Important: a Project Parameter can only be modified from the Project Parameter dialog box not 
from the Query Parameters dialog box. 

2.27.3. Creating a New Query Parameter 

To create a new query parameter, please follow the steps below. 

1. Select Query> Parameters or click the  Query Parameters icon, the Query Parameters dialog 
box appears.  

2. Either create a new parameter: 

a. If no parameters exist: 
Enter a name in the Name text box. 
Press Enter. 

b. If parameters already exist: 

Click the  New icon 
Enter a name in the Name text box. 
Press Enter. 

 

3. Create a new query using the Sales and Salesman tables. 
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4. Select the Area, Salname, Date and Total fields. 

5. Click the Parameter icon. In this example we are going to create the P_AREA parameter. 

 

6. Specify the Type according to the field type (String, Numeric, Date, Time or Timestamp). 

7. Select the Status. The Status is set to Enable by default. You can switch to Disable if the parameter 
is not used anymore but you want to keep it in the Query Parameters dialog box for use at a later 
date. 

8. Select an Update Method (default is undefined) among Value(s), Input, Input List, Input Query List, 
Formula, Query or User Property. Please see the next section for more details. 

Note: some Update Methods will display an option concerning the number of values that can be 
used in a parameter:  

• Multi-value: Yes if you accept several values to be entered separated by a semicolon,  
No: if the value must be unique. 

• Selection: select Single or Extended selection mode depending on if the user can select only 
one or more than one value. 

9. Customize the Title with the text to be displayed at the query’s runtime. 

10. Specify the Mandatory option: 
No: authorizes you to enter or modify the value by hand and authorizes the default value IGNORE 
(which is equivalent to selecting All Values).  
Yes: avoids you having to modify the proposed value(s) by hand and forbids selecting IGNORE for 
this parameter. 

11. Define the Default Value(s). Enter the value(s) for the parameter without quotation marks. If more 
than one value is required, use the semicolon “;” as separator. The default value can be IGNORE if 
the Mandatory option is set to No. 

12. Click the  icon in order to convert a query parameter into a new project parameter. 

2.27.4. Working with Update Methods 

It is possible to select from a range of different Update Method modes in the Query Parameters dialog box  

Value: enter the default value for the parameter without quotation marks. If more than one value is required, 
use the semicolon “;” as separator. The user will not be prompted with a question when running the query. 
However, this value can be changed later when assigning a query result to the same parameter or when using 
the VBScript macro language. 
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Input: the software will prompt the user with a question at run time. You can specify the Title to be displayed, 
the Mandatory option, the Default Value and if more than one value can be entered or not. If so, the user 
must separate each value with a semicolon “;”.When running the query you will be prompted to enter a value. 
Use a semicolon as a separator if Multi-value has been set to Yes and if you need the result for several 
values at the same time: 

 

 

Input List: the software will display a predefined list of values (values separated by a semicolon) or values 
from an ASCII List file previously created with Click&DECiDE Builder using the ASCII List output format. In 
this case, the first column must contain the field using the parameter as criteria. You can specify the Title to 
be displayed, the Mandatory option, the Editable option, the Default Value, the Value List, the Selection 
mode value and the Hide List’s First Column option if you want to hide the first column that will be explained 
later in this document with an example: 

 

 

2.27.5. Working with an ASCII File for the List of Values 

The list of values can be an ASCII file created by Click&DECiDE Builder. If the file retrieves the area list that 
you need then you should set the following in the Query Parameters dialog box (please see the screen shot 
below). 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

65 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

 

 

Value List: the AreaList.lst file used in this example could be an ASCII file created by Click & DECiDE Builder 
or created manually with the ASCII List file format structure. 

Note: each field must be between two straight quotation marks. If you need more than one field, use the 
comma, as a separator, as in the following example: 

ASCII List File with One Field: 

“ATLANTIC” 
“CENTRAL” 
“NORTH-WEST” 
“SOUTH” 
“WEST” 

In the above example, the unique column will be applied to the parameter on the Area field. 

ASCII List File with Two Fields: 

“AK”,”Alaska” 
”AL”,”Alabama” 
”AR”,”Arkansas” 
”AZ”,”Arizona” 
“CA”,”California” 
“CO”,”Colorado” 

In the above example, only the information from the first column: State will be applied to a parameter on the 
State field. The second column with the State Name is only here to give more information to the user. 

2.27.6. Creating the AreaList.lst File 

To create the area list.lst file used in the example above, please follow the steps below. 

1. Click File> Save As. 

2. Enter the following name for your query:  Query with parameters. 

3. Create a new query using the STATES table. 

4. Select the AREA field. 

5. Add an ascending sort condition. 
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6. Click the  icon 

7. Set the Distinct Records option to Yes in the Query Properties dialog box. 

8. Click Run to run the query. 

9. Select File> Save As. 

10. Enter the following name for the new query: area list. 

 

11. Select File> Export. 

 

12. Select ASCII List in the Select Output Format dialog box. 

13. Click OK. 

14. Click … Browse to select a destination directory and file name. 

 

Note: if the file already exists, the Action drop-down list will propose Erase file or Append.  
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15. Click OK to create or update the file.  

16. Go back to the Query with parameters query 

17. Open the Parameter dialog box.  

18. Select the P_AREA parameter. 

19. Replace the list of values ATLANTIC, CENTRAL, NORTH-WEST, SOUTH, WEST with the ASCII List 
file: C:\Users\Public\Documents\Click and DECiDE Samples\AreaList.lst 

20. Select Input Query List for the Update Method. A dialog box will be displayed:  where the user can 
enter a value or click the Search button to get values in real time. The values are the result of 
another Click&DECiDE Builder query.  

21. Specify the Title to be displayed; 

22. Select Yes or No for the Mandatory option, the Editable option, the Default Value. 

23. Click the … button to create a dynamic query or click the down arrow to select an existing query. In 
this example we will select the area list query previously created.  
Note: each time you run the query using the P_AREA parameter, the Area list will be displayed but 
this parameter will be a real time list of values. 

24. Select the Selection mode. 

25. Select Yes for the Hide List’s First Column option explained later in this document. 

 

2.27.7. Updating a Parameter using a Formula 

A parameter can be updated using a formula and depend on the value of another parameter. In this example 
we will be using the P_Numberofdays parameter. To update a parameter using a formula, please follow the 
steps below. 

1. Define the Title you want to appear in the dialog box, to ask the user to enter a number of days to be 
used in the formula feeding the last parameter "P_StartDate". 
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2. Create a new P_StartDate parameter of type Date. 

3. Note this will be updated with a formula using P_NumberOfDays: 

 

4. Apply this new parameter to the Date field using, for example, the “greater or equal to” operator. 

5. Click OK. 
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6. Note that when running the query, you will be prompted to enter a number of days and the Start Date 
will be calculated using the current date minus the number of days you specified. Note the example 
below for the last 7 days: 

 

 

2.27.8. Updating a Parameter with the Result of a Query Column 

A parameter can be updated by the result of a query column. For example a query can return a column and a 
row displaying whether a table is empty or not. If the parameter contains zero or NULL, there is no data; if the 
parameter contains a positive value, the table contains data. This parameter can be used later in a report to 
validate if the report must be run or not inside a Report book. Please refer to the section concerning Run 
Conditions in this document. 

 

2.27.9. Assigning a Parameter to a Field 

Once you have created one or several parameters, you must assign each parameter to the required field in 
the Criteria dialog box. If you forget this step, the parameter value will be prompted to the user but nothing 
will be applied to the field. 

To assign a parameter to a field, please follow the steps below. 

1. Open the Criteria dialog box. 

2. Select the required field. 

3. Select the appropriate operator according to the values that the parameter will provide. 

4. Select the Expression tab. 
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5. Either 

a. Enter the parameter name. 

 

b. Or click the Browse button. 
Select the Parameter tab. 
Double-click the parameter. 

 

6. Click OK. 

7. Click OK. 
Note: you can access the Parameters dialog box directly from the Criteria dialog box using the 
Parameters button. 

2.27.10. Assigning a Value to a Parameter 

It is also possible to assign the result of a column to a parameter. The result can be the first value, the last 
value or the sum of the values. A typical example of this feature is if you want to feed some parameters with a 
result that can be zero or a positive value. The parameter could for example be a default value equal to 1, but 
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a query can change this value with the result of a column. At a later date, a report could use this parameter 
value to be run or be ignored. To assign a value to a parameter, please follow the steps below. 

1. Create a first query on the SALES table. 

2. Create a new parameter named PDataExist. 

3. Select the Type as Numeric. 

4. Select the Update Method as Value(s). 

5. Select the Value(s) as 1. The default value is equal to 1. 

 

6. Add a parameter on the Date field. To enable you to easily run the query for the existing year to get 
data or without a year to get no data.  

 

7. Select SUM(Total). 

8. Insert a Count(*). This will mean that when you run the query for the year 2018, for example, you get 
a positive result for the Count(*) field. 
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For example, for a year such as 2015 zero will be returned. It is now possible to assign the result of the 
Count(*) or the Sum(Total) columns to the PDataExist parameter previously created. 

 

9. Select the Count column. 

10. Display the Properties. 

11. Click the right arrow in the Assigned Parameter text box. 

12. Select the PDataExist parameter. 

 

13. Select the Assigned Value.  
Note: the default value First Record is proposed, select one of the three options: First Record, Last 
Record or Sum of Records. In our example each result will be the same because we only get one 
row. However, in the case of a query returning several records, you need to select the appropriate 
Assigned Value for the condition you need. 
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14. Click Run to run the query, the PDataExist parameter, defined with a default value equal to 1, will 
take the result of the Count column, for example 104 for the year current year or 0 for the last year. 

Please see the Report section in this document for more information about how to use the value of this 
parameter to run the report only if this value if positive. 

2.27.11. Updating a Parameter with a User Property or User Group Property 

A User or User Group Property is defined in Administration Manager by the Administrator and allows to define 
one or several values that must be used in the Click&DECiDE Builder queries criteria for predefined Users 
and/or User Groups. (Refer to the Click & DECiDE Administration Manager User Guide for more 
information about how to create a Property). 

On the Click&DECiDE Builder queries criteria side, the method is the following: 

1- In the Query, open the Parameter Dialog Box 

2- Add a new Parameter 

3- Select the Type as required by the Property Type. 

4- Select the User Property as Update Method. 

5- Define Mandatory to Yes or No (Default value is No: if the Property is empty or doesn’t exist, the 
IGNORE value will be applied). 

6- Select the right arrow in the Parameter box to display the existing Property retrieved from the 
Administration Manager or enter manually the name of the Property you will have to create in 
Administration Manager. In the example below, propAREA is the Property name. 

 

Note: User Property parameters are available only when the datasource of the query is secured. 

7- Click OK 
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8- In the criteria dialog box, add the criteria for the concerned field as equal to this new parameter 
ParamProperty in the Expression Tab: 

 

9- Click OK 

10- Save the query. 

 

2.28. Using Dynamic Top with Parameters 

Note: refer to the section explaining how to define a Top value for a query. 

To use a dynamic Top value via a parameter, please follow the steps below. 

1. Create a new parameter, for example P_Top. 

2. Select the Numeric Type. 

3. Select Input List as Updated Method. 

4. Select Single Value Selection. 

5. Enter the default value you need (IGNORE or a numeric value). 

6. Enter the list of values you want to be proposed. 

7. Set the Mandatory option to Yes and the Editable option to No if you want to avoid the IGNORE 
value. The user will then have to use one of the proposed values, which will limit the data requested 
from the data source. 
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8. Copy the Parameter Name, in this example P_Top, to the clipboard. 

9. Click OK. 

10. Close the Parameter dialog box. 

11. Open the Query Properties. 

12. Paste the Parameter Name in the First Records text box. 

 

13. Click Run to run the query. 

14. Select the required value for the Top function. 
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Note: if Number of Records in Data Grid is set to 50 and you ask for a Top N Amount = 100, only 50 
records will be returned in the data grid, but up to 100 records will be returned in any other output format, 
when printing the query or the report based on this query, or when running the cross-table based on this 
query. 

2.29. Using Parameters in Native Joins 

You can use parameters in the native FROM clause with the following syntax:  

{d7p <parameter name>} 

In the following sample, in the first join conditions, the Category.FAMILY field must be equal to the value of 
the P_FAMILY parameter: 
 

 

Note: Parameters used in native FROM clause must be configured as mandatory (IGNORE value is not 
supported). 

2.30. Using Formula in Column Header  

You can use formula for defining a dynamic column header. 

Exercise: In this exercise, we are going to create a query in order to get the total amount by area and by 
salesman for the current year and the last year. The header of these 

1. Create a query from the SALESMAN and SALES tables, with a join on the SAL field. 

 

2. Select the fields AREA and SALNAME. 

3. Select the DATE field in the Sales table, right-click and select the Date to Year conversion command 
in order to create the new virtual field DATE_year containing the year of sale. 
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4. Create the new numeric virtual field Amount_CurrentYear and  containing the Total if the sale has 
been done this year: 

 

5. In the same way, create the new numeric virtual field Amount_LastYear containing the Total if the 
sale has been done last year: 
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6. Select the Amount_CurrentYear field, right-click and select Aggregate > Sum: 

 

7. Select the Amount_LastYear field, right-click and select Aggregate > Sum. 

8. Click on Query > Group By… and check in the Group By… dialog that only the fields AREA and 
SALNAME are grouped (remove the other fields in the list if needed): 
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9. Replace the default column header for the Sum_Amount_CurrentYear field with a formula returning 
the current year: 
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Note: You cannot use query fields in formula defining a column header. 

10. Replace the default column header for the Sum_Amount_LastYear field with a formula returning the 
current year: Str(Year(Now())-1 ,4,0) 

11. Run the query for displaying sales grouped by area and salesman, with Total summed for this year 
and last year. Column headers to total sums are dynamically calculated: 

 

 

2.31. Using an Advanced Query Function: UNION Statement 

Another way of getting a result from two or more tables without needing to create a join condition is to use the 
UNION statement between two or more queries. 

Important: to use the UNION statement you must respect the following rules 
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• The number of fields in each query must be the same. 

• The field type in the same column must be the same (character with character, numeric with numeric 
and so on). 

• The main query can have sorted fields and/or virtual fields. 

• The called queries cannot have sorted fields or virtual fields. 

Note: by default the UNION will apply a DISTINCT statement to the result (unless you apply a UNION 
ALL). 

Note: an ascending sort is performed by default on the first left field unless you apply another sort 
condition in the main query. 

2.31.1. Inserting a UNION 

To use a UNION statement, please perform the steps below. 

1. Create a single query on the SALESMAN table. 

2. Selecting from left to right the following fields SAL, SALNAME and AREA.  

3. Apply a sort to the SALNAME field.  

4. Select Query> Union> Insert>. 

5. Create another single query on the CUSTOMER table.  

6. Select a numeric field and two character fields because the first main query had these features. For 
example, select the fields CUST, CUSTNAME and CITY.  

7. Modify the heading text in the main query for each column so that the new text applies to all the 
columns (please see the screen shot below). 

 

Note: in the previous example the SALESMAN and CUSTOMER tables cannot be joined because no fields 
correspond in both tables. However, by using the UNION you can retrieve data from both tables. 

Important: several UNION type statements exist even if they are not all supported by all databases. The most 
common are the UNION and UNION ALL statements. By default the UNION statement will apply a DISTINCT 
statement, eliminating duplicate records, and the UNION ALL statement will keep duplicate records if they 
exist. 

2.31.2. Changing the UNION Type 

To change the UNION type, please follow the steps below. 

1. Select Query> Union> Edit>. 
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2. Click the UNION statement several times to display the other possibilities: UNION ALL, INTERSECT, 
INTERSECT ALL, MINUS, MINUS ALL.  
Note: the MINUS statement is known under the word EXCEPT by some databases. 

3. Combine or ungroup several queries by adding parenthesis levels. 

 

Please refer to the Online Help for more information, press F1 in the Union dialog box. Example: 

Query1 

 

Query2 UNION 
ALL 

UNION MINUS  
ALL 

MINUS INTERSECT 
ALL 

INTERSECT 

1 1 1 1 1 2 1 1 

1 1 1 2 2 5 1 3 

1 3 1 3 2  3 4 

2 3 1 4 2  4  

2 3 1 5 4    

2 3 2  5    

3 4 2      

4  2      

4  3      

5  3      

  3      

  3      

  3      

  4      

  4      

  4      

  5      

 

2.32. Creating Alert after running a Query 

The Alerts are described in the ClicknDECiDE_BAI_Report_User_Guide.pdf but since Click&DECiDE version 
12 you also can define an Alert in a Query or a Cross-table. This alert will be run once the query (or the 
Cross-table) has been run. To define a new Alert for a query, click the command View > Alerts to display the 
Alert Tab: The Post Run Event Alert will appear, ready to be defined: 
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Refer to the ClicknDECiDE_BAI_Report_User_Guide.pdf Manual for more details about how to configure 
all kinds of alerts. 

2.33. Creating a Cross Table from a Query 

To create a cross-table from a query, please follow the steps below. 

1. Select Query> Create Cross Table or click the  Create Cross Table icon to create a Cross Table.  

2. Refer to the Click&DECiDE Cross Tables Manual. 

2.34. Creating a Report from a Query 

To create a report from a query, please follow the steps below. 

1. Select Query> Create Report or click the  Create Report icon to create a Report.  

2. Refer to the Click&DECiDE Reports Manual. 

2.35. Creating a Data Source’s SQL from a Query 

To create a data source’s SQL from a query, please follow the steps below. 

1. Select Query> Create Data Source’s SQL or click the  Create Data Source’s SQL icon to create 
Native SQL.  

Note: this command is reserved to Advanced User and is not explained in this Manual. 

2.36. Modifying the Application’s Look 

To modify the look of your Click&DECiDE Builder, for example to change it from blue to grey, please follow 
the steps below. 

1. Select View> Application Look. 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

84 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

 

 

2. Select the Style you want. The selected look will also apply to other Click&DECiDE modules such as 
Administration Manager and Model and so on, according to the Edition you are using. 

 

3. Working with Project Options 

3.1. Defining Project Options 

Once a project has been created or opened; it is possible to define specific options for it. To do so, please 
follow the steps below. 

1. Select Tools> Project Options. 

2. Select the Enable Project Protection check box to define a password for your project. 

3. Enter the Password and confirm it 
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Note: if you want to remove a password later, clear the Enable Project Protection check box and click 
OK to confirm. The password will be deleted immediately. 

4. Click the Types/Categories tab. 

 

The Types and/or categories displayed are depending on the Project file but also on your license type. 

For example if your license is limited to BAI Type, you only can run, open or modify a Project containing at 
least this BAI Type. When you create yourself a new project file, you are prompt o specify which type or 
category you want to apply to this project file. 

5. Click the Event Log tab.  

6. Select the Generate events check box if you want events to be sent to the Event Viewer each time a 
query, report or cross-table is exported or printed.  

 

 

Note: this option is not relation to the Event Manager tab described earlier in this document which is 
displayed when you select Tools> Options in Click&DECiDE Builder (only available in the Enterprise 
Edition).  

7. Select the Properties tab. 

8. Enter the Name you want to display for the project in the Web Portal. For example the project file 
name on the disk is “Sales Statistics Development.wfv” but the visible name in the Web Portal could 
be “Company Sales Statistics”. 
Note:  the project properties will only be seen in the Web Portal when the project is visible by the 
users in a Shared Folder. Please refer to the section concerning the Web Portal further on in this 
document. 
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9. A default Model (Report Template) appears for this query. You can change it for another Report 
Template proposed by default with Builder or use a customized Report Template you have created 
with Builder. Refer to the “ClicknDECiDE_BAI_Report_User_Guide.pdf” for more information about 
the Report Templates. 

10. Click the Browse button to select another Report Template (or specify “No Template”): 

 

 

3.2. Using the About Click&DECiDE Command 

When you select Help> About Click&DECiDE the About Click and DECiDE dialog box appears. This dialog 
box displays your current Click&DECiDE version, release and the build number. This can be useful for any 
support requests. 

 

In the above example, the first row displays the version number 19.0 and the build number 7017. 
The second row displays the version number 19.0, the build date 20190319 and the release number 0. 

If necessary, you may be asked by the Technical Support Team to click the Details button to get more 
information about installed components and your windows environment. You can also generate a file named 
d7infos.d7i that can be sent to your Support Provider if necessary (recommended). 
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Click Send Mail... to automatically send the d7infos.d7i file to your support provider or click Export... to 
create and save the file so that you can send it later. 

 

4. Working with the Tools Options Property Sheet 

Once Click&DECiDE Builder is started, select Tools>Options to display the Options property sheet to 
customise default options. 

4.1.1. Working with the General Tab 

 

Show information about Click and DECiDE: displays information when starting the program and checks if a 
new version is available.  
Note: this check box cannot be removed with the Express Edition. 

Automatically open last project used: this option allows Click&DECiDE Builder to open the last project used 
when you launch Click&DECiDE Builder.. 

Show full path in the title bar: this is useful when you start Click&DECiDE Builder twice and are working 
with two different project files as you can see the full path and project name in the title bar. 
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Default Template for Query for New Project: you can specify here which Report Template for Query has to 
be used for any new Project you will create. You also can specify “No Template” if needed. 

Local default export directory: specify here the default export directory for HTML or PDF output formats. A 
sub-directory with the current project name will be added in this path. 

 

4.1.2. Working with the Query Tab 

 

Use Field Description as Heading: this option can be used if you want to use the Description of the data 
source table column instead of the column name (if this description exists of course) as a column Heading in a 
new query. 

Show Data Source’s SQL: this option can be used temporarily to display the native SQL sent to the 
database when running a query. This can help you understand how your query is translated into SQL or to 
look for a problem. 

Display table name to the right of the Alias name: this option can be used to add the table name after the 
Alias name. It was useful when the Alias Name used prefixes such as T1, T2 and so on, however it should no 
longer be used with Click&DECiDE version 10 or greater. 

Link Tables Automatically: this option can be disabled if you no longer wish to have automatic joins when 
creating a new query with more than one table. 

Number of records in a New Query’s Data Grid: this option proposes a default TOP value when you run a 
query in the Data Grid, to check if the query is working correctly. In this case you do not need to retrieve all 
the data. This default TOP value can be changed here or removed if you do not want to use it. This TOP value 
has no effect when you export data to any output format or when you run a report or a cross-table. It is only 
used as a preview in the data grid. Please see the section concerning Applying a Top Value. 

Top Records for Criteria Browse Values: this option proposes a default TOP value when you run are 
searching online existing values in the criteria dialog box for a field. The default value is 1000. 

  

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

89 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

 

4.1.3. Working with the Cross-table Tab 

 

When printing or exporting a cross-table that you have already run in Click&DECiDE Builder, you may decide 
that you do not always want to refresh your data, as it is already stored in a file with the *.vpd extension and 
the same name as the project name. 

Display a message to refresh cross-table data: select this check box if you want to display a message 
asking you if you want to refresh the data, each time you print or export a cross-table. 

Refresh Data: select this check box to ensure that cross-table data is always refreshed.   
 

4.1.4. Working with the Event Manager Tab 
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By default, Click&DECiDE Enterprise Edition is installed with an engine that will manage the Alerts that can be 
generated by a report or by a scheduled task. If the option “Send events to the Event Manager” is disabled, 
this engine is stopped. 

If you want to store events for debugging purpose or in order to get statistics about how the Web Portal is 
used, you can select the following check boxes in the Events Source section: Web Portal, Project, Query and  
Query.  

For getting statistics, select Web Portal and Query event sources. When these event sources are selected, 
the Administrator can run the following reports which are installed by default by the Enterprise Edition in the 
Web Portal: Web Portal Statistics (Daily), Web Portal Statistics (Monthly), Connections on a period, SQL 
Query on a period and Items Run on a Period. 

For a detailed description on all generated events (only for advanced users), please contact us.  

Note that the above screen can be changed only if you have the Administrator rights on your computer, when 
you try to change the options from a Builder installed in standalone. Note also that the Express Edition license 
will display this Event Manager dialog greyed and not modifiable. 

4.1.5. Working with the License Tab 

 

This screen displays your license information, such as:  

• Company Name 

• Click&DECiDE Edition installed 

• Version Number 

• Builder CAL user(s) (Client Access License) 
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• Web Portal CAL user(s) (Client Access License) 

• Web Portal Concurrent Users 

• The project types you can use with this license. (BAI, NSI etc.) 

• Workflow (the Events Manager Engine only for the Enterprise Edition). 

 

Note: if you are under Support Agreement, the expiry date is displayed. 
Note: if the license certificate is not a permanent license, the expiry date is displayed. 

Under the above Server license, you can see some other information about the Web Portal license: 

The Web Portal License is corresponding to the part downloaded to a client workstation when a user is 
starting Web Builder. This is the part of the license the User will see inside the command Tools > Options > 
License from the Click&DECiDE Builder: 

 

 

5. Exporting to an Output Format 

5.1. Working with Customizable Output Formats 

Up to now, you have run queries in the Click & DECiDE data grid,  to check the result according to the criteria 
defined, join conditions,  sort conditions and so on. To export data to an output format, please follow the steps 
below.  

1. Select File> Export or click the  Export icon to display the Click and DECiDE Output Format 
Configuration dialog box with all the output formats supported by Click&DECiDE Builder. 
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2. Select Tools> Output configuration to add, modify or remove an output format. 
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3. Select in the context menu Properties… to customize an output format as appropriate 
Note: the configuration will differ according to each category. 

4. Select the Format tab. 

5. Configure the Date, Time, Timestamp and Number Format as appropriate. 

 

Note: usually the format defined in the query column header will be use by default when exporting data, 
unless you have defined a specific format in your output format and selected the Use these formats 
instead of those defined in the query check box. 

6. Select the Option tab. 

7. Define the File Directory, the Default Extension, the File Filter and the Data Format Encoding 
(according to the Output Format in question). 
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8. Select the File tab. 

9. Configure the file structure, the Space management. 

10. Select the Set headings check box if you want to use column headers. 

 

11. Select the Header tab. 

12. Enter the values for the file’s Header structure. 

 

13. Select the Data tab. 

14. Configure the file’s data structure. 
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15. Select the Wildcard Character tab. 

16. Define how you want certain special characters in your data to be translated. 

 

5.1.1. Working with the Excel DDE Output Format 

For the Excel DDE category, the Macro Tab will contain: 

 

The Command line will depend on your Excel.exe location. The Macros will depend on the language of your 
Excel program. Then the DDE Tab will contain: 
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Note that the field separator can depend on your regional settings. 

The Application Loading or Poke Data Timeout can be increased if necessary. 

The Set Headings allows to send the Header row before the data in the Excel destination. 

Then the Options Tab will contain the Reference to the Row and Column Cell Letters used by your Excel 
program according to the Excel language to specify the cell addresses (A1 is represented in Excel DDE by 
Row 1 and Column 1, as R1C1 for an English Excel). Sheet1 is the default Sheet Name. 

 

The Row and Column Cell Letters can change according to your Excel language: for more detail refer to the 
Online Help by pressing F1 in Click&DECiDE Builder or click this link: 

http://help.clickndecide.com/Helps/Vision_Help/d7vision.htm#viscore\HIDX_CONFIG_OUTPUT.htm 

 

5.1.2. Working with the Excel XLS and XLSX Output Formats 

For the Excel XLS output format type, the Option tab is specific to Excel 97 and to Excel 2003: 
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Note: you can apply an Excel file as a Model (Template) with, for example, your company logo, look & feel 
and so on, please note that this is optional. 

For the Excel XLSX output format type, the Option tab is specific to Excel 2007 or later version: 

 

Model: you can apply an Excel file as a Model (Template) with, for example, your company logo, look & feel 
and so on, please note that this is optional. 

Write Mode: for all Excel native format (Excel XLS and Excel XLSX), the [write mode] defined after the 
destination cell can be one of the following: (always in English and in CAPITAL letters). 
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[ERASEFILE]: deletes the destination Excel file if it exists and creates a new one using a Model if defined. 

[ERASEDATA] or [ERASESHEET]: keeps the destination Excel file but removes all the data from all the rows 
in the destination Sheet, without modifying the other sheets. 

[REPLACE]: adds data to an existing Excel file by partially or totally replacing existing data, from within the 
destination cell in the specified Sheet. (Not available for Excel XLSX Big Data). 

[INSERT]: adds data to an existing Excel file by inserting rows from the destination cell. Existing data in the 
destination cell or below the destination cell is kept but moved to the base of the same Sheet. (Not available 
for Excel XLSX Big Data). 

Set headings: each output format can be defined with headings enabled or not. You can thus create two 
formats for the same output, one with headings, the other without. 

Excel XLSX Big Data: this option is specific to Excel 2007 or later version. This output format uses less 
memory as data are sent without formatting (Raw Data Mode) and is faster. It is recommended for big volume 
or if you get trouble with the standard Excel XLSX output format. 
Also note that only the ERASEFILE or ERASESHEET write modes describe bellow can be used with the 
Excel XLSX Big Data output format. 

5.1.3. Working with the Local SQL Server Output Format 

The Local SQL Server output format allows you to send data to your local SQL Server. You also can create 
a new output format to send data to any database which is already a data source defined in your 
Administration Manager. To do so, please follow the steps below. 
 

1. Double-click the Local SQL Server icon, the Local SQL Server Properties property sheet appears. 

 

2. Select the Connection tab. 

3. Note all the existing data sources are displayed. 
Note:  you cannot export data to a data source secured by Click&DECiDE, for security reasons. 

4. Select the Option tab to view the parameters that you can modify. 
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5. Select the Use Bulk Copy to allow faster export.  
Warning:  do not select this option for old versions of MSDE if you have too many columns; for 
example, the limit is 90 columns for SQL Server 2000. 

5.1.4. Saving the Output Configuration to the Database 

When exporting a query to a database, you can modify and save the settings you have configured for the 
target table (column names, length, decimal and so on). To do so, please follow the steps below. 

1. Export a query, for example the demo multi criteria query (from the Click and DECiDE 
Demonstration.wfv file) to the Local SQL Server database output format. 

 

2. Click OK. 

 

3. Click Browse to search for the full destination path for the target table. 
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4. Select a folder. 

5. Enter a new table name if necessary. 

 

6. Click Check Table Presence if you are not certain if it is a new table. 

7. Select the Description tab. 

8. Configure the column names and sizes: 
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9. Select the Users tab. 

10. Add authorization for other users. 
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11. Select the Options tab. 

12. Select the check boxes as appropriate. 

 

13. Click Load/Save in any of the tabs in the Database Output property sheet to save (or load next time) 
the configuration previously defined when exporting this query to the table. 

 

14. Enter the File Name. 
Note: next time you have to send data again to this table, from the same query, you can load this 
configuration, and then modify the Destination tab to specify if you want to append data, delete data 
or delete and create the table again. 
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15. Save the new configuration if you need to use it later. 

16. Note that you can schedule a task that will send data to a Database output format. Refer to the 
online manual “ClicknDECiDE_BAI_Web_Portal_User_Guide.pdf”. 

5.1.5. Working with the ASCII Category Format 

When editing a query in Click&DECiDE Builder, you can display the query properties as follows. 

 

This option allows you to specify your own column size in the ASCII file instead of using the default column 
length. For example a Float Type will generate a column with 15 digits. If you only want 10 as width, enter 10 
in this box. 

Exercise 3: Open your query Exercise 1 and export the data to several output formats and check the result. 
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5.1.6. Working with Atom output format 

This format is used most of the time through the Web Portal and Menu Builder. This format allows the Web 
Portal Users to copy a special link that can be paste into Excel to define some Power Pivot or Power View 
depending on the version of Excel. 

Please refer to the ClicknDECiDE_BAI_Web_Portal_User_Guide_V2015.pdf for more information about the 
use of this feature. 

5.1.7. Working with the Google Data Table output format 

This format is used to create or update files containing data that can be read by a Dashboard Application. 
Some examples of these files having “.gcd” extension are installed with Click&DECiDE Enterprise Edition and 
used by the Dashboard Charts samples. 

 

Please refer to the ClicknDECiDE_BAI_Web_Portal_User_Guide_V2019.pdf for more information about the 
use of this feature. 

5.1.8. Working with Predefined Output Formats 

Click&DECIDE Builder also provides two predefined output formats such as HTML and PDF (Acrobat 
Reader). 

Select File> HTML> Preview to check the HTML result of your report. 

Select File> HTML> Publish to Web Portal to export your query or report to an HTML format that can be 
read in the Web Portal (only available with the Professional or Enterprise Edition). 

Select File> Print to PDF to export your query or report to an Acrobat Reader (PDF) format. 

Select File> Print Preview to display a preview of your query or report. 

Select File> Print or press Ctrl+P to send your query or report to the printer you want. 

 

6. Working with Date Keywords 

6.1. Invariant Predefined Functions 

Invariant functions are keywords or expressions that are understood by Click&DECiDE whatever your 
computer language. 

INVARIANT PREDEFINED FUNCTIONS 

Function 
Range 
for x 

Comment 

HOURS (Note: in INVARIANT mode, hours is always written in plural even if the value is x=0 or x=1). 

x hours ago   0 - 12 
The date time interval from the beginning of the hour specified in the past 
from XX:00:00 to XX:59:59. 

in x hours 0 - 12 
The date time interval from the beginning of the hour specified in the future 
from XX:00:00 to XX:59:59. 

since x hours 0 - 12 
The interval from the beginning of the hour specified in the past at 
XX:00:00 up to now. 

until x hours 1 - 12 
The interval from now to the end of the hour specified in the future at 
XX:59:59. 

DAYS (Note: in INVARIANT mode, days is always written in plural even if the value is x=0 or x=1). 

x days ago   0 - 7 The date of the day specified in the past from 00:00:00 to 23:59:59. 

in x days 0 - 7 The date of the day specified in the future from 00:00:00 to 23:59:59. 
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since x days 0 - 7 
From the beginning of the date of the day specified in the past from 
00:00:00 up to now. 

until x days 1 - 7 
From now up to the end of the date of the day specified in the future at 
23:59:59. 

WEEKS (Note: in INVARIANT mode, weeks is always written in plural even if the value is x=0 or x=1). 

x weeks ago   0 - 7 
The date interval for the week specified in the past from YYYYMMDD 
00:00:00 to YYYYMMDD 23:59:59. 

in x weeks 0 - 7 
The date interval for the week specified in the future from YYYYMMDD 
00:00:00 to YYYYMMDD 23:59:59 . 

since x weeks 0 - 7 
From the beginning of the first day of the week specified in the past at 
00:00:00 up to now. 

until x weeks 1 - 7 
From now to the end of the last day of the week specified in the future at 
23:59:59. 

MONTHS (Note: in INVARIANT mode, months is always written in plural even if the value is x=0 or x=1). 

x months ago   0 - 12 
The date interval for the first day of the month specified in the past from 
YYYYMM01 00:00:00 to YYYYMM31 23:59:59. 

in x months 0 - 12 
The date interval for the first day of the month specified in the future from 
YYYYMM01 00:00:00 to YYYYMM31 23:59:59. 

since x months 0 - 12 
From the beginning of the first day of the month specified in the past at 
00:00:00 up to now. 

until x months 1 - 12 
From now up to the end of the last day of the month specified in the future 
at 23:59:59. 

QUARTER (Note: in INVARIANT mode, quarters is always written in plural even if the value is x=0 or x=1). 

q1 or Q1  
Uses the date interval for the First Quarter of the current year from  
YYYY0101 00:00:00 to YYYY0331 23:59:59. 

q2 or Q2  
Uses the date interval for the Second Quarter of the current year from 
YYYY0401 00:00:00 to YYYY0630 23:59:59. 

q3 or Q3  
Uses the date interval for the Third Quarter of the current year from 
YYYY0701 00:00:00 to YYYY0930 23:59:59. 

q4 or Q4  
Uses the date interval for the Fourth Quarter of the current year from 
YYYY1001 00:00:00 to YYYY1231 23:59:59. 

x quarters ago 1 - 4 
The date interval for the first day of the quarter specified in the past from 
YYYYMM01 00:00:00 to the last day of the same quarter at YYYYMM31 
23:59:59. 

in x quarters 1 - 4 
The date interval for the first day of the quarter specified in the future from 
YYYYMM01 00:00:00 to the last day of the same quarter at YYYYMM31 
23:59:59. 

qx 1990 <---> qx 2030 1 - 4 

Uses the date interval for the specified Quarter of the specified year from 
YYYY0101 00:00:00 to YYYY0331 23:59:59. (Note that the year can be 
between 1990 and 2030 in the current Click&DECiDE version 11.1.0 or 
greater). 

YEARS (Note : in INVARIANT mode, years is always written in plural even if the value is x=0 or x=1). 

x years ago   0 - 10 
The date interval from the first day of the year specified in the past at 
YYYY0101 00:00:00 to YYYY1231 23:59:59. 

in x years 0 - 10 The date interval from the first day of the year specified in the future at 
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YYYY0101 00:00:00 to YYYY1231 23:59:59. 

since x years 0 - 10 
From the beginning of the first day of the year specified in the past at 
YYYY0101 00:00:00 up to now. 

until x years 1 - 10 
From now up to the end of the last day of the year specified in the future at 
YYYY1231 23:59:59. 

 

6.2. Standard Days and Months Functions by Language 

In the following table the first column is the same for Invariant or English, other available languages can be 
used according to your computer language: 

Invariant 
and English %s is a French German Spanish Catalan Italian Swedish 

Days  Jours Tags Dias Dies Giorni Dagar 

DAY FROM LAST WEEK 

last %s 
Day 
name 

%s semaine 
dernière 

%s letzter 
wochse 

%s semana 
pasada 

%s setmana 
passada 

%s settimana 
scorsa 

%s förra 
vecka 

DAY ON NEXT WEEK 

next %s 
Day 
name 

%s en huit 
%s kommender 
woche 

%s semana 
próxima 

de %s en 
vuit 

%s settimana 
prossima 

%s nästa 
vecka 

NEXT COMING DAY 

coming %s 
Day 
Name %s prochain nächster %s próximo %s proper %s %s prossimo nästa %s 

LAST MOST RECENT DAY 

most recent 
%s 

Day 
Name %s dernier letzter %s %s pasado %s passat %s scorso i %ss 

SINCE A DAY 

since %s 
Day 
Name depuis %s seit %s desde %s des de %s da %s sedan %s 

UNTIL A DAY 

until %s 
Day 
Name jusqu'a %s bis %s hasta %s fins %s fino a %s till %s 

Months  Mois Monaten Meses Mesos Mesi Månader 

NEXT MONTH ON NEXT YEAR 

next %s 
Month 
Name 

%s année 
prochaine 

%s 
kommendes 
Jahr 

%s año 
próximo 

%s proper 
any 

%s anno 
prossimo 

%s nästa 
året 

MONTH OF PREVIOUS YEAR 

last %s 
Month 
Name 

%s année 
dernière 

%s letztes jahr 
%s año 
pasado 

%s any 
passat 

%s anno 
scorso 

%s förra 
året 

NEXT COMING MONTH 

coming %s 
Month 
Name 

%s prochain nächster %s próximo %s proper %s %s prossimo nästa %s 

MOST RECENT MONTH 

most recent 
%s 

Month 
Name 

%s dernier letzter %s %s pasado %s passat %s scorso i %ss 

SINCE A MONTH 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

107 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

 

since %s 
Month 
Name 

depuis %s seit %s desde %s des de %s da %s sedan %s 

UNTIL A MONTH 

until %s 
Month 
Name 

jusqu'en %s bis %s hasta %s fins %s fino a %s till %s 

 

6.3. Other Hour Functions by Language 

Invariant 
and 
English 

Range 
for x 

French German Spanish Catalan Italian Swedish 

HOURS   HEURES STUNDEN HORAS HORES ORE TIMMAR 

last hour  dernière heure Letzte Stunde hora anterior 
hora 
anterior 

ultima ora förra timmen 

this hour  cette heure  Diese Stunde   esta hora 
aquesta 
hora 

quest ora denna timme 

next hour  
prochaine 
heure 

Nächste 
Stunde 

hora 
siguiente 

hora 
següent 

prossima 
ora 

nästa timme 

0 hours ago   
/  this hour 

 
il y a 0 heures 
/ cette heure 

Vor 0 Stunden 
/ Diese 
Stunde 

hace 0 horas 
/ esta hora 

fa 0 hores / 
aquesta 
hora 

0 ore fa  / 
quest ora 

0 timmar 
sedan / 
denna timme 

1 hour ago   
/  last hour 

 
il y a 1 heure / 
dernière heure 

Vor 1 Stunde / 
Letzte Stunde 

hace 1 hora / 
hora anterior 

fa 1 hora / 
hora 
anterior 

1 ora fa / 
ultima ora 

1 timme 
sedan / förra 
timme 

x hours ago   2 - 12 il y a x heures Vor x Stunden hace x horas fa x hores x ore fa   
x timmar 
sedan   

in 0 hours   /  
this hour 

 
dans 0 heures 
/ cette heure 

In 0 Stunden / 
Diese Stunde 

en 0 horas / 
esta hora 

en 0 hores / 
aquesta 
hora 

in 0 ore / 
quest ora 

om 0 timmar / 
denna timme 

in 1 hour   /  
next hour 

 
dans 1 heure / 
prochaine 
heure 

In 1 Stunde / 
Nächste 
Stunde 

en 1 hora / 
hora 
siguiente 

en 1 hora / 
hora 
següent 

in 1 ora / 
prossima 
ora 

om 1 timme / 
nästa timme 

in x hours 2 - 12 dans x heures In x Stunden en x horas en x hores in x ore om x timmar 

since 0 
hours   /   
since this 
hour 

 
depuis 0 
heures 

Seit 0 
Stunden 

desde 0 
horas 

des de 0 
hores 

da 0 ore 
sedan 0 
timmar 

since 1 hour   
/   since last 
hour 

 

depuis 1 
heure / depuis 
la dernière 
heure 

Seit einer 
Stunde / Seit 
1 Stunde 

desde 1 hora 
/ desde la 
hora anterior 

des d'1 hora 
/ des de 
l'hora 
anterior 

da ultima 
ora / da 1 
ora 

sedan sista 
timme / 
sedan 1 
timme 

last x hours 2 - 12 
depuis x 
heures 

Seit x 
Stunden 

desde x 
horas 

des de x 
hores 

da x ore 
sedan x 
timmar 

until 1 hour  
jusque dans 1 
heure 

Bis einer 
Stunde / Bis 1 
Stunde 

hasta 1 hora 
/ hasta la 
hora 
siguiente 

fins 1 hora / 
fins l'hora 
següent 

fino a 1 ora / 
fino a ora 
prossima 

till 1 timme 

until x hours 2 - 12 
jusque dans x 
heures 

Bis x Stunden 
hasta x 
horas 

fins x hores fino a x ore till x timmar 
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6.4. Other Day Functions by Language 

Invariant 
and English 

Range 
for x 

French German Spanish Catalan Italian Swedish 

DAYS   JOURS TAGS DIAS DIES GIORNI DAGAR 

yesterday  hier Gestern  ayer ahir ieri igår 

today  
aujourd'hui  / 
ce jour 

Heute hoy avui oggi idag 

tomorrow  demain Morgen mañana demà domani imorgon 

0 days ago   /   
today 

 
il y a 0 jours / 
aujourd'hui  / 
ce jour 

Vor 0 
Tagen / 
Heute 

hace 0 días 
/ hoy 

fa 0 dies / 
avui 

0 giorni fa / 
oggi 

0 dagar 
sedan / idag 

1 day ago    /   
yesterday 

 
il y a 1 jour / 
hier 

Vor 1 Tag / 
Gestern 

hace 1 día  / 
ayer 

fa 1 dia / 
ahir 

1 giorno fa / 
ieri 

1 dag sedan 
/ igår 

x days ago 2 - 7 il y a x jours 
Vor x 
Tagen 

hace x días fa x dies x giorni fa 
x dagar 
sedan 

in 0 days  /  
today 

 
dans 0 jours / 
aujourd'hui  / 
ce jour 

In 0 Tagen / 
Heute 

en 0 días / 
hoy 

en 0 dies / 
avui 

in 0 giorni / 
oggi 

om 0 dagar / 
idag 

in 1 day   /   
tomorrow 

 
dans 1 jour / 
demain 

In 1 Tag / 
Morgen 

en 1 día / 
mañana 

en 1 dia / 
demà 

in 1 giorno / 
domani 

om 1 dag / 
imorgon 

in x days 2 - 7 dans x jours In x Tagen en x días en x dies in x giorni om x dagar 

since 0 days   
/ since today 

 
depuis 0 jours / 
depuis ce jour / 
depuis aujourd'hui 

Seit 0 
Tagen / Seit 
Heute 

desde 0 
días / desde 
hoy 

des de 0 
dies / des 
d'avui 

da 0 giorni / 
da oggi 

sedan 0 
dagar / 
sedan idag 

since 1 day   
/  since 
yesterday 

 
depuis 1 jour / 
depuis hier 

Seit 1 Tag / 
Seit 
Gestern  

desde 1 día 
/ desde ayer 

des d'1 dia 
/ des d'ahir 

da 1 giorno / 
da ieri 

sedan 1 dag 
/ sedan igår 

last x days 2 - 7 depuis x jours 
Seit x 
Tagen 

desde x 
días 

des de x 
dies 

da x giorni 
sedan x 
dagar 

until 1 day    /  
until 
tomorrow 

 
jusque dans 1 jour  
/ jusqu'à demain 

Bis 1 Tag / 
Bis Morgen 

hasta 1 día / 
hasta 
mañana  

fins 1 dia / 
fins demà 

fino a 1 
giorno / fino 
a domani 

till 1 dag / till 
imorgon 

until x days 2 - 7 
jusque dans x 
jours 

Bis x Tagen hasta x días fins x dies 
fino a x 
giorni 

till x dagar 
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6.5. Other Week Functions by Language 

Invariant 
and 
English 

Range 
for x 

French German Spanish Catalan Italian Swedish 

WEEKS   SEMAINES WOCHEN SEMANAS SEMANES SETTIMANE VECKOR 

last week  
semaine 
dernière 

Letzte 
Woche 

semana 
pasada / 
semana 
anterior 

setmana 
passada / 
setmana 
anterior 

settimana 
scorsa 

förra vecka 

this week  cette semaine 
Diese 
Woche 

esta semana / 
semana 
actual 

aquesta 
setmana / 
setmana 
actual 

questa 
settimana 

denna 
vecka 

next week  
semaine 
prochaine 

Nächste 
Woche 

semana 
próxima / 
semana 
siguiente 

propera 
setmana / 
setmana 
següent 

settimana 
prossima 

nästa 
vecka 

0 weeks 
ago   /  this 
week 

 
il y a 0 
semaines  / 
cette semaine 

Vor 0 
Wochen / 
Diese 
Woche 

hace 0 
semanas / 
esta semana 

fa 0 setmanes 
/ esta setmana 

0 settimane fa 
/ questa 
settimana 

0 veckor 
sedan / 
denna 
vecka 

1 week ago  
/  last week 

 

il y a 1 
semaine  / 
semaine 
dernière 

Vor 1 
Woche / 
Letzte 
Woche 

hace 1 
semana / 
semana 
pasada 

fa 1 setmana / 
setmana 
passada 

1 settimana fa 
/ settimana 
scorsa 

1 vecka 
sedan / 
förra vecka 

x weeks 
ago 

2 - 7 
il y a x 
semaines 

Vor x 
Wochen 

hace x 
semanas 

fa x setmanes x settimane fa 
x veckor 
sedan 

in 0 weeks  
/  this week 

 
dans 0 
semaines / 
cette semaine 

In 0 
Wochen / 
Diese 
Woche 

en 0 semanas 
/ esta semana 

en 0 setmanes 
/ esta setmana 

in 0 settimane / 
questa 
settimana 

om 0 
veckor / 
denna 
vecka 

in 1 week   
/  next 
week 

 

dans 1 
semaine / 
semaine 
prochaine 

In 1 Woche 
/ Nächste 
Woche 

en 1 semana / 
semana 
próxima 

en 1 setmana 
/ propera 
setmana / 
setmana 
següent 

in 1 settimana / 
settimana 
prossima 

om 1 
vecka / 
nästa 
vecka 

in x weeks 2 - 7 
dans x 
semaines 

In x 
Wochen 

en x semanas en x setmanes in x settimane 
om x 
veckor 

since 0 
weeks   /  
since this 
week 

 

depuis 0 
semaines / 
depuis cette 
semaine 

Seit 0 
Wochen 

desde 0 
semanas / 
desde esta 
semana 

des de 0 
setmanes / 
des d'aquesta 
setmana 

da 0 settimane 
sedan 0 
veckor 

since 1 
week   /  
since last 
week 

 

depuis 1 
semaine / 
depuis la 
semaine 
dernière 

Seit 1 
Woche 

desde 1 
semana / 
desde la 
semana 
pasada 

des d'1 
setmana / des 
de la setmana 
passada 

da 1 settimana 
sedan 1 
vecka 

since x 
weeks 

2 - 7 
depuis x 
semaines 

Seit x 
Wochen 

desde x 
semanas 

des de x 
setmanes 

da x settimane 
sedan x 
veckor 

until 1 
week 

 
jusque dans 1 
semaine 

Bis 1 
Woche 

hasta 1 
semana 

fins 1 setmana 
fino a 1 
settimana 

till 1 vecka 

until x 
weeks 

2 - 7 
jusque dans x 
semaines 

Bis x 
Wochen 

hasta x 
semanas 

fins x 
setmanes 

fino a x 
settimane 

till x veckor 
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6.6. Other Month Functions by Language 

Invariant 
and English 

Range 
for x 

French German Spanish Catalan Italian Swedish 

MONTHS   MOIS MONATEN MESES MESOS MESI MÅNADER 

last month  mois dernier Letzter Monat 

mes 
pasado / 
mes 
anterior 

mes passat 
/  mes 
anterior 

mese 
scorso 

förra månad 

this month   /  
current 
month 

 
ce mois / mois 
en cours / mois 
courant 

Dieser Monat 
este mes / 
mes actual 

aquest mes 
/ mes 
actual 

questo 
mese 

denna månad 

next month  mois prochain 
Nächster 
Monat 

mes 
próximo / 
mes 
siguiente 

proper mes 
/ mes 
següent 

mese 
prossimo 

nästa månad 

0 months 
ago   /  this 
month 

 
il y a 0 mois / 
mois en cours / 
mois courant 

Vor 0 
Monaten / 
Dieser Monat 

hace 0 
meses 

fa 0 mesos 
/ aquest 
mes / mes 
actual 

0 mesi fa / 
questo 
mese 

0 månader 
sedan / denna 
månad 

1 month ago   
/  last month 

 
il y a 1 mois / 
mois dernier 

Vor 1 Monat / 
Letzter Monat 

hace 1 mes 
/ mes 
pasado 

fa 1 mes / 
mes passat 
/ mes 
anterior 

1 mese fa / 
mese 
scorso 

1 månad 
sedan / förra 
månad 

x months 
ago 

2 - 12 il y a x mois 
Vor x 
Monaten 

hace x 
meses 

fa x mesos x mesi fa 
x månader 
sedan 

in 0 months   
/  this month 

 
dans 0 mois / 
mois en cours / 
mois courant 

In 0 Monaten / 
Dieser Monat 

en 0 meses 

en 0 mesos 
/ aquest 
mes / mes 
actual 

in 0 mesi / 
questo 
mese 

om 0 månader 
/ denna månad 

in 1 month   /  
next month 

 
dans 1 mois / 
mois prochain 

In 1 Monat / 
Nächster 
Monat 

en 1 mes o 
"mes 
próximo" 

en 1 mes / 
proper mes 
/ mes 
següent 

in 1 mese / 
mese 
prossimo 

om 1 månad / 
nästa månad 

in x months 2 - 12 dans x mois In x Monaten en x meses en x mesos in x mesi om x månader 

since 0 
months   /   
since this 
month 

 
depuis 0 mois / 
depuis ce mois 

Letzte 0 
Monate 

desde 0 
meses / 
desde este 
mes 

des de 0 
mesos / 
des 
d'aquest 
mes 

da 0 mesi 
sedan 0 
månader 

since 1 
month    /  
since last 
month 

 
depuis le mois 
dernier / depuis 
1 mois 

Seit Letztem 
Monat / Seit 1 
Monat 

desde el 
mes 
pasado / 
desde 1 
mes 

des del 
mes passat 
/ des d'1 
mes 

da mese 
scorso / da 
1 mese 

sedan 1 
månad /  
sedan förra 
månaden 

last x 
months 

2 - 12 depuis x mois 
Letzte x 
Monate 

desde x 
meses 

des de x 
mesos 

da x mesi 
sedan x 
månader 

until 1 month   
/  until next 
month 

 
jusque dans 1 
mois / jusqu'au 
mois prochain 

Bis 1 Monat / 
Bis Nächster 
Monat 

hasta 1 
mes / hasta 
el mes 
próximo 

fins 1 mes / 
fins el mes 
següent 

fino a 1 
mese / fino 
a mese 
prossimo 

till 1 månad / 
till nästa 
månaden 

until x 
months 

2 - 12 
jusque dans x 
mois 

Bis x Monate 
hasta x 
meses 

fins x 
mesos 

fino a x 
mesi 

till x månader 
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6.7. Other Quarter Functions by Language 

Invariant 
and 
English 

Range 
for x 

French German Spanish Catalan Italian Swedish 

QUARTER   TRIMESTRES QUARTALE TRIMESTRES TRIMESTRES TRIMESTRI KVARTAL 

Q1  T1 Q1 T1 T1 T1 K1 

Q2  T2 Q2 T2 T2 T2 K2 

Q3  T3 Q3 T3 T3 T3 K3 

Q4  T4 Q4 T4 T4 T4 K4 

Last 
Quarter 

 
trimestre 
dernier 

letztes 
quartal 

trimestre 
anterior 

trimestre 
anterior 

ultimo,trimestre 
förra 
kvartal 

This 
Quarter 

 ce trimestre 
dieses 
quartal 

trimestre 
actual 

trimestre 
actual 

questo,trimestre 
detta 
kvartal 

Next 
Quarter 

 
trimestre 
prochain 

nächstes 
quartal 

trimestre 
siguiente 

trimestre 
següent 

prossimo,trimestre 
nästa 
kvartal 

1 quarter 
ago 

 
il y a 1 
trimestre 

vor 1 
quartal 

hace 1 
trimestre 

fa 1 trimestre 1 trimestre fa 
1 kvartal 
sedan 

x quarters 
ago 

2 - 4 
il y a x 
trimestres 

vor x 
quartalen 

hace x 
trimestres 

fa x trimestres x trimestri fa 
x kvartaler 
sedan 

In 1 
quarter 

 
dans 1 
trimestre 

in 1 
quartalen 

en 1 trimestre en 1 trimestre in 1 trimestre 
om 1 
kvartal 

In x 
quarters 

2 - 4 
dans x 
trimestres 

in x 
quartalen 

en x 
trimestres 

en x 
trimestres 

in x trimestri 
om x 
kvartaler 

Last Qx 1 - 4 dernier Tx letztes Qx anterior Tx anterior Tx Tx scorso förra Kx 

Next Qx 1 - 4 prochain Tx 
nächstes 
Qx 

siguiente Tx següent Tx Tx prossimo nästa Kx 

Qx 1990  
to Qx 2030 
(*) 

1 - 4 
Tx 1990 to  
Tx 2030 

Qx 1990 to 
Qx 2030 

Tx 1990 to  
Tx 2030 

Tx 1990 to 
Tx 2030 

Tx 1990 to 
Tx 2030 

Kx 1990 
to 
 Kx 2030 

(*) For version 10.x and 11.0 the year range was 2004-2013, the new range 1990-2030 applies to versions 11.1 and 
greater. 
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6.8. Other Year Functions by Language 

Invariant 
and 
English 

Range 
for x 

French German Spanish Catalan Italian Swedish 

YEARS   ANNEES JAHREN AÑOS ANYS ANNI ÅR 

last year  an dernier Letztes Jahr 
año pasado / 
año anterior 

any passat / 
any anterior 

anno scorso  förra året 

this year  cette année Dieses Jahr 
este año /  
año actual 

aquest any / 
any actual   

quest anno detta året 

next year  an prochain Nächstes Jahr 
año próximo 
/ año 
siguiente 

proper any / 
any següent  

anno 
prossimo 

nästa året 

0 years ago  
/  this year 

 
il y a 0 ans / 
cette année 

Vor 0 Jahr / 
Dieses Jahr 

hace 0 años 
/ este año /  
año actual 

fa 0 anys / 
aquest any / 
any actual 

0 anni fa / 
quest anno 

0 år sedan / 
detta året 

1 year ago   
/   last year 

 
il y a 1 an  /   
an dernier 

Vor 1 Jahr /  
Letztes Jahr 

hace 1 año / 
año pasado 

fa 1 any / 
any passat / 
any anterior 

1 anno fa / 
anno scorso 

1 år sedan / 
förra året 

x years ago 2 - 10 il y a x ans Vor x Jahren hace x años fa x anys x anni fa x år sedan 

in 0 years    
/   this year 

 
dans 0 ans / 
cette année 

In 0 Jahren / 
Dieses Jahr 

en 0 años / 
este año /  
año actual 

en 0 anys / 
aquest any / 
any actual 

in 0 anni / 
quest anno 

om 0 år / 
detta året 

in 1 year    /   
next year 

 
dans 1 an  /  
an prochain 

In 1 Jahr / 
Nächstes Jahr 

en 1 año / 
año próximo 

en 1 any / 
proper any / 
any següent 

in 1 anno / 
anno 
prossimo 

om 1 år / 
nästa året 

in x years 2 - 10 dans x ans In x Jahren en x años en x anys in x anni om x års 

since 0 
years / since 
this year 

 
depuis 0 ans / 
depuis cette 
année 

Seit 0 Jahren / 
Seit Dieses Jahr 

desde 0 
años / desde 
este año 

des de 0 
anys / des 
d'aquest any 

da 0 anni  /  
da quest 
anno 

sedan 0 år / 
sedan detta 
året 

since 1 year 
/ since last 
year 

 
depuis 1 an  / 
depuis l'an 
dernier 

Seit 1 Jahr / 
Seit Letztes 
Jahr 

desde 1 año 
/ desde el 
año pasado 

des d'1 any / 
des de l'any 
passat 

da 1 anno  / 
da anno 
scorso 

sedan 1 år / 
sedan förra 
året 

last x years 2 - 10 depuis x ans Seit x Jahren 
desde x 
años 

des de x 
anys 

da x anni sedan x år 

until 1 year / 
until next 
year 

 

jusque dans 1 
an   / 
 jusqu'à l'an 
prochain 

Bis 1 Jahr / 
Bis Nächstes 
Jahr 

hasta 1 año / 
hasta el año 
próximo 

fins 1 any / 
fins el 
proper any 

fino a 1 anno 
/ fino a anno 
prossimo 

till 1 år /  till 
nästa året 

until x years 2 - 10 
jusque dans x 
ans 

Bis x Jahren hasta x años fins x anys fino a x anni till x år 
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