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1. Starting with Click&DECiDE Administration Manager 

1.1. Using the Click&DECiDE Start Menu 

The Click&DECiDE Start menu displays the following modules. To display the Start menu click Start> All 
Programs> Click and DECiDE. 

 

 

 

Administration Manager: click Administration Manager to launch the Administration Manager. The 
Administration Manager enables you to define and setup each data source you want to access. In the 
Enterprise Edition, the Administration Manager also enables you to define the Security when accessing data 
sources: User Groups, Users, Menus used in the Web Portal and the Authentication mode. 

In the Express Edition, this command only allows to define and setup each data source you want to access. 

Web Portal: click Web Portal to access your Click&DECiDE Web Portal. The Web Portal will be launched. 

 

1.1.1. Using the Start Menu’s Business Application Intelligence Folder 

Builder: click Builder to launch the Click&DECiDE Builder. The Builder is the main program which enables 
you to start the application to create queries, reports and cross-tables, all saved in the same project with a 
“.wfv” extension. 

Configuration Wizard: click Configuration Wizard to launch the Click&DECiDE Configuration Wizard again. 
You may choose to run the Configuration Wizard again in the following cases: 

• If you need to change your license certificate. 

• If you need to change the Web Portal Authentication mode. 

• If you need to change your Mail Server name. 

• If you need to change the SQL Server Authentication mode. 

  

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

6 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here. 

1.1.2. Using the Start Menu’s Tools Folder 

Model: click Model to launch the Click&DECiDE Model program (Enterprise Edition only). This program 
allows the Administrator to create end-user table views, with hidden fields, pre-defined joins, pre-prepared 
calculated fields and hidden criteria. Tables and columns can be renamed to make the names more user-
friendly to the end user. A Click and DECiDE Model data source must be then created in the Administration 
Manager in order to make queries for a Model. 

Web Menu: click Web Menu to launch the Click and DECiDE Web Menu program (Enterprise Edition only). 
This program allows the Administrator to create the Menus they want to publish via the Web Portal, according 
the User Groups defined in the Administration Manager. 

1.1.3. Using the Start Menu’s  iSeries Tools Folder: 

iSeries Help: click iSeries Help to open the Click and DECiDE iSeries Online Help. 

iSeries Host Program Installation: click iSeries Host Program Installation to run the tools required to 
upload to the AS/400 Host Program. 

iSeries Interface Batch Setup: click iSeries Interface Batch Setup to run the tools managing the rights for 
the  Batch Facility. This is a specific feature for iSeries that must be prepared by the AS/400 Administrator. 

 

1.1.4. Using the Start Menu’s  Documentation Folder 

Products and Solution Data Sheets: click Products and Solution Data Sheets to product and solution 
documents on the Click& DECiDE web site. 

Readme: click Readme to open the Readme file and read about the new features in the current version. 

Technical Documentation: click Technical Documentation to open technical documents on the 
Click&DECiDE web site. 

 

1.2. Launching the Administration Manager (Enterprise Edition) 

If you have installed the Enterprise Edition, then if you click Administration Manager in the Click and DECiDE 
Start menu, the Click and DECiDE Administration Manager module will be launched. Click and DECiDE 
Administration Manager allows you to perform the following tasks: 

• Add and configure each  data source you need to access 

• Manage Users and User Groups, and give them specific rights (new in version 2015!). 

• Manage the Security for each data source that must be accessible according to the User Group 

• Grant access to User Groups to predefined Web Menus. 

 

To launch the Click&DECiDE Administration Manager click Start> All Programs> Click and DECiDE> 
Administration Manager. 

 

Note: no login is required because, by default, the Windows Groups you belong to have been added to the 
Authorized Groups being able to run this program. 

If the Server Computer does not belong to a Domain, the Setup procedure will treat the Local Groups. 
However, if the Server Computer belongs to a Domain, the Setup procedure will treat the Domain Groups. 

 

1.3. Checking or Modifying the Administrator Group 

To check or modify the Group authorized to open this program, please follow the steps below. 
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1. Select Tools> Set Administrator Group. The Define Administrator Group dialog box appears. 

 

 

 

2. Select the Administrator Group authorized to open this program, and if necessary, create another 
specific Windows Administrator Group if necessary. 

Important note: the above feature does not depend on the Web Portal Authentication Mode chosen 
when installing Click&DECiDE Enterprise Editions. 
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Note: you can select either Windows Authentication or Click and DECiDE Authentication for the Web Portal 
when installing the software, however, this choice has no relation to the way the Click and DECiDE 
Administration Manager opens. Refer to the Click&DECiDE BAI 2015 Setup User Guide. 

 

2. Using the Data Sources Tab (Enterprise Edition) 

You must start by defining the data source you want to access. The Administration Manager allows you to add 
and setup a new configuration for each data source you need to access, manage Users and User Groups, 
manage the Security for the data sources that must be accessible depending on the User Group and give 
access to User Groups to predefined Web Menus. 

 

 

2.1. Modifying an Existing Data Source 

To modify an existing data source, please follow the steps below. 

 

1. Select the Data Sources tab. 

2. Right-click the Data Source you want to modify. For example, the Data Source Local SQL Server. 

3. Select Properties (or select File>Properties) to display the Settings dialog box. 
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4. Specify the Server Name or Server Name\Instance Name for the SQL Server you want to access. 

5. Select the appropriate check boxes. 

6. Click OK. 

7. Select the connection modes for an SQL data source (if appropriate) in the right pane. 

 

 

 

Windows Authentication: no Identification login is required. 

 

 

Unique SQL Server Authentication Profile: this can be used if your SQL Server database security 
has been configured in Dual Mode and you wish to use an identified connection. Enter the User ID, 
Password and confirm the password. Note: the end user does not need to know the Database 
password, they only need to be identified. 
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User Client Provided Profile (or a Click&DECiDE Secured Password): If you want the user to 
enter their personal SQL Server Client Login (or a Click&DECiDE Secured Password), then you must 
have selected Click and DECiDE Authentication when you ran the Configuration Wizard. In this 
case each user must be defined in the Administration Manager User Tab with a specific password. No 
Identification login is required now, but the user will be prompted to enter their client user login each 
time they connect to this data source later. 

 

 

 

8. Right-click the data source.  

9. Note the following options available in the context menu.  

 

Test connection: the connection will use the defined mode and only ask you to login if the Using 
User Client Provide Profile option was selected. 

Delete: removes this data source. 

10. Press F2 if you want to change the data source name. 
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11. Click File> Update Security or the corresponding icon   to update the Administration Manager 
configuration after each modification.  

 

2.2. Creating a New Data Source 

You can create a new data source in the Data Sources tab, to do so please follow the steps below. 

 

1. Right-click in the central pane of the Administration Manager. 

2. Click New Data Source or select File> New> Data Source. The New Data Source dialog box 
appears. 

 

 

 

3. Note that each type of Data Source will display a specific dialog box where you can define the 
configuration.  

4. Click each tab to configure the options according to the data source you want to use. 

5. Note that for some Data Sources such as SQL Server, Oracle or UDB-DB2, you need the proprietary 
client module to be installed first. If not, an error message will appear as it is trying to connect to the 
missing client module. 

 

2.2.1. Configuring an SQL Server Data Source 

To configure an SQL Server Data Source, follow the steps below. 

 

1. Right-click in the central pane of the Administration Manager. 

2. Click New Data Source or select File> New> Data Source. The New Data Source dialog box 
appears. 

3. Enter a Data Source Name, for example MySQLServer. 
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4. Select the SQL Server Data Source. 

 

 

 

5. Click OK. The Settings dialog box appears. 

6. Enter the Server Name and if appropriate the Instance Name. For SQL Server 2008 installed with the 
Click&DECiDE package, the Instance name is SQLExpress. (.\SQLExpress can be entered). 

 

7. Select the check boxes as appropriate. 

8. The SQL Server version can be specified or is automatically selected. 

9. Click OK. 

 

2.2.2. Configuring an iSeries Data Source 

To configure an iSeries Data Source, follow the steps below. 

 

1. Right-click in the central pane of the Administration Manager. 

2. Click New Data Source or select File> New> Data Source. The New Data Source dialog box 
appears. 

3. Enter a Data Source Name, for example MyAS400 for a new iSeries Data Source. 

4. Select the iSeries TCP/IP data source from the Data Source drop-down menu. 
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5. Click OK. The iSeries TCP/IP Interface property sheet appears. 

6. Enter the iSeries Name or IP address. 

 

 

 

7. Select the RDB Name tab. 

8. Enter the Relational Database Name (RDB Name). 
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9. Click Validate. The connection will be tested. 

10. Note that once the connection has been successfully tested, the new iSeries data source is ready to 
use. 

 

Note: for this data source, the Host Program Installation should be run before creating this data source. 

 

11. Right-click the MyAS400 icon in the central pane. 

12. Click Test Connection. The default login will be used.  
Note:  if this data source must be used later via the Web Portal, you must activate the Data Source 
Secured by Click and DECiDE option. End users will be then able to connect to this AS/400 Data 
Source without knowing the iSeries Login, but using their Windows Login (if Windows Authentication 
has been selected) or using a predefined login declared in the Click and DECiDE Administration 
Manager if Click and DECiDE Authentication has been selected). 
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2.2.3. Configuring an Oracle Data Source 

Important: for some Data Sources such as Oracle, the version 2015 of Click&DECiDE does not provide any 
more a native data source. The only solution consists of using now an ODBC Oracle driver 64-bit. 

If you are using queries made with the previous Click&DECiDE Native Oracle Data Source (32-bit) you will 
need to configure the ODBC Oracle 64-bit as follow: 

1- Select the Access Join Style instead of the Oracle Join Style in the ODBC Interface Setup. 

2- You can add the following rows in the DDIDOBC.INI file to make it working using the Native Oracle 
formulas instead of the Standard ODBC formulas: 

[ODBC Oracle] 
FCT=fctora.fn 

3- You can add the following rows in the DDIDOBC.INI file to get the Tables Descriptions and Columns 
Description: 

4- [ODBC Oracle] 
Tables=SELECT * FROM (SELECT DISTINCT '', 
T1.OWNER,T1.TABLE_NAME,'TABLE',T2.COMMENTS FROM SYS.ALL_TABLES T1 LEFT 
OUTER JOIN SYS.ALL_TAB_COMMENTS T2 ON T1.OWNER=T2.OWNER AND 
T1.TABLE_NAME=T2.TABLE_NAME UNION SELECT DISTINCT '', 
T1.OWNER,T1.VIEW_NAME,'VIEW',T2.COMMENTS FROM SYS.ALL_VIEWS T1 LEFT OUTER 
JOIN SYS.ALL_TAB_COMMENTS T2 ON T1.OWNER=T2.OWNER AND 
T1.VIEW_NAME=T2.TABLE_NAME) WHERE OWNER LIKE '%2' AND TABLE_NAME LIKE '%3' 
ORDER BY 1,2 
Columns=SELECT '',T1.OWNER SCHEMA_NAME,T1.TABLE_NAME,T1.COLUMN_NAME, 
decode(data_type, 'DATE',11,'FLOAT',6,'BINARY_FLOAT',6,'BINARY_DOUBLE',8, 'LONG 
RAW',-4,'LONG',-1,'CLOB',-1,'NCLOB', -10,'BLOB',-4,'BFILE',-4,'CHAR',1,'NCHAR', -8, 
'VARCHAR2',12, 'NVARCHAR2',-9,'NUMBER', (CASE WHEN T1.DATA_PRECISION IS NULL 
THEN 8 ELSE 3 END), 'TIMESTAMP',11,'TIMESTAMP(0)',11,'TIMESTAMP(3)',11, 
'TIMESTAMP(6)',11,'TIMESTAMP(9)',11,12) DATA_TYPE_ID, T1.DATA_TYPE 
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DATA_TYPE_NAME, CASE data_type when 'NUMBER' THEN NVL(T1.DATA_PRECISION, 
T1.DATA_LENGTH) ELSE T1.DATA_LENGTH END COLUMN_SIZE, T1.DATA_LENGTH 
BUFFER_LENGTH_wrong,T1.DATA_SCALE DECIMAL_DIGITS_for_numbers, 
T1.DATA_PRECISION NUM_PREC_RADIX, CASE NULLABLE WHEN 'N' THEN 0 ELSE 1 END 
NULLABLE,NVL(T2.COMMENTS, ' ') COLUMN_DEF, T1.COLUMN_ID POSITION FROM 
SYS.ALL_TAB_COLUMNS T1 LEFT OUTER JOIN SYS.ALL_COL_COMMENTS T2 ON 
T1.OWNER=T2.OWNER AND T1.TABLE_NAME=T2.TABLE_NAME AND 
T1.COLUMN_NAME=T2.COLUMN_NAME where T1.OWNER='%2' and T1.TABLE_NAME='%3' 
ORDER BY T1.COLUMN_ID 
 

2.2.4. Configuring an ODBC Data Source  

To configure an ODBC Data Source, follow the steps below. 

1. Right-click in the central pane of the Administration Manager. 

2. Click New Data Source or select File> New> Data Source. The ODBC Interface - Setup dialog box 
appears. 

3. Select an ODBC Data Source. 

 

 

 

4. Click ODBC Setup to create or modify the ODBC Data Source Setup. 
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Recommended: the data source should be defined in the System DSN Tab, rather than the User DSN Tab, if 
you wish this data source to be able to be used not only locally on the Server but also from remote 
workstation through the Web Portal or using a Click&DECiDE Connect data Source. 

 

 

 

5. Click Configure to define the ODBC setup as appropriate, according to the database type. 

6. Go back to the ODBC Interface – Setup dialog box. 

7. Select the Join Style. 
 
Regular Only: will only support Join Type #1 corresponding to the first option in the Click&DECiDE 
Builder Join Properties dialog box. 

 

SQL Server: will support all proposed Join Types in the Click&DECiDE Builder Join Properties dialog box: 
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8. Select the Timestamp format: that corresponds to your ODBC Database from the drop-down list. 

 

9. Select the Advanced check boxes as appropriate. For example, the way to display table levels or to 
manage the GROUP BY statement. 

 

2.2.5. Configuring an Excel Data Source 

An Excel data source is an ODBC data source, however, you can very easily add an Excel data source by 
following the steps below.  

 

Note: an Excel data source must refer to an Excel file having data in a Table representation, with the first row 
used as Column Header 

 

1. Close the Excel file concerned. 

2. Move the Excel file into the Click and DECiDE Administration Manager Data Source tab by using a 
drag-and-drop operation. The ODBC Setup will be created automatically. 
Note: each Excel Sheet will appear in the table list as a Table when creating a query with Click and 
DECiDE Builder. 
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2.2.6. Configuring the Click and DECiDE Connect Data Source 

This internal data source allows a user from any workstation to access any data source whose setup is 
defined in the Click and DECiDE Administration Manager. 

The following example, explains how to  create an Oracle 10 data source using a Connect Data Source, the 
client workstation does not have an Oracle proprietary client module and the Server has a proprietary client 
module. 

 

1. Select the TCP/IP Connection tab. 

2. Specify the Click and DECiDE Connect Server Name or Address. 

 

3. Select the Database Interface tab. 

 

4. Click Browse... to view the data source list from the Server. 

5. Select the corresponding Oracle data source. 
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6. Click OK to validate. 

7. Click Validate. 

8. Confirm the login. 

 

2.2.7. Configuring the Click and DECiDE Model Data Source 

This internal data source allows a user from any workstation to access a Click and DECiDE Model data 
source whose setup is defined in the Click and DECiDE Administration Manager. A Click and DECiDE Model 
data source is a specific data source corresponding to one or several views (or domains) defined with the 
Click and DECiDE Model module, which allows you to create end users views with: 

• Predefined join conditions between several tables. 

• Hidden fields. 

• Predefined calculation fields. 

• Hidden criteria. 

• Columns renamed with the names you want. 

 

The benefit for the end user is that they get a view as a single table, which makes it very user-friendly as the 
technical features are already prepared inside the Model (join, calculation fields and so on). 

The benefit for the Administrator is that it gives access to filtered information to the end user and hides 
unauthorized data.  

Click and DECiDE Model allows you to create criteria depending on the user logon. For example a user 
named Smith will only see data for the SOUTH Area from a Model, whereas another user named Baxter will 
see data from the same Model but for the NORTH Area. 

For more information, please refer to the Click and DECiDE Model Manual. 
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2.3. Working with the Data Source Secured by Click&DECiDE Option  

When a data source is not secured by Click and DECiDE Administration Manager it is not  authorized for one 
or several User Groups, and then it is authorized to any client user located on a remote workstation and using 
a Click and DECiDE Connect Data Source connected to the Server where the Click and DECiDE 
Administration Manager is installed. The benefit is that only the Server machine needs a proprietary client 
module to be installed to connect the Data Source. The remote workstation does not need this client module 
but can access the data source via the Server machine using the Click and DECiDE Connect Data Source. 

When a data source is secured by the Click and DECiDE Administration Manager it can be assigned to each 
required User Group, which allows the Administrator to control the tables each User Group can access. The 
Administrator can only give access to a library or a list of specified tables, and customize each User Group 
according to the data they can access. 

Note: for any connection via the Web Portal, the data source must be secured by Click&DECiDE.  

 

Note: for security reasons a user from a client workstation cannot write inside a table which belongs to a data 
source secured by the Click&DECiDE Administration Manager. 

 

 

 

2.4. Configuring Click and DECiDE Security Options 

Locked Access: allows to disable or enable the access to this Data Source for all users. 

Password Checked by the Data Source: the password will be checked by the Data Source for a Click and 
DECiDE Connect data source. If you want to make this feature work via the Web Portal for the login, perform 
the following steps. 

 

Note: the Password Checked by the Data Source can only be used if you activated Click and DECiDE 
Authentication in the Click and DECiDE Configuration Wizard, with the “Forms” or “HTTP Basic” 
Authentication mode: 

 

1. Activate Click and DECiDE Authentication in the Click and DECiDE Configuration Wizard if 
necessary. To do so, close all Click and DECiDE programs and run the Click and DECiDE 
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Configuration Wizard, then change the Web Portal Authentication Mode when the following screen 
appears. 

 

Optional: the Options button allows you to specify the Click&DECiDE Authentication Mode among 3 choices: 

 

If using a HTTP link: 

• The Forms Authentication: the login goes through a Click&DECiDE form in the Web Portal 
page. The password is not encrypted and Data Source Login can be used to connect to the 
Web Portal.  

• The HTTP Digest Authentication: the password is hashed. No Data Source Login can be 
used, but this mode is more secured than the Basic Authentication. 

• The HTTP Basic Authentication: the password is not encrypted (clear text). A Data Source 
Login can be used to connect to the Web Portal. 

If using a HTTPS link: 

• In the 3 above modes, the password are encrypted or hashed. 

2. Note that once the new configuration is finished, the ALIASES.INI file contains the following: 

[Web] 
UseNTUserForWebLogin=0 
DataSourceForWebLogin=iSeries 

3. Click File> Update Security or the corresponding icon   to update the Administration Manager’s 
configuration. 
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3. Working with the User Groups Tab 

3.1. Working with User Group Definitions 

The User Group tab enables you to add, remove or modify the User Groups definition.  

 

Note:  if you are under Windows Authentication, the Setup will automatically have inserted the Windows 
Group you belong to. For example, the Users Group named “Domain Users” in English or “Utilisa. du 
Domaine” in French. When selecting a User Group you can see the following options in the right pane. 

Super Administrator: this option is corresponding to the Task Administrator option from the previous version 
32-bit (V13.X) but now gives all the rights to the Users being in this Group. In fact, now, Click&DECiDE 
Manager 2015 provides an important new feature allowing to give specific rights to a User group and/or a 
User, described later in this Guide. 

Enable: allows you to disable or enable all users belonging to a User Group at the same time. For example 
the Administrator can forbid a User Group to have direct access to any database or Web Portal access during 
a certain period. 

Note: a User Group branch always displays five branches: 

• Users: by default this does not contain any users if Windows Authentication is used, unless you need 
to declare certain users as CAL users (Client Access License). This branch contains identified Users 
if Click&DECiDE Authentication is used. Refer to the User tab. 

• Data Sources Access: contains all Secured Data Sources assigned to the User Group. Refer to the 
Data Source tab. 

• Menu Access: contains all the menus assigned to the User Group. Refer to the Menu tab. 

• Model Parameter: this branch is empty by default, it can contain the parameters linked to a 
Click&DECiDE Model. Please refer to the Click&DECiDE Model Manual. 

• Rights (New since version 2015): concerns what can do or see a User Group or User in the Web 
Portal. Refer to paragraph “Modifying some Rights for a User Group or a User” 

3.2. Assigning Data Sources to a User Group 

Once the data sources you need have been created and the Secured mode has been activated, you must 
grant access rights for these data sources to the concerned User Groups. To do so, please follow the steps 
below. 

1. Select the User Group tab. 
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2. Select the User Group you need to modify, for example the group “Users” which is a Windows Group.  

3. Select the Data Sources Access branch.  

4. Note all the data sources declared as “Secured by Click and DECiDE” appear in the right pane.  

5. Click the Data Source you want, in this example click the AS/400 Data Source. 

6. Enter your login details. The Library and table list will appear. 

 

7. Select a library. 

8. Select the tables you want or give access to the whole library if you do not want to limit the access to 
only some tables. 
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In the above example, the Group named “Users” will now have access to the full AS/400 library named 
“DATAEXPRESS” but will only have access to some tables in the SAMPLE library. 

9. Select File> Update Security or the corresponding icon   to update the Administration Manager’s 
configuration. 

3.3. Adding Users to a User Group 

Although no users are required when you are in Windows Authentication Mode, you may sometimes need to 
add or remove users in a User Group, for example if you are in Click&DECiDE Authentication mode. To add 
users to a User Group, please follow the steps below. 

1. Click the User branch in a User Group you want to add the user to. 

 

Other situation: under Windows Authentication, you want to remove the non-used Admin and WebUsers 
Groups (installed by default for the Click&DECiDE Authentication) and also the non-used Admin and Guest 
Users. If you do that and try to close Click&DECiDE Administration Manager, you could have a message 
saying that no User is defined inside a User Group being Administrator or that you have perhaps remove the 
only User Group being Administrator. 

In that case, you need to define at least one Windows User Group being “Super Administrator” and drag and 
drop at least one user in this User Group. 
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2. Select the User in the All Users right pane. 

 

3. Move the User to the Users branch in the User Groups pane using a drag-and-drop operation. 

 

4. Select File> Update Security or the corresponding icon   to update the Administration Manager’s 
configuration. 

3.4. Removing Users from a User Group 

To remove users from a User Group, please follow the steps below. 

1. Click the User branch in the User Group you want to remove the user from. 
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2. Select the User in the list. 

3. Press Del. 

 

4. Click File> Update Security or the corresponding icon   to update the Administration Manager’s 
configuration. 

3.5. Adding a Menu to a User Group 

To add an existing Menu to a User Group, please perform the following steps. 

1. Click the Menu Access branch for a User Group. 

 

2. Select the Menu in the All Menus right pane. 

3. Move the Menu to the Menu Access branch in the User Groups pane using a drag-and-drop 
operation. 
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4. Select File> Update Security or the corresponding icon   to update the Administration Manager’s 
configuration. 

3.6. Removing a Menu from a User Group 

To remove an existing Menu from a User Group, please perform the following steps. 

1. Click the Menu Access branch for a User Group. 

 

2. Select the Menu in the list. 

3. Press Del. 

4. Click File> Update Security or the corresponding icon   to update the Administration Manager’s 
configuration. 

3.7. Modifying a Parameter Value for a Model 

Please refer to the Click&DECiDE Model Manual for more information. 

3.8. Modifying some Rights for a User Group or a User 

This is the main new feature for this Click&DECiDE version 2015. 
By default the Rights branch displays the following options where nothing is specified: 
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3.8.1. Super Administrator User Group 

If the User Group is defined as “Super Administrator”, any user from this Group can see and do everything: 
(not depending to any right specified in the right screen). 

 

 

 

This configuration is corresponding to the default situation in previous versions when the “Task 
Administrator” option was enabled for a User Group. 

 

Moreover, the Super Administrator is now the only one able to create and manage: 

 Generic Tasks  

And 

 SQL Tasks. 

(New in version 15.0.1) 
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3.8.2. User Group not being Super Administrator 

If nothing is specified, and the User Group is NOT defined as “Super Administrator”, any user from this 
Group can only see: 

 

This configuration is corresponding to the default situation in previous versions when the “Task Administrator” 
option was disabled for a User Group: 

Unless specified in another User Group, Users belonging to such a User Group: 

• Can see and run the available Menus applied to this User Group. 

• Can modify the View configuration, manage their Favorites and see how they are authenticated in the 
Web Portal and, if needed, manage their data source login. 

• Can create and run some Dashboards and Pivot Tables, but can only save their works in their own 
User Shared Folders (see Inserting a Shared Folder by User) 

• Cannot access to Tasks and Scheduled Tasks. 

• Cannot access to the Publish Tables. 
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3.8.1. Customizing Rights for User Groups and Users 

In this manual, the following terms are corresponding to: 

Resource: item whose right can be modified (Pivot Table, Dashboard, Folder, Group Folder, User Folder, 
User, Schedule, Task, Flow) 

Action: the operation that can be applied to a Resource. (Create, Write, Delete, Manage, Execute) 

Authorization: is this Action on this Resource is allowed or denied? 

A Right is a combination of a Resource + Action + Authorization. 

If at least one right is defined (for example _P Dashboard_Create = Allow), then all rights are considered as 
“customized” and follow the rules below: 

- “Undefined” (Empty string or “NULL”): the action on this resource is not authorized 

- “Allow”: the action on this resource is authorized. 

- “Deny”: the action on this resource is not authorized, even if authorized in another User Group. 

Moreover, you can specify some attributes (depending on the resource) to the “Allow” authorization for more 
granularity: 

- Allow(All): the action is authorized for all resources accessible to the User (not limited to the current 
User Group). This can also be written “Allow”. 

- Allow(Group.<Name>): Reserved for a future version only for _Flow Manage and _PUser Manage. 

- Manage.Allow(Menu.<Description>): the action is authorized for all resources defined in the 
specified Menu.  

You can specify more than one attribute, separating them with a comma “,”. 

Example: 

For a specific User Group, being only in one specific Group, we want to apply “Allow” to the Create 
Dashboard resource: 

In Administration Manager, select the Right “_P Dashbaord_Create” for this User Group: 
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Now click the Edit icon  and open the list box for the Authorization option: 

 

Select “Allow” and click OK. 

Now the User Group “CnD” is allowed to Create Dashboard but not authorized to create anymore some Pivot 
Tables because the Resource “Pivot table” is now undefined (blank string). 

 

Click File> Update Security or the corresponding icon   to update the Administration Manager’s 
configuration. 

In the Web Portal, a user belonging to this User Group will see this Create Menu without the Pivot Table: 

 

 

Other example: we want this User Group to be authorized to Manage his own Tasks but only concerning 
existing items from the BAI Demonstration Menu: 

In Administration Manager, select the Right “_P Task_Manage” for this User Group, and edit the value to 
enter “Allow( Self , Menu.BAI Demonstration )”: 

- “Self” means his “own” tasks only 

- “Menu.BAI Demonstration” will limit this action to the “BAI Demonstration” Menu. 
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Click File> Update Security or the corresponding icon   to update the Administration Manager’s 
configuration. 

In the Web Portal, a user belonging to this User group will see the Save Task button available for a query, a 
report or a cross table from a Menu: 

 

 

And will only see the Tasks Branch in the Schedule level: 

 

 

 

Note that: 

_P Flow_Manage can be used for a User Group or User authorized to see the Publish branch in the Web 
Portal. 
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_P User_Manage can be used for a User Group or User authorized to see the Connected Users in the 
Configure branch in the Web Portal, and thus can disconnect a user (Windows Authentication) or make him 
Inactive (Click&DECiDE Authentication). 

3.8.2. Rights Managements Organigram 

 

 

Undefined Deny 

Allow(Z1,Z2,...) 

All Self Menu.<MenuDescription> 

Group.<GroupName> 
 

(Reserved for future 
version) 

_P 

Dashboard_Create 
_P Pivot_Create 

Access to 
Dashboard 

and/or Pivot 
Application 

Can't do 

except if 
Allow 

Can't do 

even if 
Allow 

Can do N/A N/A N/A 

_P Folder_Write 
_P Folder_Delete 

_P 
Group_Folder_Write 
_P 

Group_Folder_Delete 
_P 
User_Folder_Write 

_P 
User_Folder_Delete 

Write 
Delete  
in: 

Shared Folder  
Group Folder 
User Folder 

Can't do 
except if 

Allow 

Can't do 
even if 

Allow 

Can do on 
all  

accessible 
folders 

N/A 
Can do on all  

folders of this menu 
N/A 

_P Task_Manage 

Create 

Delete 
Edit 
->Tasks 

Can't do 

except if 
Allow 

Can't do 

even if 
Allow 

Can 
manage 

tasks  
whose item 

is  

accessible 

Can 

manage 
his own 
tasks 

Can manage tasks  

whose item belong  
to the menu and  

is accessible 

N/A 

_P 

Schedule_Manage 

Create 
Delete 

Edit 
->Schedule 

Can't do 
except if 

Allow 

Can't do 
even if 

Allow 

Can 
manage 

schedules 

whose all 
tasks can 

be managed 

N/A N/A N/A 

_P 
Schedule_Execute 

Execute 

Schedule 
via shortcuts 
ONLY 

Can't do 
except if 

Allow 

Can't do 
even if 
Allow 

Can execute 
schedules  

whose items 
from all  

tasks are 

accessible 

N/A N/A N/A 

_P User_Manage 

Create / Delete 
/ Edit User 
View 

connected user 
and  
disconnect 

Can't do 

except if 
Allow 

Can't do 

even if 
Allow 

Can 

manage all 
users 

N/A N/A 

Can manage users  

that belong to the  
group 

_P Flow_Manage 

Add / Delete 

/Edit  
RSS / 
Information / 

Highlight  
flows 

Can't do 
except if 

Allow 

Can't do 
even if 
Allow 

Can 
manage all 

flows 
N/A N/A 

Can manage flows  
intended for the  
specified group 

 

 

 

  

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

35 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here. 

4. Updating Database Security 

Each time you modify the access right inside the Administration Manager program, you must update the 

database security by selecting File> Update Database Security or by clicking the Update icon . 

You must update Database Security when you create a data source, a User Group, a User and when you 
change any link between the Administration Manager Tabs (Data Source, User Group, User, Menu and 
Authentication). 

This action will update internal files used by Click&DECiDE. 

 

 

 

Note that if you close the Click&DECiDE Administration Manager without clicking Update Database 
Security...  a message will appear asking if you want to update database security.. It is always recommended 
to do so to ensure that the configuration is updated. 
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5. Working with the Users Tab 

If the User Group is a Windows Group, all the users who belong to this Group will have the same access 
rights to the database tables as defined previously. Each user name does not need to be entered in the 
Administration Manager, except if you want to declare some of them as “CAL” users (according to your 
license certificate). A “CAL” (Client Access License) must be an identified user in the Administration Manager. 
If you only have concurrent users in your license certificate, you do not need to identify them in the 
Administration Manager. 

 

5.1. Adding Users in the Users Tab 

If the User Group is not a Windows Group, and if you are in Click and DECiDE Authentication mode, then you 
need to add the users you want to manage and add each user in a User Group. To add a user, please follow 
the steps below. 

 

1. Select the Users tab. 

2. Select File> New> User or right-click and select New> User. In the example below we are going to 
create the user James Smith and declare him as a CAL user. 

 

 

3. Enter the following details in the right pane for each user: 
User ID: this is mandatory. 
Name:  this is Optional. 
Password: this is optional, depending on the Authentication mode used.  
Enable: allows the Administrator to disable or enable a specific user without disabling the whole User 
Group. For example the Administrator can forbid a user to have direct access to any database or to 
the Web Portal for a certain period. 

4. Add this user to the required User Group, for example WebUsers.  
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5. Click the User Groups tab. 

6. Select the WebUsers group. 

7. Select the Users branch. 

 

8. Select the new user, for example Smith in the right All Users pane. 

9. Move the new user from the All Users pane to the Users branch in the left User Groups pane using 
a drag-and-drop operation. 

 

10. Add the data sources that you want to authorize for the WebUsers group. In this example the 
MyAS400 data source has been added to the authorized data sources for the WebUsers group.  

11. Click the Update Security icon  to validate the changes. 
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5.2. Specifying Data Source Login for each user 

If a data source is defined in Click and DECiDE Administration Manager but you do not want to use a unique 
User ID/Password by default for all users, as in the following picture: 

 

it is possible to define in the Users Tab a specific login for one or several data sources. To do so, select the 
User in the User Tab and make a right mouse click in the right bottom window and select New> Password: 

 

Select the Data Source Name and enter the User login: 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

39 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here. 

  

Click OK to validate: 

 

When the above user will connect to the AS400TCPIP_SECURED data source, the iSeries login sent to the 
data base will be the one defined in the above screen, being specific to each user. 

If you wish to remove any row in the right bottom frame, select the required row and click the command Edit> 
Delete. 
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6. Using Group and User Group Properties 

A “Property” is new feature since version 10.2.1 allowing to apply some criteria to a Group and/or a User 
Group, decided by the Administrator. Later, when running a query, report or cube through the Web Portal or a 
Click&DECiDE Connect Data Source, the end-user will retrieve data filtered by this property. 

Example: if a Property allows a User to get data only from SOUTH and EAST areas, any query, report or cube 
based on this Property, will only return data for the SOUTH and EAST areas. If this User belongs to a Group 
whose Property also authorize to see the NORTH-WEST area, then the user will get records corresponding to 
the SOUTH, EAST and NORTH-WEST areas. 

When you select a Group or a User Group, you can see on the right pane a “Properties” frame with 3 buttons: 

 

6.1. The first button  allows to create a new Property: 

 

Name: enter a name for the Property (this name will be used later in a Click&DECiDE Builder 
parameter – Refer to the Click&DECiDE Builder Query User Guide). 

Type: select the required type for single values among String, Numeric, Date, Time or Timestamp. 
Note that for multiple values you must select the Multi values Type whatever will be the field type. 
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Description: optional, you can enter here a text to remember the purpose of the property. 

Value: if empty, nothing will be applied for the Group and User group whose Property value is empty. 
If not empty, you can enter a single value or several values with a semicolon separator if Multi values 
type has been chosen. 

Validate with OK 

 

Click the Update Security icon  to validate the changes. 

 

6.2. The second button  allows to edit an existing Property: 

Click this icon to edit and modify an existing property. Example: with the Click and DECiDE Web 
Demonstration.wfv project file, all queries inside have a parameter calling the property named AREA. 
You can thus enter the following values to test this feature with the demo database: 

 

All available values for AREA are: ATLANTIC;CENTRAL;NORTH-WEST;SOUTH;WEST 

Click the Update Security icon  to validate any changes. 

 

6.3. The third button  allows to remove partially or totally an existing 
Property: 

Click this icon if you wish to clear the values for a Group or User Group or if you wish to remove this 
property for all Groups and User Groups. 

The following choice will be prompt: 
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6.3.1. Remove partially a Property for a Group or User Group 

Click No to only clear the value(s) for the selected Group or User Group 

Click the Update Security icon  to validate any changes. 

6.3.2. Remove totally a Property for all Groups and User groups 

Click Yes to delete this property for all Groups and User Groups. Make sure that no query is still using 
this Property in your Click&DECiDE or Dashboard applications. 

Click the Update Security icon  to validate any changes. 

6.3.3. Do not make any change 

Click Cancel to do not apply any change. 

6.4. How a property is used inside a Click&DECiDE Query? 

You can see several examples by opening the Click and DECiDE Web Demonstration.wfv project file in the 
C:\Program Files\Click and DECiDE\BAI\DemoWeb directory. 

Open for example the “demo_multicriteria” query 

Click Query> Parameter to open the Parameter Dialog Box 

Select the parameter named PropertyArea 

As you can see in the next picture, this parameter is updated by a User Property, is optional and the name of 
the UserPropety is AREA, defined in Administration Manager as described previously as an example. 

When a User Property is optional, the value IGNORE will be used in the query. 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

43 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here. 

 

 

For more information, please refer to the Click&DECiDE Builder Query User Guide. 
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7. Working with the Menu Tab 

The Menu tab allows the Administrator to add or remove Menus, previously created with Click&DECiDE Web 
Menu. The Administrator can define the menu name that should be displayed via the Web Portal and the path 
to the menu file with the .wmu extension. 

 

7.1. Adding an Existing Menu 

To add an existing menu in the left Menu pane, please follow the steps below. 

1. Select File> New> Menu, or right-click and select New> Menu. 

2. Change the default “New Menu” name by the name you want. 

3. Click the Path Browse button in the right pane, to find the menu file with the .wmu extension on the 
hard disk. 

4. Click in the left pane to view the Menu Path. 

5. Modify the path to replace the beginning of the path with an environment variable if necessary. 

6. Click File> Update Security or the corresponding icon   to update the Administration Manager’s 
configuration. 

7.1. Removing an Existing Menu 

To remove an existing menu from the left pane list, please follow the steps below. 

1. Select the menu you want to delete from the left Menus pane. 

2. Press Del.  

Note: this action will not delete the menu file from the hard disk, but only from the menu list. 

7.2. Creating a New Menu 

To create a new menu in the left Menus pane, please follow the steps below. 

1. Select File> New> Menu, or right-click and select New> Menu. 

2. Change the default “New Menu” name by the name you want. 

3. Click Edit in the right pane.  This action will launch the Click and DECiDE Web Menu and create an 
empty new menu, ready to be defined with the branches you need to create. See further Use of Click 
and DECiDE Web Menu. 

7.3. Modifying an Existing Menu 

To modify an existing menu which can be seen in the left Menus pane, please follow the steps below. 
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1. Select the menu you want to modify in the left Menus pane. 

2. Click Edit in the right pane. This action will launch Click and DECiDE Web Menu and will open the 
menu you selected to modify. Modify the menu as appropriate. See further Use of Click and DECiDE 
Web Menu. 

7.4. Working with Click and DECiDE Web Menu 

When Click and DECiDE Web Menu is launched the following screen appears. 

 

The “root” in the central pane is not visible in the Web Portal, however you can modify it, replacing “root” by 
the name of the menu that you specified in the Administration Manager Menu tab. 

The toolbar includes the following icons: 

 inserts a New Folder, allowing you to create branches and sub-levels if necessary. 

 inserts a Click&DECiDE Dynamic Query 

 inserts a Click&DECiDE Dynamic Report 

 inserts a Click&DECiDE Dynamic Cube (made with a 32-bit version) 

 inserts a Click&DECiDE Static Query (a query that is already published in HTML format) 

 inserts a Click&DECiDE Static Report (a report that is already published in HTML format) 

 inserts a Click&DECiDE Static Cube (a cube that is already published in HTML format) 

 inserts a link to a file (Excel, PDF, Word and so on.) 

 inserts a URL or a link to a Dashboard. 

 inserts a link to Click&DECiDE Builder running on a specified Secured Data Source. 

 inserts a Shared Folder. 

7.4.1. Inserting a New Folder 

To insert a new folder, please follow the steps below. 

1. Click the  New Folder icon to insert a static branch whose name can be modified.  
Note: if a branch already exists, make sure the mouse cursor is on the correct location before adding 
a new folder. 

 

2. Create a sub-folder in the folder you want. 
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3. Rename the folders as follows: Queries, Reports and Cubes. 

 

7.4.2. Inserting a Click&DECiDE Dynamic Query 

To insert a dynamic query, please follow the steps below. 

1. Select the Queries folder. 

2. Click the  Dynamic Query icon in the toolbar to add a dynamic query. 

 

3. Rename the default name Dynamic Query with the name you want. For example Invoices. 

 

4. Double-click the new Dynamic Query branch or click the  icon to open Click and DECiDE Query 
property sheet. 

5. Click the Browse... button. 

6. Select the required Click&DECiDE project file (*.wfv). 

7. Select the Invoices query in the proposed item list. This example uses the Click and Decide Web 
Demonstration.wfv project file located by default in the C:\Program Files\Click and 
DECiDE\BAI\DemoWeb directory. 

8. Replace the beginning of the path with an environment variable if necessary. 
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9. Clear the Visible in browser check box if you want to hide this item in the Web Portal. In this 
example we are going to select the Visible in browser check box. 

10. Click the Format tab to specify the authorized output formats. 

Note: only the selected formats will be proposed to end users in the Web Portal. More information 
about the output formats is given in the Menu Web Output Format section.  

11. Click OK. 

7.4.3. Inserting a Click&DECiDE Dynamic Report 

To insert a dynamic report, please follow the steps below. 

1. Select the Reports folder. 

2. Click the Dynamic Report icon  icon. 

 

3. Rename the default folder name Dynamic Report to the report name you want. For example Sales 
by Area. 

 

4. Double-click the new Dynamic Report branch or click the  icon to open the Click and DECiDE 
Report property sheet. 
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5. Click the Browse... button. 

6. Select the Click and Decide Web Demonstration.wfv project file located by default in the C:\Program 
Files\Click and DECiDE\BAI\DemoWeb directory. 

7. Select the Sales by area report. 

8. Replace the beginning of the path with an environment variable if necessary. 

 

9. Select the Visible in browser check box if you want the item to be visible in the Web Portal. Clear the 
check box if you want to hide this item in the. This option is used when a report calls another hidden 
report, however you need to know the URL report inside the Menu to create the hyperlink. (Refer to 
the Click and DECiDE Report Manual). 

10. Click the Format tab to specify the authorized output formats. A report can be exported in HTML 
and PDF format with a WYSIWYG presentation and in Excel format when only data is exported, 
including breaks levels if exist.  

11. Click OK. 

7.4.4. Inserting a Click&DECiDE Dynamic Cube (V13.1 - 32-bit project) 

To insert a dynamic cube, please follow the steps below. 

1. Select the Cubes folder. 

2. Click the Dynamic Cube  icon. 

 

3. Rename the default name Dynamic Cube to the name you want. For example Sales by year and by 
Salesman. 
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4. Double-click the new Dynamic Cube or click the  icon to open the Click and DECiDE Cube 
property sheet. 

5. Click the Browse... button. 

6. Select the Click and Decide Web Demonstration.wfv project file located by default in the C:\Program 
Files\Click and DECiDE\BAI\DemoWeb directory. 

7. Select the Cube 1 Sales by Year and by Salesman cube. 

8. Replace the beginning of the path with an environment variable if necessary. 

 

9. Select the Visible in browser check box if you want the cube to be visible in the Web Portal. Clear 
the check box if you want to hide the check box in the Web Portal. 

10. Click the Format tab to specify the authorized output formats. A cube is mainly exported to HTML 
format. This allows the user to manipulate the dimensions and measures in the dynamic cube.  
Note: that exporting the cube to PDF format will generate a static PDF file with the cube inside but it 
will not be possible to use the condensed or detailed modes nor with the dimensions and measures. A 
cube can also be sent to Excel 2007, this is a new feature in Click and DECiDE version 10.1.  

11. Click OK. 

7.4.5. Inserting a Click&DECiDE Static Query 

To insert a static query, please follow the steps below. 

1. Select the Queries folder. 

2. Click the Static Queries  icon. 
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3. Launch Click&DECiDE Builder, select Start> All Programs> Click and DECiDE> Builder in the 
Start menu. 

4. Open the Click and Decide Web Demonstration.wfv project file located by default in the 
C:\Users\Public\Documents\Click and DECiDE Samples\Web Portal directory. 

5. Open the Customer file query. 

6. Export the query by selecting File> HTML> Publish to Web Portal.  

7. Select the target directory in C:\Users\Public\Documents\Click and DECiDE 

Samples\Web Portal\Publication. Note the following file name will be proposed Customer 

file.cndr 

8. Click OK. 

9. Rename the default name Static Query to Customer List. 

10. Double-click the new static query or click the  icon to open the Click and DECiDE static Query 
properties property sheet. 

11. Click the Browse... button. 

12. Select the Customer file.cndr file located in the C:\Users\Public\Documents\Click and 

DECiDE Samples\Web Portal\Publication directory. 

 

13. Select the Visible in browser check box if you want the static query to be visible in the Web Portal. 
Clear the check box if you want to hide the static query in the Web Portal.  

14. Click OK. 
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7.4.6. Inserting a Click&DECiDE Static Report 

To insert a static report, please follow the steps below. 

1. Select the Reports folder. 

2. Click the Static Report  icon. 

 

3. Rename the default Static Report name with the name you want, for example Sales by Category. 

 

4. Double-click the new static report or click the  icon to open the Click and DECiDE Static Report 
Properties property sheet. 

5. Click the Browse... button. 

6. Select the Sales by category.cndr file located in the C:\Users\Public\Documents\Click and 

DECiDE Samples\Web Portal\Publication directory. 

7. Optional: note that the path name using the Environment variable can be used. 

%CND_BAI_SAMPLES%\Web Portal\Publication\Sales by category.cndr 
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8. Select the Visible in browser check box if you want the static report to be visible in the Web Portal. 
Clear the check box if you want to hide this item in the Web Portal if necessary.  

9. Click OK. 

 

7.4.7. Inserting an URL or Click&DECiDE Dashboard 

To insert a Click&DECiDE Google Chart Dashboard, please follow the steps below. 

1. Select the root branch. 

2. Click the  New Folder icon to insert a new folder. 

3. Right-click the new folder. 

4. Select Rename and rename the folder with the name you want, for example Dashboard. 

5. Select the new folder, in this example the Dashboard folder. 

6. Click the  icon to add an URL. 

 

7. Go to the Web Portal and select in the BAI Demonstration menu, the Dashboard branch, then the 
Geo Chart Application sample: 
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8. Make a right mouse click and select Copy shortcut. 

9. Rename the default name Dashboard with the name you want, for example USA Geo Chart in this 
example. 

 

10. Double-click the new USA Geo Chart branch and paste the URL into the box: (removing the 
http://servername): 

/DVWEB/Menus/Display.aspx?__ma=BAI+Demonstration&__mi=2558&__rp=Dashboard+Samples%
2fSales+by+Area.xgc 

 

11. Optional: click the Icon Tab and enter a picture name such as “googledevelopperlogo.png” 
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The picture is located into the Server in the directory C:\Program Files\Click and 

DECiDE\dvweb\App_Themes\Click and DECiDE\Images. You also can select another picture 

in this directory. (No path has been to enter, only the picture name). 

12. Click OK to validate. 

7.4.8. Inserting a Link to a File 

To insert a link to a file, please follow the steps below. 

1. Select the root folder. 

2. Click the  New Folder icon to insert a new folder. 

3. Right-click the new folder. 

4. Select Rename. 

5. Rename the folder with the name you want, for example Other. 

6. Select the new folder, in this example the Other folder. 

7. Click the  Link to File icon to add a link to a file. 

 

8. Right-click Link to a file. 

9. Select Rename. 

10. Rename Link to a file with the name you want, for example Sales by Salesman. 
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11. Double-click the new Sales by Salesman branch or click the  icon to open the Link to a file 
properties property sheet. 

12. Click Browse.... 

13. Select the Sales by salesman.xls file located in the C:\Program Files\Click and 
DECiDE\BAI\DemoWeb directory. 

 

14. Note that the corresponding Mime Type is automatically displayed, if the file is recognized.  

15. Click the Mime Type arrow to expand the drop-down list. 

16. Click OK. 

7.4.9. Inserting a URL 

To insert a URL, please follow the steps below. The URL could launch a query, a report, a cube, a Dashboard 
as describe before, a Web Site etc. 

1. Select the Other folder. 

2. Click the  Hyperlink icon to add a link to an URL. 
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3. Right-click URL. 

4. Select Rename. 

5. Rename the default name URL with the name you want, for example Click&DECiDE Web Site. 

 

6. Double-click the new URL, in this example Click&DECiDE Web Site or click the  icon to display 
the URL Properties property sheet. 

7. Enter the URL you need, for example http://www.clickndecide.com. 

 

8. Click OK. 

7.4.10. Inserting a link to Click&DECiDE Builder 

If your license certificate located in the Server machine authorizes you to use Clik&DECiDE Builder via the 
Web Portal, using a secured data source specified by your Administrator of the Administration Manager, you 
can add a link to use this application for those authorized users. To insert a link to Click&DECiDE Builder in 
the Web Portal, please follow the steps below. 

1. Select the root folder. 

2. Click the  New Folder icon to insert a new folder 

3. Right-click the new folder. 

4. Select Rename. 

5. Rename the new folder with the name you want, for example Click&DECiDE Builder. 

6. Select the new folder, in this example the Click&DECiDE Builder folder. 

7. Click the  Insert Dynamic Link to Click&DECiDE Builder icon, to add a link to start 
Click&DECiDE Builder using a predefined secured data source, such as the one installed with 
Click&DECiDE BAI. 
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8. Right-click the default name Builder Link. 

9. Select Rename. 

10. Rename the Builder Link with the name you want, for example Click&DECiDE Builder on SQL 
Server. 

11. Double-click the new Builder Link or click the  icon to open the Query Builder Link properties 
property sheet. Now this dialog box allows to select several Data Sources (declared as Data Sources 
with Security in Administration Manager) (new since version 2015) 

 

12. Select the required Data Source(s) from the Data Source drop-down list 
Note:  the selected data source(s) must be a secured data source in the Administration Manager. 

13. Optional: you can enable access to all secured Data Sources. 

14. Click OK.  

 

Note: when the authorized end user clicks this link for the first time, they will be prompted to install 
Click&DECiDE Builder. 

7.4.11. Inserting a Shared Folder 

To insert a shared folder, please follow the steps below. 

1. Select the root folder. 

2. Click the  Insert Shared Folder icon.  
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3. Right-click the new Shared Folder. 

4. Select Rename. 

5. Rename the default name Shared Folder with the name you want, for example My Shared Folder. 

6. Double-click the new Shared Folder, in this example My Shared Folder or click the  icon to open 
the Shared Folder Properties property sheet.  

7. Select the General tab. 

 

8. Click Browse. 

9. Select the Folder Path corresponding to the directory you want to be used as a Shared Folder, 
example C:\Program Files\Click and DECiDE\BAI\DemoWeb\Shared Folder or using the Environment 
variable %DATASET_DEMO%\DemoWeb\Shared Folder. 

10. Click Display sub folders if you want to see all the sub-folders. 

11. Click Hide Empty Directories if you want to hide them. 

12. Note that by default Show files will show all files including Click&DECiDE Builder project files. To limit 
the files shown, you can enter specific files and/or items beginning with a string. For example: 

Show files = B*;W* will only display directories, files or Click&DECiDE Builder project files beginning 
with a B or W. Show files = *.wfv;*.pdf will display files with the wfv or pdf extensions. (Use a 
semicolon as separator). Note that *. will display directories names. 
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Hide files = *.lst;*.cub will hide files with the lst or cub extensions. (Use a semicolon as separator). 
Note:  queries, reports and cubes can be hidden directly from a Click&DECiDE Builder project file 
using the Visible property set to No for each required item. 

Hide extension: select this check box if you want to hide all file extensions. 

13. Select the Click and DECiDE tab: 

 

14. Select the Enable browsing in Click and DECiDE project files check box, if you want to display the 
content of each visible project file in the shared folder. If you clear this check box the project file will 
behave as a standard file and the user will get the message about the file download. 

 

If the Enable browsing in Click and DECiDE project files check box is selected, then you can see all the 
queries, reports and cubes in the same branch.  

15. Enable the Show Item Type as Subdirectory check box if you want to see three distinct branches to 
separate queries, reports and cubes. 

16. Select the Format tab. 
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17. Select the output format you want to authorize for all project items (queries, reports and cubes).  

Note: refer to the Output Format section later in this document. 

 

18. Click OK. 

7.4.12. Inserting a Shared Folder by Group 

Under Windows Authentication, you can insert a Shared Folder that will create automatically a sub-directory 
for each recognized Windows User Groups, such as Administrators, Users, Domains Users, etc. 

To do so, create a shared folder as describe in the previous paragraph but change the target path adding 
<GROUP> (in Uppercase characters) in the path: 
%CND_BAI_SAMPLES%\Web Portal\Shared Folder\<GROUP> 

If you are a User belonging to the User Group whose name in Windows is “Users”, then, when accessing this 
Shared Folder, you automatically will see the list of the Group(s) you belong to: 

 

And when you click on one of these Groups, you see the content authorized of this Group: 
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Note: this <GROUP> also will be used by the “File” > “Open” and the “File” > “Save As” commands from the 
“Create” main command in the Web Portal, used to manage the Google Charts Applications. (Refer to the 
Google Chart User Manual for more information). 

Note also that this <GROUP> can be used when defining a Task in the Destination Directory Path: 

 

(Refer to the Web Portal User Manual for more information). 

7.4.13. Inserting a Shared Folder by User 

Under Windows Authentication, you can insert a Shared Folder that will create automatically a sub-directory 
for each recognized Windows User, such as Administrator, Georges, Mary, Alicia, John etc. 

To do so, create a shared folder as describe in the previous paragraph but change the target path adding 
<USER> (in Uppercase characters) in the path: 
%CND_BAI_SAMPLES%\Web Portal\Shared Folder\<USER> 

If you are a Windows User then, when accessing this Shared Folder, you automatically will only see the 
content of the Subdirectory corresponding to your Name (User-ID): For example the current connected User is 
“Didier”: 

 

And here, with the Same Destination Directory “Shared Folder by User”, the Administrator User will see the 
content of the “Administrator” Subdirectory: 

 

Note: this <USER> also will be used by the “File” > “Open” and the “File” > “Save As” commands from the 
“Create” main command in the Web Portal, used to manage the Google Charts Applications. (Refer to the 
Google Chart User Manual for more information). 

Note also that this <USER> can be used when defining a Task in the Destination Directory Path: 
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7.4.14. Inserting a Calendar Shared Folder (New since version 15.1) 

Click&DECiDE Web Portal allows to manage a special Shared Folder containing files having a calendar suffix 
using the Y, M and D characters so that a Year, a Month or a Date can be recognized. 

In the BAI Demonstration Menu you can see a new ”Calendar Folder”: 

 

A Calendar Folder is made as a Standard Shared Folder describe previously in this Manual, but now a new 
Tab named “Calendar View” can be enabled:  

 

Enable the option “Browse this folder as a Calendar” to make this shared folder as a Calendar Folder. 

If you wish to see a calendar icon in this Menu Branch, just add the picture name “calendar.png”, already 
existing in each Web Portal Theme, in the Icon Tab: 
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The Daily Files will be recognized if their prefix contains the Year, the Month and the Day information as 
specified in the “Daily Files” frame (Standard means for example Firewall_Daily_YYMMDD.pdf, or Sales for 
the Day_YYMMDD.xlsx etc.). 

The Monthly Files will be recognized if their prefix contains the Year and the Month information as specified 
in the “Monthly Files” frame (Standard means for example Firewall_Monthly_YYMM.pdf, or Sales for the 
Month_YYMM.xlsx etc.) 

The Yearly Files will be recognized if their prefix contains the Year information as specified in the “Yearly 
Files” frame (Standard means for example Firewall_Yearly_YY.pdf, or Sales for the year_YY.xlsx etc.) 

For each level, you can customize the suffixes you need if necessary. 

 

As you can see in the Tooltip: 

The Year %Y can be with century, as decimal number (4 digits) 
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The Year %y can be without century, as decimal number (2 digits) between 00 and 99 

The Month %m must be as decimal number (2 digits) between 01 and 12 

The Day %d must be as decimal number (2 digits) between 01 and 31 

Warning: if you define for example the Custom Monthly Filtering as *_%y%m.* (with 2 digits for the year) and 
the Custom Yearly Filtering as *_%Y.* (with 4 digits for the year), then you could have sometimes a similar 
and confusing value such as this example: 

Custom Monthly Filtering = 2004 supposed to be year 2020 and Month of April 

Custom Yearly Filtering = 2004 supposed to be the year 2004 

The rule is the following: “the program will test first if the value matches the Daily filter, then if the value 
matches the Monthly filter and then if the value matches the Yearly filter”. 

In the above example a file named Sales_for_2004.pdf will be first considered as being a Monthly Filter and 
not a Yearly Filter. If you really want this file to be recognized as a Yearly filter, modify the Custom Monthly 
Filter as follow:  *_%Y%m.* (with 4 digits for the year). 

Example installed with the Demo Database: click the “Calendar Folder” in the BAI Demonstration Menu and 
click the YEAR button: the result should look like the following picture if current year is 2015: 

 

Each white square with a number of the day is corresponding to a Daily File having the suffixes defined in the 
Web Menu, so you immediately see where are the days with such files. If you click on of these squares, you 
open the content. Example if you click on November 16th, 2015: that will open this PDF file. 

 

Then you can navigate using the following arrows: 
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If you see a Daily File as the above example, November 16th, 2015 and click the middle arrow, you will jump 
to the November Monthly file (if exists): 

 

but if you are currently seeing a Monthly File (November 2015) and click the middle arrow, you will jump to the 
Yearly File for the year 2015 (if exists): 

 

if you are currently seeing a Yearly File (Year 2015) and click the right arrow, you will jump to the next Yearly 
File for the year 2016 (if exists) etc. 

Go back to the Calendar Folder branch; if you click the Month button, you will see all the days of the current 
month (or selected month): 
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Note that the current day is the one having a red frame. 

You can click the left or right arrow to go to the previous or next month. 

If you click the Today button, you will jump to the Monthly view containing the current date: 

 

Calendar folder with sub-directories: 

Since version 15.2 the Calendar Folder automatically manage the sub-directories if exist. 

In the BAI Demonstration Menu, you can see a standard Shared Folder allowing to access the Cick&DECiDE 
Network Security Intelligence directory, displaying several sample PDF files for various equipment’s: 

 

If we define a new Calendar folder on this location: 
%CND_BAI_SAMPLES%\Web Portal\Shared Folder\Network Security Intelligence 

we can navigate in each sub-directory and see the PDF files according to their dates and suffixes in a 
Calendar View mode. Example if you select the Web sub-directory you should see several files for January 
2007 and February 2007: 

 

On each file a tooltip displays the file name if you place the mouse on a date with a file. 
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Calendar folder with different file names: 

If a Calendar folder contains several file families, with different names for the same suffix (same date or same 
month or same year), since version 15.2 the Calendar Folder will automatically display each file family 
separately: 

Example: in a same directory we have a first file family with file names such as SALES_YYMM.PDF and 
another file family with file names such as ORDERS_YYMM.PDF, and also some SALES_YYMMDD.PDF and 
ORDERS_YYMMDD.PDF and some SALES_YY.PDF and ORDERS_YY.PDF. 

The Calendar Folder will display all these files as follow: If you click the Year Level, you will see all the Months 
of the current year with some white squares on the dates having some files with expected suffixes: example 
for October 2015 

 

If you place the mouse on a white square, the list of the found files appears in a Tooltip: 

 

If you click on a white square, the files are displayed so that you can now select one of them to open it: 
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You can now open for example the ORDERS_151010.PDF file, then navigate to the next or previous file 
whose name also begins with ORDERS_. 

7.5. Saving and applying a Menu 

To save and apply a menu, please follow the steps below. 

1. Select File> Save As or File> Save or click the  Save icon to save your menu with the file 
extension *.wmu. 

Note: each time you save a menu, it is not necessary to update the security via the Click&DECiDE 
Administration Manager as this menu file is a separate file. You only need to update the security if you 
modify the Menu list or Menu assigned to one or several User Groups. 

2. Enter the menu name as appropriate, for example My Menu.wmu: 

 

3. Go back to Administration Manager. 

4. Select the Menu tab. 

5. Add a new menu in the left Menus pane. 

6.  Change the name to the name you want, in this example My Menu in the right pane. 

7. Click … browse to search for your menu, in this example the menu saved as My Menu.wmu. 
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8. Click the new menu you’ve just created in the left Menus pane, in this example the My Menu row to 
see the Menu Path. 

9. Modify the path with an environment variable in the Path text box in the right pane. 

10. Select the User Group tab: 

 

11. Move the menu you created from the right All Menus pane to the Menu Access branch in the left 
User Groups pane using a drag-and-drop operation. In this example we are going to move the My 
Menu menu. 

12. Click File> Update Database Security or click the   Update icon. 

13. Launch the Web Portal, select Start> All Programs> Click and DECiDE> Web Portal. 

14. Disconnect and reconnect if you need to reload the menu list in the Web Portal. The new menu, in 
this example My Menu menu will appear if you are a user belonging to the corresponding User 
Group. 
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Or, if you start the Web Portal with http://servername/dvweb/home.aspx or hide the Left Pane you will see the 
Web Portal as follow: 

 

And if you click the Browse button, the menus will appear as follow: 

 

15. Click the My Menu branch to display the Menu Content: 

mailto:support@clickndecide.com
http://www.clickndecide.com/
http://servername/dvweb/home.aspx


 

71 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here. 

 

16. Click any branch to display the Content: 

 

or 

 

Just click the “My Menu” in the main bar to come back to the Menu List. 

7.6. Working with Advanced Menu Functions 

7.6.1. Working with the Options Dialog Box 

When you select View> Options, the Options dialog box appears. This dialog box allows you to define 
general options for the Menu program for the work directories for the following files: 

• Click&DECiDE Builder project files (*.wfv)  

• Click&DECiDE Menu files (*.wmu) 
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7.6.2. Using the Show ID Command 

Select View> Show ID to display the unique ID given to each Menu Item. Each branch will automatically be 
attributed a menu ID. 

 

Each sub-branch or final item is also attributed a specific menu ID. 
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7.6.3. Building a Report URL for a Drill-Down to Another Report 

If you want to jump from one report to another, for example if you want to create drill-downs in your reports, 
then you will need to use URLs. The IDs we saw in the above section are used in the URL that you create for 
drill-down links. In this example we are going to create a URL to enable use to jump from the Sales by Area 
report (Id=9 in the above menu) to another report, located in the Sub-Reports branch. 

Exercise 1: 

1. Add the Demo Multicriteria report into the Sub-Reports branch. 

2. Note the following menu with the Menu Id = 2632 appear for this report. 

 

3. Specify the report to be run and the output format you need (PDF for example) 

 

4. Save this Menu 

5. Launch the Web Portal. 

6. Display this branch via the Web Portal: 

 

7. Click the demo_multicriteria sub-report. 

8. Select any area for the first criteria. 

9. Leave IGNORE (for all values) for the Salesman criteria. 

10.  Leave IGNORE for the Date criteria (the default values will be used later): 
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11. Click the Share button. 

12. You get this URL given by the Web Link to this page: 

 

13. Change the link selecting Display Result: 

 

14. Open the demo_multicriteria query using Click&DECiDE Builder. 

15. Select Query> Parameters to open the Query Parameters dialog box. 

16. Select the AREA_PARAM parameter. 

17. Click the  Copy icon.  

 

18. Close the query. 

19. Open the Sales by area and distributor query that feeds the Sales by Area report. 
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20. Select Query> Parameters to open the Query Parameters dialog box. 

21. Paste the parameter previously copied with the  icon.  

22. Click OK. 

 

23. Click the leftmost column of the AREA field. The Criteria dialog box appears. 

24. Click New to add new criteria on that field. 

25. Enter the parameter name using the Expression tab. 

 

26. Click OK. 

27. Close and save the Sales by area and distributor query. 

28. Open the Sales by Area report (based on this query). 

29. Select the AREA field in the Group Header AREA.  
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30. Select the General tab in the Properties pod. 

31. Enter the following URL in the Hyperlink text box. 

=’/dvweb/Menus/Display.aspx?__ma=My+Menu&__mi=2632&AREA_PARAM=’+AREA+’&__f=PDF&__e=1’ 

Note: using the copied URL we have replaced the beginning before /dvweb with a single quote, then replaced 
the AREA_PARAM =ATLANTIC with ‘…AREA_PARAM='+AREA+'…' and _e=0 with _e=1. 

 

ShowParameters.aspx will display the parameters and output formats. 

Display.aspx will not display the parameters and output formats. 

_ma=My+Menu is the Menu name. 

_mi=2632 is the Menu ID for the called report. 

‘…AREA_PARAM='+AREA+'…' means that the parameter AREA_PARAM will take the content of the AREA 
field. 

_e=1 means that the execution of the called report will be performed immediately without offering the Cancel 
button. 

_e=0 means that the execution of the called report will be performed showing the Run and Cancel buttons. 

_f=PDF: means that the output format for the called report will be Acrobat Reader, it could be modified to 
_f=HTML for example. 

The URL can contain the following items: 

Long Syntax 
Short 
Syntax 

Description 

Menu Items 

__mnu_alias __ma 
Menu name 

Example: __ma=My+Menu 

__mnu_itemid __mi Menu ID (number), example: &__mi=28 

Shared Folder Items 

__relative_path __rp 
Relative path to a Builder Project inside a Shared Folder 

Example: &__rp=Click+and+Decide+Web+Demonstration.wfv 

__type __t 

File type in a Shared Folder 

Example: &__t=vision for a Builder Project file. If this parameter is missing 
the Builder Project File will be considered as a standard file a File Download 
dialog box will be displayed. 

__item_type __it 
Project Item Type in a Shared Folder  (1=query, 2=report, 4=cube) 

Example: &__it=2 
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__item_name __in 
Project Item Name in a Shared Folder 

Example: &__in=Demo_Multicriteria 

Parameters 

<Parameter Name>  

&paramatername=Value&  if the value fixed 

‘…&parametername=’+ ColumnName+’…’  if the value is returned by an 
alphanumeric query column 

‘…&parametername=’+ Str(ColumnName)+’…’  if the value is returned by a 
numeric query column 

‘…&parametername=’+ FormatDateTime('yyyy/mm/dd',ColumnName)+’…’  
if the value is returned by a Date or DateTime query column 

‘…&parametername=’+ ParamAsString('ParamDateName’,[x])+’…’  if the 
value is returned by a Date or DateTime Parameter.  x is optional and can 
take values from 0 to 3. (Refer to Click&DECiDE Report Manual). 

Output Format 

__format __f Output format (PDF, HTML or a C&D Builder output format) 

Execution 

__exec __e 0 = display parameter list before to be run   /  1 = run now. 

 

32. Save the Sales by Area report. 

33. Close the report. 

34. Go back to the Menu. 

35. Clear the Visible in browser check box to ensure the sub-report demo multicriteria is not visible in 
the Web Portal. (Note that you also can Hide the full branch Sub-Report). 

 

36. Click OK. 

37. Or just Clear the Visible in browser option to hide the Sub-Reports branch. 
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38. Click File> Save to save the menu. 

39. Go back to the Web Portal. 

40. Disconnect and Reconnect to refresh the Menu 

41. Note the Sub-Reports branch is now hidden. 

 

42. Click the Sales by Area dynamic report in the right pane. 

 

43. Select several Areas or leave IGNORE. 

44. Select PDF or HTML output format (but remember that the URL built contains __f=PDF) 

45. Click Run to run the report.  

46. Place the mouse in the Area field to display the URL as follows. 
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47. Click on NORTH-WEST for example. The Demo Multicriteria report will appear for the NORTH-WEST 
area: 

 

Note that the new report can be generated in the same frame or in a new frame, according to the PDF Reader 
configuration, with a new Menu Bar, so you can either click the Result Tab to see again the Sales by Area 
result, or the Demo_Multicriteria Tab to come back to the called report. 

You can come back to the Sales by Area result by clicking the Result Tab or the Browser Back button. 

7.6.4. Change Item IDs 

To change Item IDs, please follow the steps below. 

1. Select the item whose ID you want to modify. 
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2. Select Edit> Special>Change Item ID if you wish to modify the Id for this item.  
The new ID number must be a number that is not already used by another item, otherwise an error 
message will inform you that this number is already used.  

 

3. Enter a valid new ID in the New ID box. 

 

4. Click OK. 

7.6.5. Checking Menu Integrity 

To check a menu’s integrity, please follow the steps below. 

1. Select Edit> Special>Check menu integrity. 

2. Note the success message appears if no problems are found. 

 

3. Click OK. 

7.6.6. Minimizing the Next ID Value 

Each time you delete an item in a Menu or a Branch, the ID used is lost. If the highest menu Id was 32 and 
you remove the items with the ID numbers 29 to 32, the next time you add a new item, the ID number will be 
33 because 32 was the last used. 

To minimize the next ID value, please follow the steps below. 

1. Remove the item ID you want, in this example 33. 
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2. Select Edit> Special>Minimize Next Id Value if you wish to reset the next ID value to the lowest 
possible. 

3. Note the confirmation for the next ID value (this will be the first available number not already used). 

 

Or, if you have removed the branch having the ID = 25, then the message could be: 

 

If there is no item using the IDs 22 to 25. 

4. Click OK. 

7.7. Defining Web Menu Output Formats 

Each time you create a branch running a Click&DECiDE item (Query, Report or Cube), you can specify the 
authorized output formats. For example, if you want a report to only be exported to PDF format, or a Cube to 
only be exported to HTML format or to Excel Pivot Table, or a query to be exported to several formats, such 
as PDF, HTML, Excel and so on. 

To define Web Menu output formats, please follow the steps below. 

1. Click the Item Properties icon to define the item properties property sheet, for example, the Click 
and DECiDE Query property sheet. 

2. Select the Format tab to specify the authorized output formats, by clicking on the left part of the 
output format name: 

 

Note: the output format list is the one that was installed with the Click&DECiDE Builder on the Server 
machine, and if the list has been customized, the modified formats or new available output formats will appear 
in this list. 
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3. Click OK. 

4. Select File> Save. 

7.7.1. Working with Output Formats without Options 

Select HTML and/or PDF in the item properties Format tab if you wish the item to be exported later to these 
formats by the end user. 

Note the special Atom output format that can be used if you wish to be able through the Web Portal to create 
some Power Pivot inside Excel 2010 or greater. Refer to the Click&DECiDE BAI Web Portal User Guide 
v2015 for more information, chapter 4.7. 

 

 

Note the special Bigquery output format that can be used if you wish send data to the Google Cloud 
Database.  

 

 

Note the special Google Data Table output format that can be used if you wish to use the Google Dashboard 
running against already prepared data source files (*.gcd) giving a faster response time that a real-time 
connection to dynamic queries. Refer to the BAI Dashboard Google Chart User Guide for more information. 

 

 

Note the special Pivot Data Table output format that will authorize through the Web Portal to see the Pivot 
Data Table output format, allowing to create dynamically a Pivot Table. 
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Note the special WebQuery output format that can be used if you wish to be able through the Web Portal to 
see the special icon allowing to retrieve data in an Excel sheet using the corresponding URL in the command 
Data> From Web as describe in the ClicknDECiDE_BAI_Web_Portal_User_Guide_v2015.pdf manual, 
chapter 4.6. 

 

 

7.7.2. Working with ASCII Output Formats with Options 

All output formats such as ASCII, ASCII List, ASCII Sequential, CSV, RTF and so on, accept certain options 
such as a template target file and a write mode: ERASE or APPEND. 

To work with ASCII output formats with options, please follow the steps below. 

1. Click the item properties icon to display the item properties property sheet. For example, the Click 
and DECiDE Query property sheet. 

2. Select the ASCII output format. 
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3. Click Browse... to locate the ASCII template on your disk. 

 

4. Select the Write Mode, either Erase content or Append content from the Action drop-down list. 

5.  Click OK. 

 

6. Select File> Save to save your menu to apply the changes. 

Note: when the end user runs this query later and selects ASCII as the output format, the data will be sent 
using a copy of the template file and using the specified write mode. If the template file contains, for example 
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a row with all header column names, the Append content Action option must be used, because the Erase 
content mode will generate a new ASCII file without the header row. 

7.7.3. Working with Excel Output Formats with Options 

The Excel XLS and Excel XLSX output formats accept certain options such as a template file name, a Sheet 
name, the destination cell and the write mode as follows. 

7.7.3.1. Excel XLS 

To work with an Excel XLS (Excel 95 to Excel 2003) output format with options, please follow the steps below.  

1. Select the Excel XLS output format for this query. 

 

2. Click Browse to locate the ModelExcel.xls file in the C:\Users\Public\Documents\Click and DECiDE 
Samples\Web Portal directory by default. 

3. Select the demo Sheet Name. 

4. Change the cell to A8.  

5. Keep the Replace action. 

 

6. Click OK. The presentation you defined will appear 

Note: the syntax for the Excel and Sheet name is the following: 

[C:\Users\Public\Documents\Click and DECiDE Samples\Web Portal\ModelExcel.xls]demo 

or 
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[PathName\FileName.xls]SheetName 

And the destination cell and write mode are written as follows. 

A8[REPLACE] 

or 

Cell[WriteMode] 

 

7. Click OK. 

8. Select File> Save to save the menu to apply the changes. 

Note: when the end user runs this query later and selects Excel as the output format, the data will be sent 
using a copy of the Excel template loaded in memory and using the specified Sheet Name, Cell and write 
mode. 

7.7.3.2. Excel XLSX 

The same can be performed with Excel XLSX (Excel 2007, Excel 2010 or greater). Repeat the steps 
described for Excel in the section directly above. Select the ModelExcel.xlsx file instead of the ModelExcel.xls. 
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Note: the syntax for the Excel XLSX and Sheet name is as follows. 

[C:\Users\Public\Documents\Click and DECiDE Samples\Web Portal \ModelExcel.xlsx]demo 

or 

[PathName\FileName.xlsx]SheetName 

Note: when the end user runs this query later, selecting Excel XLSX as the output format, the data will be 
sent using a copy of the Excel XLSX template loaded in memory and using the specified Sheet Name, Cell 
and write mode. 

7.7.3.3. Excel XLSX Big Data 

This output format is similar to the Excel XLSX (Excel 2007, Excel 2010 or greater) but will allow a fast 
transfer performance. This option only accepts ERASESHEET or ERASEFILE write modes and sends data 
without layout neither format that you can change later under Excel This format is recommended for very big 
volume of Data. 

7.7.4. Excel Pivot Table and OWC Cube 

These output formats are specific for a Cube item and will apply to a Cube Tab. The Cube must have been 
done with a Click&DECiDE Builder version 13 (32-bit). 

This new feature; since version 10.1, allows you to send data and presentation from a dynamic cube in the 
Web Portal to Excel XLSX  (Excel 2007 or greater using *.XLSX). 

Since version 2013, the Cubes Data Tabs can also be exported to Excel Pivot Table (without the Chart 
Tabs). 

Since version 2015, a Cube can be run in HTML (Tabular views and Chart Views) using the OWC Cube 
output format. 

That is why, now, all available formats appear in the Menu Builder for a Cube: 

 

Once the menu is saved and the menu list refreshed through the Web Portal, select this output format to send 
the cube tab into an Excel XLSX file having the XLSM extension, as in the following example: 

 

Click Run 
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Open the file under Excel 2007, 2010 or greater. 

 

Using OWC Cube output format, you will get the result as follow: 
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8. Other commands 

8.1. Backup Database Security 

Use the command File> Backup Database Security to save your entire Administration Manager configuration. 

A default name such as 2010.03.17_122424.cndbck will be proposed (YYYY.MM.DD_hhmmss.cndbck) 

Note that the previous extension was .bck can still be used, but since version 10.1 the extension will be 
.cndbck. 

 

This backup file will contain all the data sources defined, all the Users and User Groups defined, all the Menu 
Names defined in this software and all the relation between each Tab 

New since Click&DECiDE version 2012: this backup also contains now the Scheduled Tasks and the 
Output Formats defined in the Server machine and made with Click&DECiDE Builder. 

Warning: this backup will not include the Menu files (with extension *.wmu) neither the Model files (with 
extension *.mod or *.mox). 

8.2. Restore a Backup for Administration Manager 

Close Click&DECiDE Administration Manager. Search for your backup file (with extension *.bck or *.cndbck) 
and double-click on this file. You will get this window. Click Yes to continue. 

 

That will restore the backup file and open Click&DECiDE Administration Manager. 

Click now the command File> Update Database Security or the corresponding icon   to be sure to 
generate again the working internal files. 

8.3. Check Database Security 

Click the command File> Check Database Security to get a windows displaying information about missing 
items such as User Group without users, Users Groups without Data Source Access, User not belonging to 
any User Group etc. 
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8.4. Export Report 

Click the command File> Export Report to get a report in RTF format about: 

Data Source summary: all the data source name, their type, the Running Mode, the security, the maximum of 
simultaneous users, the Locked status, the direct access, the default password, etc. 

User Group summary: Name, Description, Task Administrator (Supervisor), Enable status. 

Users summary: Name, ID, Password (stars only will appear if exist), Address, Zip Code, City, Phone, Enable 
status. 

User and Password summary: Data Source, ID, Password (Encrypted if exist). 

User and User Group summary: list of all Users with ID and Name for each User Group. 

User Group and Data Source Access summary: User Group, Data South, Path (if defined). 

Problems summary: the same information given by the command File> Check Database Security 

8.5. Import Windows Users and Groups 

Click the command File> Import Windows Users and Groups to import directly in Click&DECiDE 
Administration Manager one or several Windows User Groups and Users. 

You will get this window with all machines in the Domain. Select a machine to display the sub-levels Local 
Group and Global Groups: 
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Select the required level, then double click the name to display the sub-level content: 

 

Select the required sub-level to display the sub-level users: 
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And click Import to retrieve the information inside Click&DECiDE Administration Manager. 

The Details box can display some warning such as: 

 

The 'Administrator' User was not imported because of:  

The changes you requested to the table were not successful because they would create duplicate values in 
the index, primary key, or relationship.  Change the data in the field or fields that contain duplicate data, 
remove the index, or redefine the index to permit duplicate entries and try again. 

When this step is finished, click Close. 
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Apply then to any required User Group the data sources they can access to, the menu they will be able to see 
through the Web Portal, etc. 

Always finish using the command File> Update Database Security or the corresponding icon   to be sure 
to generate again the working internal files. 

8.6. Expand or Reduce all Levels with one click 

When being in the User Groups Tab or in the Users Tab, you can expand all levels using one click on the 
“plus” icon: 

 

When being in the User Groups Tab or in the Users Tab, you can reduce all levels using one click on the 
“minus” icon: 
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