
 

 

 

 

Network Security Intelligence | KBA 

www.clickndecide.com Contact us: E-mail: sales@clickndecide.com  Tél: +33 (0)6 71 99 86 60 
Sales Office: 98, route de la Reine - 92100 Boulogne-Bt, France.  
To contact your neares Click&DECiDE partner, click here. 

Knowledge Base Article: Article 214 

 

NSI Click&DECiDE Migration 

How to install Click & DECiDE - NSI 10.1.2 over Net Report 5.10.02 

 
Date: May 21st, 2010 

 

 

Table of Contents 

Table of Contents ................................................................................................................................................ 1 
Before the Migration ............................................................................................................................................ 1 
Section 1: Backup your current configuration ...................................................................................................... 2 
Section 2: Uninstall NetReport 5.10 .................................................................................................................. 11 
Section 3: Install Click & DECiDE - NSI ............................................................................................................ 12 
Section 4: Restore your configuration ............................................................................................................... 17 
Section 5: Check your configuration .................................................................................................................. 30 
 

Before the Migration 

Send us the audit document you have generated using the files included in the zip ClicknDECiDE_NSI_ 

Migration_Request.zip found here: 

http://www.clickndecide.com/downloads/WebDoc/Support/ClicknDECiDE_NSI_Migration_Request.zip 

Once done, we will provide you a new license for the Click & DECiDE - NSI 10.1.2. 

Download the last release of Click & DECiDE here: 

http://license.clickndecide.com/downloads/cndnsi_request.aspx  

 

Note: the operations described in this article require a full access to the computer. Be sure to be 
logged as an Administrator. 

http://www.clickndecide.com/downloads/WebDoc/Support/ClicknDECiDE_NSI_Migration_Request.zip
http://license.clickndecide.com/downloads/cndnsi_request.aspx
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Section 1: Backup your current configuration 

Backup your License Certificates 

1. Save your NetReport license at:  
C:\Program Files\NetReport\NetReport\_license.cert (by default). 

2. If applicable, save your DataSet Vision license at:  
C:\Program Files\NetReport\Dataset\d7vision.cert (by default). 
C:\Program Files\NetReport\WebPortal\d7vision.cert (alternate) 

Backup NetReport Configuration 

1. Start the Management Console: Start>All Programs>NetReport>Management Console. 

2. Navigate to NetReport/Localhost (by default). 

3. Click on Backup 

 

4. Save the new folder named AAAAMMDD-HHMM-user-v510 created in  
C:\Program Files\NetReport\NetReport\ConfigurationBackup (by default). 

5. Browse to the filter lists NetReport/localhost/ULA/Filters (by default). 
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6. Right click on a filter and select Export filters and parsers… 

 

7. Save the configuration for this filter. 

8. Repeat step 6. and 7. for every filters except Database Management, DataSet Alert, DataSet Audit 
and EngineEvent. 

9. Close the Management Console. 

 

Backup the WebPortal Configuration 

1. Start the Web Portal Administrator: Start>All Programs>NetReport>Web Portal Administrator. 
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2. Go to File>Backup Security Database 

 

3. Save the Security Database configuration into a .bck file. 

4. Close Web Portal Administrator. 

5. Save your own DataSet Vision projects (*.wfv files) created with the NetReport toolkit. We recommend to 
put these file in the MyProject folder located at: 
C:\Program Files\NetReport\WebPortal\Runtime_Projects\My Projects (by default). 

6. Save the external files (for example, the images) used by your own DataSet Vision projects. We 
recommend to put these file with the other image files in the Runtime_projects folder located at: 
C:\Program Files\NetReport\WebPortal\Runtime_Projects (by default). 

7. Save your customized standard reports and cubes (if applicable) respectively located in: 
C:\Program Files\NetReport\WebPortal\Runtime_Projects\enu (by default) and 
C:\Program Files\NetReport\WebPortal\Runtime_Projects\cubes (by default). 

8. Save your previously generated reports located in: 
C:\Program Files\NetReport\WebPortal\Runtime_Projects\Static (by default). 

9. Save your customized menus (if applicable): these are the *.wmu files in the Runtime_projects folder 
located at: 
C:\Program Files\NetReport\WebPortal\Runtime_Projects (by default). 

10. Save the scheduled tasks configuration file d7tasks.xml located at: 
C:\Program Files\NetReport\WebPortal\d7tasks.xml (by default). 

11. Save your own script (if applicable) which are located at:  
C:\Program Files\NetReport\WebPortal\TaskScripts (by default). 
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Backup the database files 

1. Stop the NetReport services by running the stopsvc.bat batch file located at: 
C:\Program Files\NetReport\NetReport\stopsvc.bat (by default). 

2. Stop the WebPortal services by running the stopsvc.bat batch file located at: 
C:\Program Files\NetReport\WebPortal\stopsvc.bat (by default). 

3. Start SQL Server Management Studio: Start>All Programs>Microsoft SQL Server 2005>SQL 
Server Management Studio. 

4. Choose Windows Authentication 

 

5. Navigate to Databases/netreport. 
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6. Right Click on netreport and select Tasks>Detach… 
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7. Click OK. 

 

8. Backup the netreport database files, netreport.mdf and netreport_log.ldf  located in: 
C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data (by default) 

9. In SQL Server Management Studio, navigate to Databases. 
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10. Right click on Databases and select Attach… 

 

11. Click Add… 
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12. Browse to the netreport.mdf database file. 
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13. Click OK. 

 

14. Click OK. 

15. Close SQL Server Management Studio. 
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Section 2: Uninstall NetReport 5.10 

 

Uninstall the NetReport Toolkit (if applicable) 

1. Open Start>Control Panel>Add or Remove Programs. 

2. Select DataSet Vision. 

3. Click Remove. 

4. Confirm that you want to uninstall DataSet Vision. 

5. Wait for the operation to complete. 

6. Reboot your machine. 
 

Uninstall NetReport 
 

1. Open Start>Control Panel>Add or Remove Programs. 

2. Select NetReport. 

3. Confirm that you want to uninstall NetReport. 

4. Wait for the operation to complete. 

5. Reboot your machine. 

 

Clean up remaining files 

1. Delete the NetReport folder located at: 
C:\Program Files\NetReport (by default). 

2. Open the Windows registry: Start>Run… Type regedit and click OK. 

3. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\NetReport. 

4. Right click on the NetReport key and select Delete. 

5. Click Yes. 

Note:  

You may wish to back-up your registry if you are not familiar with the fact of working in the 
registry 

you may also delete the Dataset key in HKEY_LOCAL_MACHINE\SOFTWARE\ and in 
HKEY_CURRENT_USER\SOFTWARE\ 
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Section 3: Install Click & DECiDE - NSI 

 

Turning on the Required IIS Features 

IIS is a Windows feature, to launch the Turn Windows Features On or Off module please follow the steps 

below: 

1. Select Start> Control Panel. 

2. Click Programs and Features. 

3. Click Turn Windows Features On or Off 

4. Select the following Internet Information Services features: 

5. Web Management Tools 
a. IIS Management Console 
b. IIS Management Scripts and Tools 
c. IIS Management Service 

6. World Wild Web Services 
a. Applications Development Features 

i. ASP.NET 
ii. ASP 

b. Security 
i. Basic Authentication 
ii. Windows Authentication 

7. Click OK 
 

Download and install the .NET 3.5 SP1 

Click&DECiDE need the Framework .NET to work properly. We recommend you to install the latest version 

before installing Click&DECiDE. Follow the link and install the framework : 

http://www.microsoft.com/downloads/details.aspx?familyid=AB99342F-5D1A-413D-8319-

81DA479AB0D7&displaylang=en  

 

Download and extract the Click & DECiDE - NSI setup 

1. Download the Setup of Click&DECiDE 10.01.02, CnD-NSI.10.01.02.exe,  available at: 

http://license.clickndecide.com/downloads/cndnsi_request.aspx 

2. Run the CnD-NSI.10.01.02.exe setup. 

http://www.microsoft.com/downloads/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en
http://license.clickndecide.com/downloads/cndnsi_request.aspx
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3. Choose where you want to extract the files required for the installation. 

 

4. Click Next. 

5. Wait for the extraction to complete. The Click and DECiDE - NSI Installation Wizard will launch. 

 

The Click and DECiDE - NSI Installation Wizard 

1. If you have any prerequisites, click Install to install them. 

2. On the Welcome to Installshield Wizard for Click and DECiDE - NSI dialog, click Next. 



 

14 
 

 

 

www.clickndecide.com Contact us: E-mail: sales@clickndecide.com  Tel: +33 (0)6 71 99 86 60 
Sales Offices: 98, route de la Reine - 92100 Boulogne-Bt, France.  
To contact your nearest Click&DECiDE partner, click here. 

Network Security Intelligence | KBA 

3. On the License Agreement dialog, read the license agreement and select I accept the terms in the 
license agreement to continue. 

 

4. Click Next. 

5. On the Destination Folder dialog, select a folder on a partition with enough hard disk space. See 
recommendations: 
http://www.clickndecide.com/downloads/WebDoc/Support/ClicknDECiDE_NSI_Database_Archive_Disk_
Size.zip 

 

http://www.clickndecide.com/downloads/WebDoc/Support/ClicknDECiDE_NSI_Database_Archive_Disk_Size.zip
http://www.clickndecide.com/downloads/WebDoc/Support/ClicknDECiDE_NSI_Database_Archive_Disk_Size.zip
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6. Click Next. 

7. On the Setup Type dialog, choose Click and DECiDE NSI Typical Solution. 

 

8. Click Next. 

9. Click Install. 

10. Wait for the installation to complete. 
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11. On the Installshield Wizard Completed dialog, Click Finish. 

 

12. The installation asks for a reboot. Save all your documents and close all your application and click Yes. 
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Section 4: Restore your configuration 

 

Enter your License Certificate 

1. After rebooting your machine, the Log Source Configuration launches and asks for a License 
Certificate. 

 

2. Click Change… 



 

18 
 

 

 

www.clickndecide.com Contact us: E-mail: sales@clickndecide.com  Tel: +33 (0)6 71 99 86 60 
Sales Offices: 98, route de la Reine - 92100 Boulogne-Bt, France.  
To contact your nearest Click&DECiDE partner, click here. 

Network Security Intelligence | KBA 

3. Select the License Certificate we sent you for Click & DECiDE - NSI 10.1.2. 

 

4. Click OK. 
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5. Click Cancel. 

6. Click Cancel and exit the Log Source Configuration. 

 

Restore the WebPortal Configuration 

1. Restore your own DataSet Vision projects (*.wfv files) created with the NetReport toolkit (see Section 
1.C.5). We recommend to put these file in the MyProject folder now located at: 
C:\Program Files\Click and DECiDE\BAI\Runtime_Projects\My Projects (by default). 

2. Restore the external files (for example, the images) used by your own DataSet Vision projects (see 
Section 1.C.6). We recommend to put these file with the other image files in the Runtime_projects 
folder now located at: 
C:\Program Files\Click and DECiDE\BAI\Runtime_Projects (by default). 

Note: Do not replace any existing files. Complete the guide first and then modify the files you 
think are appropriate. 
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3. Restore your previously generated reports (see Section 1.C.8) now located in: 
C:\Program Files\Click and DECiDE\BAI\Runtime_Projects\Static (by default). 

4. Restore your customized menus (see Section 1.C.9) in the Runtime_projects folder now located at: 
C:\Program Files\Click and DECiDE\BAI\Runtime_Projects (by default). 

Note: Do not replace any existing menu. Complete the guide first and then modify the menu with 
the Menu editor. 

5. Locate the Security Database backup file (.bck) from Section 1.C.3 on your hard drive. 

6. Double click on the file. Administration Manager asks if you want to restore the Security Database. 

 

7. Click Yes. 

 

8. Verify that your configuration is correct. Especially the Menu tab since the Runtime_projects folder has 
changed. 
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9. Click Update Security icon 

 

10. Click OK. 

11. Close Administration Manager. 

 

Configure Click & DECiDE - NSI Log Sources 

1. Run the Log Source Configuration tool:  
Start>All Programs>Click and DECiDE>Network Security Intelligence>Log Source Configuration. 

2. Select the same standard devices you analyzed with the previous version and for specific devices, select 
other device which have the same Category. 

3. Click Settings… in the Network section. 

Note: There is no need to reconfigure your network area settings. We will restore these settings 
in the next chapter. 

4. Click OK. 

5. Click Settings… in the Database section. 

6. Test your database connection.  

Note: Click and DECiDE - NSI  now uses Windows Authentication to connect to the database. 
For a remote database connection, additional steps are required. Please refer to the Knowledge 
Base Article: How to Connect to Remote SQL Server at:  
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http://www.clickndecide.com/downloads/WebDoc/CnDRnD/KBA/KBA200_How_to_Connect_to_
Remote_SQL_Server.pdf 

7. Note that the Log Source Configuration tool will perform an update of your database. 

 

8. Click OK. 

9. Click Settings… in the Scheduled Tasks section. 

http://www.clickndecide.com/downloads/WebDoc/CnDRnD/KBA/KBA200_How_to_Connect_to_Remote_SQL_Server.pdf
http://www.clickndecide.com/downloads/WebDoc/CnDRnD/KBA/KBA200_How_to_Connect_to_Remote_SQL_Server.pdf
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10. Configure the purge parameters and the start time of the Click & DECiDE - NSI scheduled task. 

 

11. Click OK. 

12. Click Settings… in the Web Portal section. 

13. Select Click and DECiDE Authentication. 

14. Enter your SMTP server as well as the email address for mail alerts. 

 

15. Click OK. 

16. Click Settings… in the Log Archive section. 

17. Configure your Log Archive settings. 

18. Click OK. 

19. Click OK to apply your configuration. 
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20. Confirm your choice and wait for the Log Source Configuration tool to complete the process. 

21. Close the Log Source Configuraiton. 

 

Restore your custom NSI Log Sources Configuration 

1. Copy the AAAAMMDD-HHMM-user-v440 folder (see Section 1.B.4) to the new folder: 
C:\Program Files\Click and DECiDE\NSI\ConfigurationBackup 

2. Open the Management Console:  
Start>All Programs>Click and DECiDE>Network Security Intelligence>Management Console. 

Note: the default login/password is now admin/admin. 

3. Go to NetReport/localhost/ULA/Filters. 

4. Right Click on Filters and select Import Filters and/or Parsers… 

 

5. Select a non-standard filter you exported (see Section 1.B.7). 

6. Confirm that you want to import the filter and its parsers. 
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7. On all non-standard filter re-imported, you need to add “netreport.” in front of the each table definition call 

define by this icon: . Repeat for each table definition. Example:  

 

8. Repeat steps 4. to 7. for every non standard device. 

9. Go to NetReport/localhost/Backups, you should see your previous configuration. 
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10. Navigate and select a custom initialisation or action you want to restore. For example: the RDNS net 
area initialisation. 

 

11. Click on Copy icon at the bottom of the page. 

12. Navigate where you want to paste the initialisation or action. For example: 
NetReport/localhost/ULA/Settings/Initialisations. 
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13. Select the existing initialization or action (if it exists). 

 

14. Click on Delete icon. 

15. Click on Paste icon. 
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16. Rename the pasted initialization or action. Remove Copy of. 

17. Repeat step 9. to 16. for every initialization or action you want to restore. 

18. Navigate to NetReport/localhost/ULA. 

19. Click Apply Changes. 

 

20. Open the NetReport/localhost/Agents subtree. 

21. Navigate to a node with an asterix (*). 
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22. Click Apply Changes. 

 

23. Repeat step 21. and 22. for every agent with an asterix (*). 

Note : for the Microsoft WMI or the Remote Microsoft WMI, you may need to copy and paste 
specific agent configuration form the backup. 

24. Close the Mangement Console. 

 

Restore the scheduled tasks 

This process requires an advanced knowledge of the product and is beyond the scope of this document. You 

have to create all your previous scheduled tasks manually using the Web Portal interface. Please refer to the 

Web Portal documentation for more information. 
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Section 5: Check your configuration 

 

Log Acquisition 

1. Start the log treatment. 

2. Open the Performance Counters: Start>Administrative Tools>Performance. 

3. Click the + in the toolbar. 

4. Select the NetReport Filter Engine Performance object and select All counters. 

 

5. Click Add. 

6. Click Close. 
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7. Check that you don’t have any nelrf (Click And DECiDE events) in the error queue. 

 

Note: the engine queues are stored in the folder C:\Program Files\Click and 
DECiDE\NSI\Error agent Storage. You can modify the destination of these files by changing the 
registry value: 
HKEY_LOCAL_MACHINE\SOFTWARE\NetReport\MC\Agents\Error\StoragePath. 
You have to restart the Click & DECiDE Filter Engine service after any change 

 

Log Insertion 

1. Open Web Portal: Start>All Programs>Click and DECiDE>Web Portal. 

2. Login as a member of NetReport Admin. 

3. Navigate to NSI Utilities/Database Status. 
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4. Open the project for the category of the log you have acquired. For example: Firewall Statistics 
Utilities. 

 

5. Open the report 2 - Number of Records in the Firewall Tables. 

6. Enter the time interval corresponding to the date of your logs. For example, if you are parsing logs from 
10 days ago, enter 10 in the first text box. 
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7. Click Run. 

 

8. Check that logs are inserted into the rawdata table. 

 

Report Generation 

1. Open the Scheduled Tasks panel: Start>Control Panel>Scheduled Tasks. 
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2. Right Click on Click and DECiDE Scheduled Dashboards and select Run. 

 

3. Wait for the task to complete (it may take some time depending on the volume of your logs). 

 

4. Return to Web Portal (see Section 5.B). 

5. Navigate to NSI Reports and Analysis/Published Report. 
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6. Select the category of the log you have acquired. For example: Firewall. 

 

7. Check that a report has been generated. If you have inserted yesterday’s logs, the reports should contain 
some data. 

 

Event Viewer 

1. Open the Event Viewer: Start>Administrative Tools>Event Viewer. 
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2. Select the Application event log. 

 

3. Check that there are no error from a Click and DECiDE process. 

 


