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Your Question 
 
Article: 00120 
Question: 
How to Configure External Authentication for Net Report Web Portal 
 
 

Net Report Answer 
 

Introduction 
Security devices can be used to control access to network resources. In addition, these access polices can 
ensure that only authorized users access given resources. Net Report has a built- in user database however, in 
large organizations with many devices an IT manager may prefer to leverage existing user databases without 
recreating the user database on multiple devices. Updating each network device’s user database each time a 
personnel change occurs in a network that has tens or hundreds of these devices becomes quite time 
consuming.  
 
The user authorization technologies RADIUS and LDAP, Active Directory provide services for user 
authentication through a centralized database of user information for organizations. This document explains how 
to configure Net Report to use LDAP, Active Directory, Radius to communicate with a Directory server and 
perform authentication and how to manage Net Report Web Portal login passwords for external data sources 
and NT. 
 
In addition to the standard authentication options provided by Net Report, it is possible to perform authentication 
via the following other methods: 
 
Full User Authentication & Management 
To use the following methods the administrator must create user groups via the Net Report Web Portal 
Administrator (see section 1 and the Appendix). Authentication will be performed and parameters will then 
automatically be returned to the appropriate user groups in the Net Report Web Portal Administrator and the 
administrator can continue working with their existing user databases without needing to use the Net Report 
Web Portal Administrator: 

• LDAP (Lightweight Directory Access Protocol), NetScape. 
• Active Directory, 
• RADIUS. 

 
Partial User Authentication 
To use the following methods the administrator must create users in the user groups via the Net Report Web 
Portal Administrator (see section 1 and the Appendix): 

• Password Management for the Web Portal Login for External Data Sources.  
• NT Security to check User Passwords for the Web Portal Login 

 
This document is organized as follows: 

• Section 1: Creating User Groups via Net Report Web Portal Administrator 
• Section 2: Configuring LDAP Authentication for Net Report Web Portal 
• Section 3: Configuring Active Directory Authentication for Net Report Web Portal 
• Section 4: Configuring RADIUS Authentication for Net Report Web Portal 
• Section 5: Using NT for Password Authentication 
• Section 6: Managing Passwords for External Data Sources 
• Appendix: Creating Web Portal Menus in the Net Report Web Portal Administrator 
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Section 1: Creating User Groups via Net Report Web Portal Administrator 
To create User Groups via Net Report Web Portal Administrator, please follow the steps below: 
 
You can create user access rights to the Net Report Web Portal via the Net Report Web Portal Administrator. 
For example you can add, edit and delete User Groups and Users via the User Groups and Users tabs 
respectively. 
 

 
 
Steps 

1. Select Start> Program Files> NetReport> Web Portal Administrator. 
 

2. Select the User Groups tab. 
 

3. Select Item>New> User Group. The New User Group appears. 
 

4. Rename the new User Group, for example: MyUserGroup. 
 

5. Select the Administrator check box. Note: Administrator rights give you the privilege of scheduling a 
report in the Net Report Web Portal. A normal User does not have this privilege 

 
6. Select the MyUserGroup > Data sources access branch. 
 
7. Drag and drop the appropriate data source to the Data sources access branch. 

 
8. Select the MyUserGroup > Menu access branch. 

 
9. Drag and drop the appropriate to the Menu access branch. Note you may need to create a menu, to 

find out how, please see the Appendix at the end of this document. 
 

10. Click the Refresh icon to apply the modifications you have made. 
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Section 2: Configuring LDAP Authentication for Net Report Web Portal 
To configure LDAP Authentication for Net Report Web Portal, please follow the steps below: 
 
 
Steps 

1. Select the Net Report Web Portal Directory, by default 
C:\Program Files\NetReport\WebPortal 

2. Open the Aliases.ini file. 

3. Add the following lines between the [General] and [NetReport] sections. 

[Web] 

LDAPServersForWebLogin=computer1 

LDAPServerPort=389 

LDAPConnectionString=uid=%USER%,ou=people,o=airius.com 

LDAPSearchBase=ou=people,o=airius.com 

LDAPSearchFilter=(uid=%USER%) 

LDAPAttributeForGroups=mycompanygroup 

LDAPDefaultGroup=Guest 

4. Define the following: 
 
LDAPServersForWebLogin: the hostname of the LDAP server to be queried for authentication. In this 
example, computer1. Note: use the comma “,” as a separator for multiple values for example, 
LDAPServersForWebLogin=computer1,computer2,computer3  
in which case a connection will try to be made to computer1 first, if it is not possible to connect to 
computer1 it will then try to connect to computer2 and so on. 
 
LDAPServerPort: the port number which the LDAP server is listening on. The standard port number is 
389 for a non-SSL connection.  
 
LDAPConnectionString: The character string which will be used to connect to the LDAP server, for 
example: 
uid= User ID. Please note that %USER% will be automatically replaced by the User ID the user enters 
when logging into the Web Portal. 
ou = Organisational Unit. Please modify this as appropriate, for example, people. 
o =  Organisation. Please modify this as appropriate, for example, airius.com. 
 
LDAPSearchBase: searches LDAP Server for the Organisational Unit (ou) and Organisation (o) you 
specify for example: 
ou = Organisational Unit. Please modify this as appropriate, for example, people. 
o =  Organisation. Please modify this as appropriate, for example, airius.com. 

 
LDAPSearchFilter: configures the search filter for the resources, for example: 
uid= User ID. Please note that %USER% will be automatically replaced by the User ID the user enters 
when logging into the Web Portal. 
 
LDAPAttributeForGroups: The name of the attribute of the directory entry corresponding to the user 
group created via Net Report Web Portal Administrator, for example mycompanygroup. You may need 
to add this attribute to each user in your LDAP repository in order to use Net Report Web Portal.  
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LDAPDefaultGroup: allocates user(s) to the default group if the attribute defined in 
LDAPAttributeForGroups was not found. For example, Guest 

5. Click File>Save to save the Aliases.ini file. 

 
Section 3: Configuring Active Directory Authentication for Net Report Web Portal 
To configure Active Directory Authentication for Net Report Web Portal, please follow the steps below: 
 
 
Steps 

1. Select the Net Report Web Portal Directory, by default 
C:\Program Files\NetReport\WebPortal 

2. Open the Aliases.ini file. 

3. Add the following lines between the [General] and [NetReport] sections. 

[Web] 
LDAPServersForWebLogin=computer1 
LDAPServerPort=389 
LDAPConnectionString=%USER%@mycompany.local 
LDAPSearchBase=CN=users;DC=mycompany;DC=local 
LDAPSearchFilter=(SAMAccountName=%USER%) 
LDAPAttributeForGroups=mycompanygroup 
LDAPDefaultGroup=Guest 
 

4. Define the following: 
 
LDAPServersForWebLogin: the hostname of the LDAP server to be queried for authentication. In this 
example, computer1. Note: use the comma “,” as a separator for multiple values for example,  
LDAPServersForWebLogin=computer1,computer2,computer3  
in which case a connection will try to be made to computer1 first, if it is not possible to connect to 
computer1 it will then try to connect to computer2 and so on. 
 
LDAPServerPort: the port number which the LDAP server is listening on. The standard port number is 
389 for a non-SSL connection.  
 
LDAPConnectionString: The character string which will be used to connect to the LDAP server, for 
example: 
%USER%: will be automatically replaced by the User ID the user enters when logging into the Web 
Portal. 
@mycompany.local: the domain. For example, net-report.local. 
 
LDAPSearchBase: searches the LDAP Server for the CN (Common Name), DC (Domain Component) 
and DC (Domain Component) you specify for example: 
CN: users. Please modify this as appropriate. 
DC = mycompany. Please modify this as appropriate. 
DC= local. Please modify this as appropriate. 

 
LDAPSearchFilter: configures the search filter for the resources, for example: 
SAM Account Name: (Security Accounts Manager service) Account Name 
%USER% will be automatically replaced by the User ID the user enters when logging into the Web Portal. 
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LDAPAttributeForGroups: The name of the attribute of the directory entry corresponding to the user 
group created via Net Report Web Portal Administrator, for example mycompanygroup. You may need 
to add this attribute to each user in your Active Directory in order to use Net Report Web Portal. 
 
LDAPDefaultGroup: allocates user(s) to the default group if the attribute defined in 
LDAPAttributeForGroups was not found. For example, Guest 

5. Click File>Save to save the Aliases.ini file. 

 
Section 4: Configuring RADIUS Authentication for Net Report Web Portal 
To configure RADIUS (Remote Authentication Dial In User Service) Authentication for Net Report Web Portal, 
please follow the steps below. A RADIUS server can manage user profiles for authentication (verifying user 
name and password), configuration information that specifies the type of service to deliver, and policies to 
enforce that may restrict user access. 
 
 
Steps 

1. Select the Net Report Web Portal Directory, by default 
C:\Program Files\NetReport\WebPortal 

2. Open the Aliases.ini file. 

3. Add the following lines between the [General] and [NetReport] sections. 

[Web] 
RadiusServerForWebLogin=192.168.3.113 
AltRadiusServerForWebLogin=192.168.3.114 
RadiusServerAuthenticationPort=1812 
RadiusServerAccountingPort=1813 
RadiusCHAP=0 
RadiusRetries=3 
RadiusTimeout=10, 
RadiusAttributeForGroups=25 
DefaultRadiusGroup=defaultgroup 
 

6. Define the following: 
 

RadiusServerForWebLogin: RADIUS Server Name or IP Address to use for Web Portal logins. 
 
AltRadiusServerForWebLogin: an alternative RADIUS Server Name or IP Address to use for Web 
Portal logins. This is optional. 
 
RadiusServerAuthenticationPort: the UDP port over which RADIUS authentication messages are 
sent and received. By default UDP ports 1812 and 1645 are used. UDP port 1812 is the reserved 
RADIUS-authentication port described in RFC 2138. UDP port 1645 is used by earlier RADIUS clients.  
 
RadiusServerAccountingPort: the UDP port over which RADIUS accounting messages are sent and 
received. By default, ports 1813 and 1646 are used. UDP port 1813 is the reserved RADIUS accounting 
port described in RFC 2139. UDP port 1646 is used by earlier RADIUS clients. 
 
RadiusCHAP: CHAP: Challenge Handshake Authentication Protocol. Contains the response value 
provided by the CHAP in response to the challenge. 
 
RadiusRetries: the maximum number of attempts that you wish the RADIUS server to allow. 
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RadiusTimeout: the amount of time in seconds to wait for a response from the RADIUS server before 
making another connection attempt. 
 
RadiusAttributeForGroups: the attribute of the directory entry corresponding to the user group created 
via Net Report Web Portal Administrator. You may need to add this attribute to each user in your 
RADIUS repository in order to use Net Report Web Portal. 
 
DefaultRadiusGroup: allocates user(s) to the default group if the attribute defined in 
LDAPAttributeForGroups was not found. For example, defaultgroup 

 
7. Click File>Save to save the Aliases.ini file. 

8. Select C:\Program Files\NetReport\SetSharedSecret.exe 

9. Double-click the SetSharedSecret.exe file 

10. Enter your shared secret for Radius. The Shared Secret will be encrypted and written in the Registry. 
The shared secret is used to sign RADIUS data packets to ensure they are coming from a trusted 
source, it is also used to encrypt user passwords with certain authentication methods 

11. Click OK. 

12. Note the related dictionary: default.rad in C:\Program Files\NetReport\WebPortal. 
 
 
Section 5: Using NT for Password Authentication 
To use NT User Names and Passwords in the Net Report Web Portal using NT Security, IIS and d7cgiwin must 
be on an NTFS disk.  
 
Note: the administrator must create users in the user groups via the Net Report Web Portal Administrator (see 
section 1 and the Appendix): 
 
 
 
Steps 

1. Select the Net Report Web Portal Directory, by default 
C:\Program Files\NetReport\WebPortal 

2. Open the Aliases.ini file. 

3. Add the following lines between the [General] and [NetReport] sections. 

[Web] 

UseNTUserForWebLogin=1 

Note: UseNTUserForWebLogin will override other authentication methods in the Aliases.ini file. 
 
 
Section 6: Managing Passwords for External DataSources 
To use a Data Source to login: only checks the login via the web but does not forbid using another source which 
uses another login by default, please follow the steps below: 
 
Note: the administrator must create users in the user groups via the Net Report Web Portal Administrator (see 
section 1 and the Appendix): 
 
 
Steps 

1. Select the Net Report Web Portal Directory, by default 
C:\Program Files\NetReport\WebPortal 
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2. Open the Aliases.ini file. 

3. Add the following lines between the [General] and [NetReport] sections. 

[Web] 

DataSourceForWebLogin=SQL Server D77 
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Appendix: Dealing with Menus 
You can manage the menus displayed in the Net Report Web Portal via the Net Report Web Portal 
Administrator.  
 

 
 
Menu: the name of the menu as it appears in the Net Report Web Portal Menu pane. 
 
Menu Path: the path where the *.wmu menu file is saved. 
 
…: displays the Open dialog box to enable you to select a *.wmu menu file to attribute to the menu. 
 
Edit: opens the Web Menus Builder, where you can modify a menu. 
 

 
 
Note: Double-clicking a shared folder in the Web Menus Builder enables you to view and/or modify the menus 
properties via the Shared folder properties pane. 
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Creating a new Menu in the Net Report Web Portal Administrator. 
To create a menu and assign it to a User Group in the Net Report Web Portal Administrator, please follow the 
steps below. Please note that the menu created in this example is called: MyMenu, please replace this by the 
name you want. 
 
Steps 

1. Select Start> All Programs> NetReport> Web Portal Administrator. 
 
2. Enter your User ID and Password. 

 
3. Click OK.  

 
4. Select the Menus tab. 
 
5. Right-click and select New> Menu in the context menu. 
 

 
 
6. The New Menu row appears in the Menus table. 
 
7. Rename the new menu as appropriate, in this example MyMenu. 

 
8. Select the menu you created, in this example My Menu. 
 
9. Click Edit. The Web Menus Builder appears. 
 
10. Click the Shared Folders icon in the tool bar. 
 
11. Rename the shared folder as appropriate, in this example MyMenu. 
 
12. Double-click the MyMenu shared folder. The Shared folder properties pane appears. 
 
13. Click the right-arrow and select Browse… to the right of the Folder path text box. 
 
14. Select the path: C:\Program Files\NetReport\WebPortal\Runtime_Projects\enu 
 
15. Select the Format tab. 

 
16. Double-click the HTML report row to clear its selection. 
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17. Double-click the PDF report row to enable its selection. 
 
18. Click OK. 
 
19. Click Save. 
 
20. Enter the File Name, for example: MyMenu.wmu. 
 
21. Save the file at C:\Program Files\NetReport\WebPortal\Runtime_Projects 
 
22. Close Web Menus Builder. 

 
23. Select MyMenu. 

 
24. Click … and select MyMenu.wmu. 

 
25. Click Open. 

 
26. Select the User Groups tab. 

 
27. Perform a drag-and-drop operation – drag MyMenus from the right pane to the User Group you have 

rights to, in this example to the Admin user group. 
 

 
 

28. Select File> Update Security. 
 

29. The new menu is enabled. 
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30. Refresh the Net Report Web Portal and note the MyMenu menu appears in the menu tab. 
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