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1. Using Reports 

Note: you are supposed to read the manual about Using Queries and the manual about Using Cubes before 
to read this one. 

1.1. Creating a new report from a Query 

You can create a report directly from the current open query by clicking the command Query> Create report 

or the icon , or you can create a report from the Click&DECiDE Project Report Tab by clicking the “New” 
icon: 
 

 

This command will ask you to choose among: 

 

Blank Report: creates an empty report inside of which you will insert manually the required static (Labels) or 
dynamic fields (if a query is later specified or using formulas) or other objects. This option is reserved to 
advanced users. 

Report from Query: this is the most used option that will create a report based on the query you will specify 
in the Data Source Item list box, using automatically all the query columns. 

Report Book: creates a report list of existing reports to be able to export or print them together as one global 
report. A Report Book can be printed to printer, exported to HTML or PDF formats. A Report Book cannot be 
exported to other Click&DECiDE Builder output formats. 

Report from Raw Cross Table Data: creates a report based on the cross-table you will specify in the Data 
Source Item list box by reading the cross-table rows as a data source. 

Warning: Report from Raw Cube Data: this option does not exist anymore in version 2015 because Builder 
64-bit cannot manage Microsoft Cubes, but a Report based on Raw Cube Data (as a data source) made with 
a 32-bit version of Builder (V13.x) can still be run through the Web Portal having Click&DECiDE 2015, but not 
in Builder 64-bit. 

Steps:  

1. Select the most used option Report from Query. (Other options are explained later) 

2. Click then on the Data Source Item list box to get the list of the available queries and select the one 
you need. Example selecting the demo_multicriteria from the Click and DECiDE Demonstration.wfv 
file. 

 

3. A default Report Template is proposed: 

You can select a standard template in the list and see a preview on the right pane. You can enlarge any 
preview by double clicking on the picture. Once you get the picture bigger, you also can switch to full screen if 
you want to see more details. 

Each template displays a comment about the Paper size, the Colour and Font, or information about the width 
and height size (fixed or modifiable). 
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4. Select the one you like and click OK. See also later how to create your own report templates using 
the command Tools> Report Templates command. 

5. Click OK to get automatically a new report with the following blocks or sections by default: Report 
Header, Page Header, Details, Page Footer, Report Footer. 

1.2. Saving a Report 

Once your report has been created and modified, you can save the report using the icon  or the command 
File> Save that will prompt you the Save as… dialog box proposing by default the query name on which the 
report is based. 

 

Modify the name if required and click OK. 

If you close the report, you can see in the Click&DECiDE Builder project report tab, the name of all the 
existing reports and, if the command View> Details from the Click&DECiDE Builder toolbar is activated, you 
also see some information such as Data Source (the name of the query on which the report is based), 
Description (empty by default) where you can add a comment about each report using the right mouse click 

and the Properties command or by clicking on the  icon: 

 

Also the date of creation and the date of last modification are displayed with the View> Details mode or in 
the Report Properties dialog box, as well as the Report Author that cannot be modified. 

You can sort the information in the Click&DECiDE Builder Project Report Tab by any column just by clicking 
on the heading column text. 

You also can change the position of each column from left to right or right to left moving a column to another 
location. To do that, click on a column and keep the mouse button pressed, then move the column to the right 
or to the left and drop the mouse button when the target location is reached. 
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1.3. Deleting a Report 

To remove a report, you must first open the Click&DECiDE Builder project file inside of which your report is 
located. Then select the Report Tab, select the report to be removed and use the <Del> key or press the 
<Remove> button. A warning message asks you to confirm. 

Be careful: that command could be dangerous because the lost report could be used by another report as a 
sub-report or be included in a Report Book. The Description box could be use to enter dependencies between 
several items. (Example a comment such as “This report is used as a sub-report in the report XXXX”). 

Make sure this report is not used anymore before confirming the warning message. There is no way to restore 
a report that you have deleted except if you made previously a backup of your project file (recommended). 

1.4. Reports Blocks 

A new report is made of the following blocks or sections by default: 

Report Header: printed one time at the beginning of the report 

Page Header: printed each time at the top of each page 

Details: printed on any page, containing the detailed records 

Page Footer: printed each time at the bottom of each page 

Report Footer: printed one time at the end of the report. That section is empty by default and you have to 
enlarge the size block if required. 

Other special sections can be created when using the Break levels functions. See later the Creating break 
levels. 

 

By default the Report Header is empty but you can enlarge this block to add a main title and logo for example. 

By default the Page Header contains the Column Header of your query and the Title is the query name. 

By default the Details contains the column fields of your query. 

By default the Page Footer contains the field’s saves in the Report Template such as printed date and time, 
Copyright and Page numbers. 

By default the Report Footer is not visible but you can enlarge this block to add some summary fields or totals. 
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1.4.1. General Block and Fields Properties 

You can apply to each block some properties according to the following table: 

Tab/Properties 
Report 
Header 

Page 
Header 

Detail Page Footer Report Footer 

General Tab      

Bookmark Yes Yes Yes Yes Yes 

Highlight Yes Yes Yes Yes Yes 

Format Tab      

Form Feed Yes  Yes  Yes 

New Row or Column   Yes   

Insecable Block Yes  Yes  Yes 

Visible Yes Yes Yes Yes Yes 

Width Yes Yes Yes Yes Yes 

Height Yes Yes Yes Yes Yes 

Can Grow Yes  Yes  Yes 

Can Shrink Yes  Yes  Yes 

Background Style Yes Yes Yes Yes Yes 

Background Color Yes Yes Yes Yes Yes 

Background Color 2   Yes   

Border Effect Yes Yes Yes Yes Yes 

Border Style Yes Yes Yes Yes Yes 

Border Color Yes Yes Yes Yes Yes 

Border Weight Yes Yes Yes Yes Yes 

Data Tab      

No property on a Block      

1.4.1.1. Form Feed Property: 

This property allows to specify if a section (block) must be printed on the current page or if a break page must 
be done before (or after or both) to print that section. 

Note: the Form Feed property doesn't apply to the Page Header or the Page Footer. 

Parameter Description 

No Default value. The current section (block) is printed on the current page 

Before Block The current section (block) is printed on a new page 

After Block 
The next section, coming immediately after the current section, will be 
printed on a new page 

Before & After Block 
The current section (block) is printed on a new page and the next section, 
coming immediately after the current section, will be printed also on a new 
page 

1.4.1.2. New Row or Column Property: 
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This property allows to specify if a section (block) content must be printed on a new row or new column in a 
multicolumn report. For example you can use that property to print each header group at the beginning of a 
new column in a multicolumn report. 

Parameter Description 

No 
Default value. Click&DECiDE Builder starts printing the section on the 
current page and finish printing on next page if the content doesn't feed on 
the same page, according to the Page Set-up parameters. 

Before Block 
Click&DECiDE Builder starts printing the current section (for example a 
Group Header) on a new row or column, then print the next section (for 
example a Detail) on the same row or column. 

After Block 
Click&DECiDE Builder starts printing the current section (for example a 
Group Header) on the current row or current column, then print the next 
section (for example a Detail) on a new row or a new column 

Before & After Block 
Click&DECiDE Builder starts printing the current section on a new row or 
column, then print the next section on a new row or a new column. 

Note: the New Row or Column property only applies to the Detail bloc. 

1.4.1.3. Insecable Block Property 

This property allows to specify if a section (block) content must be printed on the same page. 

Parameter Description 

No 
Click&DECiDE Builder starts printing the section on the current page and 
finish printing on next page if the content doesn't feed on the same page. 

Yes 
Click&DECiDE Builder starts printing the section on the next page if the 
section content doesn't feed on the current page. 

1.4.1.4. Visible Property 

This property allows to specify if a section (block) or an item (field) must be visible or hidden. It could be useful 
to keep access to information without displaying it in the result (in a formula for example). 

Parameter Description 

Yes Default value. The block or item is visible 

No The block or item will be hidden when editing or printing the report. 

 
Note: for the Page Header this Visible Property is particular: 

Parameter Description 

Always Default value. The Page Header block is always visible 

Never The Page Header block is never visible. 

Always except on 
widow Report Footer 
Page 

The Page Header block is always visible, except when the last Report 
Footer Page is widow. 

1.4.1.5. Height Property 

This property allows to specify the vertical size for a section (block) or an item (field). The unit is the one 
defined in the Windows Regional Settings (Inches, centimeters etc.) and two decimals are authorized after the 
decimal separator. Note: a vertical size set to zero is equivalent to the Visible option set to No. 

1.4.1.6. Width Property 

This property allows to specify the horizontal size for a section (block) or an item (field). The unit is the one 
defined in the Windows Regional Settings (Inches, centimeters etc.) and two decimals are authorized after the 
decimal separator. Note: all the Blocks have always the same width in a report. 
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1.4.1.7. Can Grow and Can Shrink Properties 

These properties allow to specify if a section (block) or an item (field) can grow or can shrink if the content, 
when editing or printing, is bigger or smaller than the current size defined. If that property is applied, the block 
size or the field size will be adjusted vertically automatically when you preview or print the report. 

Note 1: the Can Grow/Can Shrink properties do not apply to the Page Header nor the Page Footer. The result 
can be visible only when editing (preview) or printing the report. 

Note 2: if the Can Grow/Can Shrink properties are set to Yes for field items in a Block, this Block must also be 
defined with the same option set to Yes. 

Parameter Description 

Yes 
The block size or field size is adjusted vertically depending on the content 
to be printed or edited (preview) 

No 
Default value. The block size or field size will not change when printing or 
editing. Some data can be hidden if the size defined is too small. 

 

1.4.1.8. Background Style Property 

This property allows to specify if a section (block) or an item (field) must be transparent or opaque. 

Note: if transparent mode is selected, you cannot apply a Background color. As soon as you specify a 
background color, the Background Style is set to Opaque. 

Parameter Description 

Transparent 
Default value. The background is transparent and the color is the one of 
the block or the item the most on the background  

Opaque 
The block or field color will be the one defined with the property 
Background color. 

1.4.1.9. Background Color Property 

This property allows to specify the background color for a section (block) or an item (field). 

Note: when you specify a color for a block or an item, the Background Style is automatically set to Opaque 
instead of Transparent. 

The Background Color property uses as parameter a number corresponding to a specific color. 

 Use that button to display the available colors  

 Use that button to generate a customised color. 

 Use that button on the Report Format Toolbar to apply directly a color to the block or field background. 

1.4.1.10. Background Color 2 Property 

This property allows to specify a second background color for the Details block only that will give an alternate 
color to the rows in the report edition. 

Note: when you specify a color for a block, the Background Style is automatically set to Opaque instead of 
Transparent. 

The Background Color 2 property uses as parameter a number corresponding to a specific color. 

 Use that button to display the available colors  

 Use that button to generate a customised color. 

 Use that button on the Report Format Toolbar to apply directly the second color to the Details block. 

1.4.1.11. Border Effect Property 

This property allows to specify the border aspect for a section (block) or an item (field). 
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 Use that button to display the available border aspects in the combo-box list. 

 Use that button on the Report Format Toolbar to apply directly a border effect to the block or field: 

 2D -The object appears flat. 

 3D -The object has a highlight on the top and the left, and a shadow on bottom and right. 

 3D Down -The object has a shadow on the top and the left, and a highlight on bottom and 
right. 

 Grave -The object has a sunken line surrounding the control. 

 Shadow - The object has a shadow below and to the right of the control. 

 3D Underline - The object has a sunken line below the control. 

1.4.1.12. Border Style Property 

This property allows to specify the border style for a section (block) or an item (field). 

Use that button to display the available border styles in the combo-box list. 

 Use that button on the Report Format Toolbar to apply directly a border style to the block or field: 

 Default value. The border is not visible when editing or printing. 

 The border is visible as a solid line. 

 The border is visible as a dash line. 

 The border is visible as a point line. 

 The border is visible as a dash-point line. 

 The border is visible as a dash-point-point line. 

1.4.1.13. Border Color Property 

This property allows to specify the border color for a section (block) or an item (field). The Border Color 
property uses as parameter a number corresponding to a specific color. 

 Use that button to display the available colors  

 Use that button to generate a customised color. 

 Use that button on the Report Format Toolbar to apply directly a border color to the block or border field. 

1.4.1.14. Border Weight Property 

This property allows to specify the border weight for a section (block) or an item (field). 

 Use that button to display the available border weight in the combo-box list. 

 Use that button on the Report Format Toolbar to apply directly a weight to the block or field border. 

 Default value. The border weight is not visible when editing or printing. 

 The border weight is the smallest visible, as in the left example. 

 The border weight is greater, as in the left example. 
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 The border weight is greater, as in the left example. 

 The border weight is greater, as in the left example. 

 The border weight is greater, as in the left example. 

 The border weight is the greatest visible, as in the left example. 

1.4.1.15. Bookmark Property 

A bookmark can be displayed when exporting a report to a PDF format (Acrobat Reader). 

You can enter a text manually, as a bookmark displaying a fixed Title for the Report Header Block: 

 

But you also can use the  to generate a formula for the bookmark you need to display, example: 

 

Note that the formula automatically adds an equal sign at the first position. 

The above formula will generate a bookmark such as “Sales_Dashboard_2015_03” if we are a day of March 
2015. 

Warning: if you enter a formula manually, without using the Formula Editor, you must enter manually the 
equal sign at the first position. 

1.4.1.16. Highlight Property 

A highlight is an attribute modification that can be done automatically according to a predefined condition. 

For a Report Block, a highlight can affect only 3 attributes: Visible Yes/No, and Background Style and Color: 

 

For a Report Dynamic Field, a highlight can affect much more attributes such as: 
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Note the Format attribute that allows you to customize a field data format if the condition is true, instead of 
using the default format. 

Note also the Hyperlink attribute that allows you to create here a link that can be displayed if the condition is 
true.  

Example 1: this link can call a bookmark in the same PDF Report file, in that case use the # sign followed by 
the Bookmark Name as in this example:  #Events by Hour of the Day 

Example 2: A Daily Report can call using this link another Monthly Report, with a formula similar to this 
example: ='Sales_Monthly_'+  FormatDateTime('yymm', Day_Selected ) +'.pdf'. 

Note that you can add several Highlights on the same object: for example the color of the amount can be 
different according to the value: the first condition will give a red number if true: 

 

 

The second condition will give an orange number if true: 
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The third condition will give a green number if true: 

 

 

And the last condition will give a blue number if true: 

 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

17 
 

 

 

Business Application Intelligence | Training 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

One of the conditions will be always true, so the result will get the corresponding color. 

For a Report Static Field, a highlight can affect the same attributes list as a Dynamic Field, but also a 
specific attibute named “Text” allowing to modify a Label Title according to a condition. 
Example: in a report a Label Title display the word “Date” by default, when the report is run on a Daily basis. 
But sometime the same report can be run on a Hourly basis, and in that case the information displayed in the 
same column will be hour instead of days. The following Highlight condition can modify the Label Title and 
display “Time” instead of “Date”: 

 

 

 

For a Picture Field, a highlight can affect the following attributes including the picture to be used, such as a 
first condition displaying a red cross if the condition is true: 
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A second condition can display another picture if the condition is true: 

 

 

A third condition can display another picture if the condition is true: 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

19 
 

 

 

Business Application Intelligence | Training 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

 

 

And a last condition display another picture if the condition is true: 

 

The benefit of this method is to be able to display several different pictures using only one picture object. 

Test the result for year 2010 for example and see both effects: one on the color result in the Amount column, 
other one on the picture on the right of the result, in the details block: 
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Note: in the Highlight Dialog Box a toolbar displays the following icons: 

 New Condition 

 Edit Condition 

 Delete Condition 

 Move Up Item 

 Move Down Item 

 Reset the selected attribute to (Undefined) 

 Reset All attributes to (Undefined) 

 Cut 

 Copy 

 Paste 

1.4.2. Copying the custom colors 

Once you have defined in a report a customized palette of colors, you can use the command Edit> Copy 
Custom Colors and then use the command Edit> Paste in another report or another project file to restore the 
customized palette without the need to defined all colors again. 

 

1.4.3. Specific Field Properties 

Inside each Report Block, you can insert or copy several object types, such as Static Label field (static text), 
Data or Formula Field (Dynamic field) and other specific objects such as Query Data Object, Picture, Chart, 
Sub-Report, Cubes, Line, or ActiveX explained later. All these objects are proposed in the following Toolbar: 

 

 

You can apply to each Static Label or Data/Formula field additional properties according to the following table: 
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Tab/Properties 
Static 
Label 

Data / 
Formula 

Query 
Data 

Picture Graph 
Cross 
Table 

Sub-
Report 

Line 

General         

Name Yes Yes Yes Yes Yes Yes Yes Yes 

Description Yes Yes Yes Yes Yes Yes Yes Yes 

Hyperlink Yes Yes Yes Yes Yes    

Bookmark Yes Yes Yes Yes Yes Yes Yes Yes 

Highlight Yes Yes Yes Yes Yes Yes Yes Yes 

Format Tab         

Format  Yes Yes      

Visible Yes Yes Yes Yes Yes Yes Yes Yes 

Left Yes Yes Yes Yes Yes Yes Yes Yes 

Top Yes Yes Yes Yes Yes Yes Yes Yes 

Width Yes Yes Yes Yes Yes Yes Yes Yes 

Height Yes Yes Yes Yes Yes Yes Yes Yes 

Hide Duplicates  Yes       

Can Grow  Yes Yes   Yes Yes  

Can Shrink  Yes Yes   Yes Yes  

Image    Yes     

Image Type    Yes     

Draw Mode    Yes     

Horizontal Alignment    Yes     

Vertical Alignment    Yes     

Background Style Yes Yes Yes Yes  Yes Yes  

Background Color Yes Yes Yes Yes Yes Yes Yes  

Border Effect Yes Yes Yes Yes Yes Yes Yes Yes 

Border Style Yes Yes Yes Yes Yes Yes Yes Yes 

Border Color Yes Yes Yes Yes Yes Yes Yes Yes 

Border Weight Yes Yes Yes Yes Yes Yes Yes Yes 

Text Yes        

Text Color Yes Yes Yes      

Font Yes Yes Yes      

Bold Yes Yes Yes      

Italic Yes Yes Yes      

Underline Yes Yes Yes      

Strikeout Yes Yes Yes      

Text alignment Yes Yes Yes      

Display       Yes  

Data Tab         
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Tab/Properties 
Static 
Label 

Data / 
Formula 

Query 
Data 

Picture Graph 
Cross 
Table 

Sub-
Report 

Line 

Data Source  Yes Yes  Yes Yes Yes  

Aggregate  Yes       

Child Data Link   Yes   Yes Yes  

Parent Data Link   Yes   Yes Yes  

Update Method   Yes    Yes  

Assign to Parameter  Yes Yes      

Series     Yes    

Data     Yes    

First Records     Yes    

Other Series 
Records 

  
  

Yes    

Series in rows     Yes    

Reverse Data Order     Yes    

Refresh Data      Yes   

Apply defined levels      Yes   

 

In the above Table, some Properties are already explained in the previous paragraph. The other Properties 
are described here: 

1.4.3.1. Name Property 

This property allows to specify an internal name for an item (label field or data field) that can be used later in a 
formula for example. Each object must have a distinct name. The name cannot be the same as a data source 
field name. The name cannot contain space neither special characters. 

Note: Click&DECiDE Builder attributes automatically a new internal name by default when inserting a new 
label field or a new data field or any other object. If the name already exists, a number is added to this name. 

1.4.3.2. Data Source Property 

This property allows to specify how to feed a dynamic object. A query column name or a formula for a 
Data/Formula object, a query name for Query Data object, <Report Data> or a query name for a Graph, a 
report name for a Sub-Report, a cross-table name or a Cross Table. 

1.4.3.3. Aggregate Property 

This property only applies to Data / Formula object, and allows to generate a grouping function in the report, 
such as Sum, Min, Max, Average, Count, Standard Deviation and Variance. 

1.4.3.4. Child and Parent Data Link Property 

This property only applies to Query Data, Sub-Report and Cross-table objects, and allows add a criteria 
between a column of the report data source and the object data source. This property will be described more 
in detail later for the concerned objects, and is mainly used when creating Break Levels in a report. 

1.4.3.5. Assign to parameter Property 

This property allows to assign the field content to a parameter that can be used later in the same report inside 
a formula, or in a sub-report, or in another report belonging the same Report Book if the query of this report is 
also referenced with the same parameter. 
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1.4.3.6. Text Property 

This property allows to specify the visible text for a Static label field such as a Title, a Sub-Title, a Column 
name, a Comment etc. 

Note : Click&DECiDE Builder attributes automatically the default text "Text" to any new label field inserted 
inside a block report. You can use the Format Tab in the Properties Dialog Box to see or modify it. 

If the text you want to type is quite long, you can use the Text Editor by clicking on the  right browse 
button. Example: the following text in the Text Editor 

 

Will give this result in the Report: 

 

1.4.3.7. Format property 

This property allows to specify the format to be used to display the data field content when editing or printing 
the report. 

Note: Click&DECiDE Builder proposes automatically several Windows default standard formats depending on 
the field type (text, numeric, date, time or timestamp) and your Regional Settings. You can modify them. 

 Use that button to display the available formats depending on the field type 

Parameter Description 

0,00 
Example for numeric value without thousand separator and semicolon as 
decimal separator 

#.##0,00 
Example for numeric value with a dot as thousand separator and 
semicolon as decimal separator 

#.### £ Currency with the English pound without decimals 

#.##0,00;-#.##0,00;<Null> 
Example for numeric value with a dot as thousand separator, a semicolon 
as decimal separator, a minus sign for negative values and a Null 
information for null content. 

# ##0,00 €;-# ##0,00 €;<Null> 
Example for numeric value with a space as thousand separator , a 
semicolon as decimal separator, a € for Euro money, a minus sign for 
negative values and a Null information for null content. 

0% 
Example for numeric value with a percentage presentation, without 
decimal 

dd/mm/yyyy 
Example for a date value, with 2 numbers for the day, 2 numbers for the 
month and 4 numbers for the year. 
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Parameter Description 

dd/mmm/yyyy 
Example for a date value, with 2 numbers for the day, 3 first character for 
the month and 4 numbers for the year. 

hh:mm:ss 
Example for a time value, with 2 numbers for the hour, 2 numbers for the 
minutes and 2 numbers for the seconds. 

dd/mm/yy hh:mm 
Example for a timestamp value, with 2 numbers for the day, 2 numbers for 
the month, 2 numbers for the year, 2 numbers for the hour, 2 numbers for 
the minutes and no seconds. 

1.4.3.8. Left Property 

This property allows to specify the object position from the Left border of the Report. The unit is the one 
defined in the Windows Regional Settings (Inches, centimeters etc.) and two decimals are authorized after the 
decimal separator. 

1.4.3.9. Top Property 

This property allows to specify the object position from the Top border of the current report Block. The unit 
is the one defined in the Windows Regional Settings (Inches, centimeters etc.) and two decimals are 
authorized after the decimal separator. 

1.4.3.10. Hide duplicates property 

This property allows to specify if an item (dynamic field) must be duplicated or not on each row on the same 
page when the content doesn’t change. This option only concerns the Detail Block (section) in a report. It 
could be useful to not display the same information on each row when the content of a field is equal to the 
content of the previous record. 

1.4.3.11. Image Property 

This property only applies to an Image object and allows to specify the full path and file name for the required 
picture. Example: C:\Users\Public\Documents\Click and DECiDE Samples\Builder\mountain.JPG 

Note 1: this path can contain some parameters as you can see in the report example “Sales by Category” in 
the Click and DECiDE Demonstration.wfv project file. In that example note that the Image Type must be set 
to Formula. 

='%CND_BAI_SAMPLES%\Builder\'  +  "CATEGORY_NAME"  + '.JPG' 

Note 2: the picture file name can be defined using the Highlight Property in the General Tab as describe in the 
Highlight paragraph. In that case, no picture files name need to be defined in the Image Property. 

1.4.3.12. Image Type Property 

This property only applies to an Image object and allows to define if the picture is: 

Included in the report: in that case you don’t need to give the picture with the project file to somebody else, 
but the project size could be affected by many big pictures. 

Linked to the report: in that case you need to give the picture separately with the project file to somebody 
else, but the project size is not affected by the number of pictures. 
 

Example: 
C:\Program Files\Click and DECiDE\BAI\Templates\Images\cndlogo_45_45.png 

Formula: must be used if you specify a formula in the Image Property box as the above example with the 
variable environment and the parameter name. 

1.4.3.13. Draw Mode Property 

This property only applies to a Image object and allows to modify the picture presentation among 4 choices: 
Normal, Stretched, Homothetic and Mosaic. 
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Draw 
Mode 

 
Description 

Normal 

 

Default value. The picture will be displayed with the original size 
without the need recalculate the size when editing or printing the 
report, saving resources for the program. 

Stretched 

 

The picture will be displayed extended or reduced to fit the size 
object. Distortion can thus occur if needed. 

Homothetic 

 

The picture will be displayed to fit the size object without distortion. 

Mosaic 

 

The picture will be displayed to fit the size object in a mosaic mode 

1.4.3.14. Horizontal Alignment 

This property only applies to an Image object and allows to define the horizontal position in the object.  

Horizontal 
Alignment 

 
Description 

Left 

 

The picture will be displayed on the left side of the object. 

Center 

 

Default value. The picture will be displayed in the center of the 
object (horizontally). 

Right 

 

The picture will be displayed on the right side of the object. 

1.4.3.15. Vertical Alignment 

This property only applies to an Image object and allows to define the vertical position in the object.  

Vertical 
Alignment 

 
Description 

Top 

 

Default value. The picture will be displayed on the top side of the 
object. 

Center 

 

The picture will be displayed in the center of the object (vertically). 

Bottom 

 

The picture will be displayed on the bottom side of the object. 
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1.4.3.16. Series Property 

This property only applies to a Graph object. You can specify here which column has to be used as series for 
the graph. It could be one or several columns. The column could be a query column or a report dynamic field. 

Use the  icon to display this column list or the  icon to select several query or report columns. 

1.4.3.17. Data Properties 

This property only applies to a Graph object. You can specify here which column has to be used as data for 
the graph. It could be one or several columns. The column could be a query column or a report dynamic field. 

Use the  icon to display this column list or the  icon to select several query or report columns. 

1.4.3.18. First Records Property 

This property only applies to a Graph object. You can add a Top value specific to the Graph if you wish to limit 
the data displayed by a Graph without limiting the report data. It is useful for example for a Pie Chart because 
when you have more than 20 or 25 sectors, the Pie Graph can be not very readable. 

1.4.3.19. Other Series Properties 

This property only applies to a Graph object. This option allows you to specify a Legend Text to all other 
series that will be displayed as one additional series if the Top Value specified in the First Records Property is 
reached. 

1.4.3.20. Series in Rows 

This property only applies to a Graph object. The default value for a new Graph is Series in Columns. You can 
switch her for the option “Series in rows” if needed. It is useful for example sometimes with a Pie Chart. 

1.4.3.21. Reverse Data Order 

This property only applies to a Graph object. You can change the order of the displayed data (Left/Right or 
Top/Bottom). 

1.4.3.22. Text Color Property 

This property allows to specify the text color for an item (Label field or Data field). The Text Color property 
uses as parameter a number corresponding to a specific color. 

 Use that button to display the available colors. 

 Use that button to generate a customised color. 

 Use that button on the Report Format Toolbar to apply directly a color to the label or data field text. 

1.4.3.23. Font Property 

This property allows to specify the font for an item (Label field or Data field). 

The Font property uses as parameter a font name chosen in the list proposed by your Window configuration. 

 Use that button to display the available font parameters on your machine (the dialog box provided allows 
you to select a font, a style (bold, italic, etc.), a size, a color, a special effect such as underlined etc.. 

1.4.3.24. Bold Property 

This property allows to apply a bold effect to a item content (Label field, Data field or Query Data field). 

1.4.3.25. Italic Property 

This property allows to apply a Italic effect to a item content (Label field, Data field or Query Data field). 

1.4.3.26. Underline Property 

This property allows to apply an Underline effect to a item content (Label field, Data field or Query Data field). 

1.4.3.27. Strikeout Property 

This property allows to apply an Strikeout effect to a item content (Label field, Data field or Query Data field). 

1.4.3.28. Text Alignment Property 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

27 
 

 

 

Business Application Intelligence | Training 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

This property allows to specify the Alignment required for a label or data field text. 

 Use that button to display the available alignment effects in the combo-box list or use directly the following 
toolbar buttons: 

 Use that button on the Report Format Toolbar to align directly the text on the Left border of the field. 

 Use that button on the Report Format Toolbar to align directly the text on the Center of the field. 

 Use that button on the Report Format Toolbar to align directly the text on the Right border of the field. 

1.4.3.29. Description Property 

This optional property allows to specify a description for an item that can be displayed later when editing a 
formula for example. The current description will appear in the Description box when using the Quick 
Expression formula generator. This description will also be used when exporting a report to Excel, allowing to 
align all objects having the same description in the same column. 

This is useful when you create a formula that will be used later from within another formula. The description 
will help you to remember what the purpose of each formula is. 

Example: a virtual field named TOTAL_PRICE will receive the formula (price * qty) * (1-discount) and the 
description "Price after discount". Now a new formula can be created to apply the local tax. When editing the 
formula from within the Quick Expression generator, the field TOTAL_PRICE will display the description "Price 
after discount" in the Description box: 

1.4.3.30. Hyperlink Property 

This property allows to enter an URL or Hyperlink calling for example: 

a Web site: ='http://www.clickndecide.com' 

a Bookmark in the same PDF report: #HomePage or ‘#’+ Username (if Username is a dynamic query field 
used in the report) 

a Bookmark in another PDF report using a formula: ='Statistics_Monthly_'+  FormatDateTime('yymm', 
Day_Selected ) +'.pdf', Day_Selected being a parameter name. 

an URL calling a PDF or HTML report including one or several parameters: 
='/dvweb/display.aspx?__mnu_alias=Demonstration&__mnu_itemid=2357&__format=HTML&AREA_PARAM
='+AREA+’&__exec=1’. 

1.4.3.1. Refresh Data 

This property only applies to a Cross table object and allows you to specify if the Cross table must be 
recalculated at the runtime report. If not the data saved in the cross-table data file (*.vpd) will be used. 

1.4.3.2. Apply defined levels 

This property only applies to a Cross table object and allows you to specify: Yes, the levels defined with 
condensed or detailed mode will be applied as they have been saved, or No, do not apply the defined levels 
and make them all detailed. 

1.4.3.3. Display Property 

This property only applies to a Sub-Report object. This function proposes by default to retrieve from a sub-
report only the Detail and Break Blocks. But you can ask to retrieve All Blocks from a sub-report if you also 
need to retrieve the title, the column headers and the total fields (in the Report Footer Block) from the sub-
report. 

1.4.3.4. Update Method 

This property only applies to a Sub-Report or Query/Data object: Optimized means that the SQL calculated to 
run a sub-report or query/data is done only one time, as parameter values are known and Child Data Link and 
Parent Data Link are known. Forced means that this SQL will be recalculated each time. This can be used 
when a parameter value can change because of the use of the “Assign to parameter” feature. 

 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

28 
 

 

 

Business Application Intelligence | Training 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

1.5. Report Properties 

If you click the  icon, you will get the Report Properties, with 3 specific properties applying to the whole 
report: 

Report Property Description 

Run Condition 
The value of a parameter can be evaluated here to check if a 
condition is true of false. If false the report will not be printed, avoiding 
an empty page inside a Report Book. 

Single Page HTML export 
This option allows to specify that the current report must be exported 
using only 1 page if the output format is HTML. 

Web Part Entry Chart 

This option allows to specify the graph to be used as an entry point 
into a Web Part created in the Web Portal. The URL, with HTML 
output, copied from this report will only display the selected Graph in 
the Web Part, but the URL proposed in the Title will drill-down to the 
full report. (Refer to the Click&DECiDE Web Portal User Guide 
Manual to know more about Web Parts). 

 

1.6. Report Toolbars and Look 

You can modify the report look by using the commands: 

1.6.1. View> Ruler 

This command will show or hide the vertical and horizontal rulers: 

 

1.6.2. View> Grid 

This command will show or hide the grid: 

 

1.6.3. View> Header and Footer Blocks 

Use the command View> Report Header/Footer to display or remove with one click the Report Header Block 
and the Report Footer Block. Warning: when you remove these blocks, a message prevents you that you will 
lose their content. 
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Use the command View> Page Header/Footer to display or remove with one click the Page Header Block 
and the Page Footer Block. Warning: when you remove these blocks, a message prevents you that you will 
lose their content. 

1.6.4. View Toolbar 

This command allows to display several Toolbars. 

1.6.4.1. Toolbar 

 

See the legend to know what icon is doing. 

1.6.4.2. Toolbox 

 

See the legend to know which kind of object each icon will add in your report. 

1.6.4.3. Layout Bar 

 

Use this toolbar to modify the objects and fields layout. 

1.6.4.4. Alignment/Resize Bar 

 

See the legend to know what icon is doing. 

1.6.4.5. Spacing Bar 

 

See the legend to know what icon is doing. 

1.7. Reports Objects and Fields 

Once a report has been created, with the default blocks containing the default objects and fields according to 
the query structure, you can wish to: 

1.7.1. Add a new query field 

If you need to add some fields in a report already based on an existing query, do the following steps: 

1. Click the Report Property icon  then select the Data Tab where you will see the query name used a 

data source. Click the  icon to open the query. Select the new required field(s) in the query and 
save the query. 

2. Close the query and go back to the report based on that query. 

3. Click now the Query Field list icon  or on the command View> Field list and you will get a window 
containing all the query fields: 
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4. Select one or several field(s) in the above list (using the Shift+click or Ctrl+Click) and make a drag 
and drop to the required location in your report, in the concerned block. Drop the mouse button when 
the target location is correct. The new field(s) is (are) inserted on the target location. 

5. Note that you have to create and add yourself the heading text if required in the Page Header Block 
for the new inserted fields. 

1.7.2. Add a new report field or object 

If you need to add other reports objects, use the command View> Tools Bar> Toolbox 

 

1.7.2.1. Static Text (Label) 

1. Click  to add a new static text. 

2. Define the target location in the required block by drawing a frame with the dimension you need. 

3. Release the mouse. 

4. Enter now the Text in the Text box in the Properties Format Tab. 

1.7.2.2. Dynamic field (Data/Formula) 

1. Click  to add a new dynamic field that could be fed by a query field or a report formula. 

2. Define the target location in the required block by drawing a frame with the dimension you need. 

3. Release the mouse. 

4. Select the Properties Data Tab and click the  icon in the Data Source box to select a query field or 

click the  icon to open the Quick Expression Editor to enter a formula. 

1.7.2.3. Query Data 

1. Click  to add a special Query Data object 

2. Define the target location in the required block by drawing a frame with the dimension you need. 

3. Release the mouse. This object must be fed by a query but will display only the result of the first 
row and the first column of this query. 

4. Select the Properties Data Tab and click the  icon in the Data Source box to select a query 

name or click the  icon to create the appropriate query if needed. 

1.7.2.4. Picture 

1. Click  to add a picture 

2. Define the target location in the required block by drawing a frame with the dimension you need. 

3. Release the mouse. A dialog box immediately opens to search for the picture file name. 

4. Select the image file and click Open. 

5. Select then the Properties Format Tab to specify the Image Type, Draw Mode, Horizontal and 
Vertical Alignments. 

1.7.2.5. Graph 

1. Click  to add a dynamic chart 

2. Define the target location in the required block by drawing a frame with the dimension you need. 

3. Release the mouse. A dialog box immediately opens to offer a choice of chart templates. 

4. Select the one you need and click OK. 

5. Select the Properties Data Tab where the Data Source box is defined by default with <Report 
Data>. 
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6. Specify then the Series and Data boxes using the  icon to select a report field, or the  icon 
to open a dialog box allowing to select several report fields. Note that <Report Data> will build the 
Graph using the report data, avoiding to run a separate query. Nevertheless a Graph can also be 
fed directly by a query. If a query name has been used and you want to display again <Report 
Data>, display the query list and select the <Report Data> in first position or delete the query 
name with the Del key and press Enter. 

7. Optional: define a Top value in the First Records box if you want to limit the number of values for 
the Graph, the extra data will be display as one value whose legend can be defined in the Other 
Records Series. 

8. Optional: right click on the Graph and select the Edit command to open the Click and DECiDE 
Chart Designer. 

9. Once you have modified the Graph using the Chart Designer you can save your own template 
using the command File> Save As and give a customized file name to the template 
(MyGraph.cfx), located by default in the C:\Program Files\Click and DECiDE\BAI\ChartModels 
directory. 

1.7.2.6. Cross-Table 

1. Click  to add a dynamic cross-table. 

2. Define the target location in the required block by drawing a frame with the dimension you need. 

3. Release the mouse. 

4. Select the Properties Data Tab and click the  icon in the Data Source box to select a cross-

table name or click the  icon to open the specified cross-table. 

5. If needed, specify the Child and Parent Data Links. 

6. Change, if needed, the option Refresh Data defined to Yes by default. 

7. Change, if needed, the option Apply Defined Levels defined to Yes by default. 

1.7.2.7. Sub-Report 

1. Click  to add a dynamic sub-report. 

2. Define the target location in the required block by drawing a frame with the dimension you need. 

3. Release the mouse. 

4. Select the Properties Data Tab and click the  icon in the Data Source box to select a report 

name or click the  icon to open the specified report. 

5. If needed, specify the Child and Parent Data Links. 

1.7.2.8. Line 

1. Click  to add a static line. 

2. Define the target location in the required block by drawing a line with the dimension you need. 

3. Release the mouse. 

4. Specify the Border Weight as well as the other attributes. 

1.7.2.9. ActiveX Control 

1. Click  to add an ActiveX control. 

2. Select the required ActiveX in the proposed list. 

3. Define the target location in the required block by drawing a frame with the dimension you need. 

4. Release the mouse. In the Properties Data Tab, the OLE Class and Class boxes are 
automatically fed. 
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5. Only specify the query field in the Data Source box. Note that the General Tab is depending on 
the ActiveX object and contains many parameters reserved to advanced users. 

1.8. Creating Break Levels 

Click&DECiDE Builder allows to create several break levels in a Report. Each break level will allow to display 
a Group Header Block before the Detail Block and a Group Footer Block after the Detail Block. Each of 
these groups can display Static or Dynamic Title, and also calculated fields to display totals, averages, 
minimum, maximum etc. Data can be sorted inside the report through each break level. 

To explain the Break Structure, the best is to create a report as an exercise and to build, step by step, several 
break levels. 

To do so, we are going to make an example starting with a query joining the tables SALES and SALESMAN 
from the Secured SQL Server Database. You can use the demo_multicriteria query from the Click and 
DECiDE Web Demonstration.wfv project file or create the same query. (Refer to the Click&DECiDE Query 
User Guide.pdf manual if needed). 

1. Open the query demo_multicriteria (or make a copy), it should look like: 

 

2. Create a Report using a Template: 

 

3. Save this report as Report Training for example. 

4. Now, click on the command View> Field group or on the  icon to get the following dialog box:  
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5. In the above screen, click the arrow on the right of the Field Group box to get the query column list 
and select for example the AREA field to create a break level for each Area: 

 

6. Select Yes for both Group Header and Group Footer and select “With First Detail” in the last 
option. 

Group Header: That group will be display before the rows concerning the break level. Generally used 
to inform what will be the next break information 

Group Footer: That group will be display after the rows concerning the break level. Generally used to 
generate calculation fields like Sum, Min, Max, Average etc. concerning the rows of the previous 
break level. 

7. Sort Order: by default Ascending is proposed. You can switch to Descending or None. Warning: the 
None option can be used only if you are sure to get the data sorted in the query in a right way for the 
break levels. 

8. Group on: make a choice among: 

 

 Value and First Characters for a Text field. if Value is selected, the break level will be done on 
the entire value content, if First Char is selected, you can specify how many characters must be 
used to produce a break level. (For example the 2 first characters of a postal code in France will 
produce a break level on the Department area) 
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 Value and Year/Quarter/Mont/Week/Day of month/Day/Hour/Minute/Second for a Date field. if 
Value is selected, the break level will be done on the entire value content, if a Date Time 
dimension is selected, you can specify the periodicity to be used to produce a break level. (Each 
year, each month etc.). Day of the Month will produce a break by day (but taking care about the 
date), whereas Day will produce a break by day without taking care about the date, unless this 
break is created after a Month Break. 

 

 

 Value and Interval for a Numeric field: if Value is selected, the break level will be done on the 
entire value content. If Interval is selected you can specify the interval range. 

9. Keep Together: you can select an option among No, Entire group or With first detail. 

 If No is selected, a new page can be created regardless the state of the current break level 

 if Entire group is selected a page break will be done if the new Break level cannot be displayed 
or printed on the current page 

 if With first detail is selected, the new Break level will start on the current page only if several 
first detailed row can be displayed on the current page, if not a page break will be done. 

We have defined in the previous example a first break level on the AREA field. The report should appear like 
the following example: 

 

By default the Group Header AREA contains the field used in this break level, to display the name of the next 
area coming in the report edition, and by default the Group Footer AREA also contains the field used in this 
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break level to display the name of the just listed Area, but also contain the sum of any numeric field, to display 
the sum of the TOTAL field after each Area (first break level). In this example we will delete the field 
SUM(SAL) because we do not need a total on the Salesman code, but we will keep the Sum(TOTAL). 

You can edit the properties of the AREA field in the Group Header Area block and modify in the Data Source 
box in the Data Tab the AREA field into a formula such as 'Salesmen for the area ' + AREA that will appear 
with the equal sign in the Data Source box ='Salesmen for the area '+AREA. 

Warning: be sure to enlarge enough the width of this field to not truncate the result. 

You can also select a background color for the Group Header AREA and the same color for the Group Footer 
AREA. 

You can edit the properties of the AREA field in the Group Footer Area block and modify in the Data Source 
box in the Data Tab the AREA field into a formula such as 'Sub-total for the area ' + AREA that will appear 
with the equal sign in the Data Source box ='Sub-total for the area '+AREA. 

Warning: be sure to enlarge enough the width of this field to not truncate the result. 

You can modify the format of the Sum(TOTAL) field in the Group Footer AREA to customize the numeric 
format if needed (currency, decimal etc.) 

The Report should like as the next picture: 

 

If you run that Report, for the chosen year or period, you will get a detailed list of all the sales done by all the 
salesmen for each different area. All the areas are in ascending order. Each Group Header AREA will display 
the title "Salesmen for the area " followed by the area name, and after the Detail Block, the Group Footer 
AREA will display the text "Sub-total for the area" followed by the area name and the sub-total representing 
the sum of the TOTAL field for all the salesmen and dates in the list, as in the following example: 
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Note that a page break could be done between each area break if we modify the option "Keep together" from 
“With First Detail” to "Entire group" in the Field Group dialog box. Save the report Report Training. 

1.8.1. Adding a main total at the end of the Report 

If you also wish to get a main total at the end of the report, go back to the Report and increase the size of the 
Report Footer Block by selecting the black line under the block title "Report Footer" and copy again the field 
Sum(TOTAL) from the Group Footer AREA. You also can add a label text to display a title such as "Main 

total" using the  icon from the Toolbox. The bottom Report should appear like the following picture: 

 

And if you run again the report you will get the main total on last page, after the last Area break: 

 

Remark: it could be sometimes necessary to increase the size of the Total field in a Break Group or in the 
Report Footer Group because the total of all data could give a bigger result that could not feed in the Total 
field size coming from the Details Block. (the Data could be truncated unless you apply the Can Grow 
Property, or could be visible but not aligned with the same Total field from other blocks). 

1.8.2. Hide the detail block and get only the Break level result 

If you only wish to get the Break Level result and hide the Detail Block, click on the Details block and go to the 
properties dialog box: select No in the Visible box. 
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Do the same for the Group Header AREA to hide that block, to avoid to get twice the information about the 
Area in the Group Header and Group Footer. In the Page Header Block, you can also hide the heading Code, 
Salesman Name and Date to not display this text in the condensed mode because no salesman neither date 
will be display. Run the Report to screen. The result should be something like the next picture if you have 
formatted all the numeric fields for a currency for example: 

 

1.8.3. Adding a second break level 

Go back to the previous situation, with the Group Header AREA and the Detail blocks visible, and also the 
heading Code, Salesman Name and Date visible in the Page Header block. To add another break level, inside 

of each area, go back to the Field Group dialog box using the  icon: 

 

In the previous example, we will add a second break level on the SALESMAN name: 
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In the above Break level 2 for the salesman name, the Group Header is not required but the Group Footer is 
required to display the sum of the TOTAL field when the break will occur for each salesman. The option Keep 
Together is set to "With first detail", so a page break will be done only if no detail can be inserted before the 
page bottom. You can now modify the report to give another color to the Group Footer SALNAME and modify 
the SALNAME field with a formula such as =’Sub-total for the salesman ‘+SALNAME. The Report should 
appear like the next picture: 

 

If you run that report, the beginning will be the same as before, with the title for the Break level 1 for each area 
(in green in our example), then the detailed list of the sales for the first salesman. 

Then, after the first salesman and before the next salesman (in the same area), the report will produce a 
break level 2 for the total of the current salesman (in yellow in our example). 

If more salesmen exist for the same area, we get the detailed list for the next salesman and then the report 
will display another break level 2 for the total of the next salesman (in yellow in our example) and will display 
after that a break level 1 to give the sum of total for the area (in green in our example), because the next 
record will concern another area: 
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Important note: in the above example, the Group Header Area is only display the first time when starting a 
new area level. But that information is not repeated on next page until the area change. 

You can force that option to repeat the Group Header Area on each page by selecting Yes in the Section 
Repeat box in the Group Header Area properties (Format Tab). 

 

You can now again ask for no detail, hiding the Details Block and get a condensed result for the 2 break levels 
thus defined and the main total: 
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You can add other breaks levels using the same way as describe in this chapter.  

1.8.4. Sending a report with break to Excel 

When sending a report to Excel, Click&DECiDE Builder only sends the Details and Break blocks fields. The 
other report blocks such as Report Header, Page Header, Page Footer and Report Footer are ignored. 

In order to define a column header inside the target Excel Sheet, Click&DECiDE Builder uses the Description 
box content from each Details Block field. If the Description is empty, then the program uses the internal 
object Name, that cannot contain spaces neither special characters and cannot be used twice with the same 
name in a report. We strongly recommend thus to use the Description box to define such headers. 

The problem when sending a report to Excel is that all data fields from the Details Block and the various Break 
Header or Break Footer Blocks are not always aligned vertically. The solution provided by Click&DECiDE 
Builder is given if you take care about the following rule: 

“Each data field sent to Excel and having the same Description content will be sent in the same Excel 
sheet column”. 

In our report example with the 2 break levels, on Area and Salesman, we will enter in the Description box the 
word Area for all columns that should be in the same Excel sheet column: 

 

Then we will apply the same rule for the Salesman Name column. 
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And then the same rule for the Total and Sum(Total) fields that will receive the same Description, for example 
the word “Amount”. Export this report to Excel or Excel 2007, in Sheet1 and cell A1 for example and open the 
Excel result file: 

If you click on the first left level (number 1) you only see condensed data corresponding to the Main Total 
level: 

 

Note the Column Headers in Excel corresponding to the Description defined in the Click&DECiDE Report. 

If you click on the second left level (number 2) you only see condensed data corresponding to the Main Total 
and the First Break level (Area): 

 

If you click on the third left level (number 3) you only see condensed data corresponding to the Main Total, 
the First Break level (Area) level and the Second Break level (Salesman): 
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If you click on the fourth left level (number 4) you see all detailed data corresponding to all detailed and break 
levels: 

 

1.9. Adding a Graph 

Using our report example Report Training with break levels on Area and Salesman Name, we will add a 
Graph on the Group Footer Block for each Area, in order to display a Pie or Histogram for all salesmen 
belonging to the same area. 

1. To do so, enlarge vertically the Group Footer AREA Block and click on the Chart icon in the Toolbox, 
then define the target location of the graph in the Group Footer AREA: 
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2. Select for example the Pie 3D model in the proposed list and click OK. The report should be as follow 
for the Group Footer AREA: (Use the Click and DECiDE Chart Designer to modify the Graph Design). 

 

3. Now, select the graph and open the Property Data Tab: 

 

By default <Report Data> is proposed as Data Source. This choice avoids to run again a query to feed the 
graph. The graph can use the existing report data and save resources when building the report. 

4. Specify the Series and Data fields. In this example the Series will be the FGrp_SALNAME_Text field 
taken in the Group Footer Block for the SALNAME break level and the data will be the SUM(TOTAL) 
field taken from the Salesman Break Level. As you can see in the above picture the internal name of 
this field has been created automatically as “FGrp_SALNAME_Sum_TOTAL”. Of course you can 
rename this internal name if needed. 

5.  Run the report and you will get a Pie Chart on each Area break level, displaying the Salesman 
belonging to the same area. 
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When a Graph inside a report can use the Report Data, it is recommended to use that way. If it is not 
possible and you need to run a separate query, the Property Data Tab looks a little bit different: if we 
replace <Report Data> with a query name such a query giving the SUM of the TOTAL field by Salesman 
and by Area, we have to define the Data Tab as follow: 

 

In the above picture the Series is the SALNAME field and the Data is the Sum_TOTAL field from the 
query named “demo_multicriteria_salesman_sum”. This query, run separately, will give for example this 
result: 
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So, in the above Graph Properties, it is necessary to add a condition between the Child Data Link and 
the Parent Data Link, specifying which columns have to be used as additional criteria. 

In our example, the additional criteria will be the AREA field: 

 

So, only the records belonging to the same AREA will feed the Graph on each Area Break Level. If you 
forget the Child and Parent Data Links, all records from the query source will be used in each Area Break 
Level, giving a wrong result. 

But remember that a separate query will take more resources and time when running the report and we 
recommend using the <Report Data> each time it is possible. 

On the same way, we can easily add another Graph in the last Report Footer Block to compare the result 
for all the Area Blocks. 

1. Repeat the same operation by selecting for example a 3D-Vertical Bar Chart in the last report 
block. The Report Block Footer should be as this example: 

 

And the Property Data Tab as follow: 
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With the AREA field as Series and the “FGrp_AREA_Sum_TOTAL” field as Data, this field being the 
Sum(TOTAL) in the Area Break Level. 

2. Run the report and the last block should be as this example: 

 

1.10. Adding a Sub-Report 

Using our report example Report Training with break levels on Area and Salesman Name, we will add a 
Sub-report on the Group Footer Block for each Salesman, in order to display information about the products 
sold. 

We need first to create a new query, using the same parameters, but retrieving information about the products 
sold for the salesmen, then create a report that will be used as a sub-report. 

1. Make a copy of the “demo_multicriteria” query under a new name “demo_multicriteria_product”. 

2. Open this new query, select the Table Tab and add the 2 tables Sales_Details and Product as follow: 
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3. Go back to the Query Tab and select only the required fields: Salesman Name, Product, Quantity and 
Amount, using a virtual field calculating the amount as follow: 
(Sales_Details.QTY*Sales_Details.PRICE)*(1-Sales_Details.DISCOUNT), then applying a SUM on 
both numeric fields: 

 

4. Save the query and create a new report using another color model 

In the new report, arrange the items as follow to keep only the Labels in the Page Header, the Product, the 
Sum(QTY) and Sum(AmountTOTAL) in the Detail Block. Note: Use the same left position and size for the 
Amount field as the one used in the main report for the Sum(TOTAL) field to get them vertically align. Remove 
the Page Footer items and reduce its size to zero: 

 

 

5. Add now a main total for both Quantity and Amount in the Report Footer, by copying the 2 numeric 
fields in the Report Footer Block and applying a SUM to both fields, and adding a new calculated field 
with the formula ='Products sold by '+SALNAME to get the Salesman name for each sub-total: 

 

 

In the Report Footer, edit the properties of the Sum(Sum_Amount) field and change the internal name to 
_Sum_Amount_Total for example (this field will be used later in the Alert Chapter): 
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6. Save now the new report as for example “demo_multicriteria_product” 

7. Test this report using only one salesman for year 2015 for example; you should get something like: 

 

8. Now, go back to the main report, in which we want to add this report as a sub-report. 

9. To do so, enlarge vertically the Group Footer SALNAME Block and click on the  Sub-report icon in 
the Toolbox, then define the target location of the sub-report in the Group Footer SALNAME: 

 

10. Open the property dialog box for this sub-report object and select as data source the new sub-report 
“demo_multicriteria_product previously created and add a link between the SALNAME fields in the 
Child Data Link and Parent Data Link to be sure to run this sub-report only for the current Salesman 
at the break level time: 

 

11. In the Format Tab change the default Display option “Detail and Break” to “All Blocks” 

 

12. Make sure the option Can Grow in the Format Tab is set to Yes for both Group Footer SALNAME 
Block and Sub-Report object: 
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13. Save and run now the Report Training report selecting area and/or period. See the result. 

 

 

When the report is run, the sub-report is run with additional criteria “where Salesman from the sub-report is 
equal to the current Salesman from the main report in the SALNAME Break level”. 

1.11. Adding a Cross-table 

Using our report example Report Training with break levels on Area and Salesman Name, we will add a 
Cross-table in the Group Footer Block for each AREA, in order to display for example the customers found 
for each AREA according to the selected Salesmen and/or the specified period. 

To do so, make a copy of the “demo_multicriteria” query and add the Customer Table, linked to the Sales 
table with the “Cust” field. Then save this query as “demo_multicriteria_area_customer”. 

This query should look like: 
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Now create a Cross-table displaying the Customer for each Area and Salesman, for the selected Year. The 
cross-table should look like: 

 

And the result should looks like: 
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Save it as “Cross-Table by Area and customer“ and now, in the Report Training, add a cross-table object in 
the Group Footer for the Area field: 

 

Select the “Cross-Table by Area and customer“ as data source and add a Child Data Link and a Parent Data 
Link using the AREA field: 

 

Set “Refresh Data” to “Yes” and “Apply defined levels” to Yes. Save and run the report for the current year for 
example: 

 

In each AREA break level, the cross-table displays the customer values for the year and salesmen. 
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1.12. Adding a Query Data 

Using our report example Report Training with break levels on Area and Salesman Name, we will add a 
Query Data in the Group Footer Block for each AREA, in order to display for example the number of distinct 
customer found for each AREA according to the selected Salesmen and/or the specified period. 

A Query Data is a separate query that will retrieve in a report only one value, being the first column and the 
first row. 

We need first to create the required query retrieving the number of distinct customers, using the same 
parameters as the report main query. If needed refer to the Click&DECiDE BAI Query User Guide.pdf for 
more information about how to create a query. The main steps are: 

1. Make a copy of the “demo_multicriteria” query under a new name “demo_multicriteria_customer”. 

2. Open this new query, select the Table Tab and add the table Customer: 

 

3. Go back to the Query Tab and select only the required fields for the Query Data: Custname and Area: 
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4. Select the CUSTNAME field 

5. Make a right mouse click and select Distinct Aggregate>Count 

 

6. If you run this query ignoring all parameters values, you should get this result (years 2013 to 2015): 

 

As you can see, you get one row for each area, and the number of distinct Customers is selected in the 
first position. 

7. Save this query as “demo_multicriteria_customer”. 

8. Go back to the Main Report and reduce the width of the Cross-Table object in the Group Footer 
AREA to make place on the right side to add a Label displaying “Distinct Customers”: 
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9. Now add a Query/Data object near the Label “Distinct Customers” in the Group Footer AREA Block. 

To do so, click on the  Query Data icon in the Toolbox, then define the target location of the query 
data object in the Group Footer AREA, on the right of the Label previously added. Apply a light 

background color and click the  Center icon to get the result centered: 

 

10. Open the property dialog box for this query data object and select as data source the new query 
“demo_multicriteria_customer” previously created and add a link between the AREA fields in the Child 
Data Link and Parent Data Link to be sure to run this query data only for the current AREA at the 
break level time: 

 

11. Save and run now the Report Training report selecting area and/or period. See the result. 

 

As you can see, the distinct number of customer is now displayed on the right of the cross-table, because at 
the run time, the Query Data “demo_multicriteria_customer” is run with an automatic additional criterion 
saying “where AREA is equal to the current AREA value in the Group Footer AREA block”. 

In the result query previously display, only the second record appears when AREA is equal to CENTRAL: 

 

Giving in fact only one row: 

 

So, in the Report Training, the Query Data object will display the value 4, being the first row and first 
column when CENTRAL area is the current value for the AREA field, that is why the AREA field in this query 
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has been selected in second position, only to be able to define the Child Data Link and Parent Data Link with 
the query of the main report. 
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2. Defining Alerts 

The power of the Click&DECiDE Builder Report Generator is to give a choice to run a report (and send the 
result by e-mail, RSS Feed or other methods describe later) only when a condition is true. 

A condition could be any result in the report, such as for example an amount lower or greater than an alert 
value. 

Pre-requisites: on the Server machine check that the Click&DECiDE Builder command Tools> Options> 
Event Manager gets the Send Events to the Event Manager option enabled: 

 

 

Note: Each time you disable or enable this option, the Click and DECiDE LEO Service has to be restarted. It 
is done automatically by Click&DECiDE if you click Yes to the following message: 

 

 

Also click the Test button that should display ”Succesful Click and DECiDE NSI Connection”. If not, an error 
can be display such as: 
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The above error means that the Click and DECiDE Filter Engine Service is not started. Start this service 
and try again. 

 

2.1. Alert Types 

Click&DECiDE Builder provides 5 alert types: 

2.1.1. Run a Click and DECiDE Item 

This alert can run any query, report or cube taken in any Click&DECiDE project file (*.wfv). 

2.1.2. Send an e-Mail 

This alert can send an e-mail with the attached specified report to the defined recipient(s). 

2.1.3. Run/e-Mail Click and DECiDE Item 

This alert can run a report and send an e-mail in one step with the attached specified report to the defined 
recipient(s). 

2.1.4. Export Google Doc 

This alert can export the result to a Google Doc drive. 

2.1.5. Roambi Reporting Services 

This alert can export the result to the Roambi Application running under a smartphone or tablet. More 
information on demand for Roambi customers. Not describe in this Manual. 

2.1.6. Generate a RSS Feed 

This alert can add a record in the RSS Feed table, that can feed the public RSS Feed and be available for any 
user who has subscribed to the Click and DECiDE RSS Feed, visible in the Feed Headlines gadget. Refer for 
more information to the Click and DECiDE Web Portal User Guide.pdf manual. 

2.1.7. Generate a Highlight 

This option will disappear in next Click&DECiDE version 15.1. Only the alert creating an RSS Feed will be 
maintained. 

2.1.8. Generate Information 

This option will disappear in next Click&DECiDE version 15.1. Only the alert creating an RSS Feed will be 
maintained. 

2.2. Create an alert 

An alert is always created in a report block, but the condition can apply to a report field in that block. To 
create an alert follow the next steps. The example describe in this manual will use the report Report 
Training created in the previous chapters from 1.8 to 1.12. We will generate an alert if the Sum(TOTAL) 
in the Group Footer SALNAME will be lower than 500,000 USD or Euros. 

2.2.1. Alert running a Click&DECiDE item 

1. Open the report Report Training that must generate the alert. 

2. Select the Group Footer SALNAME where is the field named “FGrp_SALNAME_Sum_TOTAL” 

3. Click the command View> Alerts or, if this command has already be run, make visible the Alert Tab 
by selecting it on the left bottom pane: 
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4. The left top pane displays the Alert Tab as follow: select the Group Footer SALNAME Block and click 

the  New Alert icon 

 

 

5. Select “Run Click and DECiDE Item” in the <Define your alert type here> box. 

 

 

6. Click the browse button on the right of the <Define your condition here…> box. 

 

 

7. Enter the condition in the Quick Expression dialog box, example check if the amount for a salesman is 
lower than 500000. The formula will be: FGrp_SALNAME_Sum_TOTAL < 300000. Click OK to 
validate. 

Note: if you do not enter any condition, the program will consider that the condition is always “True”. 
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8. Enter a Description about the Alert Type and Condition. The Title of the Alert is now the description 
you entered: 

 

Feed now the Run Click and DECiDE Item Properties to specify which report have to be run, in which project 
file etc. 

9. Click the browse button to search and select the required project file (Click and DECiDE Web 
Demonstration.wfv). 

 

10. Specify the Item Type you want to run among Query, Report or Cross-table. 

 

 

11. Search and select the required item name to be run. Warning: this item cannot be the report in which 
you are defining the Alert because it will generate a permanent loop. Avoid also to call for an item 
already included in the same report (as a sub-report or a cross-table) because it will generate twice 
the alerts: one time when running this item in the main report, one time when running the same item 
generated by the Alert. If this example we are going to run the report called “Demo_Multicriteria, 
given in the Click and Decide Web Demonstration project file: 
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12. Select the Output format (PDF is proposed as default) 

 

13. Define the Destination File Name. If you wish to enter a formula instead of a permanent file name, 
enter first the equal sign before click the browse button to open the Quick Expression Editor and type 
the required formula: 

 

Type the formula such as for example: 'C:\Users\Public\Documents\Click and DECiDE 
Samples\Web Portal\Shared Folder\DemoMulticietria_' + SALNAME + '_.pdf' 

SALNAME will be replaced with the Salesman Name on each report. 
 

 

14. Optional: select a Suffix if needed (that will add after the file name and before the extension a suffix 
according to the selected item). Y for Year, M for Month, D for Day, N for a number. 

 

For example, if we are in 2015, the suffix YY will add “15” at the end of the file name. 

If we are in 2015, the suffix YY-1 will add “14” at the end of the file name. 

If we are in April 2015, the suffix YYMM will add “1504” to the file name. 

If we are in April 2015, the suffix YYMM-1 will add “1503” to the file name. 

If we are the first of April 2015, the suffix YYMM-1D will add “1503” to the file name, because the day 
before the first of April was in March. 

If we are the 14
th
 of April 2015, the suffix YYMM-1 will add “1504” to the file name, because the day 

before the 14
th
 of April was in April. 

If we are the 14
th
 of April 2015, the suffix YYMMDD will add “150414” to the file name 

If we are the 14
th
 of April 2015, the suffix YYMMDD-1 will add “150413” to the file name. 

Whatever the date is, the suffix NNNN will add “0001” to the file name if not exists, or will increment the 
number using the last one plus one if the file name already exists. 
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Select for this example the NNNN suffix, so that if several files are created and if a name already exists, 
they will get distinct names: 

 

15. Optional: define a Login valid to run this item, UserID and Password, corresponding to the Data 
Source used. If the Data Source is using the Windows Authentication, no login is required here. If you 
are using the Click and DECiDE Authentication Mode, you can enter the Admin/Admin or 
Guest/Guest default login to run this example based on the local SQL Server database. 

 

16. Feed the parameter values. As you can see the Parameters box automatically displays the 
parameters found in the selected report with their default values. 

 

Change, if needed, the default values for each parameter. In our example we absolutely need to specify 
that the AREA_PARAM parameter must apply to the Area field, and the SALNAME_PARAM parameter 
must apply to the Salesman name field, and the P_DATE must apply to the Date field. 

 

17. Save the report Report Training. 

18. Run the report to test the result. Warning! a preview will never generate Alerts, you need to print or 
export the report to any output format to generate alerts. Export the report to PDF format, by selecting 
for example Q1 2015, or a keyword such as “This Quarter” and click OK: 

 

19. Once the report is finish, go to the destination directory C:\Users\Public\Documents\Click 

and DECiDE Samples\Web Portal\Shared Folder\ to see if one or several reports have 

been generated if the Alert condition was true: 
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As we can see in the above example, 9 reports have been generated for salesmen having an amount 
lower than 300000. Open each PDF to check the result: 

The first one gives the result for Bill Raley and the amount is lower that 300000: 

 

Check the other PDF results and check if the Report Training exported for Q1 2015 contains, among all 
salesmen, only 9 salesmen having an amount lower than 300000. 

2.2.2. Alert sending an e-Mail 

In the previous paragraph, the Report Training generates the report demo_multicriteria only when the 
Alert is true, the Alert being the total amount for each Salesman lower than 300000. 

When the condition is true, one or several PDF report files are created in the Shared Folder directory. So, 
any Web User connected to the Click&DECiDE Web Portal can see any new report in this Shared Folder, 
if authorized in their menus. 

Sometimes you need to prefer to send the Alert Report to one or several users by e-mail. To do so, we 
are going to modify the report demo_multicriteria so that an e-Mail will be sent when an Alert is true. 

1. Open the sub-report demo_multicriteria. 

2. Select the Report Footer block and open the Alert Tab if not already open. 
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1. Click on the New Alert icon or make a right mouse click and select Add Alert: 

 

3. Select e-mail for the Alert Type. 

 

4. Define the Alert Condition entering the following formula: _Sum_Total_Amount < 100000, if 
_Sum_Total_Amount is the internal name of the Sum(Sum_Amount) field located in the Report 
Footer. 
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5. Enter a Description for this Alert, example “Send by e-Mail if Main Total lower than 100000”. 

 

6. Define the e-mail properties, the From and To e-mail addresses 

 

 

7. Enter the Subject that can be a formula if you click the browse button. Example enter a formula such 
as 'Alert: the products sold by the salesman ' +   SALNAME   + ' are lower than 100000 Euros' 

 

8. Enter a Text message that could be a formula if you click the browse button. Example enter a 
formula such as 'Please find attached a Report PDF file for the Salesman ' +   SALNAME   + ' whose 
total amount is ' + AsString( Floor( _Sum_Amount_Total ) )+ ' Euros' 

 

9. Keep the option Attachment = Yes to get the generated report sent with the e-mail. 

 

10. Save and close the report demo_multicriteria.. 

11. Run now the report Report Training for the period Q1 2015 for example. 

As you can see in the destination Shared Folder, 9 new reports have been generated, with a new suffix at the 
end (NNNN = 0001 the second time) of each file name if the previous number already existed, such as the 
following example: 
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12. Check your e-mail box 

If your e-mail address was in the recipient list, you should receive 7 e-mails with the attached report PDF file 
for each salesman, as follow: 

 

Each mail gives detail about the Amount for each salesman being lower than 100000 euros: 

 

13. Open any PDF file to see detailed information: 
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2.2.3. Run/e-mail Click&DECiDE Item 

This new alert since Click&DECiDE version 12 allows to run a Click&DECiDE item and send the result by e-
Mail at the same time. This is faster than run a Click&DECiDE item (See 2.2.1) and define in this item another 
alert sending the result by e-Mail (See 2.2.2). 

An example is given in the Click and DECiDE Web Demonstration.wfv project file located in the 

C:\Users\Public\Documents\Click and DECiDE Samples\Web Portal directory. 

Open the report “Alert Run and Email a Report”. This report asks you to select an Area and their Salesmen, 
then a Period and specify a Sender e-Mail address compliant with your SMTP Server. Then the result will be a 
PDF that will give you the list of the Salesman having done some sales in the chosen period. Each concerned 
salesman will get an e-Mail to their respective a-Mail Address at yopmail.com with their sales using the Demo 
Multicriteria report. 

How is defined this alert? 

1. Click View > Alerts to open the Alerts Tab. As you can see an alert has been defined in the Detail Block: 

 

Note: if the condition is not defined, then the condition is always “True”. 

2. Select the Item to be run and the Output format: 

 

3. Select the destination file name and the suffix (optional) 

 

Note that the destination file name will use the Vendor name (SALNAME field) 

4. Specify, if needed, the login (if you are not using the Windows Authentication mode) 

 

5. Specify the parameters to be used 

 

Each parameter can be linked to a column name or a parameter value. 
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6. Specify the information required to send the e-Mail 

 

The “From” box must be a Sender e-Mail address recognized by your SMTP Server. In this example we have 
a Parameter “PMailSender” that ask you this information. 

The “To” box will get the value of the Vendor e-Mail address being in the MAIL field. 

The subject could be a fixed text or a formula that will generate a customized message subject. 

The Text box can also be a fixed text or a formula that will generate a customized message text. 

7. Run the report “Alert Run and Email a Report” to PDF output format or printer. 

8. Select the parameter values 

 

9. See the result 

 

10. Go to yopmail.com to check the e-mails 

For Diane Meyer:  click “Check Inbox”: 
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Click the PDF link to open the Demo Multicriteria Report for the vendor: 

 

Note that using this alert method, it was not necessary to define any alert in the Demo Multicriteria Report. 

2.2.4. E-Mail possible troubles 

1. If you get no Report PDF result in the destination directory, it could be because no record matches 
the alert condition. Try again for another period and check the result in a preview in Click&DECiDE 
Builder or because the Click and DECiDE Filter Engine Service is not started 

2. If you get Report PDF result in the destination directory, but no e-mail, it could be because you mail 
server has not been entered when running the Configuration Wizard or is wrong. Run again the 
Configuration Wizard and check the connection to the specified mail server name. 

 

Consult if needed the Event Viewer and check your mail server. 

3. If you get Report PDF result in the destination directory, and you get a some e-mails but without the 
attached file, check if Attachment has been set to Yes in the e-mail properties: 
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Consult if needed the Event Viewer. 

2.2.5. Alert sending result to a Google Doc 

An alert can also send the result file (PDF, Excel, etc.) to a Google Doc in the specified Google Drive. 

Using the demo_multicriteria report, here are the step to follow to do that: 

1. Open the report demo_multicriteria. 

2. Click the Report Footer block and open the Alert Tab 

3. We can add another Alert on the same block send the result to a Google Doc document in your 
Google Drive. Click on the New Alert icon or make a right mouse click and select Add Alert: 

 

4. Select Export Google Doc for the Alert Type: 

 

5. Enter the Alert condition using the same formula as the one defined for the e-mail alert 

 

6. Enter a Description as for example Export to Google Doc if Amount lower than 300000 

 

7. Feed now the Export Google Doc Properties.(Login for your Google Account)  
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8. Enter now the Collection (destination folder in your Google Drive): 

 

The above example will create a file under the name “FileName” in the Public Shared Folder of the Google 
Drive. To avoid this fixed name, we can customize the file name using this formula: 

='/Public/' +  SALNAME  + '_' +  AsSTring(FormatDateTime('yyyy-mm-dd')) 

The SALNAME being the Vendor Name and the current date will be added with the format yyyy-mm-dd to end 
of the file name. 

 

9. Save and close the demo_multicriteria report. 

10. Export the Report Training report to PDF for the First Quarter 2015 for example. 

11. Now Sign In to your Google Account: 

 

12. Select Drive through the Application icon: 
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13. Select in My Drive the Public drive: 

 

As you can see in the above picture, among the 9 PDF created with an amount lower than 300000, only 7 
Reports are corresponding to the Google Doc Alert with an amount lower than 100000. 

2.2.6. Alert creating a RSS Feed record 

In the paragraph 2.2.2 “Alert sending an e-Mail”, the demo_multicriteria report was sending an e-Mail 
when the Alert was true, the Alert being the total amount for each Salesman lower than 100000. 

Using the same report, the following steps explain how to create a RSS Feed record in the RSS Feed 
table used by the Click&DECiDE Event Manager. This record will be visible for any user who has 
subscribed to the Click and DECiDE RSS feed. The RSS Feed is thus added to the Feed Headlines 
gadget. 

Refer to the Click&DECiDE Web Portal User Guide.pdf manual for more information about how to work 
with RSS Feed. 

1. Open the report demo_multicriteria. 

2. Click the Report Footer block and open the Alert Tab 
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3. We can add another Alert on the same block to generate a RSS Feed record. Click on the New Alert 
icon or make a right mouse click and select Add Alert: 

 

4. Select RSS Feed for the Alert Type: 

 

5. Enter the Alert condition using the same formula as the one defined for the e-mail alert 

 

6. Enter a Description as for example RSS Feed if Amount lower than 300000 

 

 

7. Feed now the RSS Feed Properties. Enter first the Title. It could be a dynamic formula such as 
 'The '+SALNAME+' amount is ' + STR( _Sum_Total_Amounl, 6, 2 ) + ' €' 

 

8. Enter an optional Description to be displayed in the tip near the link in the Click&DECiDE RSS Feed 
Title, for example the following formula: 'This alert for the salesman ' +  SALNAME  + ' has been 
generated because the amount sold was lower than 100000 €' 

 

9. Enter the URL allowing to open, through the Feed Headlines gadget, the report created. To know 
this URL connect to the Web Portal and open the Shared Folder in the BAI Demonstration menu, then 
select any PDF report displayed in this directory. Make a right mouse click and select “Copy shortcut”, 
then paste this URL in the URL box: It should be something like:  

http://localhost/dvweb/Menus/Display.aspx?__ma=BAI+Demonstration&__mi=2317&__rp=DemoMultiCrit
eria_Diane+Meyer_0000.pdf 
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But the formula must refer to the dynamic SALNAME field and specify the Suffix used. Modify the formula 
as follow: 

='http://localhost/dvweb/Menus/Display.aspx?__ma=BAI+Demonstration&__mi=2317&__rp=’+FileName() 

The FileName() function will build the correct file name including Salesman name and suffix used at the 
run time. 

Note: The localhost has to be replaced with the IP Address or Server Name where Click&DECiDE Web 
Server is installed. 

 

10. Optional: you can enter a Category for this RSS Feed record. (Example: Information, Warning, 
Documentation, Brochures etc.) 

 

11. Optional: specify the Users and/or the User Groups authorized to consult the created RSS Feed. 
Separate each item with a semicolon: 

 

If no user or Group is specified, the default will be Everybody. 

12. Save and close the demo_multicriteria report. 

13. Export the Report Training report to PDF for the First Quarter 2015 for example. 

You should receive new records in the Click&DECiDE RSS Feed table. Any user who has subscribed to 
the Click and DECiDE RSS feed should see in his Feed Headlines gadget the new information. 

 

 

You also can open the Favorites and display the Feeds Tab and refresh the Click & DECiDE RSS: 
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To see how many new feeds are available: 

 

If you click the link, you will see the 7 new feeds in detailed records: (the next picture only displays the 4 
first records) 

 

As you can see in the above example 7 records have been added for the 7 salesmen having an amount 
lower than 100000 €, among the 9 PDF reports created with the Report Training report. If you click a 
blue text, you can open the PDF report and see more details. 

 

2.2.6.1. Checking if records have been added in the RSS Feed table  

You would need sometimes to check if records have been sent to the RSS Feed Table. To do so: 

1. Connect to the Click&DECiDE Web Portal as a user being Super Administrator or having the right to 
manage the Publish branch. (See the Administration Manager User Guide). 

2. Click the Publish branch on the left pane 

3. Click the RSS Feed level 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

75 
 

 

 

Business Application Intelligence | Training 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

 

4. Check on the right pane the existing records. Refer to the Click&DECiDE Web Portal User Guide for 
more information about how to edit or remove some records. 

 

 

2.2.6.2. RSS Feed possible troubles:  

1. If you get no new record in the RSS Feed table, it could be because no record matches the alert 
condition. Try again for another period and check the result in a preview in Click&DECiDE Builder. 

2. If you get no new record in the RSS Feed table, it also could because the Click and DECiDE 
Filter Engine Service is not started 

3. If you get no new records in the RSS Feed table, another reason could be a wrong formula in the 
URL box 
'http://localhost/dvweb/Menus/Display.aspx?__ma=BAI+Demonstration&__mi=2317&__rp='+File
Name(). In that case consult the Event Viewer to see the error and check your formula. 

4. If you get some records in the RSS Feed Table but they do not appear in the Feed Headlines 
gadget: the reason could be because you do not belong to an authorized User Group for this 
record. Try again modifying the authorized Users or User Groups, or leave blank to authorize 
everybody.  

2.2.7. Remove an Alert 

1. Select the required Alert in the concerned Block Report 

2. Click the Delete  icon in the Alert Tool Bar 

3. Save the Report 

2.2.8. Copy or Cut and Paste Alerts 

1. Select the required Alert in the concerned Block Report 

2. Click the Copy  or Cut  icon in the Alert Tool Bar 

3. Select the destination block for this Alert 

4. Paste the Alert with the Paste  icon in the Alert Tool Bar 
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3. Report Templates 

When creating a new report, Click&DECiDE Builder provides a list of existing report templates as describe on 
chapter 1.1 Creating a new Report. 

You also can create your own report templates and customize their presentation. 

3.1. Creating a Template 

A template can also be designed from an empty report. In that case everything has to be defined: blocks 
used, logo, title, first field position for header and data, background picture, font and color etc. 

A template can be designed from an existing report or template. In that case the new template memorizes all 
the information from the original report or template (visible or invisible blocks, title, picture or logo, background 
picture, font and color, first field positions etc…) and the user can add additional information. 

3.1.1. Creating a template from an empty report. 

3.1.1.1. Required Blocks 

1. Do not open any report and use the command Tools> Report Template. The Report Template dialog 
box is opened with the Standard Tab selected by default. 

 

 

2. Select the Customized Tab 

 

 

3. Click the  New icon and enter a name for this template and click OK to validate: 

 

 

4. Enter an optional description about color, font etc., as a summary for this template, and specify if the 
block width and the block height can grow, and the horizontal and vertical field spacing. The image 
preview can be done later when any new report will be made using this template. The required picture 
has to be saved in the directory C:\Program Files\Click and DECiDE\BAI\Templates\Preview under 
the PNG format. 

Block Width Can Grow: if the user selects Yes in the Block Width Can Grow drop-down combo box 
then they authorize the block to be made wider if necessary (according to the number of columns that 
are inserted). If the user selects No, then columns will be inserted on two more rows as long as the 
user has selected to authorize the Block Height to grow. 
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Block Height Can Grow: if the user selects Yes in the Block Height Can Grow drop-down combo 
box then they authorize the block to be made higher according to the number of rows that are 
inserted. If the user selects No, then columns will be inserted according to the height available or they 
will be inserted over a wider area if the user has selected to authorize the Block Width to grow. 
 
Warning: if the user has not authorized block widths and heights to grow then certain query fields 
may not be able to be automatically inserted in the report. The user will need to add them by hand. 
 
Horizontal Spacing between Columns: defines the horizontal space between fields. 
 
Vertical Spacing between Columns: defines the vertical space between two fields if they are on 
several rows. 
 

 

 

5. Click the  Edit icon: you get an empty report-template with only the default Details Block available: 

 

 

6. Most of the time you will need a Report Header and Report Footer. To add the required block, click 
the command View> Report Header/Footer: 

 

 

7. Most of the time you will also need a Page Header and Page Footer. To add the required block, click 
the command View> Page Header/Footer: 
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Note: No break level block can be defined in a report Template. 

 

3.1.1.2. Template Fields 

Certain template-specific fields can be defined in any block and must meet template item definitions 
displayed in a list when the user right-clicks on a template field or when they select the Template Items 
command. The template field list is the following: 
 

Object’s Visible Name (modifiable) Internal Object Name (fixed) 

Title 1 !Title1 or starting with !Title1 

Title 2 !Title2 or starting with !Title2 

First Header !First_Header or starting with !First_Header 

First Column !First_Column or starting with !First_Column 

Static Format !Format_Static or starting with !Format_Static 

String Format !Format_Data or starting with !Format_Data 

Number Format !Format_Num or starting with !Format_Num 

Date Format  !Format_Date or starting with !Format_Date 

Time Format !Format_Time or starting with !Format_Time 

DateTime Format !Format_DateTime or starting with !Format_DateTime 

Line Format !Format_Line or starting with !Format_Line 

 

3.1.1.3. Title Fields 

The field(s) must correspond to the proposed selection Title 1  and/or Title 2 and must have the internal 
names !Title1 and !Title2. If two fields exist, they will be given the same title. Certain reports use two 
juxtaposed fields to give a shadow effect to the title. 

If the !Title1 or !Title2 fields do not exist, then no automatic title will be inserted in the report when it is created.  

This field will be assigned the report title (by default the report name). 

1. On the Report Header or Page Header blocks the following item list is displayed: (items that are 
already used or not applicable to the block will appear dimmed). Add a static label field in the Report 
Header block and right-click this field: 
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2. Select Title1 on the right list. Automatically the internal name (not modifiable) will be !Title1 and the 
default visible Title (modifiable) will be Title1: 

 
 

3. If necessary, repeat the procedure with a second label field in order to define a !Title2 field which will 
have the same title, but which will be juxtaposed to give a shadow or relief effect to the title: 

 
 

3.1.1.4. First Header Field 

This field will indicate the position of the first Column header in the block selected (Report Header or Page 
Header). It corresponds to the option First Header and has the following fixed internal name !First_Header. If 
the !First_Header field does not exist, then no automatic Column Header will be inserted in the report when it 
is created. If the field exists, then all the Report Header fields will be positioned horizontally from left to right 

based on the position of the First Header field and will be assigned with this field’s attributes (font, font color, 

background color, character size etc…). If all the headers do not fit on one row then there are three solutions: 

 The Block Width can Grow option is activated: the report width will be increased to ensure that all 
the headers which follow will be positioned on the same row. 

 The Block Width can Grow option is deactivated but the Block Height can Grow option is activated: 
the report height will be increased to ensure that all the headers which follow can be positioned on a 
new row. 

 None of the above options is activated: the headers which follow will not be inserted in the report and 
will therefore be missed out. 

 

1. Add now a static label field in the Page Header block and right-click this field: 
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2. Select First Header in the right list. Automatically the internal name (not modifiable) will be 
!First_Header and the default visible header (modifiable) will be First Header: 

 

 

3.1.1.5. First Column Field 

This field indicates the position of the first Data Column in the block selected (in general the Detail block). It 
corresponds to the First Column option and has the following fixed internal name !First_Column. If the 
!First_Column field does not exist, then no Data field will be automatically inserted in the report when the 

report is created. If the field exists, then all the report’s data fields will be positioned horizontally from left to 

write based on the position of the First Column and will be assigned with attributes according to the following 
rules: 

 If the query columns were assigned specific formats (number, date, datetime etc…), then the format 
of each column in the report will be the same format as the one defined in the query for the column 
in question. The column width in the query’s data grid will also be used in the report. 

 If the query columns (or certain columns) have not been assigned with a specific format (number, 
date, datetime etc…), then the format of the report’s columns will be either the one defined by 
Windows by default (number, date etc…), or the format defined in the model according to the table 
included above, that is all the fields with the internal names !Format_Data, !Format_Num, 
!Format_Date, etc. 

 
If all the data fields do not fit on a single row then there are three solutions: 

 The Block Width can Grow option is activated: the report width will be increased to ensure that all 
the columns which follow will be positioned on the same row. 

 The Block Width can Grow option is deactivated but the Block Height can Grow option is activated: 
the report height will be increased to ensure that all the columns which follow can be positioned on a 
new row. 

 None of the above options is activated: the columns which follow will not be inserted in the report and 
will therefore be missed out. 

 

1. Add now a data or formula field in the Details block and right-click this field: 
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2. Select First Column in the right list. Automatically the internal name (not modifiable) will be 
!First_Column and the default visible data source name (modifiable) will be First Column: 

 

 

3.1.1.6. Column Format Field 

As mentioned in the previous paragraph First Column Field, the format of fields inserted in a report follows 
the priority of each corresponding column of the query. 
However, if no specific format has been defined in the query, then the user can define default values to use 
when creating a report via a Template. 
The user can add fields whose position is not important but whose format will be taken into account, if it is not 
defined in the query. These additional fields are optional. 
These fields will remain invisible in the reports created using a Template and they are only used to indicate 
formats and other attributes to use (color, font, character size etc… when creating a report but also when 
adding additional columns to a report at a later date. 
It may be necessary to add a static field (label), a dynamic field (data or formula) or a separator (line) to a 
report. They will be named as follows: 
 

o  !Format_Static – For text or label items. 
o  !Format_Data – For alphanumeric data items. 
o  !Format_Num – For number data items. 
o  !Format_Date – For Date data items. 
o  !Format_Time – For Time data items. 
o  !Format_DateTime – For Datetime data items. 
o  !Format_Line – For Line items. 

 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

82 
 

 

 

Business Application Intelligence | Training 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

If an item is added to a block in a template-based report at a later date Click&DECiDE Builder will search for 
an information field in the template which corresponds to the data type and will assign the attributes and 
formats defined in the Template. 
 
A block can only contain one field for one data type. For example, if the user defines a !FormatDateTime field 
in the detail block, then this block cannot contain another Datetime format field. However, it is possible to copy 
this field to the Report Header block to define another Datetime format for the block. In this case, the field’s 
internal name will begin with !FormatDateTime (for example !FormatDateTime2). 
 
Field Search Rules 
 
If the !Format_xxxxx field is not found in the corresponding block in the template, then Click&DECiDE Builder 
will search in the template’s Details block. 
 
If the !Format_xxxxx field was not found in the template’s Details block either, then ClicknDECiDE Builder will 
either search for a Text/Label in the !First_Header field or search for Data/Formula in the !First_Column field 
in the corresponding block in the template. 
 

Note: at this stage the essentials have been defined, the formats for each column will respect the default rules 
(Query column formats, or windows default values, or additional field formats specifically designed for this 
purpose, see the next step). 

It is now possible to save the new Template, then close it and close the Report Template window by clicking 
the Close button. Open a query, create a new report and select the template that was just created in order to 
test it. 

To modify the template, select Tools> Report Templates and edit the template concerned. 

 

3.1.1.7. Additional Field Format 

Define Additional Field Formats to use when modifying a report (when adding items at a later date) or 
when creating a report if the query columns have not been assigned a specific format. Important: the 
position of these fields is not important, since only their attributes and formats will be used according to the 
data types concerned. 

3.1.1.8. Dynamic Fields in the Details Block 

For example, in the previous Template place a Data/Formula field in the Details block then right-click and 
select String Format from the list of items displayed. 
Define the attributes for this alphanumeric field which does not have a specific format except that it is aligned 
to the left and define the size, font, font color and background you wish. Note the field’s internal name will be 
!Format_Data: 
 

 

 

In the same example, place a new Data/Formula field in the Details block then right-click and select Number 
Format from the list of items displayed. 
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Define the attributes for this number field which should be aligned to the right, specify the size, font, font color 
and background as well as the number format to use (for example the format proposed by Windows or a 
customized format such as # ###,##). Note that the field’s internal name will be !Format_Num: 
 

 

 

In the same example place a new Data/Formula field in the Details block then right-click and select Date 
Format from the list of items displayed. 
Define the attributes for this Date type field which should, for example, be aligned to the left, specify the size, 
font, font colour and background as well as the Date format to use (for example the format proposed by 
Windows or a customized format such as dddd dd mmmm yyyy). Note that the field’s internal name will be 
!Format_Date: 
 

 
 

3.1.1.9. Static Fields in the Details Block 

If a Text/Label type item is added to the Details block at a later date it is also possible to predefine default 
attributes. For example, to do so, place a Label type field in the Details block then right-click and select 
Static Format from the list of items displayed. 
Define the attributes for this Static field which should, for example, be aligned to the left, specify the size, font, 
font color and background. There is no format to define for Static fields. Note that the field’s internal name will 
be !Format_Static 
 

 

 

3.1.1.10. Dynamic Fields in a Header Block 

If a Data/Formula type item is added to the Report Header or Page Header blocks at a later date it is also 
possible to predefine default attributes and formats to be applied. For example, to do so, copy (or create if 
these fields have not yet been defined) all the fields managing formats from the Details block to the Page 
Header block. 
 
Note that objects’ internal names are duplicated and end with a number to avoid doubles. For example the 
!Format_Num field will be copied as !Format_Num2, the !Format_DateTime field will be duplicated as 
!Format_DateTime3 etc. 
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These keywords will be recognized by the software since they start with the reserved syntax !Format_Data, 
!Format_Num, !Format_Date, !Format_Time, !Format_DateTime and !Format_Static. 
 

3.1.1.11. Static Format in Header Blocks 

If the user adds a Text/Label type item in a Header block at a later date, it is also possible to predefine its 
attributes by default (however, if the First Header field exists, its attributes will be used by default). For 
example, to do so, place a Label type field in the Header block, right-click and select Static Format from the 
list of items proposed.  
 
Define the attributes of this static field which the user could, for example, align to the left, select the size, font, 
font color and background. There is no need to define a format for a Static field. Note that this field’s internal 
name will be !Format_Static or will begin with the text !Format_Static if the same kind of field already exists in 
the Details block. 
 

3.1.2. Creating a template from an existing template. 

You also can create a new template starting with an existing template and then modify some attributes such 
as the font, color, logo etc. 

1. Do not open any report and use the command Tools> Report Template. The Report Template dialog 
box is opened with the Standard Tab selected by default. 

 

 

2. Select in the list the existing template you wish to use, for example the “Portrait A4 Orange Glass 
Header Extended Arial” 

 

3. Click the  New icon and enter a new name for this template and click OK to validate: 
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4. Automatically the new template appears in the Customized Tab with the new name: modify the 
description and other attributes if needed (block properties, field spacing and picture name). The 
image preview can be done later when any new report will be made using this template. The required 
picture has to be saved in the directory C:\Program Files\Click and DECiDE\BAI\Templates\Preview 
under the PNG format. 

 

 

5. Click the  Edit icon: you get a new template based on the selected existing template: 

 

 

As you can see all Template fields already exist. Change now the attribute you need such as a blue color, a 
new logo, the Calibri font, the Copyright information etc. 
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Save and close this new template and create a new report from a query to test the result. 

Refer to the paragraph 3.1.1 Creating a template from an empty report for more information about the 
Template Fields and other template attributes. 

 

3.1.3. Creating a template from an existing report. 

You also can create a new template starting with an existing report and then modify some attributes such as 
the font, color, logo etc. 

1. Open the required report, Invoices for example, and use the command Tools> Report Template. The 
Report Template dialog box is opened with last used Tab by default. 

2. Select the Customized Tab. 

 

 

3. Click the  New icon and enter a new name for this template and click OK to validate: 

 

 

4. Modify the Description and other attributes, such as block and field spacing: 
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5. Click the  Edit icon: you get a new template based on the selected existing report: 

 

 

6. Define the template Title field: right-click on the INVOICE Title and select Template Items> Title1 
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7. The Title field position is now define with the keyword !Title1 in the Report Header block. 

 

 

8. Add a Static Label field in the Page Header Block and define the first Header column position: 

 

 

9. The first Header Column position is now defined with the keyword !First_Header: 
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10. Define the first data column position in the Details block: right-click the first field and select 
Template Items> First Column: 

 

11. Remove unnecessary fields in the Details Block and, optional, define, if needed, a numeric format for 
a numeric field (if no format is defined, the query column format will be used): 

 

12. Save and close the new template. 

13. Create a report from a query using this new customized template to test it. 

 

3.2. Saving Templates 

Save the modifications made and close the Template Editor. The Template’s design is now terminated and 
can be used when creating new reports. 
 
Note that the customized templates are saved in the D7MODELS.D7 file located is in the 

C:\ProgramData\Click and DECiDE\BAI\Templates directory. It is recommended to perform a 

backup from time to time and in particular before installing an update or a new version of Click&DECiDE 
Builder, even if this file is never overwritten. 
 
Note also that the standard Templates installed by Click&DECiDE are in the file D7MODELSSTD.D7 located 

is in the C:\ProgramData\Click and DECiDE\BAI\Templates directory. This file can be overwritten 

when installing a new Click&DECiDE version. Standard templates are not modifiable. 
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4. Report Book 

When creating a new report, Click&DECiDE Builder allows you to create a Report Book. 

A Report Book is a collection of several reports you want to be printed together.  

Note: a Report Book can then be printed to printer, exported to HTML or PDF locally or to Click&DECiDE 
Web Server. A Report Book cannot be exported to another Click&DECiDE Builder output format. 

4.1. Create a Report Book 

To create a new report book, follow the next steps: 

1. Click the  New Report icon or click the command File> New> Report and select the Report Book 
option in the list, then click OK to validate: 

 

2. In the proposed empty window, right-click and select Insert… 

 

3. Select the reports you need to be included in this Report Book, using Shift+Click or Ctrl+Click and 
click OK to validate: 

 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

91 
 

 

 

Business Application Intelligence | Training 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

4. The selected reports are added in the Report Book in the order you have chosen: 

 

Note: you can move a report from a location by selecting this report with the mouse, keep the left mouse 
button pressed, move to the new location and release the mouse button. 

5. Click the command View to modify if needed the Fusion Mode: 

 

When Fusion Mode is enabled, the page number for all included reports will merge all pages from all 
reports from 1 to the total number of pages. Example: 

Report 1 generates 3 pages 

Report 2 generates 5 pages 

Report 3 generates 2 pages 

Then the Report Book will generate 10 pages, with page number starting at 1 and ending at 10. 

 

When Fusion Mode is disabled, the page number for all included reports will be the same as the one 
used if each report was alone. Example: 

Report 1 generates 3 pages 

Report 2 generates 5 pages 

Report 3 generates 2 pages 

Then the Report Book will generate 10 pages, with page number starting at 1 and ending at 3 for the first 
report, then page number starting at 1 and ending at 5 for the second report, then page number starting at 
1 and ending at 2 for the third report. 

 

6. Close the Report Book and click Yes to validate: 
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7. Enter a name for the new Report Book and click OK to validate: 

 

 

8. The new Report Book will appear in the Click&DECiDE project file, among the other reports but with a 
distinct icon: 

 

 

9. Run the Report Book into a PDF format for example and check the result. Each report will prompt the 
criteria dialog box if needed. If a parameter for criteria is used by several reports inside the same 
report book, the question will be displayed only one time. If you run this report book through the Web 
Portal, you will get a global criteria list for all criteria of all reports in one screen. 

 

4.2. Modify a Report Book 

If you wish to add (or remove) any report in a Report Book, do as follow: 

4.2.1. Remove a report from a Report Book 

1. Double-click the Report Book to open it. 

2. Select the report to be removed. You can select several reports using Shift+Click or Ctrl+Click. 

3. Click the Del key. 

4. Close and save the Report Book. 

4.2.2. Add a report in a Report Book 

1. Double-click the Report Book to open it. 

2. Select the report in front of which you need to insert another report. 

3. Right-click and select Insert 

4. Select the report(s) you need to include here in this Report Book, using Shift+Click or Ctrl+Click and 
click OK to validate 

5. Close and save the Report Book. 

4.2.3. Edit a Report from a Report Book 

1. Double-click the Report Book to open it. 

2. Select the report you want to Edit. 

3. Right-click and select Edit 

4. Modify the opened Report, then save it and close it. 
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5. Close and save the Report Book. 

4.2.4. Missing reports in a Report Book 

Sometimes you could get an error when opening a Report Book if one or several reports are not found, 
because they have been deleted or renamed. Example: if we rename the report Product by category as 
Product by categories, we will get this error when opening the “My Report Book” as describe previously in this 
manual (paragraph 4.1). 

1. Click OK on this message 

 

 

2. Then, the Report Book is opened, with a grey icon for each missing report: 

 

3. Select the concerned missing report and press the Del key. Then, if needed, add another report. 

4. Close and save the Report Book. 

4.3. Delete a Report Book 

If you wish to remove a report book inside a Click&DECiDe Builder project file, do the following: 

1. Open the project file (*.wfv). 

2. Select the Report Book. 

3. Press the Del key. 

4. Use the Save or Save All command to save your changes. Note that each time you save the project 
file, this one is automatically compacted. 

 

5. Report from Raw Data Cube 

Click&DECiDE Builder 2015 (64-bit) cannot create and run a Report from Raw Data Cube, as the Microsoft 
Cubes are not anymore supported in this version. Nevertheless if you have done with a Builder V13 (or older) 
such a Report, you can run it through the Web Portal 64-bit from Version 2015. 

To know how to create such a Report, please see the Report User Guide made for Click&DECiDE Builder 
Version 13, 32-bit: 
http://www.clickndecide.com/sites/default/files/assets/files/resources/clickndecide_bai_report_user_guide_0.p
df 
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6. Report from Raw Cross Table Data 

Click&DECiDE Builder 2015 (64-bit) can create and run a Report based on the data coming from a Cross-
table made with Builder. 

To give an example, open the Click and DECiDE Web Demonstration.wfv project file and select the Cross-
Table Tab. Then make a copy of the proposed example “Cross-Table Demo_Multicriteria” cross-table under 
another name such as “Cross-Table Demo_Multicriteria_for_Report” 

 

Then open this cross-table, run it and click the Cross Table Wizard icon to be able to modify the 
configuration: 

 

 

In the wizard, remove the Quarter and Month dimensions to avoid to get too many columns in the Cross-table, 
then for the Report: 
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and click Finish 

 

The above Cross-table can be now used as a Data Source by a Report. This is useful when a query to get 
such a presentation can be longer to realize, with automatically data in column by year for example. 

Save this Cross-Table. Now we are going to create a Report using the Raw Cross Table Data: 

1. In the Click&DECiDE project file, select the Report Tab and click the “New” icon to create a 
New Report. 

 

2. Then select in the box below the required Cross Table to be used as a Data Source: 
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3. Then select a Report Template depending on the future report size (Portait or Landscape) 

 

4. Click OK: a new report is created as follow: 

 

Each column Dimension has generated a column in the Report. The Heading Label are using the column 
name or the Dimension value. The detailed block in the report will be fed by the Cross Table data rows. 

5. Run the Repot to check the Result: 
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6. Make the required adjustments if needed, such as column width, field formats etc. 

In the following example, the column width has been increase, the fields moved to the right, the numeric field 
are now in currency format and the TOTAL has been added in the Report Footer: 

 

7. Final Result: 
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7. Click&DECiDE Chart Designer 

Once you have inserted a new graph in a report or want to modify an existing graph, you can use the 
Click&DECiDE Chart Designer by making a right click on the Chart object then click Edit: 

 

Note: the size of the Chart object in the Click and DECiDE Chart Designer is automatically depending on the 
Chart Object size in your report. Enlarge the chart in the report to get a biggest chart object in the Chart 
Designer. 

7.1. Displaying the Properties 

If the right Properties pane is closed, you can open it again using the command View> Toolbars and 
Docking Windows> Properties 

 

 

7.2. Opening a Chart Template 

Use the command File> Open and search for the required template file having the cfx extension in the default 
directory C:\Program Files\Click and DECiDE\BAI\ChartModels. This command will not display a preview of 

each template. You also can use the  icon in the Toolbar to display a preview of all existing templates and 
select the one you need. We recommend this method, much easier to see the more appropriate template. 
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7.3. Saving a Chart as a Template 

Use the command File> Save As and enter a name for the new template file with the cfx extension in the 
default directory C:\Program Files\Click and DECiDE\BAI\ChartModels 

Use the command File> Save if you only want to actualize an existing template. 

7.4. Most Used Commands 

Instead of using the advanced commands in the right Properties pane, you can use the following commands 
or icons for most of the current features: 

7.4.1. Change the Chart 3D Effect 

Use the  icon to enable or disable the Chart3D effect. In the Properties box, this icon will change the 
following Chart3D item: 
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7.4.2. Change the View 3D Effect 

If the Chart3D effect is enabled, use the  icon to modify the view 3D mode. In the Properties box, this icon 
will change the following View3D item: 

 

 

7.4.3. Change the Appearance3D AngleY 

If the Chart3D and View3D effects are enabled, use the  icon to modify the AngleY value in the above 
picture. 

7.4.4. Change the Appearance3D AngleX 

If the Chart3D and View3D effects are enabled, use the  icon to modify the AngleX value in the above 
picture. 

7.4.5. Change the Cluster Effect 

If more than one series is defined in the Data Properties , then you can 

use the  icon to change the cluster effect: 

Example with Cluster set to False in the Appearance3D properties: 

 

Example with Cluster set to True in the Appearance3D properties: 
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7.4.6. Change the Chart Type 

Use the command Type to select another chart type. 

Type Command  Properties Pane 
 

 
 
 

 
 
 
 
 
 
 
 
Any choice of a 
Chart Type will 
affect the Gallery 
and GalleryObj  
in the right 
Appearance 
Properties Pane 

 
 
 
 

 

7.4.7. Adding Point Labels 

Use the  icon to display the point labels in the Chart.This action will modify the PointLabels option in the 
right Properties pane for the Appearance: 
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7.4.8. Modifying the Point Label Color 

Once the Point Labels have been added, click the  button in the Series (Collection) box  

 

 

Then select the Point Label Color in the following Series Collection Editor: 

 

 

7.4.9. Modifying the Palette Color 

If you wish to select another palette color, click the  icon in the Palette box and select the required palette: 
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7.4.10. Modifying the Multiple Color Effect 

If you have a Bar Chart for example as follow: 

 

 

And you would like to get only one color: click on the Markers level in the right Properties pane and select 
False for the MultipleColors option: 

 

 

Then use the  to modify if needed the color to be 
used in the Series Collection Editor: 

 

 

The result could be with the above color (RGB=0,128,128): 
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7.4.11. Change the number of Series or Values 

If you wish to change the number of Series or the number of Values, click the corresponding  boxes in the 
Data level in the right Properties pane and change the number(s): 

 

 

7.4.12. Change the color for each Series 

Go back to the Series Collection Editor to change the color for each series: 

 

 

Click the  icon. Here you can change the color for the Serie#1 but also the cylinder size, the Gallery style 
(Bar, Line etc.), the Legend etc. 

 

 

Select the Series#2 if you also wish to change some attributes (color, Cylindre size, Gallery type, Legend 
etc.): 

 

 

Repeat the same steps for the Serie#3. 
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7.4.13. Display the Data Editor 

Click the  icon if you wish to display the Data Editor. You will get the data editor by default below the 
Chart: 

 

 

This command will change the right Properties pane in the Tools/Data Editor level branch: 

 

 

Click the DataEditorObj branch to modify the Data Editor attributes (position, color, alignment etc.) 

7.4.14. Display the Series Legend Box 

Click the command Format> Legend> Series or the  icon if you wish to display the Series Legend Box. 
You will get the Series Legend box by default on the right side of the Chart: 

 

 

This command will change the right Properties pane in the Tools/SerLegBox level branch: 

 

 

Click the SerLegBoxObj branch to modify the Series Legend Box attributes (position, color, alignment etc.) 
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7.4.15. Display the Legend Box 

Click the command Format> Legend> Values to display the Legend box by default on the right of the Chart. 

 

 

This command will change the right Properties pane in the Tools/LegendBox level branch: 

 

 

Click the LegendBoxObj branch to modify the Legend Box attributes (position, color, alignment etc.) 

 

7.4.16. Change the Chart View Layout 

Click the command View> Layout> Default or click the  icon to display the Default layout: 
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Click the command View> Layout> Homothetic or click the  icon to display the Homothetic layout: 

 

Click the command View> Layout> Stretch Image or click the  icon to display the Stretch Image layout: 
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7.4.17. Define Stacked Series 

If more than one series id defined, you can wish to display stacked values. To do so, open the Markers level 
branch in the right Properties pane, and select the option among No, Normal or Stacked 100: 

 

 

Example with the Normal option: 

 

 

Example with the Stacked100 option: 

 

 

All cylinders have the same height, each series being a percentage of the 100% total. 

7.4.18. Modifying Axes Values Attributes 

If you wish to modify the axes values attributes, such as Font, Color, Position, Decimal number, Autoscale etc. 
Click the corresponding axe: 
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7.4.18.1. Autoscale 

Select True for the AutoScale branch level 

 

 

7.4.18.2. Font and Size 

Define the Font and size in the Font branch level 

 

 

7.4.18.3. Label Format 

Specify the Label format and decimal number if needed in the LabelsFormat branch level: 

 

 

7.4.18.4. Label Angle 

Specify the Label Angle if needed in the LabelAngle branch level: 

 

 

Example with a 45° value: 

 

 

mailto:support@clickndecide.com
http://www.clickndecide.com/


 

110 
 

 

 

Business Application Intelligence | Training 

www.clickndecide.com Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 
To contact your nearest Click&DECiDE partner, click here. 

7.4.18.5. Staggered Values 

When the Staggered option is false all values are aligned in one row. Sometimes you need to get a staggered 
presentation:  

Staggered False: one row is used for all X values 

 

 

Staggered True: two rows are used for all X values, useful when having long texts. 

 

 

7.4.18.6. Axis Title 

Select the Title branch level to define the Axe Title, color, font, position etc. 

 

 

7.4.18.7. Display or Hide an Axe 

Select the Visible branch level for the concerned Axe and chose among True or False: 

 

 

7.4.19. Add a Chart Title 

1. Select the Titles level in the Elements branch of the right Properties pane: 
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2. Select the  button and click Add, then enter the Text Title and modify the attributes: 

 

 

 

3. Click Close 

 

 

4. Check the result 

 

 

7.4.20. Changing the Axe Style 

In the Appearance branch in the right Properties pane, select the AxesStyle level and choose among None, 
Frame3D, Math and FlatFrame. 
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7.4.21. Changing the Background 

In the Appearance branch in the right Properties pane, select the BackColor level and choose among Default 
Background, Image and Gradient. 

 

 

Example using the Gradient option: define the 2 colors using RGB codes: 

 

 

7.4.22. Changing the Chart Border 

In the Appearance branch in the right Properties pane, select the BorderObject level and choose among 
None, Default Border and Image Border: 

 

 

Example without Border: 

 

Click the + sign before BorderObject to see additional options. 
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Example with Default Border: 

 

Click the + sign before BorderObject to see additional options. 

 

Example with Image Border: note that the Emboss Type has been used in this example. 

 

Click the + sign before BorderObject to see additional options. 

 

7.4.23. Changing the Gap Values 

Foor Gap values are proposed to modify the margin between the chart and the bounding rectangle. Click the 
Gaps branch level in the right Properties pane: 

7.4.23.1. Left Gap 

Use the LeftGap to define the left margin between the chart and the bounding rectangle. The Type is 
Integer. 

The specified value sets the distance in pixels between the left border of the bounding rectangle and the 
chart. 

Example: To set a left margin of 60 pixels, enter 60 in the LeftGap box. 

7.4.23.2. Top Gap 

Use the TopGap to define the top margin between the chart and the bounding rectangle. The Type is 
Integer. 

The specified value sets the distance in pixels between the top border of the bounding rectangle and the 
chart. 

Example: To set a top margin of 10 pixels, enter 10 in the TopGap box. 

7.4.23.3. Right Gap 

Use the RightGap to define the right margin between the chart and the bounding rectangle. The Type is 
Integer. 

The specified value sets the distance in pixels between the right border of the bounding rectangle and the 
chart. 

Example: To set a right margin of 40 pixels, enter 40 in the RightGap box. 

7.4.23.4. Bottom Gap 

Use the BottomGap to define the bottom margin between the chart and the bounding rectangle. The Type is 
Integer. 
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The specified value sets the distance in pixels between the bottom border of the bounding rectangle and the 
chart. 

Example: To set a bottom margin of 50 pixels, enter 50 in the BottomGap box. 
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