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1. Requirements for Click&DECiDE Dashboards 

The use of the Google Charts in the Dashboards with Click&DECiDE requires: 

1.1. Internet Access 

An Internet Access is mandatory because the templates of all the Google Charts objects are downloaded from 
the Google Web Site. The benefit is that any new version of any object is automatically available. Note that 
your data are not sent to the Google Web Site. 

1.2. A browser or device among the following list: 

 Microsoft Internet Explorer 9.0 or greater. 

 Google Chrome. 

 Mozilla Firefox. 

 iPad or iPhone. 

 Android Tablet or Smartphone. 

2. Starting with Click and DECiDE Dashboards 

2.1. Introducing Dashboard Concepts 

The Dashboards can be used under 3 different access methods: 

2.1.1. Using a Real-time Query on your Database 

This method in the only “Real-time” way to feed your Dashboard Application using Click&DECiDE Builder 
queries against your database. This method avoids scheduling data extraction periodically, and avoids using 
data coming from a Google Drive. 

2.1.2. Using a Scheduled “Goggle Data Table” file on your Server 

This method is faster than the Real-time method because using already prepared data files stored locally on 
your Server disk. These files having the extension “.gcd” contain your data, extracted from your database 
periodically through a scheduled task. This method also avoids using data coming from a Google Drive. 

2.1.3. Using a Data stored on a Google Drive 

This method is faster than the Real-time method because using already prepared data files stored on a 
Google Drive. The Google Drive content can be extracted from your database periodically through a 
scheduled task. 

So, according to your Company Policy, or for some technical reasons, or because you really a Real-time 
response, you can select the best access method to develop your Dashboard Applications. 

If you wish to have a look at the same Dashboard Example, using the above 3 methods, you can start the 
Web Portal once you have installed the Click&DECiDE 2013 and go to the installed example in the BAI 
Demonstration Menu: click the “Dashboards” branch,  
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2.2. Creating your first Dashboard 

Open the Click&DECiDE Web Portal (http://servername/dvweb/default.htm or 
http://servername/dvweb/home.htm to get only the right pane without the left frame) 

 

Click the “Create” button to access the Dashboard Menu Editor: 

 

You get by default a new blank Dashboard, whose size is by default the one defined in the command Edit > 
Properties:  675 x 1010 is the default size for an iPad or Android Tablet. If you are already editing an existing 
Dashboard, click File > New to get this new blank Dashboard. 

2.2.1. Editing the Page Properties 

Click Edit > Page Properties to define the following attributes: 

Color: Allows you to define a background color. 

Image: the default picture here is linked to the current Web Portal Theme you are using. 

/dvweb/ActiveTheme.ashx?p=Images/background.png 

If you go to the C:\inetpub\wwwroot\dvweb\App_Themes directory, you will see all the available 

Themes that can be used in the Web Portal. Each Theme contains an “Image” directory: 

C:\inetpub\wwwroot\dvweb\App_Themes\Click and DECiDE\Images 

You can use any picture from this directory, such as the background.png sample. If you change the Theme 
later, the same picture should exist in the Images directory for the other Theme and will be used in place of 
the current one. 

http://www.clickndecide.com/
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Repeat: if the picture is a small vertical or horizontal bar such as the “blue.jpg” located in the directory: 

C:\inetpub\wwwroot\dvweb\Scripts\cnd.ebis\img 

The Repeat option will display this picture according to the various options Repeat, Repeat-X, Repeat-Y etc… 
The Path should be written as follow: 

/dvweb/Scripts/cnd.ebis/img/blue.jpg 

and will not depend on the chosen Theme. Example: 

 

 

Position: You also can decide of the position of the chosen picture, depending on the picture size. 

 

Example: 
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Resize from content: This option is set to No by default. If you enable this option (Yes), the frame size of the 
Dashboard application will change automatically when moving or changing the size object in the current 
Dashboard size. The Dashboard size will be reduced or enlarged to contain all existing objects. The Height 
and Width values will change automatically. 

Height and Width: if the “Resize from Content” is set to No, you can here enter a fixed size for the 
Dashboard frame and avoid automatic resize, according to your Application needs. 

2.2.2. Inserting a Google Chart Object 

Click now Insert > Google Chart > Table 

 

And change the position and the size of this object according to your preferences: 

http://www.clickndecide.com/
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Now you need to edit the object Properties to feed the Source box (and optionally the Source Query box) 
according to the access method you have chosen. To do so, click the second symbol described in the above 
picture to open the object Properties: 

In the object Properties you can: 

- Change the name of the Object (in this example we got Table1 as default name) 

- Define the Source link that will feed this object according to the chosen access method. 

- Define, if needed, the Source Query box, accepting an SQL command and column formats. 

- Define, if needed, the Columns to be displayed using number separated by a colon (0 = first 
column, 1=second column etc.). This option only appears for charts included in a sub-Dashboard 
object, described later in the Manual. 

- Define, if needed, the Parameter(s) to be updated when making an action on this object. 

- Define, if needed, which other objects must be updated when making an action on this object. 

- Define, if needed, which URL should be run when making an action on this object, and execute this 
URL on the same window or another window. (New, Parent or Top Window). 

Click here to remove this object 

Click here to edit the object Properties 

Click here to edit the Chart Editor 

Use this corner to enlarge this object horizontally 
and/or vertically 
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- Define, if needed, some other Advanced Parameters described later in the Manual. 

As the Source Box is the one that cannot remain empty, we will describe in the next chapter, how to feed this 
object, using the 3 access methods explained previously in the Manual. 

3. Real-Time Access Method 

This method is using a link to a query created to feed this object. This query must be created and accessible 
through the Web Portal menu, in a branch or in a Shared Folder. This allows you to know the requested URL 
to execute this query. 

3.1. Create the query and copying the URL 

The query must be previously created and available in a Menu, a branch or a shared folder. As an example 
open the Web Portal and select in the BAI Demonstration Menu, the Dynamic Queries branch and select 
the query named “Demo Multicriteria with parameters”: 

 

Once you get the next screen, select the AREA parameter and click Share to see the proposed URL 
according to the authorized Output format in this Menu for this Query: 

http://www.clickndecide.com/
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Now, copy the URL from the “Google DataTable Datasource” box: it should be like this link: 

http://localhost/dvweb/Menus/Query.ashx?__ma=BAI+Demonstration&__mi=2274&AREA_PARAM=&__f=Go
ogle+Data+Table 

The Syntax AREA_PARAM= means that this parameter is ignored by default but can take later a value given 
by another object in the Google Chart Application. 

3.2. Pasting the URL to the Google Chart Object: 

Go back to the Google Chart Editor where you have inserted a Table object and click the  Properties 
icon, then Paste the URL (Remove the beginning of the URL http://localhost or http://servername): 

 

Click OK – The Table Object is run to show immediately the result in WYSIWYG
(*)

 mode (New since version 
13.0.4) so that you can modify the size if needed according to the result: 

(*) What You See Is What You Get 

http://www.clickndecide.com/
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Save and run the Dashboard Application using the File > Run command (Save will be prompt automatically if 
not already saved). 

Select a location and enter a name for this new Dashboard Application, such as: 

 

Click OK, the extension “.xgc” will be added automatically if needed, and then the Dashboard will be run: 
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You can now modify the size, the position and other parameters such as the number of rows by page. See 
later in this Manual. 

4. Google Data Table Access Method 

If you do not need a Real-time response to run a Dashboard, because you only access to data older than the 
current date, an alternative is to export the data to the “Google Data Table” output format available from 
Click&DECiDE Builder. You will get a file with extension “.gcd” that can be saved locally on your Server, for 
example in the C:\Program Files\Click and DECiDE\BAI\DemoWeb\Dashboards\Datamart as 

the examples installed with the Click&DECiDE version 2013. 
Note that these files can be updated with a scheduled task periodically to get the data from the requested 
period. (Last Day, Last Week, Last Month etc. according to your needs. 

We are going to use the same previous Dashboard saved under a new name and change the Real-time URL 
to a Google Data Table URL, reading a “file.gcd” saved in the Server disk. This access method is faster than 
the Real-time Access Method. 

4.1. Exporting the Query to a Google Data Table format 

Start Click&DECiDE Builder and open the “Click and Decide Web Demonstration.wfv” project file located by 

default in the C:\Program Files\Click and DECiDE\BAI\DemoWeb directory. 

Open the same query as the one used for the Real-Time method, the query “Demo Multicriteria”. 

 

Click the “Export Data” icon and select the Google Data Table output format: 

http://www.clickndecide.com/
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Click OK and you will get the Parameters list.  

 

Ignore all parameters and click OK. Then specify the Target directory, for example the Shared Folder “Other 

Dashboards Sample” and the directory …\Click and DECiDE\BAI\DemoWeb\Dashboards\Datamart, 

then enter a name for this file (extension “.gcd” will be added automatically when pressing Open): 
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Click Open 

 

Click OK 

Note that it must be a directory that can be visible from the Web Portal, as we need to capture the 
corresponding URL. 

4.2. Copying the URL from the Google Data Table file 

In the BAI Demonstration Menu, go to the Dashboard>Other Dashboard Samples>Datamart level: 

You should see all the “Google Data Table” files having the ”.gcd” extension: 
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Select the Demo_Multicriteria.gcd file just created. You will see the data and the required URL link on the 
bottom: 

 

Copy the Google Chart Data Source URL. 

4.3. Pasting the required URL in the Dashboard: 

Go back to the Dashboard Editor, open the previous example “MyFirstGoogleChartRealTime.xgc” 
Dashboard (or create a new empty one and insert a new Google Chart Table object), and save this 
Dashboard under a new name such as “MyFirstGoogleChartGoogleDataTable.xgc”. 

Click the  Properties icon of the Table object, then Paste the URL (Remove the beginning of the URL 
http://localhost or http://servername): 

The link should like as follow: 

/dvweb/menus/query.ashx?__ma=BAI+Demonstration&__mi=2558&__rp=Datamart%2fDemo_Multicriteria.gcd 

http://www.clickndecide.com/
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Click OK 

Save and run the Dashboard Application using the File > Run command (Save will be prompt automatically if 
not already saved). 

 

The response time should be better than the Real-time example, but it also can depend on the Database 
performance for the Real-Time access method. 

5. Google Drive Access Method 

If you do not need a Real-time response to run a Dashboard, because you only access to data older than the 
current date, and if you accept to store your data into a Google Doc Drive, an alternative consists of 
exporting the query result to a Google Drive. You need a “gmail” or Google account where you can access to 
a Drive using a login. 
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In the Drive you can create one or several Folder, for example:  

 

If this Manual the folder used will be for example the folder “My CnD Data”. The next paragraph explains how 
to feed this Google Doc folder with the data you need for your Dashboard Application. 

Note that the files inside this folder can be updated with a scheduled task periodically to get the data from the 
requested period (Last Day, Last Week, Last Month etc.) according to your needs. 

We are going to use the same previous Dashboard saved under a new name and change the Google Data 
Table with a Google Doc URL, reading the file(s) located into the folder “My CnD Data” of this Drive. This 
access method is also faster than the Real-time Access Method. 

5.1. Exporting the Query to a Google Doc Drive 

Start Click&DECiDE Builder and open the “Click and Decide Web Demonstration.wfv” project file located by 

default in the C:\Program Files\Click and DECiDE\BAI\DemoWeb directory. 

Open the same query as the one used for the Real-Time method, the query “Demo Multicriteria”. 

Click the command View > Alert 

Insert a new Post Run Event in this query. This event will be run each time the query is run toward an output 
format.  
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Define the Post Run Event as follow:  

 

If no condition is defined, that means the condition is always “True”. 

Alert Type must be “Export Google Doc” 

Description is optional 

Google User: enter your Google Account User ID 

Google Password: enter your Google Account Password 

Collection: enter the name of the Folder and File that you want to feed in your Google Drive. (the syntax is 
=’/Folder Name/File Name’) 

Save the query and click the Export Data icon: 

 

Select the Excel XLSX output format: 
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Click OK 

 

Ignore the Parameters and press OK: 

Enter a name for this file: DemoMulticriteria.xlsx 

 

Click Open. 
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Once the Excel file is created, go to your Google Drive and check the content of the Folder “My CnD Data”: 
The Google Doc “DemoMultiCriteria” will appear in this folder with the most recent modification date. 

 

5.2. Copying the Google Drive Document URL 

In your Drive, select the required Folder “My CnD Data” and click the “DemoMultiCriteria” document: 

 

 

You can see the content of your query and see a Share button. Click the Share button:  

 

Click Change if you wish to give access to all users having the link: 
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Click Save, then copy the above link from this box into the Clipboard. 

https://docs.google.com/a/clickndecide.eu/spreadsheet/ccc?key=0ArIQa0lIxC87dEdXMW1MTmVib2gwbVJ0Z
HBoTDRrSnc&usp=sharing 

5.3. Pasting the URL to the Google Chart Object 

Go back to the Dashboard Editor, open the previous example “MyFirstGoogleChartGoogleDataTable.xgc” 
Dashboard (or create a new empty one and insert a new Google Chart Table object), and save this 
Dashboard under a new name such as “MyFirstGoogleChartGoogleDoc.xgc”. Then click the  Properties 
icon of the Table object, then Paste the URL previously copied. The original link should like as follow: 

https://docs.google.com/a/clickndecide.eu/spreadsheet/ccc?key=0ArIQa0lIxC87dEdXMW1MTmVib2gwbVJ0Z
HBoTDRrSnc&usp=sharing 

Important: change the /ccc?key after the /spreadsheet text to /tq?key 

The final link to be copied in the Source box of the Table Properties should be: 

https://docs.google.com/a/clickndecide.eu/spreadsheet/tq?key=0ArIQa0lIxC87dEdXMW1MTmVib2gwbVJ0ZH
BoTDRrSnc&usp=sharing 
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Click OK 

Save and run the Dashboard Application using the File > Run command (Save will be prompt automatically if 
not already saved). 

 

The response time should be better than the Real-time example, but it also can depend on the Database 
performance for the Real-Time access method. 

5.4. Printing the Dashboard 

When running the same Dashboard from the Web Portal, but not from the Google Chart Editor, a Printer 
Button will appear in the Menu Bar: 
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6. Improving the Dashboard 

6.1. Customize the Table object presentation 

6.1.1. Number of Rows per page 

Open the Dashboard Editor and click the  Chart Editor icon on the left of the Table object Name: 

 

 

In the above screen, select the “Customize” Tab and click “Paging” and select a value in the proposed list, 10 
for example. (Note that if you need a value not proposed in this list, you can change later the chosen value 
through the Advanced button in the Object Properties  modifying the pageSize box). 

 

Click OK to validate. Run again the Dashboard. Now the maximum number of rows per page is 10 and several 
buttons are displayed, allowing to go directly to any group of records: 
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6.1.2. Displaying your Dashboard Object in Full Screen 

New since Click&DECiDE version 13.0.4, the Toolbar  icon allows you to display any Dashboard object in 
full screen. Then some other icons appear such as: 

 

The Black Cross icon allows you to leave the full screen mode 

The Magnifying Glass   icon allows you to see the data sent by the URL and feeding the object. This icon 
is now only visible if the Full Screen Toolbar is enabled. 

6.1.3. Display or Hide the Full Screen Toolbar icon 

Note that the   Toolbar Icon on the left top corner can be hidden using the Advanced button in the Object 
Properties. Click the  icon and modify the toolbar list box from Left to None. 

6.2. Inserting a Goggle Chart 

Open the Dashboard Editor with the Create button in the Web Portal. Open the Dashboard you have created 
for the Real-time Access Method “MyFirstGoogleChartRealTime.xgc”. Move the Table to the right and click 
Insert> Google Chart > Pie and place the Graph near the Table object: 

 

6.2.1. Define the Source for the Graph 

6.2.1.1. For a Real-Time Access Method: 

This Pie Chart should be fed by a Query giving only the SUM(TOTAL) for each AREA. 
You have 2 ways to do that:  

1. Create a new Query returning the AREA and Sum of Total by AREA, add this query in the Menu and 
capture the new URL corresponding to this query and paste it into the Source box. 

2. Use the existing URL from the query feeding the Table1 object in the Source box and add in the Source 
Query box an easy SQL command, based on the columns of this query (First column = A, second column 
= B, third column = C etc.) as the following example: (select A, SUM(F) group by A) 
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6.2.1.2. For a Google Data Table Access Method: 

This Pie Chart should be fed by a link corresponding to a Google Data Table file having a .gcd extension 
giving only the SUM(TOTAL) for each AREA. You have 2 ways to do that:  

1. Create a new file.gcd returning the AREA and Sum of Total by AREA, add this file into the Datamart 
directory in the Menu and capture the new URL corresponding to this file and paste it into the Source 
box. 

2. Use the existing URL from the DemoMultiCriteria.gcd file feeding the Table1 object in the Source box 
and add in the Source Query box an easy SQL command, based on the columns of this file.gcd (First 
column = A, second column = B, third column = C etc.) as the following example: (select A, SUM(F) group 
by A) 

6.2.1.3. For a Google Doc Access Method: 

This Pie Chart should be fed by a link corresponding to a Google Document giving only the SUM(TOTAL) for 
each AREA. You have 2 ways to do that:  

1. Create a new Google Doc document returning only the AREA and Sum of Total by AREA, and add the 
corresponding URL to the Source box. 

2. Use the existing URL from the existing Google Doc DemoMultiCriteria feeding the Table1 object in the 
Source box and add in the Source Query box an easy SQL command, based on the columns of this 
Google Doc Document (First column = A, second column = B, third column = C etc.) as the following 
example: (select A, SUM(F) group by A) 

 

If you click OK and run the Dashboard, the Pie Chart will appear with the result for each AREA: 

 

Now, if you click a Pie Sector a tooltip will display the Name of the selected AREA and the value of the 
Amount column. 
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Note that the format can be changed in the Source Query SQL by adding format SUM(F) '$ #,##0.00' after 
the SQL command. The SQL should be: select A, SUM(F) group by A format SUM(F) '$ #,##0.00' 

 

Note that the column format can be the one of the column in the Query, Google Data Table or the Google 
Document if you do not use the Source Query box. When using an SQL command in the Source Query box, 
the format cannot be automatic and should be defined if needed. 

But up to now, any action on the Pie Chart has no effect. Next paragraph explains how to update a Parameter 
when clicking on the Pie Chart. 

6.2.2. Define the Parameter to be updated 

This action is the same for Real-time, Google Data Table and Google Doc methods 
Open again the PieChart1 Properties and click the Update Parameters Setting icon: 
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In the above screen: 

- Click the Name combo box to get the available parameter(s) list and select the AREA_PARAM 
parameter. If no parameter appears, click New… to add a parameter. 

- Check the proposed Type combo box, and modify it if needed. Here “String” is convenient for this 
parameter on AREA. 

- Define in the Initialisation Type combo box the appropriate method. Here “Selection” will mean that 
the Pie Sector selected with the mouse, when running the Dashboard, will give the Area value to the 
Parameter. 

- Click Apply to validate then OK and run the Dashboard. 

 

Click any sector of the Pie Chart, for example NORTH-WEST. You can check that this value has been given 
to the AREA_PARAM parameter by making the following action on the Dashboard background: 
Ctrl + Double Click: will display the value(s) of all current parameters: 

Before clicking on the Pie Chart, the AREA_PARAM should have the value IGNORE 

After clicking on NORTH-WEST, the AREA_PARAM should have the value NORTH-WEST 
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This could help sometimes to check the values given from one action to another objects in a Dashboard 
application. 

But up to now, any action on the Pie Chart has no action on the Table object, and only updates the chosen 
Parameter. Next paragraph explains how to update other objects. 

6.2.3. Define the Object to be Update 

Open again the PieChart1 Properties and click the Select Controls to Update icon: 

 

 

Select the Table1 object that will be updated when clicking on a Pie Sector for the concerned AREA. 

Warning: according to the Access Method that is used, this modification is sufficient for the Real-time Access 
Method but not sufficient for the Google Data Table nor the Google Doc Access Method. 

6.2.3.1. Real-time Access Method: 

As the URL feeding the Table object contains already the AREA_PARAM parameter, the modification 
previously explained is sufficient: 

The new value for the AREA_PARAM parameter will be replace in the URL: 

The URL in the Source Box is: 

/dvweb/Menus/Query.ashx?__ma=BAI+Demonstration&__mi=2274&AREA_PARAM=&__f=Google+Data+Table 

This URL will be change dynamically at the run time to this URL if Area WEST is selected:: 

/dvweb/Menus/Query.ashx?__ma=BAI+Demonstration&__mi=2274&AREA_PARAM=WEST&__f=Google+Data+Table 

Click OK to validate, Run and Save the Dashboard, then select the WEST Area in the Pie: 

http://www.clickndecide.com/
mailto:support@clickndecide.com
http://www.clickndecide.com/


 

 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
                          Page   32 

Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here.  

 

The Amount column format and the Date column format are coming from the query used in this URL. 

Note: an alternative could be to use also the Source Query Box and enter an easy SQL if you wish to select 
only some fields from the query define in the Source box. (See this method describe below for the Google 
Data Table Access Method or the Google Doc Access Method). 

6.2.3.2. Google Data Table Access Method: 

As the URL feeding the Table object does not contain the AREA_PARAM parameter, the modification 
previously explained is not sufficient. You will need to add an SQL command in the Source Query box to 
specify the criteria according to this parameter: 

select A, B, C, D, E, F where A=[AREA_PARAM] format F '$#,##0.00', E 'MM-dd-yyyy' 

As we use an SQL command, it is recommended to give a format to the numeric and date fields. 

Click OK to validate, Run and Save the Dashboard, then select the CENTRAL Area in the Pie: 

 

Note that you can click the Help button near the Source Query box to have some help about the SQL syntax, 
the format syntax etc. Warning: the syntax is mostly case sensitive! 
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6.2.3.3. Google Doc Access Method: 

As the URL feeding the Table object does not contain the AREA_PARAM parameter, the modification 
previously explained is not sufficient. You will need to add an SQL command in the Source Query box to 
specify the criteria according to this parameter: 

select A, B, C, D, E, F where A=[AREA_PARAM] format F '$#,##0.00', E 'MM-dd-yyyy' 

As we use an SQL command, it is recommended to give a format to the numeric and date fields. 

Click OK to validate, Run and Save the Dashboard, then select the SOUTH Area in the Pie: 

 

6.2.4. Define the URL to be Run 

You also can define, if needed to execute an URL when clicking on an object. For example in the Table 
object, you can decide that a click on any row will run a Report using some parameters as the Area, the 
Salesman Name or the Date or the Year of the Date etc. 

6.2.4.1. Selecting the Report and copying the URL 

Go back to the BAI Demonstration Menu in the Web Portal and select the Dynamic Reports branch, then 
the report Demo Multi Criteria. Click the 3 parameters without entering any value and click Share to see the 
Web link: 

Click here to get some Help about the SQL commands 
and the format syntax etc. 
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Copy the Web link and remove http://localhost and keep only this part: 

/dvweb/Menus/ShowParameters.aspx?__ma=BAI+Demonstration&__mi=2316&AREA_PARAM=&SALNAME_PARAM=&
P_DATE=&__f=PDF&__e=0 

As you can see the 3 parameters are included in this URL without any value, which means the default value is 
IGNORE. 

As we need to use this URL in a Google Dashboard and in a Google Table object, we do not want to display 
the parameters at the run time. So, we need to replace ShowParameters.aspx with Display.aspx. Using this 
syntax we do not need anymore the parameter __e=1 that could replace the __e=0 (means to be run 
immediately), as Display.aspx will have the same effect. 

The new URL should be this one: (with Display.aspx) 

/dvweb/Menus/Display.aspx?__ma=BAI+Demonstration&__mi=2316&AREA_PARAM=&SALNAME_PARAM=&P_DATE

=&__f=PDF 

Or this one, if you do not want to see the Navigation Bar: (with Display.ashx) 

/dvweb/Menus/Display.ashx?__ma=BAI+Demonstration&__mi=2316&AREA_PARAM=&SALNAME_PARAM=&P_DATE

=&__f=PDF 

6.2.4.2. Pasting the URL and defining the Parameters 

Go back to the Dashboard Editor and open the Dashboard you have created for the Real-time Access Method 
“MyFirstGoogleChartRealTime.xgc” for example. 

Click the Table Properties  icon and paste one of the two previous URLs into the “Execute URL” box: 

 

Change the execute URL Mode to “Execute in new window”. 

If you click OK, save and run the Dashboard, the Report “Demo Multi Criteria” will be launch in PDF format in 
a new window each time you will click on any row of the table grid. But no parameter being defined, you will 
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get the report for all records. It is thus necessary at this step to add the Parameters to be updated when 
making a click on a table row. Click the Parameter icon: 

 

Then we need to feed the 3 parameters used by the Demo Multi Criteria Report. 

In the Table Parameter screen, select the AREA_PARAM parameter in the list: 

 

Check the Parameter Type (String), and define the Initialization Type among Selection, Column selection, 
Script, Value or URL. In this example we need to use the Column selection type and enter the column 
value. The Area value being on the first column, enter the number 1 in the value box. Click Apply to validate. 

Now, we need to add another parameter that will take the value of the Salesman Name: 

As this parameter already exists in the Dashboard, select the SALNAME_PARAM parameter using the name 
combo box: 

 

Then check the Parameter Type (String) and define the Initialization Type as Column selection but with 
the value 3, as the Salesman name appears in the third column in the Table grid. Click Apply to add this 
parameter in the list: 
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Note that the New button can be used to add a parameter not being already in this Dashboard but used by the 
external Report called by the URL. 

If you click OK, save and run the Dashboard, the Report “Demo Multi Criteria” will be launch in PDF format in 
a new window each time you will click on any row of the table grid, taking care about the Area and Salesman 
selected. 
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7. Main Menu Commands 

7.1. File Command 

7.1.1. File >New 

Use this command to create a new empty Dashboard. The default presentation can be defined using the 
command Edit Page Properties. 

7.1.2. File > Open 

Use this command to open an existing Dashboard, with extension “.xgc”. If the current Dashboard is not save, 
you will be prompt to save it. 

7.1.3. File > Save 

Use this command to save the current Dashboard. If this one has never been saved before, the Save As 
dialog box will be proposed. 

7.1.4. File > Save As 

Use this command to save a new Dashboard or an existing Dashboard under a new name. The extension 
“.xgc” will be added automatically if not specified. 

7.1.5. File > Delete 

Use this command to delete the current Dashboard having extension “.xgc”. 

7.1.6. File > Run 

Use this command to run the current Dashboard. If this one has not been saved since the last modification, 
you will be prompt to save it, then it will be run immediately. 

7.1.7. File > Convert xgc V12 

Note that this menu only appears with Google Chrome or Mozilla Firefox. This command allows the user to 
convert existing Dashboard files (with extension .xgc) coming Click&DECiDE version 12.x. 

Open the file to be converted. 

Warning: before saving the file, note that any function such as GetParameterValue("ParamName") or 
tableBarFormat (6,{width:120}) will be replaced with env.getParameterValue("ParamName") or 
env.tableBarFormat (6,{width:120}). 

Function names are case sensitive: env.getParameterValue should contain a small "g". 

Save the file to convert it. 

7.2. Edit Command 

7.2.1. Edit > Cut 

Use this command to cut an object in the current Dashboard. The object will remain in memory so that you 
can paste it in another Dashboard, opened in another browser window. 

7.2.2. Edit > Copy 

Use this command to copy an object in the current Dashboard. The object will remain in memory so that you 
can paste it in the same Dashboard or another Dashboard, opened in another browser window. 

7.2.3. Edit > Paste 

Use this command to paste an object (previously copied or cut from the current Dashboard or from another 
Dashboard) in the current Dashboard. 

7.2.4. Edit > Delete 

Use this command to delete an object in the current Dashboard. This object will not be kept in memory. 

7.2.5. Edit > Copy Style 
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Use this command to copy the style from an object in the current Dashboard. Some attributes will remain in 
memory so that you can later paste the style to another object, in the same Dashboard or another Dashboard, 
and thus apply the same attributes. 

7.2.6. Edit > Paste Style 

Use this command to paste the style previously copied from an object in the current Dashboard or another 
Dashboard. The attributes, kept in memory, will be applied to the selected object when using this command 
Paste Style. 

7.2.7. Edit > Select All 

Use this command to select all objects in the current Dashboard, then use another command such as Copy, 
Delete etc. 

7.2.8. Edit > URLs… 

Use this command when you wish to edit all the URLs used inside a Dashboard and make a search and 
replace, avoiding to modify each one separately and being sure to not forget any URL. The proposed dialog 
box will display all the URLs found on this Dashboard: 

 

Enter the string to be replaced, then the string to be used as replacement, and then click Replace All. 
Click Close when finish. 

7.2.9. Edit > Parameters 

Use this command if you wish to see, add, remove or modify any Parameters used when running the Dash 
board, at the start time (Global Parameter). This represent the default values to be use at the Dashboard run 
time. Later any value can change according to the action of the user and the rules defined in the application. 

The top window shows all the existing parameters with their default values. 

You can click any row and change: 

 The parameter type (String, Number, Date, Time, Date time) 

 The initialization type (value, script, URL) 

 The value (Enter IGNORE if you want the value to be IGNORE. An empty value is not equal to 
IGNORE) 

Note in the example given below can you can use a parameter to feed the Source box for any object.  In this 
example the parameter named Source_GCD will use an URL calling a local file.gcd on the Server and use the 
Google Data Table Access Method. If later we want to use the Google Doc Access Method, we just have to 
change the value by the one save in the Source_GDoc parameter. 
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Tip: note in the above example that instead of entering 2013 for the last year, you can use a Java Script 
language to calculate the result to be used dynamically: for the last year, the formula will be: 

(function(){var d=new Date(); return d.getFullYear()-1;})() 

In the above screen; click New to add a new global parameter and enter the parameter Name: 

 

Click OK and define the Parameter Type, the Initialization type and the default value. 

When modifying an existing Parameter, click Apply. 

Click Remove to delete any parameter from this list. 

Click OK to validate when done. 

7.2.10. Edit > Timer 

Use this command if you wish to refresh some objects in your Dashboard Application periodically: 
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In the above screen enter a number of seconds (interval between each refresh), then select the objects to be 
updated, they will appear in the Ordering column. 

Note that you can drag and drop any object in the Ordering column to change the order according to your 
needs. Click All only if all objects have to be updated. Validate with OK. 

7.2.11. Edit > Order 

Use this command if you want to define the order in which objects must be updated, when running the 
Dashboard. Drag and drop each item to a new location until you get the required order. 

 

7.2.12. Edit > Page Properties 

Use this command if you want to modify the Page Properties. This command has already been described in 
the beginning of this Manual (See Paragraph 2.2.1 Editing the Page Properties) 
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7.3. Format Command 

In the following commands remember that you can select two or more objects using two methods: 

a) Press and keep pressed the Ctrl key and make a mouse click on all required objects 

b) Use the mouse alone by keeping the left button pressed and moving the mouse over the required objects. 

7.3.1. Format > Align 

Use this command if you want to Align two or several objects in a Dashboard.xgc.  

Then click Format > Align > Left to align all object with the most left border. 

Or click Format > Align > Center to align all object with the center position of the previous position. 

Or click Format > Align > Right to align all object with the most right border. 

Or click Format > Align > Top to align all object with the most top border. 

Or click Format > Align > Middle to align all object with the middle position of the previous position. 

Or click Format > Align > Bottom to align all object with the most bottom border. 

7.3.2. Format > Size 

Use this command if you want to modify the Size of two or several objects in a Dashboard.xgc. 

Then click Format > Size > fit to Tallest to adjust the size to the tallest object (vertically). 

Or click Format > Size > fit to Shortest to adjust the size to the shortest object (vertically). 

Or click Format > Size > fit to Widest to adjust the size to the widest object (horizontally). 

Or click Format > Size > fit to Narrowest to adjust the size to the narrowest object (horizontally). 

7.3.3. Format > Center 

Use this command if you want to move one or several objects to the center position in a Dashboard.xgc. 

Then click Format > Center > Horizontal to move the object(s) to the horizontal center position of the current 
Dashboard page. 

Or click Format > Center > Vertical to move the object(s) to the vertical center position of the current 
Dashboard page. 

Remember that the Page size can be modified using the Edit > Page Properties command. 

 

7.4. Insert Command 

7.4.1. Insert > Google Chart 

You can see, run and edit several Samples if you select this branch in the BAI Demonstration Menu in the 
Web Portal: Dashboards > Other Dashboard Samples > Dashboard Samples: 

 

7.4.1.1. Insert > Google Chart > Annotation 

New since version 13.0.4: Use this command if you want to insert a Google Chart Annotation object in a 
Dashboard.xgc. 

See example Annotation Chart Sample.xgc. 
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7.4.1.2. Insert > Google Chart > Area 

Use this command if you want to insert a Google Chart Area object in a Dashboard.xgc. 

See example Area Chart Sample.xgc. 

 

7.4.1.3. Insert > Google Chart > Bar 

Use this command if you want to insert a Google Chart Bar object in a Dashboard.xgc. 

See example Bar Chart Sample.xgc. 

 

7.4.1.4. Insert > Google Chart > Bubble 

Use this command if you want to insert a Google Chart Bubble object in a Dashboard.xgc. 

See example Bubble Chart Sample.xgc. 
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7.4.1.5. Insert > Google Chart > Calendar 

New since version 13.0.4: Use this command if you want to insert a Google Chart Calendar object in a 
Dashboard.xgc. See example Calendar Chart Sample.xgc. 

 

7.4.1.6. Insert > Goolge Chart > Candlestick 

Use this command if you want to insert a Google Chart Candlestick object in a Dashboard.xgc. 

See example Candlestick Chart Sample.xgc. 

 

7.4.1.7. Insert > Google Chart > Column 

Use this command if you want to insert a Google Chart Column object in a Dashboard.xgc. 

See example Column Chart Sample.xgc. 

 

7.4.1.8. Insert > Google Chart > Combo 

Use this command if you want to insert a Combo Chart in a Dashboard.xgc. 

See example Combo Chart Sample.xgc. 
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7.4.1.9. Insert > Google Chart > Donut 

New since version 13.0.4: Use this command if you want to insert a Donut Chart in a Dashboard.xgc. 

See example Donut Chart Sample.xgc. 

 

7.4.1.10. Insert > Google Chart > Gauge 

Use this command if you want to insert a Gauge Chart in a Dashboard.xgc. 

See example Gauge Chart Sample.xgc. 

 

7.4.1.11. Insert > Google Chart > Geo 

Use this command if you want to insert a Geo Chart in a Dashboard.xgc. 

See example Geo Chart Sample.xgc. 

 

7.4.1.12. Insert > Google Chart > Histogram 

New since version 13.0.4: Use this command if you want to insert a Histogram Chart in a Dashboard.xgc. 

See example Histogram Chart Sample.xgc. 

 

http://www.clickndecide.com/
mailto:support@clickndecide.com
http://www.clickndecide.com/


 

 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
                          Page   45 

Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here.  

 

7.4.1.13. Insert > Google Chart > Line 

Use this command if you want to insert a Line Chart in a Dashboard.xgc. 

See example Line Chart Sample.xgc. 

 

7.4.1.14. Insert > Google Chart > Map 

Use this command if you want to insert a Map Chart in a Dashboard.xgc. 

See example Map Chart AddressCityStateCountry.xgc  

See also example Map Chart Latitude Longitude Sample.xgc. 

 

7.4.1.15. Insert > Google Chart > Motion 

Use this command if you want to insert a Motion Chart in a Dashboard.xgc. 

See example Motion Chart Sample.xgc. (Warning: this object requires Adobe Flash Player) 
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7.4.1.16. Insert > Google Chart > Pie 

Use this command if you want to insert a Pie Chart in a Dashboard.xgc. 

See example Pie Chart Sample.xgc. 

 

7.4.1.17. Insert > Google Chart > Sankey 

New since version 13.0.4: Use this command if you want to insert a Sankey Chart in a Dashboard.xgc. 

See example Sankey Chart Sample.xgc. 

 

7.4.1.18. Insert > Google Chart > Scatter 

Use this command if you want to insert a Scatter Chart in a Dashboard.xgc. 

See example Scatter Chart Sample.xgc. 
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7.4.1.19. Insert > Google Chart > Stepped Area 

Use this command if you want to insert a Stepped Chart in a Dashboard.xgc. 

See example Stepped Area Chart Sample.xgc. 

 

7.4.1.20. Insert > Google Chart > Table 

Use this command if you want to insert a Table in a Dashboard.xgc. 

See example Table Sample.xgc. 

 

Warning: if not already existing or added, you must add, through the Advanced Button and using the New 
button, a new Property Name called allowHtml = true if you want to see any script effect in a Table object: 

 

 

 

See in the Script paragraph how to add an horizontal bar in each table row for a numeric value, how to add 
some text and background colors depending on one or several conditions etc. such as the following example: 
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7.4.1.21. Insert > Google Chart > Timeline 

New since version 13.0.4: Use this command if you want to insert a Timeline in a Dashboard.xgc. 

See example Timeline Sample.xgc. 

 

7.4.1.22. Insert > Google Chart > Tree Map 

Use this command if you want to insert a Tree Map in a Dashboard.xgc. 

See example Tree Map Sample.xgc. 

 

To feed this kind of object, you need to make several UNION with several queries. 

See the example TreeMap Chart using real time query on the Database.xgc: 
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This TreeMap Chart is fed by a query named “TreeMap Chart MAIN” located into the Click&DECiDE Builder 
project file name “_Real Time Access.wfv” that you can see in the Datamart branch in the Web Portal: 

 

 

7.4.2. Insert Google Chart Dashboard 

New since version 13.0.4: This feature allows you to insert a Dashboard object inside you main Dashboard. 
A Dashboard object is made of 3 items: 

- A Parent Dashboard Frame that will contain the Source URL retrieving the data, from a dynamic 
query, or a Google Data Table (file.gcd) or a Google Doc. 

- At least one Children Google Chart- Object (Table by default but can be changed to a Chart): this 
object will be fed by the data from the Main Dashboard Frame through the column selection defined. 
As data are already in memory, no additional query or URL is required, and it is thus much faster. You 
can add more Children Google Chart Objects later. 

- At least one automatic Children Filter to be used to search data and change the result inside the 
Google Chart- Object(s), without the need to define yourself this additional filter object: the data 
displayed in some of these filters will also come from the existing data in memory (no additional query 
or URL is required). You can add more filter later. 

When you click Insert > Google Chart > Dashboard, the list of the Filters appears: 

 

7.4.2.1. Inserting a Dashboard with Category Filter 

Select Dashboard > Category Filter: 
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Now feed the Main Dashboard Frame with the required URL, example the URL taking data in the sales.gcd 
file:  /dvweb/menus/query.ashx?__ma=BAI+Demonstration&__mi=2558&__rp=Datamart%2fSales.gcd 

 

Validate, the preview is displayed in the Table object: 

 

By default the Category Filter value is 0 in the “Filter Column” box, meaning the first column, base 0. 

You can see that the title of this filter is Area, being the first column. 

The “bind to” box links this Filter to the specified object(s), here “Table3”. 
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Run and save this Dashboard: 

 

Click the List Combo Box to display existing value from the Area column: 

 

Select any value (single selection only), for example CENTRAL: 

 

The CENTRAL filter appears on the right side of the filter box, select another value: 
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CENTRAL appears in grey as already selected: 

 

Select SOUTH: now the two selected values appear as filtered. 

 

Remove any filtered value by just clicking the blue cross on the left side of the value. 

7.4.2.2. Inserting a Dashboard with 2 or more Category Filters 

It is possible to add more than one Category Filter and Bind a filter with another one, but the rules are the 
following: a category filter added can be bind to another one (works in “cascade” mode) but not in 
reverse mode. 

Example: in the previous example, the existing filter was on the AREA column. To add a new Category filter, 
select first the Table object inside this Dashboard, then use the command Insert > Google Chart Filters > 
Category Filter: 
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Check that the first filter is depending on the column zero (first column being AREA) in the Table and that the 
new filter is depending on the column 2 (third column being Vendor) in the Table: 

 

If you run this dashboard both filters are working but are independent: you can select for example 3 areas and 
3 vendors but the most restrictive criteria will apply: in the example below, if you select ATLANTIC, CENTRAL 
and SOUTH areas, all vendors from these 3 areas are displayed in the Table result. 

Then, if you select with the other filter some Vendors, all vendors appear in the list because no link exists 
between the 2 filters: 

 

But you can “bind” a filter with the other filter as follow: 
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Click the Properties icon on the Area Filter: 

 

Click the Edit icon on the right edge of the “bind to” box and enable the “CategoryFilterVendor”: 

 

Validate, save and run: now if you select one or several Areas with the Area Filter, then using the Vendor 
Filter will only display the vendors existing in the chosen area(s): 

 

You can decide to do the opposite, depending on your needs: 

 Remove the bind between Area Filter with Vendor Filter. 

 Add in the Vendor Filter a bind to the Area Filter. 

 

The result will be that the Area(s) displayed will depend on the previously selected Vendor(s): 

If you select for example a vendor from NORTH-WEST area (Bill Raley) and  another vendor from SOUTH 
area (Jean Martin) then only NORTH-WEST and SOUTH areas will be displayed by the Area Filter: 
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Warning: you cannot bind Area Filter to Vendor Filter and bind Vendor Filter to Area Filter at the same 
time! 

7.4.2.3. Inserting a Dashboard with Chart Range Filter 

Select Dashboard > Chart Range Filter: 

 

Now feed the Main Dashboard Frame (named here ChartRangeFilter_D1) with the required URL, example the 
URL taking data in the sales.gcd file: 

/dvweb/menus/query.ashx?__ma=BAI+Demonstration&__mi=2558&__rp=Datamart%2fSales.gcd 

Add in the Source Query box the required command to get the correct data for the chart type you will choose: 

select D, sum(E) where year(D)=[P_Year] group by D 

The first column must be a date field, the second column a numeric field. 
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The Chart object is fed by the view column box (if this box is empty all column are taken in the Source Query 
box of the ChartRangeFilter_D1 object). The number columns are based zero (first column is 0): 

 

Then the ChartRange Filter specifies the filter column to be used for the Time axis. The number columns are 
based zero (first column is 0): 

 

Validate, save and run the Dashboard: 

 

You can now play with the Chart Range Filter to see a detailed period on the Chart. You also can change the 
Chart Type to another Chart (Bar Chart, Area Chart etc.) 

7.4.2.4. Inserting a Dashboard with Number Range Filter 

Select Dashboard > Number RangeFilter: 
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Now feed the Main Dashboard Frame with the required URL, example the URL taking data in the sales.gcd 
file:  /dvweb/menus/query.ashx?__ma=BAI+Demonstration&__mi=2558&__rp=Datamart%2fSales.gcd 

 

Validate, the preview is displayed in the Table object: 

 

As you can see the Total column is in position 5, so the View Column in the Number Filter Rnage object 
should be 4: 

 

Run and save this Dashboard: 
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Now, you can play with the Number Filter Range to display only the rows whose Total will be between the 
range thus modified: 

In the next example, the number range filter has been set to display Total between 303031 and 400276: 

 

Here also, you can replace the Table object with a Google Chart object if you previously modify the source 
query for the Main Dashboard Frame and the View Columns number for the chosen chart. You also can add 
another Number Range Filter in the same above example, for the Quantity column: 

 

Validate: 
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Save and Run: 

 

 

7.4.2.5. Inserting a Dashboard with String Filter 

Select Dashboard > String Filter: 

 

Now feed the Main Dashboard Frame with the required URL, example the URL taking data in the sales.gcd 
file:  /dvweb/menus/query.ashx?__ma=BAI+Demonstration&__mi=2558&__rp=Datamart%2fSales.gcd 

 

And Validate. Automatically the preview is displayed in the Table object using all columns: 
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But you can change the selected only the required columns in the Table Properties using the View Columns 
box where a Tooltip displays the syntax if you just move the mouse cursor in this box (without selecting the 
box): 

 

Enter for example 0 for first column (Area), 2 for third column (Vendor), 3 and 4 for columns 4 and 5 (Total 
and Quantity): 

 

Validate. Adjust the Table size and number of row per page (5), and then run (and save) the Dashboard to 
see the result: 

In the top of the Dashboard the String Filter appears, ready to enter any value: not that the characters or string 
you can enter will be translated as “beginning with” the corresponding argument: 
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Enter in the String Filter a “C” and you will get only the Areas beginning with “C”: (not case sensitive) 

 

You can change the Google Chart Table to another type of Chart: the  Chart Editor icon. But most of the 
time you probably need previously to change the URL in the Main Google Frame and/or in the View Columns 
box of the Google Chart object because the chart you will select needs probably other columns than the one 
already selected. 

If we modify the Main Google Frame URL adding this Source Query to get only the sum of the total by State 

name: select A, B, year(D), sum(E) where year(D)=[P_Year] group by A, B, year(D) 
format sum(E) '#,###.00' 

 

and if we modify the View Columns in the Table Object with 1,3 we can then switch the Table object to a Bar 

Chart without getting errors because the expected fields do not match the Bar Chart structure. 
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Then select the Charts Tab and chose another kind of Chart such as Bar Chart: 

 

Then validate and run the Dashboard: 

 

 

Now you can use the String Filter to see only some States beginning with t=he required string or character: 

Enter the “N” character: only the States beginning with “N” appear: 
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Enter “NE”, now only States beginning with “NE” appear: 

 

 

7.4.3. Insert Google Chart Filter 

New since version 13.0.4: 

As describe in the previous paragraph about the Insert > Google Chart > Dashboard command, you can insert 
a Dashboard including a specific Filter, among 4 filter types proposed, but is it also possible to add one or 
more filter(s) inside an existing Dashboard, each filter must just be linked to an object (Table, Chart etc.). 

The command Insert > Google Chart Filter is greyed when not available. You need first to select the Google 
Chart Object in a Dashboard to which you want to assign a new or additional filter before running the 
command Insert > Google Chart Filter. 

7.4.3.1. Inserting a Category Filter 

First select first the Google Chart Object to which you want to apply a Category Filter then click the command 
Insert > Google Chart Filter > Category Filter. 

Example: open the Bar Chart Sample.xgc file located in the //BAI Demonstration/Dashboards/Other Dashboard 

Samples/Dashboard Samples directory 
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Make a copy of this example saving it as Bar Chart Sample with category filter.xgc 

Note that the Bar Chart is fed by the following URL and Source Query and that the click on a Bar will update 
the Table object using the P_Vendor parameter: 

 

If you add a Category Filter to this Bar Chart, you will get automatically 3 objects: A Background Dashboard 
object that will include the Bar Chart and the Category Filter: 

- First select the Bar Chart Object 

- Click  now the command Insert > Google Chart Filters > Category Filter 

 

The Dashboard will appear modified as follow: 
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Click the Dashboard1 Properties icon to see the URL and Source Query:  

 

Click the Bar Chart Properties icon to see the modifications: 

 

In the Bar Chart the Source URL and Source Query have been replace with the view columns box. The data 
are now coming from the Dashboard1 object. If no column is specified all data are taken from the source 
query box from the Dashboard1 object. 

Click the Category Filter Properties icon to see how it is defined: this filter is bind to the BarChart1 object, 
through the first column (base 0). 
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Save and Run the Dashboard: the new filter appears and allows you to select one or more vendor(s) in the 
list: the selected vendor names appear near the category filter and you can remove any value by clicking the 
blue cross on the left side of the name: 

 

Note that the Table object under the Bar Chart is not updated by the Category Filter. It is possible to change 
this status by adding the “bind” in the Category Filter to the Table object: click the Category Filter Properties 
icon and add the Table object in the “Bind to“ box: 

 

Warning 1: it could be that in the above picture the “Table” object does not appear: the reason is that this 
object is not included in the “Dashboard1” frame containing the Category Filter. You can select the Table 
object, then click Edit > Cut, the select the “Dashboard1” object and click Edit > Paste. You should then see 
the Table object in the Bind to above dialog box. 
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Warning 2: in this example the Year Radio button have been defined to update automatically the Table object 
and the Bar Chart. But now these Table and Bar Chart objects are inside the Dashboard1 object. You need to 
define again the Update List in the Year Properties box to add the Dashboard1 object: 

 

Save and Run again the Dashboard: 

 

You can use the Category Filter to display only some vendors to compare their sales on the selected year. 

7.4.3.2. Inserting a Chart Range Filter 

First select first the Google Chart Object to which you want to apply a Chart Range Filter then click the 
command Insert > Google Chart Filter > Chart Range Filter. 

 

7.4.3.3. Inserting a Number Range Filter 

First select first the Google Chart Object to which you want to apply a Number Range Filter then click the 
command Insert > Google Chart Filter > Number Range Filter. 
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Example: open the Table Sample.xgc file located in the //BAI Demonstration/Dashboards/Other Dashboard 

Samples/Dashboard Samples directory 

Make a copy of this example saving it as Table Sample with Number Range filter.xgc 

Note that the Table1 Object is fed by the following URL and Source Query and that the click on a City will 
update the Table2 object using the P_City parameter: 

 

Note that the Table2 object is fed by the following URL and Source Query: 

 

Select the Table1 object and click the command Insert > Google Chart Filters > Number Range Filter: 

 

The Dashboard will appear modified as follow: 
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Note that the Table2 is still out of the Dasboard1 Frame, so not link to the Number Range Filter. 

The new object Dashboard1 contains now the URL and Source Query previously defined for the Table1: 

 

The new Number Range Filter is bind to the Table1 object and the Filter Column is defined by default to 1  
but should applies to a numeric value, which is column Sum(G) in the Source query box. This column is in 
position 5, so you have to modify the Filter Column to 4 (Column 5 base 0 = 4): 

 

The Table1 object has been modified to: 

 

As you can see, the Source URL and Source Query have been replaced with a view columns box. (If empty, 
all data from the dashboard1 object are taken). 

Warning: the Year box was updating previously Table1 and Table2. Now you must specify that the 
Dashboard1 object should be updated in place of Table1: 

 

Validate, save and run the Dashboard: the result appear with the new Number Filter Range displaying by 
default the min and max values found in the Sum Amount column: 
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You can move the min and max cursors from the Number Range Filter to reduce the result to a shorter 
number of records: example between 1,500,000 and 2,000,000: 

 

Note that this filter has no effect in the Table2 being out of the Dashboard1 object. 

But if you select now any city in Table1, the Table2 is updated: 

 

 

 

 

 

7.4.3.4. Inserting a String Filter 

First select first the Google Chart Object to which you want to apply a String Filter then click the command 
Insert > Google Chart Filter > String Filter. 

Example: open the Timeline Chart Sample.xgc file located in the //BAI Demonstration/Dashboards/Other 

Dashboard Samples/Dashboard Samples directory 

Make a copy of this example saving it as Timeline Chart Sample with String filter.xgc 

Note that the Timeline1 Object is fed by the following URL and Source Query: 

 

Select the Timeline1 object and click the command Insert > Google Chart Filters > String Filter: 
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The Dashboard will appear modified as follow: 

 

Note that the String Filter is bind to the Timeline chart and has been defined to column 1 instead of default 
value 0 because the need was to make a filter on the Product Name (column 2) and not on the Category 
Name (Column 1): 

 

Note that the main Dashboard1 object is now fed by the Source URL and Source Query previously defined tp 
the Timeline chart: 

 

Note that the Timeline chart has been modified automatically to get the view column box instead of Source 
URL and Source Query: 

 

If no column is specified, all data from the Dashboard1 object are taken. If columns are specified, the syntax 
must be 0,1,2   etc. (Base 0  First column =0) 

Move the Product String Filter on the right top of the Dashboard1 object, then save and run the Dashboard: 
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You can now enter one or several characters to see only some products to be compared, example enter a “B”: 

 

Warning: the Year object needs to be modified to update the Dashboard1 object instead of Table1 and 
Timeline1 objects: 

 

Now the year will affect also the result, with the same filter: example switch to 2014: 

 

7.4.3.5. Filter Advanced Properties 

In each Filter Type, you can see an Advanced button giving access to more properties. Click the Help button 
for more information from the Google Developers Site. 
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Example for the Category Filter: 

 

Click the Help button for more information from the Google Developers Site. 

Example for the Chart Range Filter: 

 

Click the Help button for more information from the Google Developers Site. 

Example for the Number Range Filter: 
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Example for the String Filter: 

 

Click the Help button for more information from the Google Developers Site. 

7.4.4. Insert > Other Controls 

Note that all other controls (that means “objects”) that you can insert in a Google Dashboard Application are 
not object coming from Google but objects developed by Click&DECiDE. 

7.4.4.1. Insert > Other Controls > Label 

Use this command if you want to insert a Label in a Dashboard.xgc. 

 

Click the  Properties Icon to change the Static Text or Title to be displayed. 

 

7.4.4.2. Insert > Other Controls > Input 

Use this command if you want to insert an Input box in a Dashboard.xgc. 
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Select the Input Type among: Text (Input box where you can enter a dynamic value when running the 
Dashboard), Checkbox, Radio buttons, Date field, Date Time field, Time field, Month field and Week field. 

 

Select the Input Type in the Type Combo box list. 

Define, if needed, the Parameter(s) to be update (see paragraph “6.2.2 Define the Parameter to be updated”) 

See the example Other Controls Sample.xgc in the BAI Demonstration Menu in the Web Portal: Dashboards 
> Other Dashboard Samples > Dashboard Samples: 
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7.4.4.3. Insert > Other Controls > Button 

Use this command if you want to insert a Button in a Dashboard.xgc. 

 

Click the  Properties Icon to change the Text to be displayed in the Button. 

 

Define, if needed, the Parameter(s) to be update (see paragraph “6.2.2 Define the Parameter to be updated”) 
Define, if needed, the objects that must be Updated (see paragraph “6.2.3 Define the Object to be Updated”) 
Define, if needed, the URL to be run and the URL Mode Execution. (see paragraph “6.2.4 Define the URL to 
be Run”) 
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7.4.4.4. Insert > Other Controls > List 

Use this command if you want to insert a List box in a Dashboard.xgc. 

 

Click the  Properties Icon to change the Source that will feed this List: 

 

Select the Selection Type among the proposed list: Multiple or Single. 

Define the Source box. It could be a query URL as describe for the Real-time Access Method, or a GCD file 
URL as describe for the Google Data Table Access Method, or a Google Doc URL as describe for the Google 
Doc Access Method. You also have an easier way to feed the Source box when the number of values for this 
list is small, with 2 alternatives: 

You can enter directly the values to be used separated with a semicolon, if the values to be displayed are the 
same. For example if you want to display a list of Years and if the year can be used directly as criteria, you 
can enter for example: 2010;2011;2012;2013;2014 in the Source Box. 

You also can enter the value using 2 arguments: the first one is the value to be used in the criteria (through a 
parameter), the second one is the value to be displayed in the List object in the Dashboard Application. 

Example: 1|Item1;2|Item2;3|Item3 
The list box will display vertically the values Item1, Item2 and Item3 

The parameter updated by the selected value in the list box will received 1 if Item1 is selected, 2 if Item2 is 
selected etc. and will received 1;3 if Item1 and Item3 are selected (if Multiple value enabled). 

Define the Source Query box, if needed and only if Source is fed by an URL. (See Source Query Real-time or  
Source Query Google Data Table or Source Query Google Doc). 

Define, if needed, the Parameter(s) to be update (see paragraph “6.2.2 Define the Parameter to be updated”) 
Define, if needed, the objects that must be Updated (see paragraph “6.2.3 Define the Object to be Updated”) 
Define, if needed, the URL to be run and the URL Mode Execution. (see paragraph “6.2.4 Define the URL to 
be Run”). 

7.4.4.5. Insert > Other Controls > Document 

Use this command if you want to insert a Document object in a Dashboard.xgc. 
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This object has been developed to be able to insert a PDF Report or a Cube inside a Google Dashboard 
Application. Note, for a Cube, that the dynamic HTML format only can be run under Internet Explorer but not 
under Chrome neither Firefox, which will provide a static image of the Cube. 

Click the  Properties Icon to change the Source that will feed this document: 

 

In the above example the Source is the URL calling the Demo Multi Criteria Report as a PDF output format. 

It is also possible to call a Cube, but with HTML result only under the Internet Explorer browser. 

See the following example in the Dashboard Application: select a Vendor in the top right table and click the 
“Call Document and Graph Screen” button to see the child dashboard displaying a PDF Report: 

 

7.4.4.6. Insert > Other Controls > Image 

Use this command if you want to insert a Picture in a Dashboard.xgc. 

 

Click the  Properties Icon to change the Source that will feed this picture: 
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The logo.png, for example, is located into the default directory: 

C:\inetpub\wwwroot\dvweb\Scripts\cnd.ebis\img 

You can enter another path if you need to use a picture from another location. 

Define, if needed, the Parameter(s) to be update (see paragraph “6.2.2 Define the Parameter to be updated”) 
Define, if needed, the objects that must be Updated (see paragraph “6.2.3 Define the Object to be Updated”) 
Define, if needed, the URL to be run and the URL Mode Execution. (see paragraph “6.2.4 Define the URL to 
be Run”). 

7.4.4.7. Insert > Other Controls > List Sorted Selection 

Use this command if you want to Insert an List Sorted Selection object in a Dashboard.xgc. 

This object is quite similar to a List Box but offers more possibilities: 

- The list can be Expandable: a button appears: 

 

 and shows the list when you click the button: 

 

The user can change the order of the proposed items in the List at the run time. 
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- The list can be No Expandable and appears directly as a List,  not as a Button: 

-  

- The user can change the order of the proposed items in the List at the run time: 

o  

 

See example List Sorted Selection Sample.xgc, inside of which, using one, two or three objects, plus a 
Table objects, you can create and customize your own Cross-Table. 

 

Click the  Properties Icon to change the Source that will feed this List Sorted Selection object: 

 

Enter a Name for this object. 

Define the Type among Expandable or Not Expandable. 

Define the Source: in the example List Sorted Selection Sample.xgc, we have built a cross-table with 3 List 
Sorted Selection objects: one for the Rows, one for the Columns and one for the Measure. The Source box is 
fed by a list of column with first argument being hidden and second argument being the visible column name. 
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The content is as follow for the Rows(s) object: 

C|Area;G|State;H|StateName;F|City;E|Customer;B|Salesman;L|Family;K|CategoryName;J|Product 

If you add in the row list the visible columns Area and City, then the SQL feeding the Table object will replace 
Area and City with SELECT C, F, using parameters (one parameter for the columns being in rows, one 
parameter for the columns being in column and one parameter for the column being in the measure area. 

The content is as follow for the Column(s) object: 

C|Area;G|State;H|StateName;F|City;E|Customer;B|Salesman;L|Family;K|CategoryName;J|Product 

The content is as follow for the Measure(s) object: 

Sum(P)|Sum Amount;sum(M)|Sum Quantity;Avg(P)|Avg Amount;Avg(M)|Avg Quantity;Min(P)|Min 
Amount;Min(M)|Min Quantity;Max(Amount)|Max Amount;Max(Quantity)|Max Quantity 

The Source box for the Table object contains the following URL: (Google Data Table Access Method): 

/dvweb/menus/query.ashx?__ma=BAI+Demonstration&__mi=2558&__rp=Datamart%2fList+Sorted+Sample.gcd 

And the Source Query box contains this SQL: 

SELECT {CnD:"P_Column"}, {CnD:"P_Measure"} Where year(D)=[P_Year] Group by {CnD:"P_Column"} Pivot 
{CnD:"P_Pivot"} Format {CnD:"P_Measure", sep:" '#,##0', "} '#,##0' 

The parameters P_Column, P_Measure and P_Pivot will replace the selected column names with their 
respective letters, such as this example: 

If the Row(s) object contains the fields Area and Salesman: 

 

And if the Column(s) object contains the field Family: 

 

And if the Measure(s) object contains the fields Sum(Amount) and Sum(Quantity): 

 

Then the SQL feeding the Table result will be translated to: 

SELECT C,B,SUM(P),SUM(M) Where year(D)=[P_Year] Group by C,B Pivot L Format {SUM(P),SUM(M), 
sep:" '#,##0', "} '#,##0' 
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You can check the Parameter Values using the Ctrl + double Click on the background of the Dashboard 
when running: 

 

Then, click the Update button which will update the Table object: 

 

And see the result: 

 

7.4.5. Insert > Other Controls > Pivot 

New since version 13.0.4: Use this command if you want to insert a Pivot object in a Dashboard.xgc. This 
new object will replace the existing Cubes based on the Microsoft Cubes Web Components 2003 that is 
limited to the Internet Browser and limited to the compatibility with Windows 64-bit versions and also soon not 
supported anymore by Microsoft. A Pivot can also be used under Google Chrome or Mozilla Firefox browsers. 

7.4.5.1. Add a Pivot Object 
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Click first the  Properties icon and paste the URL you need to be used in the Source box, for example the 
URL using the Sales.gcd data: 

/dvweb/menus/query.ashx?__ma=BAI+Demonstration&__mi=2558&__rp=Datamart%2fSales.gcd 

 

Validate with OK 

Click now the  Chart Editor icon: 

 

For example, the data coming from the sales.gcd link in the Datamart directory we can display the following 
pivot: Area as rows, Vendor as Columns and Total as measure. 

Warning: only one measure can be added in this version. If you add a second measure, only the first one is 
displayed, but you can use the SumOverSum function to get the result of Sum(Measure1) / Sum(Measure2). 
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Enlarge the Pivot to see maximum of columns horizontally. 

Click OK to validate your configuration. 

7.4.5.2. Run a Pivot Object: 

Click File> Run (and Save this Pivot) to see the result as an end-user: 

 

Use the Horizontal Scroll bar to see the Totals Column on the right side. 

Use the Toolbar  icon if you wish to get a full screen overview. In the full screen mode you can use the 

Magnifying Glass icon and the Pivot Tools  icon. 

7.4.5.3. Modify the Pivot Dimensions and Measures 

Use the Pivot Tools   icon if you wish to modify dynamically the Pivot presentation: 
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In the above example we have moved the Vendor dimension under the Area dimension in the Row 
Dimension box, and added the “Date Year” dimension in the Column Dimension box. 

7.4.5.4. Modify the Pivot Presentation 

Select in the Pivot Type list box the required presentation according to the proposed list: 

 

 Table Barchat: 

This Pivot Type will add Histogram Bar inside each numeric cell (except Totals) according to the displayed 
values: 

 

 Heatmap 

This Pivot Type will add a background range color inside each numeric cells of the current measure according 
to the displayed values. Another distinct range color is applied to the Total Row and Total Column that are 
displayed in bold. 
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 Row Heatmap 

This Pivot Type will add a background range color inside each numeric row cell of the current measure 
according to the horizontal displayed values. Another distinct range color is applied to the Total Row and 
Total Column that are displayed in bold. 

 

 Col Heatmat 

This Pivot Type will add a background range color inside each numeric column cell of the current measure 
according to the vertical displayed values. Another distinct range color is applied to the Total Row and Total 
Column that are displayed in bold. 
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 Line Chart 

This Pivot Type will change the Pivot Cube View to a Pivot Chart View using a Line Chart. 
 
Note: this chart (and the 2 next one described later) cannot be modified if you are running this option as an 
end-user but can be modified if you are the Author of this Pivot. In that case just double-click the Chart 
preview to get the Chart Editor: 
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 Bar Chart 

This Pivot Type will change the Pivot Cube View to a Pivot Chart View using a Bar Chart: 

 

 Area Chart 

This Pivot Type will change the Pivot Cube View to a Pivot Chart View using an Area Chart: 
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7.4.5.5. Modify the Pivot Measure Presentation 

Select in the Pivot Measure Type list box the required presentation according to the proposed list: 

 

 Sum (default measure type): will display the value with 2 decimals, decimal and thousand separators. 
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 Integer Sum: will display the value with zero decimals and thousand separators. 

 

 

 Count: will display the number of occurrences of the values in the cell. 

 

 

 Count Unique: will display the distinct number of occurrences of the values in the cell. If we replace 
the Total Field in the measures with the State field, we get the number of distinct State where each 
Vendor has sold something for each year. 

 

 

 List Unique: will display the distinct occurrences of the values in the cell. The same previous example 
will display the Distinct State Codes instead of the number of distinct values found: 
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 Average: will display the average of the values in each cell. In the previous example, using again the 
Total field as measure: 

 

 

 

 SumOverSum: this function requires 2 fields in the Measure Box Area. The result will be a division 
between the Sum of the first field (Total) and the Sum of the second field (Quantity): 
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 Sum as Percent of Total: will display Percent value in each cell compared to the Main Total Sum 
cell (including all rows and all columns): 

 
 

 Sum as Percent of Row: will display a Percent value in each cell compared to the Main Row Total 
Sum cell (including all rows): 
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 Sum as Percent of Column: will display a Percent value in each cell compared to the Main Column 
Total Sum cell (including all columns): 

 

 

 

 Count as Percent of Total: will display a Percent value in each cell compared to the Main Total 
Count (number of values) (including all rows and all columns): 
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 Count as Percent of Row: will display a Percent value in each cell compared to the Main Row 
Count (number of values) (including all rows): 

 

 Count as Percent of Column: will display a Percent value in each cell compared to the Main 
Column Count (number of values) (including all columns): 
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7.4.5.6. Working with Parameters in a Pivot 

You can define some parameters whose values will be updated when making a single click anywhere on the 
Pivot result. To do so, first add the required parameters in the Edit > Parameter command: 

For example, in this pivot feed with the sales.gcd data file, we add 3 parameters, the one used by the report 
“Demo Multicriteria” in the Click and DECiDE Web Demonstration.wfv project file: 

AREA_PARAM for the Area dimension 

SALNAME_PARAM for the Vendor dimension 

P_DATE for the Date Year dimension 

 

 

Then, click the  Properties icon of the Pivot object: 
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Click now the  icon on the right of the Param box and add the first AREA_PARAM parameter: 

Click the List Box of the Name field and select the AREA_PARAM parameter. 

Check the Type (String by default) 

Click the Initialisation Type and select the Dimension Selection (New since version 13.0.4): 

 

Validate by clicking “Apply” and also add the 2 other parameters SALNAME_PARAM and P_DATE: 
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Note that the Dimension Name in the value box is linked to each parameter (case sensitive). 

Run now the Pivot and check the values given to these 3 parameters according to the mouse click. 

To avoid too many data in the following examples, apply a filter to get only Atlantic and Central areas: 

 

In the above screen, if you select nothing, all parameters should be defined to IGNORE. Press Ctrl+Double 
click to see the parameter values: 

 

Now; click the Central cell in the above pivot result. All data in the red frame will apply to the parameters: 
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Check again the parameter values: The AREA_PARAM is CENTRAL, the 3 vendors are in the 
SALNAME_PARAM but the P_DATE is ignored because all years are concerned. 

 

Now; click the Karen Walker cell in the above pivot result. All data in the red frame will apply to the 
parameters: 

 

Check again the parameter values: The AREA_PARAM is ATLANTIC, the SALNAME_PARAM is only Karen 
Walker but the P_DATE is ignored because all years are concerned. 

Now; click the cell containing the value “156” in the above pivot result. All data in the red frames will apply to 
the parameters: 
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Check again the parameter values: The AREA_PARAM is ATLANTIC, the SALNAME_PARAM is only Tim 
Rosenberg and the P_DATE gets the value of the year 2013: 

 

Now; click the cell containing the value “485” in the vertical Totals Column in the above pivot result. All data in 
the red frames will apply to the parameters: 

 

Check again the parameter values: The AREA_PARAM is CENTRAL, the SALNAME_PARAM is only John 
Brown but the P_DATE is ignored because all years are concerned: 

 

Calling Dynamically a Report from a Pivot: 

Now, we can add an URL in that Pivot that will call the “Demo Multi Criteria” Report. In the Web Portal the 
Share button will build the following URL if you select the 3 parameters Area, Salesman and Date for this 
report: 

http://www.clickndecide.com/
mailto:support@clickndecide.com
http://www.clickndecide.com/


 

 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
                          Page   100 

Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here.  

/dvweb/Menus/ShowParameters.aspx?__ma=BAI+Demonstration&__mi=2316&AREA_PARAM=&SALNAME
_PARAM=&P_DATE=&__f=PDF&__e=0 

We can modify this URL as follow to not show the parameters but to run directly the report from a click in the 
Pivot: 

/dvweb/Display.aspx?__ma=BAI+Demonstration&__mi=2316&AREA_PARAM=&SALNAME_PARAM=&P_DA
TE=&__f=PDF&__e=1&__nav=0&__content=1 

 

Click the  Properties icon of the Pivot object and paste this URL in the “execute url”  box: 

 

Define the “execute url mode” as in new window. Validate and run the Pivot: 

 

If you click for example the value 1,117,395.96 for Diane Meyer (Area ATLANTIC and Year 2013) the “Demo 
Multi Criteria” report is immediately run and will display the corresponding result for the following parameter 
values: 

 

The report will be: 
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Alternative: instead of entering the dimension name in the value box, you can write in lowercase characters 
the words “row” or “col”. In that case the value given to the parameter will be the string concatenation of the 
dimensions displayed in the row or the column. 

The “row” will return the string concatenation of the row dimensions, each dimension being separated with a 
dash. 

The “col” will return the string concatenation of the column dimensions, each dimension being separated with 
a dash. 

Of course this can be useful only if you have at least 2 row dimension or 2 column dimensions. 

This alternative allows you to get the full value of all dimensions being in row or column instead of the unique 
value of the selected cell in a Pivot. 

Example: replace “Area” with “row” and “Vendor” with row in this window: 

 

Validate and remove the “execute url” as the new values given by the “row” parameter cannot be used to run 
the previous report “Demo Multi Criteria”. 

Run again the Pivot and check the values given to each parameter according the location of your click: 
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Selecting a total in a cell: 

In the above example, if you click the value “240,590.29” and then check the parameter values, you will get 
“ATLANTIC-Tim Rosenberg” for the AREA_PARAM, “ATLANTIC-Tim Rosenberg” for the 
SALNAME_PARAMETER, and “2013” for the P_DATE. 

 

 

Selecting a Vendor in a cell: 

 

In the above example, if you click the value “Tim Rosenberg” and then check the parameter values, you will 
get “ATLANTIC-Tim Rosenberg” for the AREA_PARAM, “ATLANTIC-Tim Rosenberg” for the 
SALNAME_PARAMETER, and “IGNORE” for the P_DATE. 
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Selecting an Area in a cell: 

 

 

In the above example, if you click the value “ATLANTIC” and then check the parameter values, you will get 
“ATLANTIC-Diane Meyer;ATLANTIC-Karen Walker;ATLANTIC-Tim Rosenberg” for the AREA_PARAM, 
each value being separated by a semicolon. You will get “ATLANTIC-Diane Meyer;ATLANTIC-Karen 
Walker;ATLANTIC-Tim Rosenberg” for the SALNAME_PARAMETER, and “IGNORE” for the P_DATE. 

 

 

7.4.5.7. Filtering data in a Pivot 

When running a Pivot, you can apply some filter to not see all data. To do so, just click the Pivot Tools  
icon, and then double-click the required Dimension Field. A window will appear with all values of that 
dimension. 

You can then unselect some of them, clear all values, or select all values. 

To validate, just leave this window by clicking again in the Pivot background. 

Example:  

http://www.clickndecide.com/
mailto:support@clickndecide.com
http://www.clickndecide.com/


 

 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
                          Page   104 

Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here.  

 

Unselect the required value(s) or Select None or Select All… 

Just click the Pivot windows again to apply the filter modifications: 

 

Note that the filter selection is not saved when you leave the Pivot. It is only a temporary way to search for 
data when consulting the result. 
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7.5. Help Command 

This command is calling and opening the online current User Manual. 
The last Edition Date is displayed on first page, as it could be updated periodically. 

 

The file name is ClicknDECiDE_BAI_Google_Chart_User_Guide_V2013.pdf 

http://www.clickndecide.com/sites/default/files/assets/files/resources/clickndecide_bai_google_chart_user_gui
de_v2013.pdf 
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8. Advanced Properties 

Most of the Objects that can be inserted in a Dashboard Google Application propose an Advanced button that 
will be describe here only one time for the common parts: 

8.1. Basic and Common Advanced Properties 

Most of the objects you can insert will display the following common Advanced Properties: 

Click any Object Properties  icon of a Button for example: 

 

Click the Advanced button: 

 

Or for a standard Google Chart, the common Advanced box can display: 

 

Most of the Advanced buttons display standard options as the one displayed in the above example, but 
sometimes the proposed list of options can contains more options. 

8.1.1. Title 

This is the Title for any object which can be a free text. 
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8.1.2. Height 

This is the height size in pixels (Automatically updated if you modify the height with the mouse). 

8.1.3. Width 

This is the width size in pixels (Automatically updated if you modify the width with the mouse). 

8.1.4. Text Color 

This is the Text color that you can customize. Click the right icon to access the color Editor. The chosen color 
and color code will appear in the text color box. Remove this code to delete the color. 

 

8.1.5. Back Color 

This is the Background color that you can customize. Click the right icon to access the color Editor. The 
chosen color and color code will appear in the back color box. Remove this code to delete the color. 

 

8.1.6. Color Editor 

 

Select the required color with the mouse and validate with OK. You can return to a transparent mode (No 
color) using the most right bottom Red Cross. 

8.1.7. Font 

Use this Font option to change some font attributes such as: 
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8.1.7.1. Family 

Select a font family in the proposed list, or enter manually a Family that does not appear in this list: 

 

8.1.7.2. Size 

Select a font size in the proposed list or enter a value that does not appear in this list: 

 

8.1.7.3. Style 

Select a font style in the proposed list: 

 

8.1.7.4. Weight 

Select a font weight in the proposed list: 
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Click OK twice and check the result: 

 

 

The summary of the Font attributes will appear as follow coming back to the Advanced button: 

 

8.1.8. Border 

Use this Border option to change some border attributes such as: 

 

8.1.8.1. Style 

Select a border style in the proposed list: 

 

8.1.8.2. Width 

Enter a border width as a number, optional px (pixel) will be added automatically: 
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8.1.8.3. Color 

Select a border color by clicking the right icon to access the Color Editor. The chosen color and color code 
will appear in the color box. Remove this code to delete the color. 

 

 

8.1.8.4. Radius 

Select a radius value in the proposed list or enter a value that does not appear in this list. 

This value can be an integer number (px) or a percent representation (%). 

 

Click OK twice and check the result: 

 

The summary of the Border attributes will appear as follow coming back to the Advanced button: 

 

 

8.1.9. BoxShadow 

Use this BoxShadow option to change some Box Shadow attributes such as: 
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8.1.9.1. h-Shadow 

Use this h-shadow option to add a shadow effect horizontally. Enter a number of pixels for the shadow 
horizontal position. Negative values are allowed. Required to define a shadow. 

 

8.1.9.2. v-Shadow 

Use this v-shadow option to add a shadow effect vertically. Enter a number of pixels for the shadow vertical 
position. Negative values are allowed. Required to define a shadow. 

 

8.1.9.3. Blur 

Use this blur option to modify the blur distance. Enter a number of pixels for this blur effect. Optional for a 
shadow. 
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8.1.9.4. Spread 

Use this spread option to modify the size of the shadow. Enter a number of pixels this size. Optional for a 
shadow. 

 

8.1.9.5. Color 

Use this color option to modify the shadow color. See . Optional for a shadow. 

 

Click OK twice and check the result: 

 
The summary of the BoxShadow attributes will appear as follow coming back to the Advanced button: 

 

8.1.10. Visible 

Use this Visible option to hide or display any object in the Dashboard Application. The default value is true… 

 

Click the true… button to change the value. You can enter false to always hide this object. 

Sometimes you would like to hide or show an object according to a condition. An example exists in the 
Dashboard GC sub.xgc file located in the following directory: 

//BAI Demonstration/Dashboards/Other Dashboard Samples/Dashboard Samples 

This example displays 2 charts in the same place, and 2 buttons allow to make them hidden or visible. 
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In the Bar Chart button, the parameter P_Chart is updated as follow: 

{P_Chart={"value":"Bar"}} 

The action will update the Chart named “customer_bar_chart”. 

In the Pie Chart button, the parameter P_Chart is updated as follow: 

{P_Chart={"value":"Pie"}}  

The action will update the Chart named “customer_pie_chart”. 

In the customer_pie_chart graph, the Visible option that you can see using the Advanced button contains 
this command: 

env.getParameterValue("P_Chart")=="Pie" 

 

In the customer_bar_chart graph, the Visible option that you can see using the Advanced button contains 
this command: 

env.getParameterValue("P_Chart")=="Bar" 

When running this Dashboard Application, the Parameter P_Chart has the following default value defined in 
Edit> Parameter: 

{P_Chart={"value":"Bar"}} 

So, the Bar Chart is displayed by default because the condition in the Visible attribute is set to 

env.getParameterValue("P_Chart")=="Bar" 

When the user clicks the Pie Chart button, the parameter P_Chart takes the value {P_Chart={"value":"Pie"}} 
and the Pie Chart is updated. 

So, the Pie Chart is now displayed because the condition in the Visible attribute is set to 

env.getParameterValue("P_Chart")=="Pie". 

8.2. Object Receiving Data Advanced Options 

All the objects that can receive data contain up to 5 special options not available in objects that are not 
updated with data: this concerns most of the Google Chart Objects but also some Other Objects such as 
Input, List that can receive data. 
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8.2.1. Toolbar 

This option allows you to display or hide the   Toolbar icon, by default visible on the left top corner of a 
Table Grid or any Google Chart. This icon allows the user to get a full screen mode. This icon can be set to 
Left, Right or None (Hidden). 

8.2.2. Client Cache 

This option allows to define a Cache Connection, the default value is 20 minutes, and make faster the 
response time when, running a Dashboard Application. If you select for example the Area WEST and the Year 
2013 and get the result in 15 seconds the first time, then, later when selecting again the same values, the 
response time will be immediate. You can modify this value if needed, using zero when no cache connection 
is required. 

8.2.3. Script 

This option allows to define a specific script to improve your Google Dashboard Application. You will find 
below some most used scripts, nice to know:   

Script Syntax (case sensitive) Explanation 

Functions 
 

env.getParameterValue("ParamName") 

 

Returns the Parameter value 

Table with H-Bar in the rows (the table must have the allowHtml = true property) 

env.tableBarFormat(x, {width:y}) 

Displays a Horizontal Bar in all 
rows of a Table for the column 
whose position is x and size is 
y (in pixels). 

Table with solid color for values and background (the table must have the allowHtml = true property) 

env.tableColorFormat(x, {range: {from:null, to:500000, 

color:"red", bgcolor:"#cee5ce"}}); 

Displays with solid colors the 
result value and the 
background in all rows of a 
Table for a column whose 
position is x, according to one 
condition. 

env.tableColorFormat(x, {range:[{from:null, to:20000, 

color:"red", bgcolor:"cee5ce"}, {from:20000, to:40000, 

color:"#007f3f"} , {from:40000, to:null, 

color:"blue"}]}); 

Displays with solid colors the 
result value and the 
background in all rows of a 
Table for a column whose 
position is x, according to 
several conditions. 

Table with gradient color for values and background (the table must have the allowHtml = true property) 
env.tableColorFormat(x, {gradientrange:{from:800000, 

to:null, color:"blue", fromBgColor:"yellow", 

toBgColor:"green"}}); 

Displays with gradient solid 
colors the result value and the 
background in all rows of a 

http://www.clickndecide.com/
mailto:support@clickndecide.com
http://www.clickndecide.com/


 

 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
                          Page   115 

Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here.  

Table for a column whose 
position is x, according to one 
condition. 

env.tableColorFormat(x, {gradientrange:[{from:800000, 

to:null, color:"red", fromBgColor:"yellow", 

toBgColor:"red"}, etc..]}); 

Displays with gradient solid 
colors the result value and the 
background in all rows of a 
Table for a column whose 
position is x, according to 
several conditions. 

Visible/Hidden conditions  

env.getParameterValue("P_Chart")=="Pie" 

The parameter value is equal to 
"Pie": if true, the object is 
visible. 

env.getParameterValue("P_Chart")!="Bar" 

The parameter value is not 
equal to "Bar": if true, the object 
is visible. 

Date and Time   
new Date().toISOString() Returns the current date time 

 

8.2.4. New 

This option allows you to add some specific options supported by this object. You also can remove some 
unnecessary options by clicking on the small black cross. The option list can be thus customizable, according 
to your need. 

Warning: remember that the case is sensitive! 

See next paragraph about the Help button which will give you some information of the available functions you 
can use, depending on the current Google Chart object. 

Example: you insert a Table under the Chrome browser and click the  Properties icon, then the Advanced 
button: you get the default advanced functions as follow: 
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As you can see nothing appears about the number of rows per page for the Table Grid, but you can add a 
new function to manage the number of rows by page, manually or automatically. 

8.2.4.1. Adding automatically a new Advanced Function: 

Leave this above screen and click now the  Chart Editor icon. For a Table you will get this screen if you 
click the Customize Tab: 

 

Click now the Paging check box and select a value in the combo list, for example 10. 

 

Note that other options are proposed and enabled by default. 

Validate and go back to the Advanced button in the the  Table Properties: 
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As you can see some new functions have been added automatically in the Advanced box. 

You can now customize the pageSize with a number such as 5 or 12 that were not proposed in the combo 

list. 

Any customizable function can be removed using the tight black cross .  

8.2.4.2. Adding manually a new Advanced Function: 

Taking the same previous example as the Google Table Object, if you click the Help button, you can see 
some more functions that you can add for a Table, such as for example the alternatingRowStyle. 

 

To add manually this function, click the New button and enter the function name (case sensitive): 

 

Validate with OK. The new function is added in the Advanced box, enter the required value according to what 
is proposed in the Help: true is the default value: 

 

Click OK and save and run the Dashboard: 
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8.2.5. Help 

This option allows to call the Google Developers Help for each Google Chart referenced in their site. Here you 
can discover some features that you would like to add in your Google Chart Object. See the previous chapter 
about the New command to see how to add such a new function. 

9. Calling a Child Dashboard from a Parent Dashboard 

As you can see in the example “Dashboard Application” in the BAI Demonstration Menu, the first main 
Dashboard displays a button that can call another sub-dashboard, passing the required values to several 
parameters: 

 

This Dashboard Application is corresponding to the “Dashboard GC Main.xgc” file located into the 
C:\Program Files\Click and DECiDE\BAI\DemoWeb\Dashboards\Dashboard Samples 

directory, and can be visible in the Web Portal in the following branch: 

http://www.clickndecide.com/
mailto:support@clickndecide.com
http://www.clickndecide.com/


 

 
 

 

 

Business Application Intelligence | Manual 

www.clickndecide.com 
                          Page   119 

Contact us: E-mail: support@clickndecide.com Tel: +33 (0)4 67 84 48 00 
Headquarters: Click&DECiDE 130, rue du Baptistou - 34980 St Gély du Fesc, France. 

To contact your nearest Click&DECiDE partner, click here.  

 

The Parent Dashboard (“Dashboard GC Main.xgc” file) is calling the Child Dashboard (“Dashboard GC 

Sub.xgc” file, using a button “Call Document and Graph Screen”: 

 

This button is running the URL calling the Child Dashboard when the user clicks it. To know what is the Child 
Dashboard, display the “Dashboard GC Sub.xgc” file in the Web Portal, then put the mouse on this file, 

make a right mouse click and select the Copy Shortcut command: 

 

Then paste the shortcut in the “execute URL” box of the button: 

http://servername/dvweb/Menus/Display.aspx?__ma=BAI+Demonstration&__mi=2558&__rp=Dashboard+Sa
mples%2fDashboard+GC+Sub.xgc 

Then add the required parameter(s) as follow: &ParameterName= for each required parameter: 

In the given example the “Call Document and Graph Screen” button executes this URL: 

/dvweb/Menus/Display.ashx?__ma=BAI+Demonstration&__mi=2558&__rp=Dashboard+Samples%2fDashboa
rd+GC+Sub.xgc&PRODREF_PARAM=&FAMILY_PARAM=&YEAR_PARAM=&SALNAME_PARAM=&CUST_
PARAM=&CUSTNAME_PARAM= 

Parent Dashboard 

Child Dashboard 
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Comments: 

The Display.ashx is used to display the result without showing the parameters and without showing the 

Navigation Bar. 

All the parameters used in the Child Dashboard are defined in this URL and will take the value according to 
the User action in the Parent Dashboard before clicking the “Call Document and Graph Screen” button. 

When no value is written in the above URL, that means IGNORE by default. 

If the user, for example, selects the year 2013 and the Vendor Joe Kramer, he can checks with the Ctrl + 
double click action that the values of all parameters will be: 

 

And when the User will click the “Call Document and Graph Screen” button, the URL will be updated as 
follow: 

/dvweb/Menus/Display.ashx?__ma=BAI+Demonstration&__mi=2558&__rp=Dashboard+Samples%2fDashboa
rd+GC+Sub.xgc&PRODREF_PARAM=IGNORE&FAMILY_PARAM=IGNORE&YEAR_PARAM=2013&SALNA
ME_PARAM=Joe%20Kramer&CUST_PARAM=IGNORE&CUSTNAME_PARAM=IGNORE 

The Child Dashboard will be opened and displayed in the same window with the result for the Vendor Joe 
Kramer and for the year 2013: 

 

10. Coming Back to the Parent Dashboard 

Most of the time, when you call a Child Dashboard from a Parent Dashboard, as describe in the previous 
chapter, you will need to come back to the Parent Dashboard, with the same parameter values and 
sometimes with new values for some parameters. 
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You have 2 ways to come back to the previous Parent Dashboard: 

10.1. Coming back automatically 

You can use a button (or any other object that can execute an URL) and use the =document.referrer 

command, and add, if needed, the parameter name(s) that must come back with a value updated. In the given 
example, the Child Dashboard “Dashboard GC Sub.xgc” Dashboard contains this “Back” button: 

 

The execute URL box contains the following URL: 

=document.referrer+"&PRODREF_PARAM=&FAMILY_PARAM=&YEAR_PARAM=&SALNAME_PARAM=&C
UST_PARAM=&CUSTNAME_PARAM=" 

But when the User comes back from the Child Dashboard to the Parent Dashboard, this URL will contain the 
most recent values for each parameter updated by the User actions. 

Example: if the User has selected in the Parent Dashboard the Year 2013 and then the Vendor Joe Kramer, 
then has called the Child Dashboard and selected the customer “The Polar Bicycle”, the parameter values will 
be: 

 

 

And the Back URL will be: 
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=document.referrer+"&PRODREF_PARAM=&FAMILY_PARAM=&YEAR_PARAM=2013&SALNAME_PARAM
=Joe%20Kramer&CUST_PARAM=1010&CUSTNAME_PARAM=The%20Polar%20Bicycle" 

When clicking the Back button in the Child Dashboard, the previous Parent Dashboard will be display. 

10.2. Coming back manually 

Instead of using the =document.referrer command, you also can enter the required full URL whose 

shortcut has been copied and modified with the required parameter(s): 

 Display the Parent Dashboard.xgc file in the Web Portal (in our example it will be the Dashboard 

GC Main.xgc file) 

 Make a right mouse click on this Dashboard file and select the Copy Shortcut command. 

 Paste this shortcut in the “execute URL” box of the Back button and add, if needed, the required 
parameters. 

With our example, the URL should be as follow: 

http://localhost/dvweb/Menus/Display.aspx?__ma=BAI+Demonstration&__mi=2558&__rp=Dashboard+Sampl
es%2fDashboard+GC+Main.xgc 

and can be modified, adding the parameters, as follow: 

/dvweb/Menus/Display.aspx?__ma=BAI+Demonstration&__mi=2558&__rp=Dashboard+Samples%2fDashboa
rd+GC+Main.xgc&PRODREF_PARAM=&FAMILY_PARAM=&YEAR_PARAM=&SALNAME_PARAM=&CUST
_PARAM=&CUSTNAME_PARAM= 

11. Technical Appendix 

Here are some technical information about shortcuts, URLs functions etc. 

11.1. Shortcut Pages 

Warning: all shortcuts have changed in version 2013 

 

Click&DECIDE Version 2013 

 

 

Shortcut Pages 

 

 

Old Shortcut Page 

 

Replace with 

/dvweb/Display.aspx 

 

/dvweb/Menus/ShowParameters.aspx 

/dvweb/Menus/Display.aspx 

/dvweb/Menus/Display.ashx 

/dvweb/Menus/Download.ashx 

/dvweb/WebQuery.ashx /dvweb/Menus/Query.ashx 

 

For compatibility reasons, old shortcuts are still supported but we recommend you to switch to the new syntax. 
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11.2. Common Parameters 

 

Click&DECIDE Version 2013 

 

 

Common Parameters 

 

Shorcuts Description Old Name Type Unit/Values/Example 

__ca= 
Value for the 

Cache (1) 
  Integer Minutes 

__f= 
Output format 

name 
__format String 

PDF, HTML, Excel+XLS, ASCII, 

Excel+XLSX,Google+Data+Table etc 

__ma= Menu Alias __mnu_alias= String __ma=BAI+Demonstration 

__mi= Menu Iem ID __mnu_itemid= Integer __mi=2316 

__rp= Relative Path __relative_path= String __rp=Area+Chart+Sample.xgc 

__t= Type __type= String vision 

__it= Item Type __item_type= Integer (1 : query; 2 : report; 3: pivot; 4 : cube) 

__in= Item Name __item_name= String   

 

(1) Only concerns the Dashboard Applications (Query.ashx) 

 

 

11.3. ShowParameters 

 

Show Parameters 

 

Function Description 
Supported 

Parameters 
Action Remarks 

ShowParameters.aspx 

/dvweb/Menus/ShowParameters.aspx? 

Show the 

parameter list 

for the selected 

item 

__sav=0 
shows the 

file 
  

__sav=1 
downloads 

the file 
  

__e=0 

displays 

parameters 

before 

running 

Old name: _exec= 

__e=1 

runs without 

showing 

parameters 

Old name: _exec= 

Note: if __e=1 and if a result 

already exists for the same 

query string, the result will be 

directly displayed. You need 

to click again the Run or 

Export button to reload the 

report or query. 

/dvweb/Menus/ShowParameters.aspx?__ma=BAI+Demonstration&__mi=2316  
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11.4. Display 

 

 

Display 

 

Function Description Comment 

Display.aspx 

/dvweb/Menus/Display.aspx? 

Displays a runnable Menu item 

result with the navigation bar 

(Under a tablet or smartphone, no 

navigation bar is displayed). 

Note: in the case of a runnable item, if the result 

already exists, it will be directly displayed, if not it 

will be run without the possibility to cancel. To run 

directly an item with the possibility to cancel, you 

must use ShowParameters.aspx with the &__e=1 

/dvweb/Menus/Display.aspx?__ma=BAI+Demonstration&__mi=2558&__rp=Area+Chart+Sample.xgc  

Display.ashx 

/dvweb/Menus/Display.ashx? 

Displays a runnable Menu item 

result without the navigation bar, 

useful for drill-down/drill-up 

reports or Parent/Child 

Dashboards. 

Note: in the case of a runnable item, if the result 

already exists, it will be directly displayed, if not it 

will be run without the possibility to cancel. 

/dvweb/Menus/Display.ashx?__ma=BAI+Demonstration&__mi=2558&__rp=Dashboard+GC+Main.xgc 

 

 

11.5. Download 

 

 

Download 

 

Functionalities Description Comment 

Download.ashx 

/dvweb/Menus/Download.ashx? Downloads a Menu Item or it result. 

Note: in the case of a runnable item, if 

the result already exists, it will be 

directly displayed, if not it will be run 

without the possibility to cancel. To run 

directly an item with the possibility to 

cancel, you must use 

ShowParameters.aspx with the 

&__e=1&__sav=1 

/dvweb/Menus/Download.ashx?__ma=BAI+Demonstration&__mi=2538&YEAR_PARAM=&SALNAME_PARAM=&PROD
REF_PARAM=&__f=PDF 
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11.6. Query/WebQuery 

 

Query /WebQuery 

 

Function Comment 

Query.ashx 

/dvweb/Menus/Query.ashx? 
Returns the raw data from a 

Menu Item Result. 

Always run without the possibility to cancel. Use the 

&__ca=NN (minutes) to enable the browser cache in 

order to improve the performances. 

/dvweb/Menus/Query.ashx?__ma=BAI+Demonstration&__mi=2528&P_Year=&__f=Google+Data+Table 

/dvweb/Menus/Query.ashx?__ma=BAI+Demonstration&__mi=2528&P_Year=["P_Year","P_Year"]&__f=WebQuery 

WebQuery.ashx 

/dvweb/WebQuery.ashx? 
Returns the raw data from a 

Menu Item Result. 

Short version of Query.ashx used for WebQueries. Do 

not need the &__f=WebQuery flag. 

/dvweb/WebQuery.ashx?__ma=BAI+Demonstration&__mi=2528&P_Year=["P_Year","P_Year"] 

Note that for WebQuery URL longer than 255 characters, you can use the TinyURL describe in the Web Portal User 

Guide page 57. 

 

 

11.7. Share button shortcuts 

 

Copy Shortcut in the Share Button 

 

Parameters 

Checked Value Result 

No default The URL will not contain this parameter and the default value will be used for the query 

Yes 

Empty The URL will contain &PARAM= or &PARAM=["PARAM","PARAM"] for WebQueries 

default The URL will not contain this parameter and the default value will be used for the query 

other The URL will contain &PARAM=VALUE 
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